Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 27-10-2017 13:19:01

yboufalca
Membre
Inscription : 27-10-2017

probleme avec samba ne demarre pas

See "systemctl status smbd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript smbd, action "start" failed.
● smbd.service - Samba SMB Daemon
   Loaded: loaded (/lib/systemd/system/smbd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Fri 2017-10-27 13:07:51 CEST; 10ms ago
     Docs: man:smbd(8)
           man:samba(7)
           man:smb.conf(5)
  Process: 4176 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=255)
Main PID: 4176 (code=exited, status=255)
   Status: "Starting process..."

oct. 27 13:07:51 debian systemd[1]: smbd.service: Supervising process 4176 which is not our child. We'll most likely not n…it exits.
oct. 27 13:07:51 debian smbd[4176]: [2017/10/27 13:07:51.970775,  0] ../source3/auth/auth_util.c:761(get_guest_info3)
oct. 27 13:07:51 debian smbd[4176]:   SamInfo3_for_guest: Unable to locate guest account [invite]!
oct. 27 13:07:51 debian smbd[4176]: [2017/10/27 13:07:51.970885,  0] ../source3/auth/auth_util.c:830(make_new_session_info_guest)
oct. 27 13:07:51 debian smbd[4176]:   get_guest_info3 failed with NT_STATUS_NO_SUCH_USER
oct. 27 13:07:51 debian smbd[4176]: [2017/10/27 13:07:51.970941,  0] ../source3/smbd/server.c:1894(main)
oct. 27 13:07:51 debian systemd[1]: smbd.service: Main process exited, code=exited, status=255/n/a
oct. 27 13:07:51 debian systemd[1]: Failed to start Samba SMB Daemon.
oct. 27 13:07:51 debian systemd[1]: smbd.service: Unit entered failed state.
oct. 27 13:07:51 debian systemd[1]: smbd.service: Failed with result 'exit-code'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: erreur de traitement du paquet samba (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u1) ...
Des erreurs ont été rencontrées pendant l'exécution :
samba

Hors ligne

#2 27-10-2017 13:44:08

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : probleme avec samba ne demarre pas

Salut yboufalca et bienvenue sur df !

Il ne faut pas te contenter d'indiquer le titre et des retours de lignes de commande mais il nous faut aussi les commandes elles-mêmes avec et surtout les renseignements de ton profil dans le menu pour t'aider.
Voir le tuto : Trop cool d'indiquer son installation dans son profil ! smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 27-10-2017 20:51:23

yboufalca
Membre
Inscription : 27-10-2017

Re : probleme avec samba ne demarre pas

voici la commande et le resultat merci de m aider

root@debian:/home/yannick#

aptitude install  samba


Les NOUVEAUX paquets suivants vont être installés :    
  attr{a} samba tdb-tools{a}
0 paquets mis à jour, 3 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o/1 003 ko d'archives. Après dépaquetage, 11,4 Mo seront utilisés.
Voulez-vous continuer ? [Y/n/?] y
Récupération des rapports de bogue… Fait      
Analyse des informations Trouvé/Corrigé… Fait
Sélection du paquet tdb-tools précédemment désélectionné.
(Lecture de la base de données... 147263 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../tdb-tools_1.3.11-2_amd64.deb ...
Dépaquetage de tdb-tools (1.3.11-2) ...
Sélection du paquet samba précédemment désélectionné.
Préparation du dépaquetage de .../samba_2%3a4.5.12+dfsg-2_amd64.deb ...
Dépaquetage de samba (2:4.5.12+dfsg-2) ...
Sélection du paquet attr précédemment désélectionné.
Préparation du dépaquetage de .../attr_1%3a2.4.47-2+b2_amd64.deb ...
Dépaquetage de attr (1:2.4.47-2+b2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u1) ...
Traitement des actions différées (« triggers ») pour systemd (232-25+deb9u1) ...
Paramétrage de tdb-tools (1.3.11-2) ...
update-alternatives: utilisation de « /usr/bin/tdbbackup.tdbtools » pour fournir « /usr/bin/tdbbackup » (tdbbackup) en mode automatique
Traitement des actions différées (« triggers ») pour man-db (2.7.6.1-2) ...
Paramétrage de samba (2:4.5.12+dfsg-2) ...
Samba is not being run as an AD Domain Controller, masking samba-ad-dc-service.
Please ignore the following error about deb-systemd-helper not finding samba-ad-dc-service.
Created symlink /etc/systemd/system/multi-user.target.wants/nmbd.service → /lib/systemd/system/nmbd.service.
Failed to preset unit: Unit file /etc/systemd/system/samba-ad-dc.service is masked.
/usr/bin/deb-systemd-helper: error: systemctl preset failed on samba-ad-dc.service: No such file or directory
Created symlink /etc/systemd/system/multi-user.target.wants/smbd.service → /lib/systemd/system/smbd.service.
Job for smbd.service failed because the control process exited with error code.
See "systemctl status smbd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript smbd, action "start" failed.
● smbd.service - Samba SMB Daemon
   Loaded: loaded (/lib/systemd/system/smbd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Fri 2017-10-27 13:07:49 CEST; 11ms ago
     Docs: man:smbd(8)
           man:samba(7)
           man:smb.conf(5)
  Process: 4056 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=255)
 Main PID: 4056 (code=exited, status=255)
   Status: "Starting process..."

oct. 27 13:07:49 debian systemd[1]: smbd.service: Supervising process 4056 which is not our child. We'll most likely not n…it exits.
oct. 27 13:07:49 debian smbd[4056]: [2017/10/27 13:07:49.335866,  0] ../source3/auth/auth_util.c:761(get_guest_info3)
oct. 27 13:07:49 debian smbd[4056]:   SamInfo3_for_guest: Unable to locate guest account [invite]!
oct. 27 13:07:49 debian smbd[4056]: [2017/10/27 13:07:49.335962,  0] ../source3/auth/auth_util.c:830(make_new_session_info_guest)
oct. 27 13:07:49 debian smbd[4056]:   get_guest_info3 failed with NT_STATUS_NO_SUCH_USER
oct. 27 13:07:49 debian smbd[4056]: [2017/10/27 13:07:49.336018,  0] ../source3/smbd/server.c:1894(main)
oct. 27 13:07:49 debian systemd[1]: smbd.service: Main process exited, code=exited, status=255/n/a
oct. 27 13:07:49 debian systemd[1]: Failed to start Samba SMB Daemon.
oct. 27 13:07:49 debian systemd[1]: smbd.service: Unit entered failed state.
oct. 27 13:07:49 debian systemd[1]: smbd.service: Failed with result 'exit-code'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: erreur de traitement du paquet samba (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Paramétrage de attr (1:2.4.47-2+b2) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u1) ...
Traitement des actions différées (« triggers ») pour systemd (232-25+deb9u1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 samba
E: Sub-process /usr/bin/dpkg returned an error code (1)
Paramétrage de samba (2:4.5.12+dfsg-2) ...
Failed to preset unit: Unit file /etc/systemd/system/samba-ad-dc.service is masked.
/usr/bin/deb-systemd-helper: error: systemctl preset failed on samba-ad-dc.service: No such file or directory
Job for smbd.service failed because the control process exited with error code.
See "systemctl status smbd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript smbd, action "start" failed.
● smbd.service - Samba SMB Daemon
   Loaded: loaded (/lib/systemd/system/smbd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Fri 2017-10-27 13:07:51 CEST; 10ms ago
     Docs: man:smbd(8)
           man:samba(7)
           man:smb.conf(5)
  Process: 4176 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=255)
 Main PID: 4176 (code=exited, status=255)
   Status: "Starting process..."

oct. 27 13:07:51 debian systemd[1]: smbd.service: Supervising process 4176 which is not our child. We'll most likely not n…it exits.
oct. 27 13:07:51 debian smbd[4176]: [2017/10/27 13:07:51.970775,  0] ../source3/auth/auth_util.c:761(get_guest_info3)
oct. 27 13:07:51 debian smbd[4176]:   SamInfo3_for_guest: Unable to locate guest account [invite]!
oct. 27 13:07:51 debian smbd[4176]: [2017/10/27 13:07:51.970885,  0] ../source3/auth/auth_util.c:830(make_new_session_info_guest)
oct. 27 13:07:51 debian smbd[4176]:   get_guest_info3 failed with NT_STATUS_NO_SUCH_USER
oct. 27 13:07:51 debian smbd[4176]: [2017/10/27 13:07:51.970941,  0] ../source3/smbd/server.c:1894(main)
oct. 27 13:07:51 debian systemd[1]: smbd.service: Main process exited, code=exited, status=255/n/a
oct. 27 13:07:51 debian systemd[1]: Failed to start Samba SMB Daemon.
oct. 27 13:07:51 debian systemd[1]: smbd.service: Unit entered failed state.
oct. 27 13:07:51 debian systemd[1]: smbd.service: Failed with result 'exit-code'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: erreur de traitement du paquet samba (--configure) :
 le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Traitement des actions différées (« triggers ») pour libc-bin (2.24-11+deb9u1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 samba



Edit à toto :

Mis la commande root sous la balise Commande root du forum pour plus de clarté.

Hors ligne

#4 28-10-2017 08:39:04

yboufalca
Membre
Inscription : 27-10-2017

Re : probleme avec samba ne demarre pas

oui je fait bien la commande

aptitude install  samba


et ca ne fonctionne pas

Edit à toto :

Mis la commande root avec la balise Commande root

Hors ligne

#5 28-10-2017 09:20:48

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : probleme avec samba ne demarre pas

Salut yboufalca et bienvenue sur df !

Afin de nous permettre de vous communiquer les meilleurs réponses, ou d'entendre au mieux tes interventions, il est bon de renseigner de manière permanente sous ton avatar la configuration du (des) PC que tu utilises.
Voir le tuto : Trop cool d'indiquer son installation dans son profil ! smile

Que donne la commande user :

cat /etc/apt/sources.list


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#6 28-10-2017 09:28:00

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : probleme avec samba ne demarre pas

Bonjour

de mémoire samba ne démarre pas a l'installation , il faut le configurer et le redémarrer.

Hors ligne

#7 28-10-2017 12:42:19

yboufalca
Membre
Inscription : 27-10-2017

Re : probleme avec samba ne demarre pas

voici mon fichier sources.list

#
# deb cdrom:[Debian GNU/Linux
#testing _Stretch_ - Official Snapshot amd64 NETINST Binary-1 20170206-05:24]/ stretch main

#deb cdrom:[Debian GNU/Linux testing _Stretch_ - Official Snapshot amd64 NETINST Binary-1 20170206-05:24]/ stretch main

deb http://ftp.fr.debian.org/debian/ stretch main
deb-src http://ftp.fr.debian.org/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main
deb-src http://security.debian.org/debian-security stretch/updates main

# stretch-updates, previously known as 'volatile'
#deb http://ftp.fr.debian.org/debian/ stretch-updates main
#deb-src http://ftp.fr.debian.org/debian/ stretch-updates main
#deb http://deb.debian.org/debian/ stretch main
#deb http://security.debian.org/ stretch/updates main
#deb http://deb.debian.org/debian/ stretch-updates main
#deb http://deb.debian.org/debian stretch-backports main
#deb http://deb.debian.org/debian/ stretch main contrib non-free
#deb http://security.debian.org/ stretch/updates main contrib non-free
#deb http://deb.debian.org/debian/ stretch-updates main contrib non-free
#deb http://deb.debian.org/debian stretch-backports main contrib non-free



Edit à toto :

Mis les sources sous la balise Code option apt_sources

Hors ligne

#8 28-10-2017 12:44:14

yboufalca
Membre
Inscription : 27-10-2017

Re : probleme avec samba ne demarre pas

le message d erreur quand je redémarre samba

root@debian:/home/yannick#

service samba restart


Failed to restart samba.service: Unit samba.service is masked.



Edit à toto :


Mis la commande root sous la balise Commande root du forum.

Hors ligne

#9 28-10-2017 20:22:24

yboufalca
Membre
Inscription : 27-10-2017

Re : probleme avec samba ne demarre pas

je ne comprend pas ?

Hors ligne

#10 28-10-2017 20:30:38

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : probleme avec samba ne demarre pas

yboufalca a écrit :

je ne comprend pas ?


Il te faut configurer samba :

robert2a a écrit :

de mémoire samba ne démarre pas a l'installation , il faut le configurer et le redémarrer.


Mais là, je sais pas.

Il y a un tuto dans l'atelier qui peut t'aider peut-être :
https://debian-facile.org/atelier:chant … age-reseau smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#11 29-10-2017 07:16:41

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : probleme avec samba ne demarre pas

Bonjour

oui le tuto est une bonne base pour configurer samba (le fichier de configuration smb.conf )
le minimum est d'éditer ce fichier et de voir ce qu il contient
pour le visualiser


cat /etc/samba/smb.conf
 



pour le modifier


nano /etc/samba/smb.conf
 



nota : une petite remarque presque hors sujet
dans le tuto il est noté autoriser la découverte du réseau (dans windows par exemple )
cela a pour effet d'activer upnp (zéro conf ) et parfois dlna
ce protocole http (port 9000 de mémoire ) n'a aucune vérification de l utilisateur et mdp  , il peu y avoir un accès aux ressources depuis le réseau local ou internet si upnp est activé sur le modem routeur (ou un bug de celui ci )
sur gnome buster les deux sont activés (upnp et dlna pour le partage de musique (logiciel de musique de gnome ). pas vérifié sur gnome stretch , mate a priori ne l utilise pas
le souci toutes les ressources peuvent etre annoncé (a protéger par mot de passe si possible ).
upnp (ou dlna) permet sans configuration d'avoir tous les appareils compatibles partager leurs ressources (ce qui est super pratique parfois ) , serveur de vidéo par exemple.
voila c'est ma minute sécurité wink
personnellement je coupe upnp et je désinstalle quand c'est possible et je configure en dur
ps : sur windows je désactive la découverte du réseau
samba utilise un mot de passe (et un nom d'utilisateur ) pour un accès au partage (il est visible par tous les clients du réseau local )

Dernière modification par robert2a (29-10-2017 07:41:18)

Hors ligne

#12 31-10-2017 20:13:58

yboufalca
Membre
Inscription : 27-10-2017

Re : probleme avec samba ne demarre pas

Bonjour
toujours un probleme avec  samba

root@debian:/etc/samba#  /etc/init.d/samba restart[ ok ] Restarting nmbd (via systemctl): nmbd.service.
[....] Restarting smbd (via systemctl): smbd.serviceJob for smbd.service failed because the control process exited with error code.
See "systemctl status smbd.service" and "journalctl -xe" for details.
failed!

Hors ligne

#13 31-10-2017 22:03:47

potemkine17
Membre
Distrib. : Débian 9
Noyau : i386
(G)UI : LXDE
Inscription : 17-09-2014

Re : probleme avec samba ne demarre pas

Bonsoir,
qu'as tu mis sur ton fichier de conf. ?

Hors ligne

#14 31-10-2017 22:42:43

yboufalca
Membre
Inscription : 27-10-2017

Re : probleme avec samba ne demarre pas

voici ma configuration


[global]

workgroup = WORKGROUP    # par défaut et à laisser tel quel

netbios name = debian       # nom du serveur visible sur le poste client Windows
server string = Samba %h     # nom du serveur samba
guest account = invite
security = user
#browseable = yes  

# hosts allow = 192.168.1.43 # ajouté et à modifier selon l'IP du réseau local

#security = user               # à décommenter

# bind interfaces only = yes    # mettre "yes" pour utiliser le choix des interfaces (ligne au dessous)
# interfaces = 192.168.0.15/24  # Pour éviter le wifi, on peut mettre à la place de l'IP/masque, le nom de l'interface "eth0:0"


[distrib]
@@@                                                                            
"/etc/samba/smb.conf" 43L, 1270C                              16,24        Haut



Edit  toto :

Mis la configuration dans la balise Autre code du forum.

Hors ligne

#15 01-11-2017 02:43:59

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : probleme avec samba ne demarre pas

Salut yboufalca,

Il est nécessaire que tu utilises les balises du forum pour poster tes configurations et code.
Le tuto en choco là :
Ce serait cool si tu pouvais éditer tes messages pour faire ressortir les commandes, leurs sorties, etc. en utilisant la balise code comme toto le fait depuis le début ici sur tes posts.
Voir le tuto : Le code, ça pique moins les yeux en couleur

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#16 01-11-2017 11:55:22

yboufalca
Membre
Inscription : 27-10-2017

Re : probleme avec samba ne demarre pas

bonjour

yannick@debian:~$

testparm smb.conf


Load smb config files from smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Error loading services.
 

Hors ligne

#17 01-11-2017 12:03:58

yboufalca
Membre
Inscription : 27-10-2017

Re : probleme avec samba ne demarre pas

root@debian:/home/yannick#

testparm smb.conf
 


rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Error loading services.
root@debian:/home/yannic




root@debian:/home/yannick#

systemctl restart samba
 


Failed to restart samba.service: Unit samba.service is masked.



Edit à toto :

Mis les commandes en Commande root comme l'indique le dièse : # les précédents et en isolant la partie propre à la commande seule.

Hors ligne

#18 01-11-2017 15:27:14

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : probleme avec samba ne demarre pas

Bonjour

tu a configuré le partage ?


#======================= Share Definitions =======================

[homes]
   comment = Home Directories
   browseable = no

# By default, the home directories are exported read-only. Change the
# next parameter to 'no' if you want to be able to write to them.
   read only = yes

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
   create mask = 0700

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
   directory mask = 0700

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server.
# The following parameter makes sure that only "username" can connect
# to \\server\username
# This might need tweaking when using external authentication schemes
   valid users = %S

# Un-comment the following and create the netlogon directory for Domain Logons
# (you need to configure Samba to act as a domain controller too.)
;[netlogon]
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   read only = yes

# Un-comment the following and create the profiles directory to store
# users profiles (see the "logon path" option above)
# (you need to configure Samba to act as a domain controller too.)
# The path below should be writable by all users so that their
# profile directory may be created the first time they log on
;[profiles]
;   comment = Users profiles
;   path = /home/samba/profiles
;   guest ok = no
;   browseable = no
;   create mask = 0600
;   directory mask = 0700
 



dans la config que tu a posté on ne voit aucun partage
tu a la doc samba et surement un tuto dans le wiki de D_F

=>  https://debian-facile.org/doc:reseau:samba

Dernière modification par robert2a (01-11-2017 15:29:37)

Hors ligne

#19 02-11-2017 09:47:27

yboufalca
Membre
Inscription : 27-10-2017

Re : probleme avec samba ne demarre pas

Bonjour j ai bien configurer un  partage et je suis sous debian 9

*

root@debian:/etc/samba# vi smb.conf
 



[global]

workgroup = WORKGROUP    # par défaut et à laisser tel quel

netbios name = debian       # nom du serveur visible sur le poste client Windows
server string = Samba %h     # nom du serveur samba
guest account = invite
security = user
#browseable = yes  

# hosts allow = 192.168.1.43 # ajouté et à modifier selon l'IP du réseau local

#security = user               # à décommenter

# bind interfaces only = yes    # mettre "yes" pour utiliser le choix des interfaces (ligne au dessous)
# interfaces = 192.168.0.15/24  # Pour éviter le wifi, on peut mettre à la place de l'IP/masque, le nom de l'interface "eth0:0"


[global]

workgroup = WORKGROUP    # par défaut et à laisser tel quel

netbios name = debian       # nom du serveur visible sur le poste client Windows
server string = Samba %h     # nom du serveur samba
guest account = invite
security = user
#browseable = yes  

# hosts allow = 192.168.1.43 # ajouté et à modifier selon l'IP du réseau local

#security = user               # à décommenter

# bind interfaces only = yes    # mettre "yes" pour utiliser le choix des interfaces (ligne au dessous)
# interfaces = 192.168.0.15/24  # Pour éviter le wifi, on peut mettre à la place de l'IP/masque, le nom de l'interface "eth0:0"
# bind interfaces only = yes    # mettre "yes" pour utiliser le choix des interfaces (ligne au dessous)
# interfaces = 192.168.0.15/24  # Pour éviter le wifi, on peut mettre à la place de l'IP/masque, le nom de l'interface "eth0:0"
 
 
[distrib]  
path = /home/ylann       # créé sur le système lors de la création d'un nouvel utilisateur
comment = repertoire pour tout le monde
guest ok = yes
guest only = yes
writeable = no
read only = yes
browseable = yes
 
[ylann]
comment = /home/ylann
browsable = no
writable = yes
create mode = 0777

#read only = no
-- VISUEL --                                        i         19,1          35%





                                                                                                                                       16,1         Haut
 

Hors ligne

#20 02-11-2017 12:39:04

potemkine17
Membre
Distrib. : Débian 9
Noyau : i386
(G)UI : LXDE
Inscription : 17-09-2014

Re : probleme avec samba ne demarre pas

#security = user               # à décommenter


Les lignes concernants les adresses IP locales  ne doivent-elles êtres pas deécommentées ?

Hors ligne

#21 02-11-2017 13:08:22

yboufalca
Membre
Inscription : 27-10-2017

Re : probleme avec samba ne demarre pas

j ai décommentées
root@debian:/etc/samba#

testparm smb.conf


 Load smb config files from smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
WARNING: Ignoring invalid value 'user # à décommenter' for parameter 'security'
Error loading services.




root@debian:/etc/samba#

systemctl restart samba
 



Edit à toto :

Mis les balises root en conformité.

Dernière modification par yboufalca (02-11-2017 13:16:14)

Hors ligne

#22 02-11-2017 23:15:00

potemkine17
Membre
Distrib. : Débian 9
Noyau : i386
(G)UI : LXDE
Inscription : 17-09-2014

Re : probleme avec samba ne demarre pas

J'ai installé Samba sur mon pc plus par défi que par besoin , sans compétences particulières et sans même trop me rappeler comment , étant passé depuis à plein d'autres choses.
Je peux publier mon fichier de conf. si ça peut t'aider , bien qu'il soit devenu conséquent, il me semble,  depuis la mise en service de samba - un vrai foutoir en fait.

Hors ligne

#23 03-11-2017 08:11:22

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : probleme avec samba ne demarre pas

Bonjour


service smbd status
 


retour


● smbd.service - Samba SMB Daemon
   Loaded: loaded (/lib/systemd/system/smbd.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2017-10-14 23:10:24 CEST; 2 weeks 5 days ago
     Docs: man:smbd(8)
           man:samba(7)
           man:smb.conf(5)
  Process: 2565 ExecReload=/bin/kill -HUP $MAINPID (code=exited, status=0/SUCCESS)
 Main PID: 1321 (smbd)
   Status: "smbd: ready to serve connections..."
    Tasks: 7 (limit: 4915)
   CGroup: /system.slice/smbd.service
           ├─1321 /usr/sbin/smbd
           ├─1327 /usr/sbin/smbd
           ├─1328 /usr/sbin/smbd
           ├─1334 /usr/sbin/smbd
           ├─3875 /usr/sbin/smbd
           ├─3876 /usr/sbin/smbd
           └─3881 /usr/sbin/smbd

oct. 20 11:16:46 debian1 smbd[12653]: pam_unix(samba:session): session closed for user nobody
oct. 25 13:40:10 debian1 smbd[12687]: pam_unix(samba:session): session closed for user nobody
oct. 31 07:29:02 debian1 smbd[27271]: pam_unix(samba:session): session closed for user nobody
nov. 01 09:01:07 debian1 smbd[1998]: pam_unix(samba:session): session closed for user nobody
nov. 01 14:40:54 debian1 smbd[3872]: pam_unix(samba:session): session closed for user nobody
nov. 01 14:41:16 debian1 smbd[3874]: pam_unix(samba:session): session closed for user nobody
 



test du fichier de conf


testparm /etc/samba/smb.conf
 


retour


Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
WARNING: The "syslog only" option is deprecated
WARNING: The "syslog" option is deprecated
Processing section "[homes]"
Processing section "[sharing]"
Loaded services file OK.
Server role: ROLE_STANDALONE

Press enter to see a dump of your service definitions
 


taper la touche "ENTER"


# Global parameters
[global]
  bind interfaces only = Yes
  interfaces = xxx.xxx.xxx.xxx/24 ethx
  server string = serveur %h (Samba %v, Debian)
  log file = /var/log/samba/log.%m
  max log size = 1000
  syslog = 0
  panic action = /usr/share/samba/panic-action %d
  map to guest = Bad User
  obey pam restrictions = Yes
  pam password change = Yes
  passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
  passwd program = /usr/bin/passwd %u
  server role = standalone server
  unix password sync = Yes
  idmap config * : backend = tdb


[homes]
  comment = Documents Utiles
  browseable = No
  create mask = 0700
  directory mask = 0700
  valid users = %S


[sharing]
  path = /home/user/Public
  create mask = 0770
  directory mask = 0700
  read only = No
  valid users = xxxx
  write list = xxxx
 



sinon j'ai remarqué que debian Buster ne voit pas mon partage samba sur le bureau Mate , ça ne fonctionne plus (les clients sur stretch c'est OK )
nota : je pense que c'est un problème coté client et surement mate (la configuration (paquets installés identique entre stretch et buster) identique) (j'utilise caja pour visualiser le partage samba sur mate )
les "xxxx" sont a remplacé par les bonnes valeurs pour toi
les clients samba (autoriser au partage ) sont a créer (voir la doc samba )

pas d'imprimante partagée pour samba (sur mon smb.conf), elle est en réseau et visible de tous les clients

le dossier de test partagé est /home/user/public  (user a remplacer par le tien )

pour ceci


rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
WARNING: The "syslog only" option is deprecated
WARNING: The "syslog" option is deprecated
 


rien de méchant , faut que je regarde les changements sur samba depuis jessie et mettre a jour le smb.conf  pour ceci  => "WARNING: The "syslog only" option is deprecated"

je vois pas quoi te dire de plus , sinon bien lire la documentation samba et le wiki

Dernière modification par robert2a (03-11-2017 08:23:01)

Hors ligne

Pied de page des forums