Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-11-2017 16:46:43

redelap
Membre
Lieu : SAINTES 17
Distrib. : Debian Stretch 9.2 / Xfce & Raspbian
Noyau : Linux 4.9.0-3
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

[RESOLU] Compatibilité avec un processeur "Kaby Lake".?

Bonjour !
Fiche d'une machine vendue sans OS. Ses caractéristiques techniques me plaisent.
Son microprocesseur est un Intel Core i3-7100U(dual core 2,4 Ghz) de type "Kaby Lake"
Le vendeur précise toutefois "L'installation de Windows 7 / 8 / 8.1 n'est pas possible sur ce modèle équipé d'un processeur Intel Kaby Lake".
Ce Micro processeur sera t'il compatible avec la dernière distribution Débian ?
Merci de vos réponses... si connues...

Dernière modification par redelap (11-11-2017 12:48:15)


Debian 9.2 Stretch-Xfce sur Lenovo Y520 SSD128-HD1000
MacBook X.6.8 - Raspbian Strech sur Raspberry P3

Hors ligne

#2 10-11-2017 08:23:36

Go10
Membre
Distrib. : Debian Stretch Stable
Noyau : 4.9
(G)UI : Gnome 3.22.2
Inscription : 10-11-2017

Re : [RESOLU] Compatibilité avec un processeur "Kaby Lake".?

Hello,
J'ai un Laptop sous I5 7200u, Kaby Lake donc, et aucun soucis ici sous Debian Stretch 9. J'ai installé les Intel-Microcode pour l'exploiter pleinement après avoir ajouté les dépôts contrib et non-free.

Laptop : Dell XPS 13 DE 9360 sous Debian 9 stable : FHD/ I5 7200U / 256 gb SSD / 8gb RAM
Desktop : Intel Skull Canyon sous Debian 9 stable : I7 6770 HQ / 2 x 512 gb SSD / 2 x 16 gb RAM

Hors ligne

#3 10-11-2017 10:33:23

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Compatibilité avec un processeur "Kaby Lake".?

Bonjour
un 7700 (Kabylake)  en buster , je regrette il fonctionne très bien en stretch
la seule différence avec Skylake c'est la prise en charge par le gpu de certain format vidéo qui ne risque de ne pas fonctionner avec GNU Linux (uniquement avec win10)
idem pour la série 8 (CoffeeLake) le cpu passe a 6 coeurs mais impose de changer la carte mère en 1151 v2 (les anciennes cartes ne fonctionnent pas , socket incompatible)
enfin bref j'utilise KabyLake depuis que stretch est en testing sans aucun souci (et un petit I3 6100 en SkyLake)
j'installe juste le paquet pour le gpu intégré firmware-misc-nonfree


apt-get install firmware-misc-nonfree
 


j'utilise pas le paquet intel-microcode , juste mon bios UEFI a jour , je sais pas de quand date la dernière  mise a jour de ce paquet.
ce ne sera pas le cpu qui posera problème sur le laptop ( peut etre le wifi par exemple mais rien de méchant )
quand a l'annonce comme quoi win 7 , 8  ne fonctionne pas , c'est Microsoft qui ne veut pas , pour forcer le passage a win10 (pour tous les nouveaux matériel en général)
nota: très peu de différence entre le Z170 et Z270 (série 6 et 7 ) sur les processeurs
juste la série 8 qui ajoute 2 cores , un chipset Z370 uniquement , et un socket 1151 incompatible avec l'ancien
pour les portables je suppose qu il va y avoir une gamme aussi pour la 8eme génération

sous stretch tu pourra regarder avec lscpu (ici sur un pc de bureau avec un I7 7700 )


lscpu
 


retour


Architecture :                           x86_64
Mode(s) opératoire(s) des processeurs :  32-bit, 64-bit
Boutisme :                               Little Endian
Processeur(s) :                          8
Liste de processeur(s) en ligne :        0-7
Thread(s) par cœur :                     2
Cœur(s) par socket :                     4
Socket(s) :                              1
Nœud(s) NUMA :                           1
Identifiant constructeur :               GenuineIntel
Famille de processeur :                  6
Modèle :                                 158
Nom de modèle :                          Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz
Révision :                               9
Vitesse du processeur en MHz :           3600.000
Vitesse maximale du processeur en MHz :  4200,0000
Vitesse minimale du processeur en MHz :  800,0000
BogoMIPS :                               7200.00
Virtualisation :                         VT-x
Cache L1d :                              32K
Cache L1i :                              32K
Cache L2 :                               256K
Cache L3 :                               8192K
Nœud NUMA 0 de processeur(s) :           0-7
Drapaux :                                fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf tsc_known_freq pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch cpuid_fault epb intel_pt tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 hle avx2 smep bmi2 erms invpcid rtm mpx rdseed adx smap clflushopt xsaveopt xsavec xgetbv1 xsaves dtherm ida arat pln pts hwp hwp_notify hwp_act_window hwp_epp
 


ps : la seule différence sera que tu a la série U (portable) et un I3 7100

depuis la série 6 rien de bien nouveau et debian est compatible , juste pour la série 8 pour contrer AMD avec Ryzen et forcer l'achat d une nouvelle carte mère .
je ne testerais pas la série 8  tongue  wink et en espérant ne pas vous avoir ennuyé avec mes explications  un peu hors sujet sur la question de départ , laptop "kabylake" compatible debian 9 (stretch) , oui il est compatible smile .

Hors ligne

#4 10-11-2017 16:38:29

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : [RESOLU] Compatibilité avec un processeur "Kaby Lake".?

Hello,
J'ai également une config avec du kaby_Lake et cela fonctionne très bien.
d33p

science sans conscience n'est que ruine de l'âme...

Hors ligne

#5 11-11-2017 09:57:32

redelap
Membre
Lieu : SAINTES 17
Distrib. : Debian Stretch 9.2 / Xfce & Raspbian
Noyau : Linux 4.9.0-3
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

Re : [RESOLU] Compatibilité avec un processeur "Kaby Lake".?

Merci beaucoup à tous pour vos éclaircissements rassurants...
Jouant avec les nombreuses options proposées, finalement je me suis tourné vers un machine qui, je pense, me donnera satisfaction.. et sera suffisante pour mes modestes besoins pour quelques années.
je devrais la recevoir lundi ou mardi.
LEGION PC Portable Gamer Lenovo Y520 15IKBN 15"6 FHD -RAM 8 Go -Sans OS-Intel Core i5-7300HQ -GTX1050 -Stockage 1To + 128Go SSD
Système sur le SSD, et /home sur le HD
Ouala !
merci !

Debian 9.2 Stretch-Xfce sur Lenovo Y520 SSD128-HD1000
MacBook X.6.8 - Raspbian Strech sur Raspberry P3

Hors ligne

#6 11-11-2017 10:27:28

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Compatibilité avec un processeur "Kaby Lake".?

Bonjour
la GTX1050 va poser problème avec le driver libre "nouveau"
voir aussi si cette machine utilise 2 gpu (intel + nvidia) ou 1 gpu (nvidia)

Hors ligne

#7 11-11-2017 10:58:58

redelap
Membre
Lieu : SAINTES 17
Distrib. : Debian Stretch 9.2 / Xfce & Raspbian
Noyau : Linux 4.9.0-3
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

Re : [RESOLU] Compatibilité avec un processeur "Kaby Lake".?

Merci Robert.;
C'est quoi ce driver libre "nouveau"...? je devrais normalement trouver le driver ad-hoc sur le site du constructeur .. non? (non-libre)

Debian 9.2 Stretch-Xfce sur Lenovo Y520 SSD128-HD1000
MacBook X.6.8 - Raspbian Strech sur Raspberry P3

Hors ligne

#8 11-11-2017 11:13:42

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Compatibilité avec un processeur "Kaby Lake".?

quand tu installe debian , aucun paquet nonfree est installé
donc tu n'aura pas le paquet "firmware-misc-nonfree" pour le gpu intel et tu utilisera le paquet "xserver-xorg-video-nouveau"  pour nvidia
pour des raisons de consommation , il est possible que tu démarre sur le gpu intel et que tu bascule sur nvidia quand tu a besoin de plus de ressources (bumblebee)
tu parle de compatibilité , juste pour te prévenir d'éventuel problèmes
pour le driver nonfree nvidia il est disponible sur les dépots debian (sources.list avec contrib et nonfree) , pas la peine d'utiliser celui du site "Nvidia" , qui n'est pas forcément  optimisé pour debian .
juste pour te prévenir , il aura surement plus apte que moi a te guider sur l'installation de debian (j'insiste sur debian 9 stretch qui est la stable actuelle ).

Hors ligne

#9 11-11-2017 11:17:56

redelap
Membre
Lieu : SAINTES 17
Distrib. : Debian Stretch 9.2 / Xfce & Raspbian
Noyau : Linux 4.9.0-3
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

Re : [RESOLU] Compatibilité avec un processeur "Kaby Lake".?

Parfait. je te remercie... Je sais modifier le sources.list pour cela.

Merci et bon WE.

Dernière modification par redelap (11-11-2017 11:18:46)


Debian 9.2 Stretch-Xfce sur Lenovo Y520 SSD128-HD1000
MacBook X.6.8 - Raspbian Strech sur Raspberry P3

Hors ligne

#10 11-11-2017 11:32:27

robert2a
Membre
Lieu : France
Distrib. : Stretch 9
Noyau : Linux 4.9.0-3 4.9.30-2
(G)UI : Mate
Inscription : 15-11-2014

Re : [RESOLU] Compatibilité avec un processeur "Kaby Lake".?

pour etre plus clair  ton processeur  =>  https://ark.intel.com/fr/products/97456 … o-3_50-GHz

dans la partie graphique tu vois qu il est équipé d un gpu HD630 , si sur ton portable il n'est pas désactivé , tu aura 2 gpu (intel + nvidia )
si c'est le cas , nécessite la technologie "bumblebee" et le driver nonfree des dépots debian

un lspci peu donner les renseignements sur le matériel


lspci
 

Hors ligne

#11 11-11-2017 12:49:36

redelap
Membre
Lieu : SAINTES 17
Distrib. : Debian Stretch 9.2 / Xfce & Raspbian
Noyau : Linux 4.9.0-3
(G)UI : Xfce
Inscription : 14-05-2012
Site Web

Re : [RESOLU] Compatibilité avec un processeur "Kaby Lake".?

Ok. je testerai tout cela dès réception de l'engin.
merci pour tes précieux conseils.

Debian 9.2 Stretch-Xfce sur Lenovo Y520 SSD128-HD1000
MacBook X.6.8 - Raspbian Strech sur Raspberry P3

Hors ligne

Pied de page des forums