Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-11-2017 20:52:23

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

[Résolu] Compilation difficile avec Makefile

Bonjour à tous,

Comme il n'y a pas de paquet .deb, je cherche à compiler depuis Github le programme LXBat. Celui-ci n'a pas été mis à jour depuis 5 ans, d'où une certaine appréhension, mais j'ai décidé de tenter le coup quand même car c'est pour l'instant la solution la plus simple à ce problème.

J'ai donc téléchargé l'archive zip et l'ai décompressé. Une fois dedans il n'y a pas de fichier configure mais directement un makefile. Voici donc ce que j'obtiens en lançant make :

make


cc `pkg-config --cflags lxpanel --cflags gtk+-2.0` -Wall -Wextra -O -g -shared -fPIC lxbat.c -o lxbat.so `pkg-config --libs lxpanel --libs gtk+-2.0`
/bin/sh: 1: pkg-config: not found
/bin/sh: 1: pkg-config: not found
lxbat.c:16:21: fatal error: gtk/gtk.h: Aucun fichier ou dossier de ce type
 #include <gtk/gtk.h>
                     ^
compilation terminated.
Makefile:22 : la recette pour la cible « lxbat.so » a échouée
make: *** [lxbat.so] Erreur 1
 


N'étant pas très calé, je ne sais pas si la compilation a plus ou moins fonctionné (il est marqué "compilation terminated") etq eu je peux lancer make-install ou si les erreurs sont rédibitoires (et, dans ce cas, si je peux y faire quelque chose).

Merci d'avance pour vos réponses

Dernière modification par Harashi (30-11-2017 10:16:59)


Dell-Latitude D430

Hors ligne

#2 19-11-2017 21:08:43

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.11.12
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Compilation difficile avec Makefile

Salut,

Tu peux essayer déjà d'installer le paquet « pkg-config » :


apt-get install pkg-config
 



Mais ça ne suffira probablement pas. Il va manquer aussi les fichiers de développement. Tu devras rajouter aussi :
« gir1.2-gtk2.0 » et peut-être d'autres…


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#3 19-11-2017 21:52:12

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : [Résolu] Compilation difficile avec Makefile

Merci pour ta réponse, j'ai installé pkg-config mais là le make me met ça :

cc `pkg-config --cflags lxpanel --cflags gtk+-2.0` -Wall -Wextra -O -g -shared -fPIC lxbat.c -o lxbat.so `pkg-config --libs lxpanel --libs gtk+-2.0`
Package lxpanel was not found in the pkg-config search path.
Perhaps you should add the directory containing `lxpanel.pc'
to the PKG_CONFIG_PATH environment variable
No package 'lxpanel' found
Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found
Package lxpanel was not found in the pkg-config search path.
Perhaps you should add the directory containing `lxpanel.pc'
to the PKG_CONFIG_PATH environment variable
No package 'lxpanel' found
Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found
lxbat.c:16:21: fatal error: gtk/gtk.h: Aucun fichier ou dossier de ce type
 #include <gtk/gtk.h>
                     ^
compilation terminated.
Makefile:22 : la recette pour la cible « lxbat.so » a échouée
make: *** [lxbat.so] Erreur 1
 


De ce que je comprend il ne trouve pas lxpanel, ce qui est bizarre parce que je suis certain de l'avoir.

Par contre gir1.2-gtk2.0 ne semble pas être dans les dépôts stables.

EDIT : Avec gcc cela donne ça :

gcc lxbat.c


lxbat.c:16:21: fatal error: gtk/gtk.h: Aucun fichier ou dossier de ce type
 #include <gtk/gtk.h>
                     ^
compilation terminated.
 

Dernière modification par Harashi (19-11-2017 21:57:31)


Dell-Latitude D430

Hors ligne

#4 19-11-2017 22:48:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Compilation difficile avec Makefile

Bonsoir,

Installe les paquets libgtk2.0-dev et lxpanel-dev, qui fournissent ces fichiers de développement !
Par ailleurs le paquet gir1.2-gtk2.0 n'existe pas, effectivement, le nom correct est gir1.2-gtk-2.0.

Hors ligne

#5 19-11-2017 23:37:56

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.11.12
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Compilation difficile avec Makefile

humm gir1.2-gtk-2.0 pas dans stable (stretch) ? Pas possible :

https://packages.debian.org/stretch/gir1.2-gtk-2.0

Je m'étais juste trompée dans l'orthographe exacte…

Dernière modification par enicar (19-11-2017 23:40:16)


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#6 20-11-2017 11:19:34

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : [Résolu] Compilation difficile avec Makefile

En effet, hier soir je n'ai pas cherché plus loin que l'orthographe, maintenant c'est installé. Par contre j'obtiens ça :

make


cc `pkg-config --cflags lxpanel --cflags gtk+-2.0` -Wall -Wextra -O -g -shared -fPIC lxbat.c -o lxbat.so `pkg-config --libs lxpanel --libs gtk+-2.0`
Package lxpanel was not found in the pkg-config search path.
Perhaps you should add the directory containing `lxpanel.pc'
to the PKG_CONFIG_PATH environment variable
No package 'lxpanel' found
Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found
Package lxpanel was not found in the pkg-config search path.
Perhaps you should add the directory containing `lxpanel.pc'
to the PKG_CONFIG_PATH environment variable
No package 'lxpanel' found
Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found
lxbat.c:16:21: fatal error: gtk/gtk.h: Aucun fichier ou dossier de ce type
 #include <gtk/gtk.h>
                     ^
compilation terminated.
Makefile:22 : la recette pour la cible « lxbat.so » a échouée
make: *** [lxbat.so] Erreur 1
 


De ce que je comprend le chemin vers les dépendances n'est pas spécifié dans "pkg-config search path". Faut-il le rajouter à la main ou installer autre chose ?


Dell-Latitude D430

Hors ligne

#7 20-11-2017 13:26:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Compilation difficile avec Makefile

Re-,

Comme un petit peu suggéré au post #4 installer autre chose est une bonne idée ;

– le paquet lxpanel-dev, qui fournit :

/usr/lib/x86_64-linux-gnu/pkgconfig/lxpanel.pc


– le paquet libgtk2.0-dev, qui fournit :

/usr/lib/x86_64-linux-gnu/pkgconfig/gtk+-2.0.pc
/usr/include/gtk-2.0/gtk/gtk.h


À noter que le paquet gir1.2-gtk-2.0 est une dépendance du précédent...

Hors ligne

#8 20-11-2017 13:35:22

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.11.12
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Compilation difficile avec Makefile

Pour info, ce n'est pas encore le cas sur stretch visiblement, mais c'est le cas dans sid :
le paquet libgtk2.0-dev n'existe plus, on utilise plus que gir1.2-gtk-2.0…
Je ne sais pas ce que ça change en ce qui concerne les déclarations dans les fichiers sources.

La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#9 20-11-2017 14:08:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Compilation difficile avec Makefile

(Re-,

Pour info, [...] dans sid : le paquet libgtk2.0-dev n'existe plus, [...]

Ah ? Bon. Quelqu'un a juste dû se tromper dans l'orthographe exacte)

Hors ligne

#10 20-11-2017 15:05:37

enicar
Membre
Lieu : Grenoble
Distrib. : debian/sid
Noyau : Linux 4.11.12
(G)UI : openbox
Inscription : 26-08-2010

Re : [Résolu] Compilation difficile avec Makefile

èfpé a écrit :

Bon. Quelqu'un a juste dû se tromper dans l'orthographe exacte)


Non, même pas, j'ai des hallucinations, c'est la seule explication big_smile

Dernière modification par enicar (20-11-2017 15:05:58)


La machine, c'est dépassé ! On va tout remplacer par des humains big_smile

Hors ligne

#11 20-11-2017 17:30:21

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : [Résolu] Compilation difficile avec Makefile

èfpé a écrit :

Comme un petit peu suggéré au post #4 installer autre chose est une bonne idée ;


Alors en fait j'ai scrollé trop vite et je n'avais tout simplement pas vu le post mrgreen.gif

Du coup j'ai installé ces deux paquets, et maintenant ça donne ça :

make


cc `pkg-config --cflags lxpanel --cflags gtk+-2.0` -Wall -Wextra -O -g -shared -fPIC lxbat.c -o lxbat.so `pkg-config --libs lxpanel --libs gtk+-2.0`
lxbat.c:31:33: error: unknown type name ‘Plugin’
         GdkEventButton * event, Plugin * plugin);
                                 ^~~~~~
lxbat.c:35:35: error: unknown type name ‘Plugin’
           GSourceFunc apply_func, Plugin * plugin,
                                   ^~~~~~
lxbat.c:181:31: error: unknown type name ‘Plugin’
 static int lxbat_constructor (Plugin * p, char **fp)
                               ^~~~~~
lxbat.c:249:31: error: unknown type name ‘Plugin’
 static void lxbat_destructor (Plugin * p)
                               ^~~~~~
lxbat.c:262:36: error: unknown type name ‘Plugin’
 static void lxbat_apply_configure (Plugin * p)
                                    ^~~~~~
lxbat.c:270:30: error: unknown type name ‘Plugin’
 static void lxbat_configure (Plugin * p, GtkWindow * parent)
                              ^~~~~~
lxbat.c:285:39: error: unknown type name ‘Plugin’
 static void lxbat_save_configuration (Plugin * p, FILE * fp)
                                       ^~~~~~
lxbat.c:294:1: error: unknown type name ‘PluginClass’
 PluginClass lxbat_plugin_class = {
 ^~~~~~~~~~~
lxbat.c:297:2: error: ‘PLUGINCLASS_VERSIONING’ undeclared here (not in a function)
  PLUGINCLASS_VERSIONING,
  ^~~~~~~~~~~~~~~~~~~~~~
lxbat.c:300:2: error: field name not in record or union initializer
  type:"lxbat",
  ^~~~
lxbat.c:300:2: note: (near initialization for ‘lxbat_plugin_class’)
lxbat.c:300:7: warning: excess elements in scalar initializer
  type:"lxbat",
       ^~~~~~~
lxbat.c:300:7: note: (near initialization for ‘lxbat_plugin_class’)
lxbat.c:301:2: error: field name not in record or union initializer
  name:N_("Lx Battery Plugin"),
  ^~~~
lxbat.c:301:2: note: (near initialization for ‘lxbat_plugin_class’)
In file included from lxbat.c:18:0:
/usr/include/glib-2.0/glib/gi18n.h:28:20: warning: excess elements in scalar initializer
 #define N_(String) (String)
                    ^
lxbat.c:301:7: note: in expansion of macro ‘N_’
  name:N_("Lx Battery Plugin"),
       ^~
/usr/include/glib-2.0/glib/gi18n.h:28:20: note: (near initialization for ‘lxbat_plugin_class’)
 #define N_(String) (String)
                    ^
lxbat.c:301:7: note: in expansion of macro ‘N_’
  name:N_("Lx Battery Plugin"),
       ^~
lxbat.c:302:2: error: field name not in record or union initializer
  version:"1.0",
  ^~~~~~~
lxbat.c:302:2: note: (near initialization for ‘lxbat_plugin_class’)
lxbat.c:302:10: warning: excess elements in scalar initializer
  version:"1.0",
          ^~~~~
lxbat.c:302:10: note: (near initialization for ‘lxbat_plugin_class’)
lxbat.c:303:2: error: field name not in record or union initializer
  description:N_("Displays the battery charge percentage."),
  ^~~~~~~~~~~
lxbat.c:303:2: note: (near initialization for ‘lxbat_plugin_class’)
In file included from lxbat.c:18:0:
/usr/include/glib-2.0/glib/gi18n.h:28:20: warning: excess elements in scalar initializer
 #define N_(String) (String)
                    ^
lxbat.c:303:14: note: in expansion of macro ‘N_’
  description:N_("Displays the battery charge percentage."),
              ^~
/usr/include/glib-2.0/glib/gi18n.h:28:20: note: (near initialization for ‘lxbat_plugin_class’)
 #define N_(String) (String)
                    ^
lxbat.c:303:14: note: in expansion of macro ‘N_’
  description:N_("Displays the battery charge percentage."),
              ^~
lxbat.c:306:2: error: field name not in record or union initializer
  one_per_system:TRUE,
  ^~~~~~~~~~~~~~
lxbat.c:306:2: note: (near initialization for ‘lxbat_plugin_class’)
In file included from /usr/lib/x86_64-linux-gnu/glib-2.0/include/glibconfig.h:9:0,
                 from /usr/include/glib-2.0/glib/gtypes.h:32,
                 from /usr/include/glib-2.0/glib/galloca.h:32,
                 from /usr/include/glib-2.0/glib.h:30,
                 from /usr/include/glib-2.0/gobject/gbinding.h:28,
                 from /usr/include/glib-2.0/glib-object.h:23,
                 from /usr/include/glib-2.0/gio/gioenums.h:28,
                 from /usr/include/glib-2.0/gio/giotypes.h:28,
                 from /usr/include/glib-2.0/gio/gio.h:26,
                 from /usr/include/gtk-2.0/gdk/gdkapplaunchcontext.h:30,
                 from /usr/include/gtk-2.0/gdk/gdk.h:32,
                 from /usr/include/gtk-2.0/gtk/gtk.h:32,
                 from lxbat.c:16:
/usr/include/glib-2.0/glib/gmacros.h:284:14: warning: excess elements in scalar initializer
 #define TRUE (!FALSE)
              ^
lxbat.c:306:17: note: in expansion of macro ‘TRUE’
  one_per_system:TRUE,
                 ^~~~
/usr/include/glib-2.0/glib/gmacros.h:284:14: note: (near initialization for ‘lxbat_plugin_class’)
 #define TRUE (!FALSE)
              ^
lxbat.c:306:17: note: in expansion of macro ‘TRUE’
  one_per_system:TRUE,
                 ^~~~
lxbat.c:309:2: error: field name not in record or union initializer
  expand_available:FALSE,
  ^~~~~~~~~~~~~~~~
lxbat.c:309:2: note: (near initialization for ‘lxbat_plugin_class’)
In file included from /usr/lib/x86_64-linux-gnu/glib-2.0/include/glibconfig.h:9:0,
                 from /usr/include/glib-2.0/glib/gtypes.h:32,
                 from /usr/include/glib-2.0/glib/galloca.h:32,
                 from /usr/include/glib-2.0/glib.h:30,
                 from /usr/include/glib-2.0/gobject/gbinding.h:28,
                 from /usr/include/glib-2.0/glib-object.h:23,
                 from /usr/include/glib-2.0/gio/gioenums.h:28,
                 from /usr/include/glib-2.0/gio/giotypes.h:28,
                 from /usr/include/glib-2.0/gio/gio.h:26,
                 from /usr/include/gtk-2.0/gdk/gdkapplaunchcontext.h:30,
                 from /usr/include/gtk-2.0/gdk/gdk.h:32,
                 from /usr/include/gtk-2.0/gtk/gtk.h:32,
                 from lxbat.c:16:
/usr/include/glib-2.0/glib/gmacros.h:280:15: warning: excess elements in scalar initializer
 #define FALSE (0)
               ^
lxbat.c:309:19: note: in expansion of macro ‘FALSE’
  expand_available:FALSE,
                   ^~~~~
/usr/include/glib-2.0/glib/gmacros.h:280:15: note: (near initialization for ‘lxbat_plugin_class’)
 #define FALSE (0)
               ^
lxbat.c:309:19: note: in expansion of macro ‘FALSE’
  expand_available:FALSE,
                   ^~~~~
lxbat.c:312:2: error: field name not in record or union initializer
  constructor:lxbat_constructor,
  ^~~~~~~~~~~
lxbat.c:312:2: note: (near initialization for ‘lxbat_plugin_class’)
lxbat.c:312:14: error: ‘lxbat_constructor’ undeclared here (not in a function)
  constructor:lxbat_constructor,
              ^~~~~~~~~~~~~~~~~
lxbat.c:312:14: warning: excess elements in scalar initializer
lxbat.c:312:14: note: (near initialization for ‘lxbat_plugin_class’)
lxbat.c:313:2: error: field name not in record or union initializer
  destructor:lxbat_destructor,
  ^~~~~~~~~~
lxbat.c:313:2: note: (near initialization for ‘lxbat_plugin_class’)
lxbat.c:313:13: error: ‘lxbat_destructor’ undeclared here (not in a function)
  destructor:lxbat_destructor,
             ^~~~~~~~~~~~~~~~
lxbat.c:313:13: warning: excess elements in scalar initializer
lxbat.c:313:13: note: (near initialization for ‘lxbat_plugin_class’)
lxbat.c:314:2: error: field name not in record or union initializer
  config:lxbat_configure,
  ^~~~~~
lxbat.c:314:2: note: (near initialization for ‘lxbat_plugin_class’)
lxbat.c:314:9: error: ‘lxbat_configure’ undeclared here (not in a function)
  config:lxbat_configure,
         ^~~~~~~~~~~~~~~
lxbat.c:314:9: warning: excess elements in scalar initializer
lxbat.c:314:9: note: (near initialization for ‘lxbat_plugin_class’)
lxbat.c:315:2: error: field name not in record or union initializer
  save:lxbat_save_configuration
  ^~~~
lxbat.c:315:2: note: (near initialization for ‘lxbat_plugin_class’)
lxbat.c:315:7: error: ‘lxbat_save_configuration’ undeclared here (not in a function)
  save:lxbat_save_configuration
       ^~~~~~~~~~~~~~~~~~~~~~~~
lxbat.c:315:7: warning: excess elements in scalar initializer
lxbat.c:315:7: note: (near initialization for ‘lxbat_plugin_class’)
lxbat.c:150:12: warning: ‘update_display’ defined but not used [-Wunused-function]
 static int update_display (LxbatPlugin * pLxbat)
            ^~~~~~~~~~~~~~
Makefile:22 : la recette pour la cible « lxbat.so » a échouée
make: *** [lxbat.so] Erreur 1
 


Dell-Latitude D430

Hors ligne

#12 20-11-2017 20:02:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Compilation difficile avec Makefile

Re-,

OK ; donc en gros yapluka réécrire lxbat.c, en s'inspirant du code source de lxpanel 0.9.3-1 big_smile

À noter que les paquets Debian de Pau Oliva étaient surtout destinés à Ubuntu 11.10/12.04 hmm

Hors ligne

#13 20-11-2017 23:22:19

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : [Résolu] Compilation difficile avec Makefile

Bonsoir smile
Et ce n’est pas possible d’utiliser le plugin de xfc4 xfce4-battery-plugin sur lxde ? J’imagine que non et c’est dommage car il répond à la demande d’affichage je crois.
Ou voir si xfce ne pourrait remplacer lxde ?

Hors ligne

#14 21-11-2017 19:42:11

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : [Résolu] Compilation difficile avec Makefile

chalu a écrit :

Et ce n’est pas possible d’utiliser le plugin de xfc4 xfce4-battery-plugin sur lxde ?


Dans le doute j'ai essayé mais effectivement ça ne marche pas avec LXPanel.

chalu a écrit :

Ou voir si xfce ne pourrait remplacer lxde ?


En fait c'est l'inverse cool, avant j'étais sur xfce et je suis passé à lxde car mon ordi est très vieux (plus de 10 ans) et il réagi mieux avec lxde, en plus openbox donne plus de batterie. Du coup je ne vais pas re-changer juste parce que je veux avoir le pourcentage de batterie affiché en permanence (dans le pire des cas je met tint2 à la place de LXPanel).

èfpé a écrit :


OK ; donc en gros yapluka réécrire lxbat.c, en s'inspirant du code source de lxpanel 0.9.3-1


En gros c'est foutu, quoi hmm ?


Dell-Latitude D430

Hors ligne

#15 21-11-2017 21:14:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Compilation difficile avec Makefile

Re-,

Vu le nombre d'erreurs, rendre le bidule compilable sur Debian 9 Stretch prendrait un certain temps... mais pour l'anecdote le bazar (la bibliothèque lxbat.so) est compilé en trois secondes sur Debian 7 Wheezy (Live) ; avant d'écrire que c'est foutu, et n'ayant rien à perdre, je tenterais tout de même la version compilée pour Ubuntu 12.04 :

cd ~/Téléchargements
wget http://ppa.launchpad.net/poliva/pof/ubuntu/pool/main/l/lxbat/lxbat_1.0-ubuntu1_amd64.deb

et,

dpkg -x lxbat_1.0-ubuntu1_amd64.deb lxbat

cp ./lxbat/usr/lib64/lxpanel/plugins/lxbat.so /usr/lib/x86_64-linux-gnu/lxpanel/plugins

ou

dpkg -i lxbat_1.0-ubuntu1_amd64.deb
ln -s /usr/lib64/lxpanel/plugins/lxbat.so /usr/lib/x86_64-linux-gnu/lxpanel/plugins


La méthode manuelle copie la bibliothèque lxbat.so dans le bon répertoire (avec ses copines greffon⋅ne⋅s), alors que l'installation du paquet nécessite un ajustement, suivi d'un changement de session. Le machin (Lx Battery Plugin) apparaît dans la liste des greffons disponibles, puis dans celle des appliquettes du tableau de bord, mais je ne sais pas s'il est fonctionnel, car je n'ai testé qu'en Live... sur un bon vieux desktop hmm

Dernière modification par èfpé (23-11-2017 20:14:42)

Hors ligne

#16 22-11-2017 14:22:30

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : [Résolu] Compilation difficile avec Makefile

Alors, j'ai tenté la première méthode (avec dkpg -x) et j'ai effectivement "LX battery plugin" dans la liste des ajouts du tableau de bord LXPanel. Du coup je l'ajoute au tableau de bord et j'ai bien un espace comme si le plugin était là, mais rien ne s'affiche. Un clic droit depuis le tableau de bord ne donne rien, mais en double-cliquant dessus dans la liste des plugins j'ai accès aux paramètres et l'écriture est bien réglée sur blanc (rouge si le niveau est critique), donc elle ne se confond pas avec le tableau, c'est juste qu'elle ne s'affiche pas.

Y'a moyen de bidouiller, ou on s'aventure en terrain dangereux biggreen.gif ?

Dell-Latitude D430

Hors ligne

#17 22-11-2017 21:30:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Compilation difficile avec Makefile

Re-,

OK ; ça commence à sentir le sapin de Noël, mais bon... devoir survoler l'applet pour avoir le pourcentage « exact », n'est pas la mort, non plus. Quoi qu'il en soit il pourrait être intéressant de savoir si le truc fonctionn/e/ait sous Debian 7 Wheezy (Live) :

sudo apt-get update
sudo apt-get install --no-install-recommends libgtk2.0-dev libmenu-cache1-dev
mkdir ~/Downloads
cd ~/Downloads
wget https://github.com/poliva/lxbat/archive/master.zip
unzip master.zip
cd lxbat-master

make

cc `pkg-config --cflags lxpanel --cflags gtk+-2.0` -Wall -Wextra -O -g -shared -fPIC lxbat.c -o lxbat.so `pkg-config --libs lxpanel --libs gtk+-2.0`

sudo make install

mkdir -p //usr/lib64/lxpanel/plugins
/usr/bin/install -c -m 644 ./lxbat.so //usr/lib64/lxpanel/plugins/

sudo ln -sv /usr/lib64/lxpanel/plugins/lxbat.so /usr/lib/x86_64-linux-gnu/lxpanel/plugins

`/usr/lib/x86_64-linux-gnu/lxpanel/plugins/lxbat.so' -> `/usr/lib64/lxpanel/plugins/lxbat.so'


À noter que lxbat va chercher les infos dans le répertoire /proc/acpi/battery :

ls -lR /proc/acpi/battery


Et comme tu l'as déjà écrit par ailleurs il y a toujours Conky et compagnie wink

Dernière modification par èfpé (24-11-2017 10:30:42)

Hors ligne

#18 24-11-2017 16:34:41

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : [Résolu] Compilation difficile avec Makefile

èfpé a écrit :

devoir survoler l'applet pour avoir le pourcentage « exact », n'est pas la mort, non plus.


Non c'est vrai, en fait je ne pensais pas que compiler un aussi petit truc qu'un indicateur de pourcentage de batterie s'avèrerait si compliqué big_smile Je vais plutôt essayer de me tourner vers d'autres solutions (car je me sers de cet ordinausore pour prendre mes cours et j'ai l'habitude de tout faire au clavier car la souris est un trackpad, d'où la flemme de survoler l'applet wink).

èfpé a écrit :

À noter que lxbat va chercher les infos dans le répertoire /proc/acpi/battery


Ca explique peut-être pourquoi ça ne fonctionne pas, car je n'ai pas ce répertoire sous Stretch :

ls /proc/acpi/


button  wakeup


Dell-Latitude D430

Hors ligne

#19 24-11-2017 21:26:42

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Compilation difficile avec Makefile

Re-,

Hé oui... nous aurions dû commencer par là, l'applet native va chercher les infos ailleurs :

ls -lR /sys/class/power_supply


Pour finir, contribuer à l'applet Debian LXDE officielle aurait bien plus de sens roll

Hors ligne

#20 27-11-2017 11:25:38

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : [Résolu] Compilation difficile avec Makefile

Et donc, en désespoir de cause, n'y aurait-il pas moyen de modifier quelques lignes dans le code de lxbat pour le faire aller chercher ces informations dans le bon répertoire ? Ou bien cela s'annonce-t-il trop compliqué ?

Dell-Latitude D430

Hors ligne

#21 27-11-2017 22:42:24

èfpé
Membre
Inscription : 10-07-2016

Re : [Résolu] Compilation difficile avec Makefile

Re-,

Alors, lxbat étant diffusé selon les termes de la GNU General Public License v2.0, une adaptation du code est envisageable... encore faudrait-il parvenir à le compiler sous Debian 9 Stretch et pouvoir le tester sur une machine similaire ; actuellement ce n'est pas le cas (je ne peux pas tester à ta place les manips des posts #17 et #19, par exemple).

Encore une fois, contribuer à l'applet Debian LXDE officielle (rapport de bogue, contribution au code) serait bien plus élégant et dans l'esprit du libre... si tu restes sur ta première idée, n'hésite pas à ouvrir une discussion dans la section adaptée.

Dernière modification par èfpé (27-11-2017 22:52:24)

Hors ligne

#22 30-11-2017 10:14:58

Harashi
Membre
Lieu : Paris
Distrib. : Debian 9.1 (Stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : Lxde
Inscription : 15-09-2017

Re : [Résolu] Compilation difficile avec Makefile

èfpé a écrit :

Encore une fois, contribuer à l'applet Debian LXDE officielle (rapport de bogue, contribution au code) serait bien plus élégant et dans l'esprit du libre...


Ce serait avec plaisir, mais je pense n'avoir ni le temps ni les compétences pour le faire hmm Étant donné que la compilation a tout de même réussie, bien que difficilement, je vais passer le sujet en résolu. Je suis tout de même étonné que personne au sein du projet LXDE n'ait jamais pensé à ça, parce qu'afficher le pourcentage de batterie me parait être une fonction de base qui ne demande pas tant de ressources que ça, mais il doit sûrement y avoir une raison.

En tout cas merci à vous pour votre aide smile

Dernière modification par Harashi (30-11-2017 10:16:18)


Dell-Latitude D430

Hors ligne

Pied de page des forums