Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-11-2017 20:40:59

evanescente~ondine
Membre
Distrib. : Debian 9 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : mate
Inscription : 31-10-2014

erreurs /etc/sudo.conf, ligne 0 chargement greffon " sudoers_policy "

=>

sudo nano /etc/sudo.conf


sudo: erreur dans /etc/sudo.conf, ligne 0 lors du chargement du greffon « sudoers_policy »
sudo: seul le propriétaire doit pouvoir écrire dans /usr/lib/sudo/sudoers.so
sudo: erreur fatale, impossible de charger les greffons



Qu'est-ce ça veut donc dire ?
C'est arrivé juste après avoir interrompu avec Ctrl-c une commande du type sudo chmod a+rw /usr.
Redémarré, c'était toujours là, j'ai du purgé et réinstallé sudo, remodifié /etc/passwd, pour rétablir. Puis c'est revenu trente minutes plus tard !

Edit à toto : mis la commande sudo et son retour avec les balises Code user du forum.

Hors ligne

#2 21-11-2017 23:32:56

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : erreurs /etc/sudo.conf, ligne 0 chargement greffon " sudoers_policy "

Bonsoir

Pourrais-tu me copier/coller dans ton prochain message
le retour de la commande suivante ?

ls -l /usr/lib/sudo/sudoers.so



Ça devrait donner un retour comme ça :

ls -l /usr/lib/sudo/sudoers.so


-rw-r--r-- 1 root root 337696 juin   5 14:22 /usr/lib/sudo/sudoers.so
michel@debian:~$



Merci

=======
Comme je n'en avais jamais vu, et pour vérifier,
je viens d'installer un système debian avec, et un autre sans sudo
et je n'y ai pas trouvé de fichier /etc/sudo.conf
Bizarre…Il s'agit peut-être d'une autre distribution comme Elementary OS par exemple.

Dernière modification par MicP (21-11-2017 23:41:15)

Hors ligne

#3 22-11-2017 04:21:12

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : erreurs /etc/sudo.conf, ligne 0 chargement greffon " sudoers_policy "

@evanescente~ondine : Comme toto l'a fait pour ton post précédent, ce serait cool si tu pouvais éditer tes messages pour faire ressortir les commandes, leurs sorties, etc. en utilisant la balise code.
Voir le tuto Le code, ça pique moins les yeux en couleur en lien ici : http://wiki.debian-facile.org/atelier:c … syntaxique.

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 22-11-2017 10:51:20

evanescente~ondine
Membre
Distrib. : Debian 9 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : mate
Inscription : 31-10-2014

Re : erreurs /etc/sudo.conf, ligne 0 chargement greffon " sudoers_policy "

Ok!

ls -l /usr/lib/sudo/sudoers.so
 

-rwxrwxrwx 1 root root 337696 juin   5 14:22 /usr/lib/sudo/sudoers.so
 

Hors ligne

#5 22-11-2017 11:14:21

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : erreurs /etc/sudo.conf, ligne 0 chargement greffon " sudoers_policy "

evanescente~ondine a écrit :

-rwxrwxrwx 1 root root 337696 juin   5 14:22 /usr/lib/sudo/sudoers.so


Les droits sont tous ouverts alors que ceux proposés en exemple par

MicP a écrit :

-rw-r--r-- 1 root root 337696 juin   5 14:22 /usr/lib/sudo/sudoers.so


Sont beaucoup plus limités.

Voir la page des droits unix pour comprendre :
https://debian-facile.org/doc:systeme:droits-unix
ou ici plus détaillé en complément :
https://debian-facile.org/doc:systeme:droits-unix-bis

Force et courage


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#6 22-11-2017 14:32:57

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : erreurs /etc/sudo.conf, ligne 0 chargement greffon " sudoers_policy "

Bonjour

Il faudrait que tu change les droits du fichier /usr/lib/sudo/sudoers.so
avec la ligne de commande suivante entrée avec les privilèges du compte root :

chmod 644 /usr/lib/sudo/sudoers.so


Peut-être, si cela t'es encore possible, en utilisant la ligne de commandes suivante
depuis ton compte utilisateur :

sudo chmod 644 /usr/lib/sudo/sudoers.so

Dernière modification par MicP (22-11-2017 14:33:45)

Hors ligne

#7 22-11-2017 14:36:39

evanescente~ondine
Membre
Distrib. : Debian 9 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : mate
Inscription : 31-10-2014

Re : erreurs /etc/sudo.conf, ligne 0 chargement greffon " sudoers_policy "

Peut on fermer/mettre en veille en ligne de commande sans passer par su ? On peut bien le faire en cliquant sur un bouton...
Sinon, ça marche. Merci. J'ai déjà vu le cas ailleurs, où trop de droits mettait en berne une fonction. Assez logique, même si faut le savoir.

Hors ligne

#8 22-11-2017 14:46:18

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : erreurs /etc/sudo.conf, ligne 0 chargement greffon " sudoers_policy "

evanescente~ondine a écrit :

Peut on fermer/mettre en veille en ligne de commande sans passer par su ?


avec :

sudo -i


Tu restes superutilisateur wink


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#9 22-11-2017 14:48:32

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : erreurs /etc/sudo.conf, ligne 0 chargement greffon " sudoers_policy "

Tout dépends des privilèges qui ont été accordés sur ton système debian au compte utilisateur qui va entrer la commande,
et du type de veille que tu veux utiliser.

Essaye avec :

systemctl suspend


ou bien, pour la veille prolongée (aussi appelée "hibernation") :

systemctl hibernate

EDIT : Je viens de faire un test,
les deux lignes de commande ci-dessus ont fonctionné depuis un compte utilisateur non privilégié sur ma machine.

=======
Sinon, peut-être aussi en utilisant ces lignes de commande
avec les privilèges du compte root par sudo

sudo systemctl suspend

ou, si c'est possible, depuis le compte root
ou en utilisant la ligne de commande proposée par smolsky qui te permettra passer sous le compte root dans son environnement.

Dernière modification par MicP (22-11-2017 15:06:47)

Hors ligne

#10 22-11-2017 16:31:33

evanescente~ondine
Membre
Distrib. : Debian 9 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : mate
Inscription : 31-10-2014

Re : erreurs /etc/sudo.conf, ligne 0 chargement greffon " sudoers_policy "

Oh ! Agréable surprise. J'étais convaincu du contraire ! Merci beaucoup.

Hors ligne

#11 22-11-2017 17:37:16

MicP
Membre
Distrib. : debian stable
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce
Inscription : 29-02-2016

Re : erreurs /etc/sudo.conf, ligne 0 chargement greffon " sudoers_policy "

… On peut bien le faire en cliquant sur un bouton.…


Si tu veux créer une icône sur ton bureau que tu n'aura plus qu'à cliquer pour mettre ta machine en hibernation,
il te faut faire un clic droit sur le bureau,
et dans la liste des options du menu contextuel qui s'affiche,
choisir : Créer un lanceur…

puis mettre systemctl suspend dans la zone de saisie associée à Commande :

ensuite, tu mets ce qu'il te plait dans les autres champs de la boîte de dialogue.

Hors ligne

#12 22-11-2017 22:06:13

evanescente~ondine
Membre
Distrib. : Debian 9 (stretch)
Noyau : Linux 4.9.0-3-amd64
(G)UI : mate
Inscription : 31-10-2014

Re : erreurs /etc/sudo.conf, ligne 0 chargement greffon " sudoers_policy "

Je me suis aperçu que les commandes marchaient bien sans sudo, contrairement à ce que je pensais. Très bien ! Les raccourcis fonctionnent donc et je garde une bonne sécurité quand même.

Hors ligne

#13 22-11-2017 22:43:46

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : erreurs /etc/sudo.conf, ligne 0 chargement greffon " sudoers_policy "


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums