Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-11-2009 13:07:15

dnartreb89
Membre
Distrib. : Squeeze
Noyau : 2.6.30-2-686
(G)UI : gnome
Inscription : 09-09-2008
Site Web

Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

Salut les gars !

Suite à la remarque de  smolski j'ouvre un autre post au lieu de polluer les existants ! big_smile

Bon, j'explique ce qui m'arrive.

Mon Pc tournait depuis un bon moment sur lenny. Et moi trés trés content.

J'ai acheté la semaine dernière un disque dur extérne de 1To5 pour faire de l'archivage. Et pour pouvoir passer chez les potes avec, je l'ai gardé en ntfs.

Mais du coup, sous lenny, je me retrouvait avec

sudo ntfs-3g /dev/sdd /monmontage

dès que je voulait y accéder.

Je me suis donc dit, voila l'occasion de repasser en testing. Ca devrait résoudre le problème.

Problème résolu. J'ai accés facilement au disque.

Par contre, plus de 3D. Et j'aime la 3D ! big_smile

Donc, recherche un peu partout. Et aprés bien des opérations, aucun résultat.

J'ai fait :

[c]# rm -rf /usr/src/modules
# apt-get install nvidia-kernel-common
# apt-get install -t unstable nvidia-kernel-source
# m-a update
# m-a prepare
# m-a clean nvidia-kernel
# m-a a-i nvidia-kernel-source
# apt-get install -t unstable nvidia-glx
# apt-get install nvidia-settings[/c]

avec ce source.list :

[c]# Squeeze
deb http://ftp.fr.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ squeeze main contrib non-free

deb http://security.debian.org/ squeeze/updates main contrib


## sid
deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ sid main contrib non-free

deb http://download.tuxfamily.org/dvorak/debian squeeze main[/c]

et ce fichier de préférences:

[c]
Package: *
Pin: release a=testing
Pin-priority: 900

Package: *
Pin: release a=unstable
Pin-priority: 90[/c]


Rien ! Nenni.

J'ai même essayer le .run de nvidia, rien nenni.

mon noyau : 2.6.30-2-686

Sur ce coup la, j'y comprend rien. J'ai désinstallé tout ce qui touchait à nvidia. Refait la manip 6 ou 7 fois, et rien.

Quelqu'un à une piste ?

merci d'avance

Dernière modification par dnartreb89 (11-11-2009 16:16:27)

Hors ligne

#2 07-11-2009 13:44:20

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

Bonjour (re) dnartreb89,

Pour la carte jeu sais pas. roll

Pour l'accès au disk avec lenny, je pense à des problèmes de droits à mettre en place. cool

Yop ! big_smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 07-11-2009 18:52:17

Tophe
Membre
Lieu : Ardeche
Distrib. : Stable
(G)UI : Kde
Inscription : 11-10-2008

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

Sur ma Squeeze, j'avais du installer les drivers nvidia de Sid. Actuellement je ne sais pas car je ne l'ai pas mise à jour depuis qq temps.
Je mets mon tuto "perso" mais as tu vérifié l'activation du driver nvidia dans le fichier /etc/X11/xorg.conf comme indiqué plus bas ? on ne sait jamais hmm

INSTALLATION DES PILOTES NVIDIA :

À PARTIR DE SID :
apt-get install -t unstable nvidia-kernel-source nvidia-kernel-common
ensuite
    m-a prepare
    m-a update
    m-a a-i nvidia
et puis si tout c'est bien passé on finit par :
apt-get install -t unstable nvidia-glx nvidia-settings


RETOUR D'EXPÉRIENCE
Si ça coince à la compilation avec module-assistant c'est qu'il y a un conflit avec une installation antérieure
Donc voila une suite de commande à faire dans un terminal :
$ su
# rm -rf /usr/src/modules/nvidia-kernel/
# cd /usr/src
# tar xjvf nvidia-kernel.tar.bz2
# cd modules/nvidia-kernel/debian
# cp control.template control
# m-a a-i -i nvidia-kernel-source
# apt-get install -t unstable nvidia-glx (si on installe à partir de Sid)
ou
# apt-get install nvidia-glx (si on installe à partir de Stable)

Vérifier l'activation du driver nvidia dans le fichier /etc/X11/xorg.conf
Section "Device"
    Identifier    "Configured Video Device"
    Driver        "nvidia"
    Option        "NoLogo"
EndSection

Puis rebooter l'ordi

PS : lorsque l'on compile un autre noyau nvidia, et avant de redémarrer, il faut modifier xorg.conf et remettre "nv". Ensuite, une fois démarré sur le bon noyau, on recompile nvidia pour le nouveau noyau.
Si l'on oublie et que le serveur X ne redémarre pas, faaire la modif par : nano /etc/X11/xorg.conf

Dernière modification par Tophe (07-11-2009 18:53:48)


* AMD Athlon 64 3500+ / ASUS A8N-SLI / nVidia GeForce 6200 / RAM 1Go / Debian Stable / KDE
* Eee PC X101CH / RAM 1Go / Debian Stable / KDE
Xtophe - Ardèche

Hors ligne

#4 07-11-2009 19:25:49

dnartreb89
Membre
Distrib. : Squeeze
Noyau : 2.6.30-2-686
(G)UI : gnome
Inscription : 09-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

Décidement j'ai pas de bol !

J'ai essayé une première fois ta techique. J'ai vu un résultat de compilation trés différent de ce que je voyait jusque la, donc j'y ait cru a fond. Modification d'xorg ! Et rien du tout !

Du coup, j'ai retiré tout les paquets "nvidia", fait un apt-get clean, effacé le répertoire /usr/src/modules, effacé l'ancien paquet .deb nvidia généré, les linux-headers plus nécessaires(2.6.26*) dans /usr/src et recommencé la manip. Toujours rien.

La ! pour le coup, je séche.

Je pourrait sinon revenir au noyau précédent et faire une compilation de la branche stable, mais se serait dommage, j'ai des périphériques reconnus depuis le nouveau noyau, je préférerait le garder.

Quelqu'un a une autre idée? big_smile

Dernière modification par dnartreb89 (07-11-2009 19:27:30)

Hors ligne

#5 07-11-2009 19:47:00

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

Hop !

Ou bien te mettre en sid, des fois que..?
http://debian-facile.org/wiki/manuel:so … e_unstable

Yep ?

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#6 07-11-2009 20:11:49

dnartreb89
Membre
Distrib. : Squeeze
Noyau : 2.6.30-2-686
(G)UI : gnome
Inscription : 09-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

je cherche ! je cherche ! je vais finir par y arriver ! big_smile

Hors ligne

#7 07-11-2009 20:19:33

dnartreb89
Membre
Distrib. : Squeeze
Noyau : 2.6.30-2-686
(G)UI : gnome
Inscription : 09-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

J'y comprend plus rien !

Pour nettoyer toute trace de mon test avec le .run

J'ai fait un :

[c]
# find / -name "*nvidia*" -delete[/c]

Puis j'ai supprimé à la mano les répertoires contenant le mot nvidia que find ne voulait pas effacer.

Cf :http://forum.debian-fr.org/viewtopic.ph … 80493e7bc4

J'ai refait toute la manip, effacé les paquets, apt-cache clean, on recommence ! Et rien !

Passer en Sid, j'ai un doute, j'étais revenu à une époque en stable pour que ca tourne rond, super rond. Je repasse en testing, je me sent pas passer en unstable.

Hors ligne

#8 07-11-2009 20:26:15

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

Salut dnartreb89

# Squeeze
deb http://ftp.fr.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ squeeze main contrib non-free

deb http://security.debian.org/ squeeze/updates main contrib


Il manque une ligne à ton sources.list
Voici comment je l'écrirais

# Squeeze
# main, contrib et non-free
deb http://ftp.fr.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ squeeze main contrib non-free

# sécurité
deb http://security.debian.org/ squeeze/updates main contrib
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

# sid
deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ sid main contrib non-free

deb http://download.tuxfamily.org/dvorak/debian squeeze main


dnartreb89 a écrit :

J'ai fait :

# rm -rf /usr/src/modules
# apt-get install nvidia-kernel-common
# apt-get install -t unstable nvidia-kernel-source
# m-a update
# m-a prepare
# m-a clean nvidia-kernel
# m-a a-i nvidia-kernel-source
# apt-get install -t unstable nvidia-glx
# apt-get install nvidia-settings


Evite de lancer cette commande # rm -rf /usr/src/modules
c'est à éviter

Evite aussi cette commande

# m-a a-i nvidia-kernel-source


Elle ne fonctionne pas

Suit donc cette méthode

- Méthode à suivre

# aptitude install nvidia-kernel-common
# aptitude install -t unstable nvidia-kernel-source
# m-a update
# m-a prepare
# m-a clean nvidia-kernel
# aptitude install -t unstable nvidia-glx
# vim /etc/X11/xorg.conf
(Remplacé "nv" par "nvidia")


Utilise donc aptitude il gère mieux les dépendances.

Bon courage !
damien


logo_3dminfographie_signature.png

Hors ligne

#9 07-11-2009 21:15:54

dnartreb89
Membre
Distrib. : Squeeze
Noyau : 2.6.30-2-686
(G)UI : gnome
Inscription : 09-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

Merci de l'info ! Je vais réessayer un peu plus tard ! Aprés x tests, j'en ai un peu marre.

Hors ligne

#10 07-11-2009 21:50:29

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

De rien man

S'il te plait peux-tu indiquer clairement où est-ce qu'il plante ?
GNU/Linux te renvoie toujours un message que ce soit une erreur ou non...
Recopie le message d'erreur sur un feuille de papier et écrit le sur cette discussion.
Voici un exemple ici
C'est plus facile ensuite pour t'aider.

Peux-tu me dire si le paquet xserver-xorg-video-nv est installé sur ton système ?
Voici une commande intéressante qui te permet de savoir

aptitude show xserver-xorg-video-nv


Comment as-tu fait pour mettre à jour ta debian ?
un conseil utilise aptitude update puis aptitude safe-upgrade

Bon courage !
damien


logo_3dminfographie_signature.png

Hors ligne

#11 09-11-2009 09:26:31

dnartreb89
Membre
Distrib. : Squeeze
Noyau : 2.6.30-2-686
(G)UI : gnome
Inscription : 09-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

Hello !

xserver-xorg-video-nv est bien installé, je tourne actuellement sur ce pilote.

En effet, aptitude gére mieux les dépendances, il m'a mis à jour la fameuse libc6 que apt ne m'avait pas mis à jour !

Pour ma mise à jour, j'avais fait un

apt-get dist-upgrade puis apt-get upgrade

Du coup, j'ai refait la manip compléte, et toujours rien !

Mais voici un extrait de log d'Xorg:

[c](II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
    compiled for 1.6.5, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
    compiled for 1.6.5, module version = 1.1.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
    compiled for 4.0.2, module version = 1.0.0
    Module class: X.Org Video Driver
(EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
(EE) NVIDIA:     system's kernel log for additional error messages.
(II) UnloadModule: "nvidia"
(II) Unloading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(EE) Failed to load module "nvidia" (module-specific error, 0)
(EE) No drivers available.

Fatal server error:
no screens found[/c]

J'avais pensé à une erreur avec les doubles / , mais les autres modules se chargent ainsi.

j'ai pensé aussi à une abcence de nvidia_drv.so dans le dossier indiqué, mais il est bien la !

Je vais continuer à chercher. big_smile

Hors ligne

#12 09-11-2009 10:05:33

dnartreb89
Membre
Distrib. : Squeeze
Noyau : 2.6.30-2-686
(G)UI : gnome
Inscription : 09-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

Une chose intéressante !

Une nouvelle piste. Une fois tout installé, un petit :


[c]
modprobe nvidia[/c]

me renvoie :

[c]root@debian:/sbin# modprobe nvidia
WARNING: All config files need .conf: /etc/modprobe.d/nvidia-kernel-nkc, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/lrm-video, it will be ignored in a future release.[/c]

je part donc à la recherche de lrm-video qui semble abcent du répéertoire /etc/modprobe.d

A bientôt

Hors ligne

#13 09-11-2009 11:08:08

dnartreb89
Membre
Distrib. : Squeeze
Noyau : 2.6.30-2-686
(G)UI : gnome
Inscription : 09-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

Bon, lrm-video est une fausse piste.

Je m'emballe. C'est ce bon sang de pilote nvidia qui fait la tronche.

J'en viens à me poser la question de passer en sid, de laisser la pilote nv ou je sait pas encore.

Ce qui est sur, c'est que je ne voudrait pas réinstaller. Raz le bol des installs.

J'ai quitté Ubuntu car une mise à jour tout les 6 mois, ca m'agacait. J'ai remis une debian stable parce que je veut pas passer mon temps à régler des détails sur le pc ( pleins d'autres choses à faire en dehors), du coup je sait plus trop quoi faire pour ce problème nvidia.

Je vais attendre un peu, pas aller trop vite! big_smile

Hors ligne

#14 09-11-2009 14:02:53

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

Salut dnartre89 !

Peux-tu nous renvoyer ce que te dit cette commande

cat /etc/X11/xorg.conf


a+
damien


logo_3dminfographie_signature.png

Hors ligne

#15 09-11-2009 14:11:01

dnartreb89
Membre
Distrib. : Squeeze
Noyau : 2.6.30-2-686
(G)UI : gnome
Inscription : 09-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

Voila mon fichier Xorg.conf, actuellement avec le pilote libre !

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"

  # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

  # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbLayout" "fr"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       30.0 - 110.0
    VertRefresh     50.0 - 150.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "nVidia Corporation NV43 [GeForce 6600 GT]"
    Driver         "nv"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


big_smile

et pour info , le résultat de :

$ dpkg -l | grep nvidia

ii  nvidia-glx                             185.18.36-2                 NVIDIA binary Xorg driver
ii  nvidia-kernel-2.6.30-2-686             185.18.36-2+2.6.30-8        NVIDIA binary kernel module for Linux 2.6.30-2-686
ii  nvidia-kernel-common                   20080825+1                  NVIDIA binary kernel module common files
ii  nvidia-kernel-source                   185.18.36-2                 NVIDIA binary kernel module source
ii  nvidia-libvdpau1                       185.18.36-2                 NVIDIA vdpau libraries
ii  nvidia-settings                        185.18.31-1                 Tool for configuring the NVIDIA graphics driver
ii  nvidia-xconfig                         1.0+20080522-2              The NVIDIA X Configuration Tool

Dernière modification par dnartreb89 (09-11-2009 18:03:24)

Hors ligne

#16 09-11-2009 20:19:40

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

Salut dnartreb89

Il va falloir que tu régénère ton xorg.conf
Avant toute opération fait une copie de ton xorg.conf

cp /etc/X11/xorg.conf /home/ton_user/xorg.conf


Ensuite voici la marche à suivre
Ouvre le tty2 Ctrl+Alt+F2
login : root
mot de passe : ton_mot_de_passe_root

# /etc/init.d/gdm stop


Ensuite

# Xorg -configure


Tu obtiendras un nouveau xorg
cf. /root/xorg.conf.new
Ensuite il ne reste plus qu'à remplacer ton ancien xorg par le nouveau

# cp /root/xorg.conf.new /etc/X11/xorg.conf


Puis tu redémarre gdm

# /etc/init.d/gdm start


Ensuite tu vas pouvoir relancer l'install de ton pilote nvidia comme écrit ci-dessous

# aptitude install nvidia-kernel-common
# aptitude install -t unstable nvidia-kernel-source
# m-a update
# m-a prepare
# m-a clean nvidia-kernel
# aptitude install -t unstable nvidia-glx
# vim /etc/X11/xorg.conf
(Remplacé "nv" par "nvidia")


Bon courage !
damien


logo_3dminfographie_signature.png

Hors ligne

#17 09-11-2009 20:51:55

dnartreb89
Membre
Distrib. : Squeeze
Noyau : 2.6.30-2-686
(G)UI : gnome
Inscription : 09-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

Ben ca m'a fait un beau xorg.conf tout propre:

Section "ServerLayout"
  Identifier     "X.org Configured"
  Screen      0  "Screen0" 0 0
  InputDevice    "Mouse0" "CorePointer"
  InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
  ModulePath   "/usr/lib/xorg/modules"
  FontPath     "/usr/share/fonts/X11/misc"
  FontPath     "/usr/share/fonts/X11/cyrillic"
  FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
  FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
  FontPath     "/usr/share/fonts/X11/Type1"
  FontPath     "/usr/share/fonts/X11/100dpi"
  FontPath     "/usr/share/fonts/X11/75dpi"
  FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
  FontPath     "built-ins"
EndSection

Section "Module"
  Load  "dri2"
  Load  "dbe"
  Load  "extmod"
  Load  "glx"
  Load  "dri"
  Load  "record"
EndSection

Section "InputDevice"
  Identifier  "Keyboard0"
  Driver      "kbd"
EndSection

Section "InputDevice"
  Identifier  "Mouse0"
  Driver      "mouse"
  Option      "Protocol" "auto"
  Option      "Device" "/dev/input/mice"
  Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
  Identifier   "Monitor0"
  VendorName   "Monitor Vendor"
  ModelName    "Monitor Model"
EndSection

Section "Device"
  Identifier  "Card0"
  Driver      "nvidia"
  VendorName  "nVidia Corporation"
  BoardName   "NV43 [GeForce 6600 GT]"
  BusID       "PCI:6:0:0"
EndSection

Section "Screen"
  Identifier "Screen0"
  Device     "Card0"
  Monitor    "Monitor0"
  SubSection "Display"
    Viewport   0 0
    Depth     1
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     4
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     8
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     15
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     16
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     24
  EndSubSection
EndSection


Mais toujours pas de prise en charge du drivers. !

Merci quand même.  Personnellement, ca fait un moment que je suis sous linux, mais la je comprend pas ce qui m'ennuie ! big_smile

Hors ligne

#18 09-11-2009 21:08:12

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

En tout cas, très jolie galerie dnartreb89 !

Sur ton site...

Beaucoup de délicatesses dans la couleur de tes macros et natures mortes !
Et tes chat (tons) sont craquants ! big_smile

Amitié, Joel

PS : Pas de présentation, j'y poste là  off topic comme on dit... wink

Dernière modification par smolski (09-11-2009 21:08:42)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#19 09-11-2009 21:15:22

dnartreb89
Membre
Distrib. : Squeeze
Noyau : 2.6.30-2-686
(G)UI : gnome
Inscription : 09-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

Merci smolski ! big_smile

Malheureusement je la met trés rarement à jour ! smile

Hors ligne

#20 09-11-2009 23:58:23

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

re dnartre89

Donne nous ton fichier sources.list et ton fichier preferences stp.
Merci

logo_3dminfographie_signature.png

Hors ligne

#21 10-11-2009 07:37:36

dnartreb89
Membre
Distrib. : Squeeze
Noyau : 2.6.30-2-686
(G)UI : gnome
Inscription : 09-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

Durant mes tests, je l'ai fait un tout petit peu évoluer :

$ cat /etc/apt/sources.list
## Stable (lenny)
deb http://ftp.fr.debian.org/debian/ lenny main non-free contrib
deb-src http://ftp.fr.debian.org/debian/ lenny main non-free contrib

## Testing (Squeeze)
deb http://ftp.fr.debian.org/debian/ squeeze main non-free contrib
deb-src http://ftp.fr.debian.org/debian/ squeeze main non-free contrib

## Unstable (Sid)
deb http://ftp.fr.debian.org/debian/ sid main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ sid main contrib non-free

## Security
deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

deb http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free

## Multimedia
deb http://www.debian-multimedia.org/ lenny main
deb http://www.debian-multimedia.org/ squeeze main
deb http://www.debian-multimedia.org/ unstable main

## Experimental
# deb http://ftp.fr.debian.org/debian/ experimental main


$ cat /etc/apt/preferences

Package: *
Pin: release o=Debian,a=testing,l=Debian-Security
Pin-Priority: 900

Package: *
Pin: release o=Unofficial Multimedia Packages,a=testing,l=Unofficial Multimedia Packages
Pin-Priority: 900

Package: *
Pin: release o=Debian,a=testing,l=Debian
Pin-Priority: 900

Package: *
Pin: release o=Debian,a=stable,l=Debian-Security
Pin-Priority: 800

Package: *
Pin: release o=Unofficial Multimedia Packages,a=stable,l=Unofficial Multimedia Packages
Pin-Priority: 800

Package: *
Pin: release v=4.0*,o=Debian,a=stable,l=Debian
Pin-Priority: 800

Package: *
Pin: release o=Unofficial Multimedia Packages,a=unstable,l=Unofficial Multimedia Packages
Pin-Priority: 90

Package: *
Pin: release o=Debian,a=unstable,l=Debian
Pin-Priority: 90

Hors ligne

#22 10-11-2009 17:19:54

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

Peux-tu renvoyer ce que te dit ces commandes

apt-cache madison paquet nvidia-kernel-source


et

apt-cache madison paquet nvidia-glx


logo_3dminfographie_signature.png

Hors ligne

#23 10-11-2009 18:20:37

dnartreb89
Membre
Distrib. : Squeeze
Noyau : 2.6.30-2-686
(G)UI : gnome
Inscription : 09-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

$ apt-cache madison paquet nvidia-kernel-source
nvidia-kernel-source | 185.18.36-2 | http://ftp.fr.debian.org sid/non-free Packages
nvidia-kernel-source | 173.14.09-5 | http://ftp.fr.debian.org lenny/non-free Packages
nvidia-kernel-source | 173.14.09-5 | http://ftp.fr.debian.org squeeze/non-free Packages
nvidia-graphics-drivers | 173.14.09-5 | http://ftp.fr.debian.org lenny/non-free Sources
nvidia-graphics-drivers | 173.14.09-5 | http://ftp.fr.debian.org squeeze/non-free Sources
nvidia-graphics-drivers | 185.18.36-2 | http://ftp.fr.debian.org sid/non-free Sources


$ apt-cache madison paquet nvidia-glx
nvidia-glx | 185.18.36-2 | http://ftp.fr.debian.org sid/non-free Packages
nvidia-glx | 173.14.09-5 | http://ftp.fr.debian.org lenny/non-free Packages
nvidia-glx | 173.14.09-5 | http://ftp.fr.debian.org squeeze/non-free Packages
nvidia-graphics-drivers | 173.14.09-5 | http://ftp.fr.debian.org lenny/non-free Sources
nvidia-graphics-drivers | 173.14.09-5 | http://ftp.fr.debian.org squeeze/non-free Sources
nvidia-graphics-drivers | 185.18.36-2 | http://ftp.fr.debian.org sid/non-free Sources


Je connaissait pas ! apt-cache madison big_smile

Hors ligne

#24 11-11-2009 16:18:00

dnartreb89
Membre
Distrib. : Squeeze
Noyau : 2.6.30-2-686
(G)UI : gnome
Inscription : 09-09-2008
Site Web

Re : Problème nvidia aprés mise à jour vers Squeeze [RÉSOLU]

Résolu en s'inspirant de ce post sur ubuntu-fr :

http://forum.ubuntu-fr.org/viewtopic.php?id=288003

Bon, je suis avec les .run du site nvidia.

Pas trés propre, mais ça marche.

Du coup, j'ai presque résolu tout mes soucis depuis ma mise à jour vers Squeeze.

Bonne journée à tous !

Hors ligne

Pied de page des forums