Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-11-2017 13:12:12

quentinlac
Membre
Lieu : France
Distrib. : Debian 9
Noyau : Linux 4.9.0-3-686-pae
(G)UI : gnome
Inscription : 28-02-2017
Site Web

Problème de dépendance avec apt.

Bonjour, j'ai un petit soucis sur debian, je ne peut plus installer de paquet via apt, car il y a un problème de dépendance:

sudo apt-get dist-upgrade


Reading package lists... Done
Building dependency tree      
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 perl : Depends: perl-base (= 5.20.2-3+deb8u8) but 5.20.2-3+deb8u9 is installed
E: Unmet dependencies. Try using -f.
 



J'ai essayé apt-get -f install sans succès, j'ai essayé des méthodes proposées en ligne, mais rien à faire sad

Merci d'avance smile

Hors ligne

#2 29-11-2017 14:27:28

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Problème de dépendance avec apt.

Bonjour
Il serait intéressant de savoir quel dépôts sont utilisé pour ton système car cette version de perl-base correspond a Debian Jessie

cat /etc/apt/sources.list


cat /etc/apt/sources.list.d/*


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#3 29-11-2017 14:43:27

quentinlac
Membre
Lieu : France
Distrib. : Debian 9
Noyau : Linux 4.9.0-3-686-pae
(G)UI : gnome
Inscription : 28-02-2017
Site Web

Re : Problème de dépendance avec apt.

Petite précision, ce n'est pas vraiment debian mais raspbian(Debian pour raspberry pi) qui a un problème. Je sais que ce n'est pas un forum pour raspbian, mais c'est pareil que debian jessie et en plus je préfère ce forum, il y a plus de monde que ceux pour raspbian smile.

Donc, la commande retourne:

cat /etc/apt/sources.list


deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi



et

cat /etc/apt/sources.list.d/*


deb http://www.deb-multimedia.org jessie main non-free
deb-src http://www.deb-multimedia.org jessie main non-free
deb http://archive.raspberrypi.org/debian/ jessie main ui
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspberrypi.org/debian/ jessie main ui
 



Merci

Hors ligne

#4 29-11-2017 14:53:30

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Problème de dépendance avec apt.

ah oui je ne saurais dire les sources qu'il faut avoir pour raspian
Que renvoi

apt-cache policy perl


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#5 29-11-2017 15:03:30

quentinlac
Membre
Lieu : France
Distrib. : Debian 9
Noyau : Linux 4.9.0-3-686-pae
(G)UI : gnome
Inscription : 28-02-2017
Site Web

Re : Problème de dépendance avec apt.

apt-cache policy perl


perl:
  Installed: 5.20.2-3+deb8u8
  Candidate: 5.20.2-3+deb8u9
  Version table:
     5.20.2-3+deb8u9 0
        500 http://mirrordirector.raspbian.org/raspbian/ jessie/main armhf Packages
 *** 5.20.2-3+deb8u8 0
        100 /var/lib/dpkg/status
 

Hors ligne

#6 29-11-2017 15:14:45

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Problème de dépendance avec apt.

recharge la liste des paquets

apt update


puis

apt full-upgrade



est ce que cela fonctionne mieux?


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#7 29-11-2017 15:48:33

quentinlac
Membre
Lieu : France
Distrib. : Debian 9
Noyau : Linux 4.9.0-3-686-pae
(G)UI : gnome
Inscription : 28-02-2017
Site Web

Re : Problème de dépendance avec apt.

Malheureusement non, toujours le même problème sad

Hors ligne

#8 29-11-2017 15:56:56

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Problème de dépendance avec apt.

apt remove perl


apt install perl


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#9 29-11-2017 16:01:15

quentinlac
Membre
Lieu : France
Distrib. : Debian 9
Noyau : Linux 4.9.0-3-686-pae
(G)UI : gnome
Inscription : 28-02-2017
Site Web

Re : Problème de dépendance avec apt.

apt remove perl


Reading package lists... Done
^Cilding dependency tree... 89%
root@raspberrypi:/etc/apt/sources.list.d# apt remove perl
Reading package lists... Done
Building dependency tree      
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 apache2 : Depends: perl but it is not going to be installed
 apache2-bin : Depends: perl but it is not going to be installed
 autoconf : Depends: perl (> 5.005) but it is not going to be installed
 debhelper : Depends: perl but it is not going to be installed
 dh-autoreconf : Depends: perl but it is not going to be installed
 dh-php5 : Depends: perl but it is not going to be installed
 dh-strip-nondeterminism : Depends: perl but it is not going to be installed
 i2c-tools : Depends: perl but it is not going to be installed
 intltool-debian : Depends: perl but it is not going to be installed
 libalgorithm-c3-perl : Depends: perl but it is not going to be installed
 libalgorithm-diff-perl : Depends: perl but it is not going to be installed
 libalgorithm-diff-xs-perl : Depends: perl (>= 5.20.0-4) but it is not going to be installed
 libalgorithm-merge-perl : Depends: perl but it is not going to be installed
 libarchive-extract-perl : Depends: perl (>= 5.13.6) but it is not going to be installed
 libarchive-zip-perl : Depends: perl but it is not going to be installed
 libcgi-fast-perl : Depends: perl but it is not going to be installed
 libcgi-pm-perl : Depends: perl but it is not going to be installed
 libclass-c3-perl : Depends: perl but it is not going to be installed
 libclass-c3-xs-perl : Depends: perl (>= 5.20.0-4) but it is not going to be installed
 libcpan-meta-perl : Depends: perl but it is not going to be installed
                     Depends: perl (>= 5.19.10) but it is not going to be installed or
                              libparse-cpan-meta-perl (>= 1.4414)
 libdata-optlist-perl : Depends: perl but it is not going to be installed
 libdata-section-perl : Depends: perl but it is not going to be installed
 libdbd-mysql-perl : Depends: perl (>= 5.20.2-3+deb8u1) but it is not going to be installed
 libdbi-perl : Depends: perl (>= 5.20.0-4) but it is not going to be installed
 libdpkg-perl : Depends: perl but it is not going to be installed
 liberror-perl : Depends: perl but it is not going to be installed
 libfcgi-perl : Depends: perl (>= 5.20.2-3+deb8u1) but it is not going to be installed
 libfile-copy-recursive-perl : Depends: perl (>= 5.6.0-16) but it is not going to be installed
 libfile-fcntllock-perl : Depends: perl (>= 5.20.0-4) but it is not going to be installed
 libfile-stripnondeterminism-perl : Depends: perl but it is not going to be installed
 libhtml-template-perl : Depends: perl but it is not going to be installed
 liblog-message-perl : Depends: perl but it is not going to be installed
 liblog-message-simple-perl : Depends: perl but it is not going to be installed
 libmail-sendmail-perl : Depends: perl (>= 5.6.0-16) but it is not going to be installed
 libmodule-build-perl : Depends: perl but it is not going to be installed
                        Depends: perl (>= 5.13.9) but it is not going to be installed or
                                 libversion-perl (>= 1:0.8700)
 libmodule-pluggable-perl : Depends: perl but it is not going to be installed
 libmodule-signature-perl : Depends: perl but it is not going to be installed
 libmro-compat-perl : Depends: perl but it is not going to be installed
 libpackage-constants-perl : Depends: perl but it is not going to be installed
 libparams-util-perl : Depends: perl (>= 5.20.0-4) but it is not going to be installed
 libperl4-corelibs-perl : Depends: perl but it is not going to be installed
 libpod-latex-perl : Depends: perl but it is not going to be installed
 libpod-readme-perl : Depends: perl but it is not going to be installed
 libregexp-common-perl : Depends: perl but it is not going to be installed
 libsoftware-license-perl : Depends: perl but it is not going to be installed
 libsub-exporter-perl : Depends: perl but it is not going to be installed
 libsub-install-perl : Depends: perl but it is not going to be installed
 libsys-hostname-long-perl : Depends: perl but it is not going to be installed
 libterm-readkey-perl : Depends: perl (>= 5.20.0-4) but it is not going to be installed
 libterm-ui-perl : Depends: perl but it is not going to be installed
 libtext-soundex-perl : Depends: perl (>= 5.20.0-4) but it is not going to be installed
 libtext-template-perl : Depends: perl but it is not going to be installed
 libtimedate-perl : Depends: perl but it is not going to be installed
 mysql-client-5.5 : Depends: perl but it is not going to be installed
 mysql-server-5.5 : Depends: perl (>= 5.6) but it is not going to be installed
 phpmyadmin : Depends: perl but it is not going to be installed
 po-debconf



apt install perl


Reading package lists... Done
Building dependency tree      
Reading state information... Done
Suggested packages:
  perl-doc libterm-readline-gnu-perl libterm-readline-perl-perl
The following packages will be upgraded:
  perl
1 upgraded, 0 newly installed, 0 to remove and 42 not upgraded.
2 not fully installed or removed.
Need to get 0 B/2,050 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Reading changelogs... Done
dpkg: warning: files list file for package 'vim-tiny' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'nmap' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'locales' missing; assuming package has no files currently installed
(Reading database ... 123588 files and directories currently installed.)
Preparing to unpack .../perl_5.20.2-3+deb8u9_armhf.deb ...
Unpacking perl (5.20.2-3+deb8u9) over (5.20.2-3+deb8u8) ...
dpkg: error processing archive /var/cache/apt/archives/perl_5.20.2-3+deb8u9_armhf.deb (--unpack):
 trying to overwrite '/usr/bin/config_data', which is also in package libmodule-build-perl 0.421000-2+deb8u1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/perl_5.20.2-3+deb8u9_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

Hors ligne

#10 29-11-2017 16:57:03

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Problème de dépendance avec apt.

Bonjour smile
As-tu essayé la commande indiquée dans le retour plus haut :

apt-get -f install

Hors ligne

#11 29-11-2017 17:00:09

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Problème de dépendance avec apt.

Je me demande si c'est pas ton dépôt multimédia qui aurait pu mettre le fouillis
As tu fais un fichier de preference pour évité qu'il ait les meme priorité que la version main?
Que donne

apt-cache policy


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#12 29-11-2017 17:26:03

quentinlac
Membre
Lieu : France
Distrib. : Debian 9
Noyau : Linux 4.9.0-3-686-pae
(G)UI : gnome
Inscription : 28-02-2017
Site Web

Re : Problème de dépendance avec apt.

chalu a écrit :

Bonjour smile
As-tu essayé la commande indiquée dans le retour plus haut :

apt-get -f install



Oui, j'ai bien essayé cette commande mais ça ne marche pas.

Par contre, la commande:

apt-cache policy


Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://archive.raspberrypi.org/debian/ jessie/ui armhf Packages
     release o=Raspberry Pi Foundation,a=oldstable,n=jessie,l=Raspberry Pi Foundation,c=ui
     origin archive.raspberrypi.org
 500 http://archive.raspberrypi.org/debian/ jessie/main armhf Packages
     release o=Raspberry Pi Foundation,a=oldstable,n=jessie,l=Raspberry Pi Foundation,c=main
     origin archive.raspberrypi.org
 500 http://mirrordirector.raspbian.org/raspbian/ jessie/rpi armhf Packages
     release o=Raspbian,a=oldstable,n=jessie,l=Raspbian,c=rpi
     origin mirrordirector.raspbian.org
 500 http://mirrordirector.raspbian.org/raspbian/ jessie/non-free armhf Packages
     release o=Raspbian,a=oldstable,n=jessie,l=Raspbian,c=non-free
     origin mirrordirector.raspbian.org
 500 http://mirrordirector.raspbian.org/raspbian/ jessie/contrib armhf Packages
     release o=Raspbian,a=oldstable,n=jessie,l=Raspbian,c=contrib
     origin mirrordirector.raspbian.org
 500 http://mirrordirector.raspbian.org/raspbian/ jessie/main armhf Packages
     release o=Raspbian,a=oldstable,n=jessie,l=Raspbian,c=main
     origin mirrordirector.raspbian.org
Pinned packages:
 

Hors ligne

#13 29-11-2017 17:38:48

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Problème de dépendance avec apt.

quentinlac a écrit :

Oui, j'ai bien essayé cette commande mais ça ne marche pas.


le retour pourrait être intéressant pour comprendre pourquoi ça bloque et pourquoi tu ne peux pas installer la mise à jour de perl
on ne sait pas quels sont les paquets mal installés ou mal supprimés.

Hors ligne

#14 29-11-2017 17:43:09

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Problème de dépendance avec apt.

apt-get clean


dpkg --configure -a


apt-get upgrade -f


apt-get update


apt-get upgrade


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#15 29-11-2017 22:54:47

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.14.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : Problème de dépendance avec apt.

Salut,

Tu peux essayer avec aptitude ( à installer ) : https://debian-facile.org/doc:systeme:apt:aptitude
Son solveur de dépendance va te proposer une solution que tu peux refuser pour qu'il t'en trouve une autre .
smile

Dernière modification par nono47 (29-11-2017 22:55:56)

Hors ligne

Pied de page des forums