Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-12-2017 16:04:28

valmy
Membre
Lieu : Lille (France)
Distrib. : Stretch
(G)UI : gnome
Inscription : 29-02-2016

Synaptic : erreur

Depuis la version de stretch j'ai ce message d'erreur dans synaptic après avoir cliqué sur "Recharger". Savez-vous comment s'en débarasser ?

http://deb.debian.org/debian/dists/stre … /InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.The repository 'http://deb.debian.org/debian stretch/updates Release' does not have a Release file.Updating from such a repository can't be done securely, and is therefore disabled by default.See apt-secure(8) manpage for repository creation and user configuration details.http://security.debian.org/dists/stretch/updates/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.http://deb.debian.org/debian/dists/stretch-backports/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.http://deb.debian.org/debian/dists/stretch/Release.gpg: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.http://www.deb-multimedia.org/dists/stretch/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.

Hors ligne

#2 08-12-2017 16:12:12

pili36
Membre
Lieu : Lille
Distrib. : Debian stretch / Raspbian Jessie
Noyau : 4.9_amd64 / 3.16_armhf
(G)UI : Xfce / Lxde
Inscription : 03-11-2009

Re : Synaptic : erreur

EDIT : La procédure ci-dessous ne résout pas le problème.

Bonjour,


J'ai eu ce problème aussi une fois. De mémoire, il suffit de (ré)installer le paquet Debian contenant les clés Debian. Par contre je n'a pas trouvé l'explication de ce phénomène.

apt-get install --reinstall debian-archives-keyring


Et le problème devrait être réglé.

Dernière modification par pili36 (10-12-2017 09:57:26)


Debian stretch amd64, Xfce, Lenovo G50, Amd Q4000 4*1,3Ghz, 4Go RAM, Amd Radeon R3
Debian Stretch amd64, (pour Steam), Xfce, Amd Athlon 860K 4*3.7Ghz, 8Go RAM, AMD Radeon R7 250 2Go
Raspbian Jessie Armhf, Lxde, Raspberry Pi model B

Hors ligne

#3 08-12-2017 17:26:10

Mercredi
Membre
Distrib. : Testing/Sid
Noyau : 4.14
(G)UI : Gnome-shell
Inscription : 25-09-2015

Re : Synaptic : erreur

Il y a plusieurs fils du forum qui traitent de ce problème et de sa résolution, chercher "trusted.gpg" pour trouver.
C'est aussi signalé dans le wiki pour Synaptic wink

De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

#4 08-12-2017 17:52:00

èfpé
Membre
Inscription : 10-07-2016

Re : Synaptic : erreur

Bonjour,

Et en cherchant « bien » on trouve un fil de discussion ouvert par toi, valmy.

C'est clair je dois cruellement et définitivement manquer de pédââgôôgie hmm

Hors ligne

#5 08-12-2017 20:41:36

valmy
Membre
Lieu : Lille (France)
Distrib. : Stretch
(G)UI : gnome
Inscription : 29-02-2016

Re : Synaptic : erreur

Oui èfpé mais le problème qui me semblait résolu ne l'est pas. L'erreur revient. Agaçant.

Hors ligne

#6 08-12-2017 21:26:00

èfpé
Membre
Inscription : 10-07-2016

Re : Synaptic : erreur

Re-,

OK ; et donc où en es-tu, là tout de suite maintenant ? le souci est-il de nouveau réglé, ou pas ?

rm /etc/apt/trusted.gpg

apt-key adv --keyserver hkp://keys.gnupg.net --recv-keys 5C808C2B65558117


Recrée un fichier trusted.gpg au bon format, et immunise définitivement contre ce fichu bogue !
Note : la clé 5C808C2B65558117 n'a pas totalement été choisie au hasard (cf. deb-multimedia)

edit: alors oui... pour que l'astuce fonctionne le paquet deb-multimedia-keyring doit être purgé ;

apt-get purge deb-multimedia-keyring


Par ailleurs, la commande apt-key machin requiert le paquet dirmngr, à installer s'il ne l'est pas.

Dernière modification par èfpé (09-12-2017 23:56:00)

Hors ligne

#7 10-12-2017 09:55:12

pili36
Membre
Lieu : Lille
Distrib. : Debian stretch / Raspbian Jessie
Noyau : 4.9_amd64 / 3.16_armhf
(G)UI : Xfce / Lxde
Inscription : 03-11-2009

Re : Synaptic : erreur

Bonjour,

Je viens de nouveau d'avoir le problème et la solution de èfpé fonctionne parfaitement. Par contre, mes souvenirs exposés dans le #2 semble complètement mauvais car cela n'a pas résolu le problème cette fois-ci.
Donc merci èfpé :-)

Debian stretch amd64, Xfce, Lenovo G50, Amd Q4000 4*1,3Ghz, 4Go RAM, Amd Radeon R3
Debian Stretch amd64, (pour Steam), Xfce, Amd Athlon 860K 4*3.7Ghz, 8Go RAM, AMD Radeon R7 250 2Go
Raspbian Jessie Armhf, Lxde, Raspberry Pi model B

Hors ligne

#8 10-12-2017 11:16:26

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Synaptic : erreur

Bonjour
\o/
Voir le tuto : C'est résolu ! Bravo mais il faut l'indiquer dans l'titre.
Si vous insistez pour me donner un point choco de bon matin big_smile

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#9 10-12-2017 13:38:00

èfpé
Membre
Inscription : 10-07-2016

Re : Synaptic : erreur

Bonjour,

@Croutons : Bandit ! Voyou ! Voleur ! Chenapan ! À cette heure nous ne savons pas ce qu'il en est pour l'OP et il s'agit d'un cas manifeste de bernacle du forum DF... mais puisqu'on ne prête qu'aux riches, sur ce forum capitaliste, je laisse un⋅e modo décomplexé⋅e se goberger au nez et à la barbe des pauvres gens hmm

Dernière modification par èfpé (10-12-2017 13:48:00)

Hors ligne

#10 10-12-2017 14:55:29

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Synaptic : erreur

ah oui bernacle j'avais pas fais gaffe woohoo.gif

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#11 10-12-2017 14:56:40

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : Synaptic : erreur

Ok.. Donc l'attribution du point df reste en suspend alors...
Ô point choco, suspend ton vol....
tongue

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#12 10-12-2017 15:17:55

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch
Noyau : Linux 4.9.0-3-amd64
(G)UI : Mate 1.16
Inscription : 11-03-2016

Re : Synaptic : erreur

Roooh mais non pas bernacle wink
pili36 a gentiment fait un retour par rapport au message #2 qu’il a écrit dans ce fil en indiquant que ce n’etait pas la bonne solution et que celle-ci se trouve dans le message #6
Bon du coup je prends tous les points chocos c’est bien ça le nouveau règlement n’est-ce pas ? lol

Hors ligne

#13 11-12-2017 02:18:04

ayaf
Membre
Lieu : Torcy / Seine et Marne
Distrib. : Debian Jessie 8.1
Noyau : Linux 3.16.0-4-686-pae
(G)UI : xfce
Inscription : 25-10-2017

Re : Synaptic : erreur

La guerre du "choco" aura-t'elle lieu ?...  scratchhead.gif
Sûr que la période actuelle excite les papilles et attise les convoitises !...  wiscot.png

Dernière modification par ayaf (11-12-2017 02:18:37)


banner223x19.png    ^!^  Pentium4-3,2 Ghz/Ram2Go/Geforce6200/Linux3.16.0-4-686-pae/xfce
"Prends le temps de savourer l'instant présent !..."  -- ( Carpe Diem ) --
"Oublie ton passé, qu'il soit simple ou composé, participe à ton présent pour que ton futur soit plus que parfait"  -- (Yves Duteil)

Hors ligne

#14 11-12-2017 12:26:54

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-3-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : Synaptic : erreur

La guerre du "choco" aura-t'elle lieu ?..


Tu parles que oui c'est bientôt nowel need les chocos lol


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

Pied de page des forums