Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-12-2017 11:36:03

Oursonobo
Membre
Inscription : 12-12-2017

[RÉSOLU] Un beau problème lors du démarrage

Bonjour,

Suite à un démarrage alors que je n'avais plus de batterie sur le PC... je n'arrive plus à lancer Debian, j'ai le message suivant:

Failed to Start File System Check on /dev/disk/by-uuid ...
Dependency Failed for /home
Dependency Failed for Local File System

Lors du reboot j'ai un message trop furtif pour le prendre en note qui évoque un problème de bus

J'ai toujours accès au GRUB, le démarrage en WIN7 - je suis en dual-boot - fonctionne sans soucis.

J'ai fait une clef live et réussi à accéder à ma partition /home pour récupérer mes données.

Si vous avez une idée ou une solution je suis preneur, pour une réparation ou pour récupérer ma personnalisation, sinon je suis bon pour une ré-installation complète.

Par avance merci

Dernière modification par Oursonobo (17-12-2017 22:27:23)

Hors ligne

#2 12-12-2017 11:47:44

Tristan07
Adhérent(e)
Distrib. : Debian 9, Stretch
Noyau : Linux 4.9.0-4-amd64
(G)UI : Gnome 3.22
Inscription : 21-05-2016
Site Web

Re : [RÉSOLU] Un beau problème lors du démarrage

Salut,

Cela semble concerner le fichier des partitions (  fstab ), mais il va falloir attendre plus compétent que moi.
En attendant, il faudra donner le plus d'info spossible : version, bureau utilisé, carte graphique, pilotes Libre ou privateur etc ... certaines infos peuvent être décrite dans ton profil, cela facilite la tâche des bénévoles de DF ! wink
merci

Dernière modification par Tristan07 (12-12-2017 11:48:33)


Debian Stable est ce qui rend la vie plus intéressante que l'informatique ( voir Robert Filliou pour l'origine de cette citation smile
Debian c'est pas difficile ! zen.gif
https://lescahiersdudebutant.fr/
Pour une aide efficace sur le forum : https://debian-facile.org/viewtopic.php?id=13352

Hors ligne

#3 13-12-2017 01:02:25

raleur
Membre
Inscription : 03-10-2014

Re : [RÉSOLU] Un beau problème lors du démarrage

Apparemment systemd n'a pas réussi à trouver l'UUID de /home.
Vérifie la correspondance entre la sortie de blkid et le contenu de /etc/fstab.

Hors ligne

#4 13-12-2017 05:37:12

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : [RÉSOLU] Un beau problème lors du démarrage

raleur a écrit :

Vérifie la correspondance entre la sortie de blkid et le contenu de /etc/fstab


Les tutos :
https://debian-facile.org/doc:systeme:fstab
https://debian-facile.org/doc:systeme:blkid
wink


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#5 17-12-2017 12:02:12

Oursonobo
Membre
Inscription : 12-12-2017

Re : [RÉSOLU] Un beau problème lors du démarrage

Réponse tardive,

Je viens de vérifier les infos données par blkid et celles par fstab.
Je ne vois pas d'erreurs dans les UUID.
Une seule différence avec le tuto j'ai l'ordre suivant:
sda5 => /
sda7 => /home
sda6 => /swap

En redémarrant et en regardant de plus près les erreurs j'ai un : fsck failed error type 4
Si j'ai bien compris ça se situe dans /usr/sbin/alsactl,
      la fin de l'extension dépasse la valeur autorisée,
      /dev/sda7 inconsistence inatendue

Je suis toujours preneur d'idées.

Merci

Hors ligne

#6 17-12-2017 12:15:57

raleur
Membre
Inscription : 03-10-2014

Re : [RÉSOLU] Un beau problème lors du démarrage

Rapporte les informations exactes et complètes (contenu des fichiers, messages) plutôt que ton interprétation.

Hors ligne

#7 17-12-2017 12:16:21

Oursonobo
Membre
Inscription : 12-12-2017

Re : [RÉSOLU] Un beau problème lors du démarrage

Avec un peu de lecture :
https://debian-facile.org/doc:systeme:fsck
je pense que je peux essayer de réparer /home,

Il me reste une question, si je vais ça au démarrage, en root, est-ce que j'ai besoin de démonter la partition vu qu'elle ne se monte pas?

Merci

Hors ligne

#8 17-12-2017 12:26:49

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-7-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [RÉSOLU] Un beau problème lors du démarrage

Bonjour
Il n'y a pas de commande conseillé après le message d'erreur?

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#9 17-12-2017 12:28:22

Oursonobo
Membre
Inscription : 12-12-2017

Re : [RÉSOLU] Un beau problème lors du démarrage

raleur a écrit :

Rapporte les informations exactes et complètes (contenu des fichiers, messages) plutôt que ton interprétation.



https://photos.app.goo.gl/F96idFrU3jNzEiHf1

Désoler de ne pas pouvoir faire mieux

Merci

Cette fois le lien devrait fonctionner sad

Dernière modification par Oursonobo (17-12-2017 12:43:05)

Hors ligne

#10 17-12-2017 12:29:00

Oursonobo
Membre
Inscription : 12-12-2017

Re : [RÉSOLU] Un beau problème lors du démarrage

Croutons a écrit :

Bonjour
Il n'y a pas de commande conseillé après le message d'erreur?



Du coup si, exécuter fsck en manuel

Hors ligne

#11 17-12-2017 12:56:14

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-7-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [RÉSOLU] Un beau problème lors du démarrage

Fais un fsck sur la partition problématique
Tu peux consulter

man fsck


Pour l'avoir fais quand c'était conseillé je dois dire que cela ma bien remis mon système en ordre
mais un conseil met régulièrement a jour tes sauvegardes


-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#12 17-12-2017 13:29:45

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : [RÉSOLU] Un beau problème lors du démarrage

Le tuto facile fsck en lien ici : https://debian-facile.org/doc:systeme:fsck smile

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#13 17-12-2017 13:36:37

Oursonobo
Membre
Inscription : 12-12-2017

Re : [RÉSOLU] Un beau problème lors du démarrage

smolski a écrit :

Le tuto facile fsck en lien ici : https://debian-facile.org/doc:systeme:fsck smile


Merci, je l'ai lu mais il me reste les questions suivantes:
Lorsque je démarre il ne monte pas /home. Je me connecte en root. Est-ce que j'ai besoin de unmount la partition vu qu'elle est pas montée  (je sais ça peu paraître idiot comme question)
Si j'utilise le clef live, est-ce que la procédure est différente ?

Encore merci

Hors ligne

#14 17-12-2017 13:39:38

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : [RÉSOLU] Un beau problème lors du démarrage

tuto fsck wiki df a écrit :

la démonter toujours sous root :


Si la partition n'est pas montée, pas montée c'est pas montée et donc rien à faire, et pour la clef idem. smile


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#15 17-12-2017 13:45:25

Croutons
Membre
Distrib. : Handylinux 2.5 vers Jessie et Debian Stretch
Noyau : Linux 3.16.0-4-686-pae, Linux 4.9.0-7-686-pae
(G)UI : xfce
Inscription : 16-12-2016

Re : [RÉSOLU] Un beau problème lors du démarrage

au pire tu peux umount ta partition , le systeme te renverra un message d'erreur si elle est pas monté
Depuis la clé live je sais pas si la commande est présente par defaut d'apres me man elle fait parti du paquet util-linux

-->les cahiers du debutant<--      WikiDF-->Découvrir les principales commandes Linux<--
L' expérience, c'est le nom que chacun donne à ses erreurs. Oscar Wilde

Hors ligne

#16 17-12-2017 13:47:48

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : [RÉSOLU] Un beau problème lors du démarrage

Modifié le tuto en conséquence là :
https://debian-facile.org/doc:systeme:f … partitions

Merci Oursonobo yes.gif

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#17 17-12-2017 22:25:56

Oursonobo
Membre
Inscription : 12-12-2017

Re : [RÉSOLU] Un beau problème lors du démarrage

Merci à tous pour vos réponses,merci.gif

fsck après la connexion en root au démarrage, ça a corrigé un soixantaine d'erreur et je vous écris depuis une session qui fonctionne et qui est à jour.

Hors ligne

Pied de page des forums