Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-12-2017 23:12:15

Geai dechaine
Membre
Lieu : Provence
Distrib. : Squeeze 6.0
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 25-06-2009

[Résolu] Débian 9.3 écran noir après install

Bonjour tout le monde,

J'ai un gros échec à l'install de la nouvelle Debian.

Installation de Debian 9.3 (stable) par live-usb sur ordi portable Samsung Ativ Book 9 Lite.

Le système live marche bien, reconnait la connection wifi, j'ai du son, je décide d'installer à partir de la clé.

Tout semble bien se passer mais, au démarrage, écran noir.

Pb avec Grub ?

À la toute fin de l'install on me demande où installer Grub, mais je n'en sais rien du tout.

Je fais tout installer sur une seule partition, et je paramètre en manuel pour Grub /dev/sda, échec et écran noir. Je réinstalle avec à la fin /dev/sda1, nouvel échec et écran noir.

Comment paramétrer ça ?

Le pb peut il venir d'ailleur ? Pb graphique ? J'ai une carte ATI, faut-il installer un truc proprio ?

Je voulais remplacer Kubuntu installé en 2014 sans pb sur le même ordi. Maintenant je n'ai plus rien sauf la connection internet avec la live-usb qui me permet de lancer cet appel à l'aide wink

Olivier

Dernière modification par Geai dechaine (31-12-2017 13:34:28)


pc Medion MT6, cg ATI X300SE. J'utilise aptitude.

Hors ligne

#2 31-12-2017 08:38:23

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.14.0-3-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : [Résolu] Débian 9.3 écran noir après install

Salut,

Tu pourrais essayer d'installer grub à partir du live cd à partir d'un chroot .
Le wiki sur chroot - https://debian-facile.org/doc:systeme:chroot

ou

si l'installateur le permet, tu choisis le rescue mode ( et non pas installation au premier écran qui s'affiche )

... dans les deux cas, c'est pour se retrouver à la racine du système à dépanner en root .

et tu installes le grub : Réparer Grub2 https://debian-facile.org/doc:systeme:grub2:reparer

Si c'est juste grub qui coince, ça devrait le faire .
smile

Le pb peut il venir d'ailleur ? Pb graphique ? J'ai une carte ATI, faut-il installer un truc proprio ?


non, ça ne devrait pas empêcher l'affichage de grub .

Dernière modification par nono47 (31-12-2017 08:42:39)

Hors ligne

#3 31-12-2017 12:31:49

Trefix
Adhérent(e)
Lieu : 48
Distrib. : kiss0s-0.7
Noyau : Linux 4.9.0-4-amd64
(G)UI : Fluxbox by arpinux
Inscription : 15-02-2015

Re : [Résolu] Débian 9.3 écran noir après install

Bonjour.
Deux choses, pas forcément en rapport immédiat mais des pistes à explorer :

- je viens d'avoir avec l'installeur Debian de kiss0s-0.7 (Stretch, donc) un soucis en cours d'installation jusqu'à ce que je fasse une "image DD" avec Rufus sous W$ (puisque je n'avais plus de partition système, effacée avec Gparted avant install'),

- j'ai déjà eu plusieurs fois le soucis de l'installation du Grub où il m'a fallu passer par le choix "manuel" puis indiquer "à la main" le bon /dev/sdx, le choix proposé par défaut par l'installeur ne fonctionnant pas (même si /dev/sdx correct).

Bon courage.

HL > DF // Les cahiers du débutant // DFLinux
.
JE SUIS toujours abonné à CHARLIE

Hors ligne

#4 31-12-2017 13:32:56

Geai dechaine
Membre
Lieu : Provence
Distrib. : Squeeze 6.0
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 25-06-2009

Re : [Résolu] Débian 9.3 écran noir après install

Merci pour vos réponses.

J'ai réinstallé, 3x au total..., en réglant manuellement Grub avec installation sur /dev/sda (une seule partition). Maintenant ça marche au redémarrage avec une Debian (KDE) qui s'installe vite. Reste quelques petites bizarreries à régler, notamment le système ne semble pas complètement en fr et le système démarre avec le clavier en qwerty. Mais c'est un autre problème.

Bonnes fêtes,

Olivier

Dernière modification par Geai dechaine (31-12-2017 13:33:49)


pc Medion MT6, cg ATI X300SE. J'utilise aptitude.

Hors ligne

Pied de page des forums