Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-11-2009 19:30:11

dnartreb89
Membre
Distrib. : Squeeze
Noyau : 2.6.30-2-686
(G)UI : gnome
Inscription : 09-09-2008
Site Web

[RÉSOLU] Passage lenny -> squeeze : mise en veille de l'écran ;)

Salut à tous !

Je passait vous questionner il y a peu avec ma carte nvidia, et j'ai un autre problème depuis mon passage de Lenny à Squeeze auquel je ne trouve pas de réponse.

Mon écran se met en veille automatiquement même pendant un film, alors que j'ai tout fait pour que cela se désactive.

J'ai commencé par les réglages en graphique. Désactivés toutes les options qui mettent en veille automatiquement.

Rien !

Puis, j'ai fait un petit "gconf-editor" pour désactivé toutes les options qui pourrait s'y rapporter !

Rien non plus !

J'ai fait quelques recherches du coup, et je suis tombé sur la possibilité d'une mauvaise prise en charge de la fréquence du moniteur. Étonnant car depuis plusieurs années que cet écran tourne sous GNU/Linux, je n'ai jamais eu ce soucis.

Bon, j'essaye de forcer la fréquence dans xorg.conf !

Toujour rien !

Et maintenant, je séche. Aucune idée de ce qui met désagréablement mon écran en veille.

Pour info, mon écran est un AOC 210S avec un affichage en 1680*1050 à 50-60Hz.

Et voici mon xorg.conf :

$ cat /etc/X11/xorg.conf
Section "ServerLayout"
  Identifier     "X.org Configured"
  Screen      0  "Screen0" 0 0
  InputDevice    "Mouse0" "CorePointer"
  InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
  ModulePath   "/usr/lib/xorg/modules"
  FontPath     "/usr/share/fonts/X11/misc"
  FontPath     "/usr/share/fonts/X11/cyrillic"
  FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
  FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
  FontPath     "/usr/share/fonts/X11/Type1"
  FontPath     "/usr/share/fonts/X11/100dpi"
  FontPath     "/usr/share/fonts/X11/75dpi"
  FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
  FontPath     "built-ins"
EndSection

Section "Module"
     # Load "GLcore"
     Load "bitmap"
     Load "ddc"
     Load "dbe"
     Load "dri"
     Load "extmod"
     Load "freetype"
     Load "glx"
     Load "int10"
     Load "type1"
     Load "vbe"
EndSection

Section "InputDevice"
  Identifier  "Keyboard0"
  Driver      "kbd"
EndSection

Section "InputDevice"
  Identifier  "Mouse0"
  Driver      "mouse"
  Option      "Protocol" "auto"
  Option      "Device" "/dev/input/mice"
  Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
  Identifier   "Monitor0"
  VendorName   "Monitor Vendor"
  ModelName    "Monitor Model"
EndSection

Section "Device"
  Identifier  "Card0"
  Driver      "nvidia"
  VendorName  "nVidia Corporation"
  BoardName   "NV43 [GeForce 6600 GT]"
  BusID       "PCI:6:0:0"
  Option "XAANoOffscreenPixmaps"
EndSection


Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "1680x1050_60 +0+0"
    SubSection     "Display"
        Depth       24
  Modes      "1680x1050_60.00"
    EndSubSection
EndSection


Section "Extensions"
     Option "Composite" "Enable"
EndSection


Si l'un de vous à une idée qui expliquerait se désagrément ! big_smile

Merci d'avance ! wink

Dernière modification par dnartreb89 (07-12-2009 00:20:34)

Hors ligne

#2 12-11-2009 19:51:15

le_fada
Membre
Lieu : Toujours à l'ouest
Distrib. : Sid «ad vitam æternam»
Noyau : 2.6.33-amd64
(G)UI : gnome-shell
Inscription : 23-09-2009

Re : [RÉSOLU] Passage lenny -> squeeze : mise en veille de l'écran ;)

Salut,

essaye de lancer xscreensaver-demo dans un terminal pour voir si ce n'est pas lui qui t'embète.

Hors ligne

#3 12-11-2009 19:56:43

dnartreb89
Membre
Distrib. : Squeeze
Noyau : 2.6.30-2-686
(G)UI : gnome
Inscription : 09-09-2008
Site Web

Re : [RÉSOLU] Passage lenny -> squeeze : mise en veille de l'écran ;)

$ xscreensaver-demo
bash: xscreensaver-demo : commande introuvable


Je l'ai désinstaller il me semble. yikes

Hors ligne

#4 07-12-2009 00:19:21

dnartreb89
Membre
Distrib. : Squeeze
Noyau : 2.6.30-2-686
(G)UI : gnome
Inscription : 09-09-2008
Site Web

Re : [RÉSOLU] Passage lenny -> squeeze : mise en veille de l'écran ;)

Cool ! Je savait bien que j'avais vu une solution déjà à ce problème.

Résolu avec cette petite commande lancée automatiquement au démarrage de la session:

xset -display :0 s off -dpms


Bonne soirée à tous ! smile

Hors ligne

#5 07-12-2009 07:19:18

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RÉSOLU] Passage lenny -> squeeze : mise en veille de l'écran ;)

Merci du retour dnartre89 !

Bonne continuation. smile

Aùitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums