Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-01-2018 18:16:34

G_
Membre
Distrib. : Stretch
(G)UI : xfce
Inscription : 07-01-2018

[Résolu]Wifi déconnecté

Salut,

Depuis une mise à jour (je pense que le problème est lié) je ne peut plus me connecter à ma box.
La tentative de connexion échoue, comme si le MDP n'était pas le bon.

matériel: Asus EEEPC seashell 1015T
Stretch + xfce

lspci -nn | grep -i network donne:
02:00.0 Network controller [0280]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)

lspci -k | grep -i network -A 2 donne:
02:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
    Subsystem: AzureWave AW-NE785 / AW-NE785H 802.11bgn Wireless Full or Half-size Mini PCIe Card
    Kernel driver in use: ath9k

dmseg donne à la fin:
IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready

Merci de votre aide.

Dernière modification par G_ (09-01-2018 00:05:34)

Hors ligne

#2 07-01-2018 18:39:44

gargamel79
Membre
Lieu : Bressuire
Distrib. : wheezy jessie Stretch
Noyau : 4.9.0-6-686-pae
(G)UI : xfce ou mate
Inscription : 15-11-2009

Re : [Résolu]Wifi déconnecté

Question bête : est-ce que tu vois ta box dans les connexions wifi disponibles ?

Hors ligne

#3 07-01-2018 18:45:38

G_
Membre
Distrib. : Stretch
(G)UI : xfce
Inscription : 07-01-2018

Re : [Résolu]Wifi déconnecté

Oui, je vois ma box et celles alentour.

Hors ligne

#4 07-01-2018 19:27:01

gargamel79
Membre
Lieu : Bressuire
Distrib. : wheezy jessie Stretch
Noyau : 4.9.0-6-686-pae
(G)UI : xfce ou mate
Inscription : 15-11-2009

Re : [Résolu]Wifi déconnecté

Je te propose d'essayer, si ce n'est déjà fait...
  dans un terminal
  /sbin/ifcvonfig
   histoire de voir si le dhcp de ta box t'affecte bien une adresse ip
  Si tu connais l'ip de ta box (pour orange c'est 192.168.1.1 les autres je ne sais pas)
  ping <l'adresse ip de ta box>
Désolé, c'est tout ce que je vois pour l'instant
  A+

Hors ligne

#5 07-01-2018 19:37:32

G_
Membre
Distrib. : Stretch
(G)UI : xfce
Inscription : 07-01-2018

Re : [Résolu]Wifi déconnecté

merci de ton aide,

ifconfig donne:
wlp2s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether xx:xx:xx:xx:xx:xx  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Hors ligne

#6 07-01-2018 21:40:59

gargamel79
Membre
Lieu : Bressuire
Distrib. : wheezy jessie Stretch
Noyau : 4.9.0-6-686-pae
(G)UI : xfce ou mate
Inscription : 15-11-2009

Re : [Résolu]Wifi déconnecté

Je me demande au vue de ton device en IPV6, est que ta box ne comprendrait que l'ipv4 ?
Mais dans ce cas, je ne vois pas trop quoi faire. J'espère que quelqu'un pourra t'aider.
  A+

Hors ligne

#7 07-01-2018 22:21:44

G_
Membre
Distrib. : Stretch
(G)UI : xfce
Inscription : 07-01-2018

Re : [Résolu]Wifi déconnecté

Le fichier /proc/net/if_inet6 est vide. Donc je pense ipv6 est inactif.
J'ai quand même désactivé IPV6 selon cette méthode: https://www.memoinfo.fr/tutoriels-linux … ur-debian/
Mais c'est pareil.

Possible que ce soit un problème matériel?

Hors ligne

#8 08-01-2018 10:12:51

gargamel79
Membre
Lieu : Bressuire
Distrib. : wheezy jessie Stretch
Noyau : 4.9.0-6-686-pae
(G)UI : xfce ou mate
Inscription : 15-11-2009

Re : [Résolu]Wifi déconnecté

Est-il possible de te connecter à ta box avec un câble Ethernet (RJ-45) . Si oui est-ce OK ?
Si je comprend bien, ta box ne te demande pas de mot passe quand tu essais de te connecter.
Si cela fonctionne avec un câble, il doit être possible, avec un navigateur d'y accéder.
En étant administrateur, il doit être possible de voir qui peut se connecter...
  A+

Hors ligne

#9 08-01-2018 12:26:23

G_
Membre
Distrib. : Stretch
(G)UI : xfce
Inscription : 07-01-2018

Re : [Résolu]Wifi déconnecté

La connexion Ethernet fonctionne.
La box demande un mot de passe pour le wifi, mais tout se passe comme si il n'était pas bon, alors que je ne l'ai pas changé et que ça fonctionnait bien le mois dernier.
Je peux me connecter en wifi à la box avec mon téléphone, ou avec l'ordi portable de ma fille (également en Stretch + Xfce).

Hors ligne

#10 08-01-2018 12:42:11

gargamel79
Membre
Lieu : Bressuire
Distrib. : wheezy jessie Stretch
Noyau : 4.9.0-6-686-pae
(G)UI : xfce ou mate
Inscription : 15-11-2009

Re : [Résolu]Wifi déconnecté

Puisque tu as réinstallé, l'enregistrement de tes mots de passe sur ton PC est peut-être incorrect.
Est-ce que tu peux aller dans ta box (avec la liaison Ethernet) et te mettre administrateur.
Je sais faire avec orange mais ce n'est peut-être pas la marque de ta box...
   A+

Hors ligne

#11 08-01-2018 19:19:32

G_
Membre
Distrib. : Stretch
(G)UI : xfce
Inscription : 07-01-2018

Re : [Résolu]Wifi déconnecté

Non, j'ai vérifié et reférifié le MDP est correct.

Hors ligne

#12 08-01-2018 19:50:22

bonyred
Membre
Distrib. : Debian buster
Noyau : 4.14.0-3-686
(G)UI : mate
Inscription : 15-05-2015

Re : [Résolu]Wifi déconnecté

Bonsoir,

Petite question bête.

N'as tu pas par étourderie désactivé le wifi de ton portable en appuyant les touches

Fn+F2.

A plus.

Hors ligne

#13 08-01-2018 19:55:26

G_
Membre
Distrib. : Stretch
(G)UI : xfce
Inscription : 07-01-2018

Re : [Résolu]Wifi déconnecté

Salut bonyred, pas ça non plus puisque je "vois" les box wifi autour de moi.

Hors ligne

#14 08-01-2018 20:54:04

Y316
Membre
Distrib. : stretch
Noyau : Linux 4.9.0-8-amd64
(G)UI : MATE 1.16.2
Inscription : 15-11-2012

Re : [Résolu]Wifi déconnecté

La box demande un mot de passe pour le wifi, mais tout se passe comme si il n'était pas bon,

Quand un mot de passe n'est pas bon le système le dit (invalid password). Est-ce cela qui se passe ?
Et si non que se passe-t-il exactement ?


Debian 9 (stretch)  + la pire ICC que vous ayez probablement jamais rencontré.

Hors ligne

#15 08-01-2018 22:02:11

G_
Membre
Distrib. : Stretch
(G)UI : xfce
Inscription : 07-01-2018

Re : [Résolu]Wifi déconnecté

Salut Y316,

Pas de message "invalid password".
Après avoir tenté de se connecter, le système retourne à la fenêtre en attente de mot de passe.
dmseg donne à la fin:
IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready

Hors ligne

#16 08-01-2018 22:28:06

Y316
Membre
Distrib. : stretch
Noyau : Linux 4.9.0-8-amd64
(G)UI : MATE 1.16.2
Inscription : 15-11-2012

Re : [Résolu]Wifi déconnecté

Pour dmseg, ce n'est pas moi qui pourra te répondre.

J'ai eu ce genre de symptômes il y peu : il m'était impossible de me loger chez mon FAI.
Au final c'était parce que j'avais modifié firefox dans "about:config". Des conseils de sécurité que j'avais lu ici pour éviter le traçage.
En pratique, j'étais logé puis délogé automatiquement. Si tu veux je recherche quelles étaient les modifications concernées.

Debian 9 (stretch)  + la pire ICC que vous ayez probablement jamais rencontré.

Hors ligne

#17 08-01-2018 22:31:01

G_
Membre
Distrib. : Stretch
(G)UI : xfce
Inscription : 07-01-2018

Re : [Résolu]Wifi déconnecté

Allélouia!

Ce message IPv6: link is not ready me tracassait, j'avais essayé toutes les pssibilité de réglages de network manager sur l'ipv6, y compris "ignorer". Et j'ai même désactivé l'ipv6 avec sysctl rien n'y faisait!

La solution que j'ai trouvé est de désactiver l'ipv6 au niveau de la box (j'aurai dû y penser plus tôt!)

Merci à tous!

Hors ligne

#18 08-01-2018 22:41:12

Y316
Membre
Distrib. : stretch
Noyau : Linux 4.9.0-8-amd64
(G)UI : MATE 1.16.2
Inscription : 15-11-2012

Re : [Résolu]Wifi déconnecté

Allez ! c'est Noël  !  soyons bon !
lol  Qui veut du choco ? lol

Debian 9 (stretch)  + la pire ICC que vous ayez probablement jamais rencontré.

Hors ligne

#19 08-01-2018 23:20:46

bendia
Admin stagiaire
Distrib. : Stretch (et un peu Jessie)
Noyau : Linux 4.9.0-2-amd64
(G)UI : Gnome + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu]Wifi déconnecté


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

Pied de page des forums