Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-01-2018 09:24:34

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Multi-fonctions PIXMA MP640 - Invalid argument - (sur MINT)

Hello la compagnie,

J'ai mis en place un pc pour ma petite fille, j'ai voulu tester MINT CINNAMON (bouhouhou, je me demande quand même si je vais pas remettre un debian de base... à voir, car au final, je ne vois pas forcement de "plus-value", bref...) version - Linux Mint 18.3 Sylvia

info MINT:

uname -a


Linux E780 4.13.0-26-generic #29~16.04.2-Ubuntu SMP Tue Jan 9 22:00:44 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux



Je n'arrive pas à scanner via mon Multi-fonctions PIXMA MP640 de chez CANON.
Il est connecté via le reseau et fonctionne parfaitement avec mes autres PCs sous Debian...
Le Multi-fonctions PIXMA MP640 repond bien au ping depuis la machine de ma fille.

Lorsque je lance ceci:

scanimage -L


device `pixma:MP640_192.168.2.11' is a CANON Canon PIXMA MP640 multi-function peripheral


Il semble bien voir le scanner reseau.

Ensuite, next step:

scanimage -T


scanimage: open of device pixma:MP640_192.168.x.x failed: Invalid argument



Voici en image le retour, depuis scanimage:
1515917973.png

"l'utilisateur", ma fille est bien dans le group scanner:

groups louise


louise : louise adm cdrom sudo dip plugdev lpadmin [b]scanner [/b]sambashare


dpkg -l | grep sane


ii  libsane:amd64                                               1.0.25+git20150528-1ubuntu2.16.04.1          amd64        API library for scanners
ii  libsane-common                                              1.0.25+git20150528-1ubuntu2.16.04.1          all          API library for scanners -- documentation and support files
ii  libsane-extras:amd64                                        1.0.22.3ubuntu1                              amd64        API library for scanners -- extra backends
ii  libsane-extras-common                                       1.0.22.3ubuntu1                              amd64        API library for scanners -- documentation and support files
ii  libsane-hpaio:amd64                                         3.16.3+repack0-1                             amd64        HP SANE backend for multi-function peripherals
ii  sane-utils                                                  1.0.25+git20150528-1ubuntu2.16.04.1          amd64        API library for scanners -- utilities
 



Voila, au niveau info, il y a de la matière, si quelqu'un a une idée d'ou le probleme pourrait venir, je suis preneur.
Il y a des pistes sur le net comme quoi ce serait peut etre un bug...

merci d'avance,

JC

Dernière modification par d33p (14-01-2018 11:06:12)


science sans conscience n'est que ruine de l'âme...

Hors ligne

#2 16-01-2018 09:40:23

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : Multi-fonctions PIXMA MP640 - Invalid argument - (sur MINT)

hello,
un petit up smile
merci.
JC

science sans conscience n'est que ruine de l'âme...

Hors ligne

#3 16-01-2018 09:48:00

anonyme-6
Invité

Re : Multi-fonctions PIXMA MP640 - Invalid argument - (sur MINT)

Bonjour,
peut-être ajoutant le groupe lp

#4 16-01-2018 09:57:21

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : Multi-fonctions PIXMA MP640 - Invalid argument - (sur MINT)

hello,
je testerais, lp ou lpadmin.
merci pour la 1ere idée, je donnerai le retour des que j'aurai testé.
@ bientôt.
JC

science sans conscience n'est que ruine de l'âme...

Hors ligne

#5 16-01-2018 20:07:21

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : Multi-fonctions PIXMA MP640 - Invalid argument - (sur MINT)

re-hello,
cet ajout ne change rien sad
merci.
@ bientôt.
JC

science sans conscience n'est que ruine de l'âme...

Hors ligne

#6 17-01-2018 00:26:42

èfpé
Membre
Inscription : 10-07-2016

Re : Multi-fonctions PIXMA MP640 - Invalid argument - (sur MINT)

Salut salut,

La piste du bogue est effectivement des plus sérieuses. Linux Mint 18.3 est basée sur Ubuntu 16.04 LTS, laquelle fournit une version de développement obsolète de paquets binaires issus du paquet source sane-backends ; la version du dépôt stretch étant bien évidemment la version stable.

Une solution alternative à l'installation de Debian 9 Cinnamon, est la mise à niveau (1.0.25+gitmachin → 1.0.27) des paquets libsane, libsane-common et sane-utils depuis le PPA (sane-git ou sane-release) de Rolf Bensch.

Dernière modification par èfpé (17-01-2018 12:36:42)

Hors ligne

#7 17-01-2018 08:59:01

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : Multi-fonctions PIXMA MP640 - Invalid argument - (sur MINT)

Hello,
ça se precise cette histoire de bug, en effet, j'aime toujours que quelqu'un confirme ou infirme. merci pour la participation au poste èfpé.
j'aime pas trop sortir des packages "conventionnels" proposés par la distrib, genre aller piocher chez github & co, j'ai peut-être tort, mais bon...
je pensais être tranquille à mettre à la petite ce qu'ils appellent un OS "plus clé en main" mais en fait, plus ça avance, plus je me rends compte que toutes ces distribs n'ont en fait pas vraiment de valeur ajoutée par rapport à Debian dont elles decoulent... Je me demande même si je vais pas passer la petite en Stretch tout simplement...
à bientôt.
JC

science sans conscience n'est que ruine de l'âme...

Hors ligne

#8 17-01-2018 09:04:27

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : Multi-fonctions PIXMA MP640 - Invalid argument - (sur MINT)

Ou alors,
Je pensais à une chose, hier j'ai fait un essai, ça n'a pas été très concluant.
J'ai voulu installer les paquets de Debian à la mano sur la Mint, j'ai donc téléchargé les packages liés à sane, xsane etc...
Genre:
https://packages.debian.org/buster/sane-utils
(avec lesdependances etc...)
Mais ensuite, lors d'un apt-get update / upgrade etc... sur l'OS en question, ici Mint, forcement, il les voit comme des packages cassés et me demande de les réparer.
Il y a un moyen d'exclurer ces paquets du check d'update et de l'upgrade? voire de ne plus les signaler en broken?

Merci.
à bientôt.
JC

science sans conscience n'est que ruine de l'âme...

Hors ligne

#9 17-01-2018 09:19:13

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 9 (stretch) 64 bits + backports
Noyau : 4.9.65-3+deb9u2
(G)UI : gnome
Inscription : 21-10-2008

Re : Multi-fonctions PIXMA MP640 - Invalid argument - (sur MINT)


"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#10 17-01-2018 09:31:45

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : Multi-fonctions PIXMA MP640 - Invalid argument - (sur MINT)

hello, merci smolski, je vais regarder ceci quand j'ai un peu de temps.

JC

science sans conscience n'est que ruine de l'âme...

Hors ligne

#11 17-01-2018 12:28:42

èfpé
Membre
Inscription : 10-07-2016

Re : Multi-fonctions PIXMA MP640 - Invalid argument - (sur MINT)

@d33p,

Il faut parfois rester simple : les paquets Mint sont des paquets Ubuntu, donc à upgrader en conséquence.
Rolf Bensch n'est pas portnawik... Ton bogue a été corrigé par Louis Lagendijk le 2015-06-27, c'est ballot.

Hors ligne

#12 17-01-2018 12:36:41

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : Multi-fonctions PIXMA MP640 - Invalid argument - (sur MINT)

je ne comprends pas, s'il est corrigé et que l'OS est à jour, pourquoi cela réagit comme ça?

science sans conscience n'est que ruine de l'âme...

Hors ligne

#13 17-01-2018 12:46:42

èfpé
Membre
Inscription : 10-07-2016

Re : Multi-fonctions PIXMA MP640 - Invalid argument - (sur MINT)

Re-,

Corrigé en amont (upstream), mais pas intégré aux dépôts Ubuntu... d'ailleurs ça râle un peu sur le rapport de bogue.
Quoi qu'il en soit nous avons là une parfaite illustration du fait que chez Debian, le terme stable n'est pas un vain mot.

Hors ligne

#14 17-01-2018 12:52:38

d33p
Adhérent(e)
Lieu : Lorraine
Distrib. : Debian testing buster 64bits
Noyau : En fonction des updates testing buster
(G)UI : En fonction des updates testing buster
Inscription : 01-12-2015

Re : Multi-fonctions PIXMA MP640 - Invalid argument - (sur MINT)

ben vraiment, je vois de moins en moins la "valeur ajoutée" de ces OS... j'en viens à les trouver meme limite en dessous de Debian. (c'est vraiment un avis perso) comme je suis encore "jeune" dans le monde linux, j'essaie parfois de tester une distrib par-ci une distrib par-la, mais au final, retour à Debian.... sans faire l'extremiste...

science sans conscience n'est que ruine de l'âme...

Hors ligne

Pied de page des forums