Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-01-2018 23:00:41

Marc02
Membre
Distrib. : DFLinux Stretch
Noyau : Debian 9
(G)UI : xxxxx
Inscription : 14-01-2018

Pas de boot en USB

Bonjour à tous,

PC Acer Veriton, Windows 10 x64, partition GPT.

J'ai DFLinux sur une clé USB bootable faite avec l'outil de gravure Rufus, d'après l'image ISO dflinux-stretch-rev1-amd64.

Dans le BIOS => BOOT le tableau affiche sous Boot Priority Order :

1st Boot Device    =  Windows Boot Manager
2d  Boot Device    =  CD & DVD
3d  Boot Device    =  Removable Device
4th Boot Device    =  LAN
Hard Disk Drive Priority     =  [Press Enter]
Optical Disk Drive Priority  =  [Press Enter]
Removable Device Priority =  [Press Enter]
Network Device Priority     =  [Press Enter]

Dans les quatre du haut, les flèches sont inactives. Je ne peux pas faire monter 3d Boot Device (Removable, donc la clé USB) en première position.

Dans les quatre du bas, je sélectionne Removable Device Priority et je tape Entrée.

Une nouvelle fenêtre s'affiche. Dans sa partie droite, la plus grande, j'ai Removable Device Priority. Dans la partie gauche, plus petite :

F7  : Load user defined Defaults
F8  : Save as user defined
F9  : Optimize Defaults
F10: Save and Exit

Je les ai tous essayés l'un après l'autre après reboot de la machine, F7, F8, F9, sans résultat : le Bios ne reconnaît pas l'USB et boot toujours sur Windows. Que dois-je faire pour entrer dans DFLinux ?

Hors ligne

#2 15-01-2018 00:13:42

tux12
Membre
Lieu : ./
Distrib. : stable
Noyau : celui de la stable
(G)UI : KDE
Inscription : 27-02-2008

Re : Pas de boot en USB

Bonjour,

Avec les options de la partie la plus petite de la fenêtre ouverte en sélectionnant le "Removable Device Priority" tu dois pouvoir modifier l'ordre de démarrage pour ce type de périphérique. Alternativement essaie de sélectionner le premier de la liste (actuellement Windows Boot Manager - soit le HDD Priority d'après ton post) dans la partie basse et de le faire descendre/reculer dans l'ordre des priorités. Ça devrait permettre aux autres types de médias (CD et Removable) de remonter.

Dans tous les cas je pense que les 4 lignes hautes reflètent la config courante et les 4 basses permettent les réglages.

J'espère que mon laïus est compréhensible. tongue

Dernière modification par tux12 (15-01-2018 00:14:23)

Hors ligne

#3 15-01-2018 10:29:44

Marc02
Membre
Distrib. : DFLinux Stretch
Noyau : Debian 9
(G)UI : xxxxx
Inscription : 14-01-2018

Re : Pas de boot en USB

Ton post est parfaitement clair, tux12. Tu as raison : les 4 lignes hautes reflètent certainement la config courante (celle qui est actuellement utilisée) et les 4 basses permettent les réglages.

Avec les flèches je parcours toute la liste de haut en bas puis de bas en haut, les sélectionnant les uns après les autres. Mais rien (en tout cas rien de ce que j'ai essayé) ne me permet de placer Removable Device en position prioritaire.

En toute logique la manip semble être :

1°/ Sélectionner Removable Device Priority dans la partie principale de la fenêtre.

2°/ Taper F8 : Save as user defined (Sauvegarder ce réglage choisi par l'utilisateur)

Et ça ne marche pas. Le Bios boot toujours sur windows, je viens de refaire les manips ce matin.

Hors ligne

#4 15-01-2018 12:36:05

raleur
Membre
Inscription : 03-10-2014

Re : Pas de boot en USB

Le PC n'a pas un menu de démarrage qu'on affiche en appuyant sur une touche particulière (souvent une des touches F1 à F12) et dans lequel on pourrait sélectionner le système ou le périphérique à amorcer ?

Hors ligne

#5 15-01-2018 15:02:36

Marc02
Membre
Distrib. : DFLinux Stretch
Noyau : Debian 9
(G)UI : xxxxx
Inscription : 14-01-2018

Re : Pas de boot en USB

Oui bien sûr, mais n'est-ce pas le Bios dont tu parles ?  Sur l'Acer on entre dedans en tapant Suppr à l'ouverture, alors que c'était F2 sur mon précédent ordi.

Le Bios donne effectivement des choix pour sélectionner le périphérique à amorcer. Et c'est précisément cette étape que je ne parviens pas à dépasser : je n'arrive ni à faire descendre Windows Boot Manager (prioritaire par défaut), ni à remonter Removable Device pour qu'il devienne le 1st Boot Device tout en haut de la liste, commandant au Bios de booter  sur la clé USB. Il y a là une manip qui m'échappe parce que cette sélection devrait être très simple ; je l'ai fait des dizaines de fois sur mon ancien PC, hélas HS !

Hors ligne

#6 15-01-2018 15:11:22

raleur
Membre
Inscription : 03-10-2014

Re : Pas de boot en USB

1) C'est un firmware UEFI, pas un BIOS.
2) Non, ce n'est pas de cela dont je parle. F2/Suppr donne accès aux paramètres du firmware. La touche dont je parle déclenche un menu de démarrage qui permet de choisir le système ou le périphérique à amorcer cette fois-ci seulement.

Hors ligne

#7 15-01-2018 16:19:35

Marc02
Membre
Distrib. : DFLinux Stretch
Noyau : Debian 9
(G)UI : xxxxx
Inscription : 14-01-2018

Re : Pas de boot en USB

UEFI tu as raison. Il n'empêche que quand j'entre dedans (Suppr à l'ouverture) il y a bel et bien BIOS écrit en toutes lettres.

Pour l'autre touche dont tu parles, celle qui déclencherait un menu de démarrage, je ne vois vraiment pas. Est-ce une touche qu'il faut taper comme celle du Bios, juste après le boot, pendant les 2 ou 3 secondes où l'invitation s'affiche en bas à gauche ?

Hors ligne

#8 15-01-2018 16:25:26

raleur
Membre
Inscription : 03-10-2014

Re : Pas de boot en USB

Oui. Parfois l'écran de démarrage du firmware BIOS ou UEFI a l'amabilité d'afficher de quelle touche il s'agit, par exemple :

F2: Enter Setup
F8: Boot Menu

Ça devrait aussi être mentionné dans le manuel de la carte mère ou du PC.
Dans le cas contraire, il faut tâtonner. Cela fait longtemps que je n'ai pas vu de PC qui n'avait pas cette option.

Dernière modification par raleur (15-01-2018 16:27:23)

Hors ligne

#9 15-01-2018 17:46:18

potemkine17
Membre
Distrib. : Débian 9
Noyau : i386
(G)UI : LXDE
Inscription : 17-09-2014

Re : Pas de boot en USB

Bonjour,
une simple question  (au ca soù ce la n'a pas été vérifier) ;En faisant "entrée" sur les autres options de boot, est-il proposé "hard-disk 0, hard-disk 1..."? Que ce soit sur Windows ou CD-DVd ?

Hors ligne

#10 15-01-2018 20:30:57

Marc02
Membre
Distrib. : DFLinux Stretch
Noyau : Debian 9
(G)UI : xxxxx
Inscription : 14-01-2018

Re : Pas de boot en USB

C'est fait ... et à la fois pas fait !
La bonne commande se trouve dans les 4 d'en haut. Il faut ouvrir 1st Boot Device [Entrée], une petite fenêtre bleue s'ouvre, donnant le choix de sélectionner l'un des 4 "Devices" proposés : Windows Boot Manager ; CD&DVD ; Removable Device ; LAN. Celui que l'on sélectionne, validant par Entrée, passe en première position et devient le 1st Boot Device par défaut. F10 Save Settings and Exit.
C'est gagné ... du moins le croyais-je.
Non, rien n'est gagné du tout. Removable Device est bien passé en position 1st Boot dans le menu du Bios, mais ça ne change malheureusement rien, le PC continue de booter sur Windows 10. A tout hasard j'ai fait un essai en rendant CD&DVD prioritaire. Zéro. C'est toujours sur Windows que ça boot. Je n'y comprends plus rien.

A titre documentaire :
System BIOS, Version R02-A3, Build date 07/05/2017, EC Firmware, Version 1.03, Build date 09/30/2016.

Hors ligne

#11 15-01-2018 20:56:42

Marc02
Membre
Distrib. : DFLinux Stretch
Noyau : Debian 9
(G)UI : xxxxx
Inscription : 14-01-2018

Re : Pas de boot en USB

La touche dont parle "raleur", celle qui déclenche un menu de démarrage, c'est F12 sur mon Acer. Elle ouvre une fenêtre bleue, Please select boot device.

Il n'y a que 2 propositions :

Windows Boot Manager
UEFI : Sandisk, Partition 1


ENTER to select boot device
ESC to boot using defaults

Les flèches verticales ne font que sélectionner l'un des deux, soit "Windows Boot Manager", soit "UEFI : Sandisk, Partition 1."

CD&DVD, Removable Device et LAN ont disparu.

Hors ligne

#12 15-01-2018 21:17:02

raleur
Membre
Inscription : 03-10-2014

Re : Pas de boot en USB

Sandisk, c'est la clé USB ou le SSD du PC ?

Hors ligne

#13 15-01-2018 22:06:18

Marc02
Membre
Distrib. : DFLinux Stretch
Noyau : Debian 9
(G)UI : xxxxx
Inscription : 14-01-2018

Re : Pas de boot en USB

Propriétés du Lecteur F => Matériel

Sandisk CruzerFit USB Device

Hors ligne

#14 15-01-2018 22:15:07

Marc02
Membre
Distrib. : DFLinux Stretch
Noyau : Debian 9
(G)UI : xxxxx
Inscription : 14-01-2018

Re : Pas de boot en USB

A l'aide des flèches verticales je sélectionne UEFI : Sandisk, Partition 1 => Entrée

Une fenêtre rouge s'affiche :

SECURE BOOT VIOLATION
Invalid signature detected : check secure boot policy in setup

Hors ligne

#15 15-01-2018 22:42:08

raleur
Membre
Inscription : 03-10-2014

Re : Pas de boot en USB

Il faut désactiver le secure boot dans les paramètres UEFI.

Hors ligne

#16 15-01-2018 23:44:23

Marc02
Membre
Distrib. : DFLinux Stretch
Noyau : Debian 9
(G)UI : xxxxx
Inscription : 14-01-2018

Re : Pas de boot en USB

Où c'est-y qu'on les trouve les paramètres UEFI ?

Hors ligne

#17 16-01-2018 10:50:09

d33p
Adhérent(e)
Lieu : Longwy
Distrib. : Debian testing buster 64bits
Noyau : Linux, en fonction des updates testing buster
(G)UI : GNOME, en fonction des updates testing buster
Inscription : 01-12-2015

Re : Pas de boot en USB

hello,
est ce que ce lien peut t'aider?
http://grl.infor.services.free.fr/Documents/03.pdf
(parfois pour bricoler l'option secure boot, il faut mettre un password sur le BIOS, que tu peux enlever apres coup)
au dela de desactiver le secure boot, il faut aussi parfois activer CSM selon l'OS, cf:

The Compatibility Support Module (CSM) is a component of the UEFI firmware that provides legacy BIOS compatibility by emulating a BIOS environment, allowing legacy operating systems and some option ROMs that do not support UEFI to still be used.

(source wikipedia)
JC


science sans conscience n'est que ruine de l'âme...
Location:
https://framacarte.org/en/map/debian-fa … 78/5.76506

Hors ligne

#18 16-01-2018 12:12:54

Marc02
Membre
Distrib. : DFLinux Stretch
Noyau : Debian 9
(G)UI : xxxxx
Inscription : 14-01-2018

Re : Pas de boot en USB

Un grand merci pour votre aide.
Sur mon Acer, c'est la 1ère procédure qui fonctionne (pour Aspire XC100)
TOUT a été fait dans les règles.

Removable Device est positionné en 1st Boot.
Dans Authentification du Bios, Secure Boot est désactivé.
Lancer CSM => Toujours
F10 Save and Exit

Et ça boot encore sur Windows ! Ce *¤#µ# de bios Acer ne reconnait pas mes commandes et continue de n'obéir qu'à Windows Boot Manager. Alors qu'avec mon vieux XP je remontais l'USB en 1st Boot en deux clics de souris et le PC bootait sur la clé impec ......
Ils appellent ça le progrès.

Hors ligne

#19 16-01-2018 12:31:50

d33p
Adhérent(e)
Lieu : Longwy
Distrib. : Debian testing buster 64bits
Noyau : Linux, en fonction des updates testing buster
(G)UI : GNOME, en fonction des updates testing buster
Inscription : 01-12-2015

Re : Pas de boot en USB

ya aussi parfois les options "fastboot" si c'est le cas, faut desactiver.
ou.
tu peux pas mettre "windows boot manager" en disable?
sinon une autre idée, l'usb sur la machine, si c'est de l'usb 3 parfois faut juste le passer en usb2 (compatible) ça peut empecher une clé de booter.
sinon la clé elle-meme, t'as essayé avec une autre clé usb? de la meme maniere, as -tu essayé avec un autre iso? l'iso / la clé sont bien bootable (genre testé sur une autre machine)?
...
car si tous les parametres bios sont ok, ça peut venir d'autre chose.

Dernière modification par d33p (16-01-2018 12:34:20)


science sans conscience n'est que ruine de l'âme...
Location:
https://framacarte.org/en/map/debian-fa … 78/5.76506

Hors ligne

#20 16-01-2018 12:38:15

Marc02
Membre
Distrib. : DFLinux Stretch
Noyau : Debian 9
(G)UI : xxxxx
Inscription : 14-01-2018

Re : Pas de boot en USB

HIP HIP HIP .... ! ! ! ça marche.
Il fallait retourner à F12 sur "Please Select Boot Device" choisir UEFI : Sandisk, Partition 1
C'est bon : la page de DFLinux s'est affichée par la clé USB. Il me reste maintenant à explorer tranquillement (enfin!) cette nouvelle version de HandyLinux dont on dit patout beaucoup de bien.
Merci raleur
Merci d33p
Merci à Tous

Hors ligne

#21 16-01-2018 13:03:25

Marc02
Membre
Distrib. : DFLinux Stretch
Noyau : Debian 9
(G)UI : xxxxx
Inscription : 14-01-2018

Re : Pas de boot en USB

Eh oui ... les nouveaux réglages ne sont pas enregistrés de façon permanente. Quittant DFLinux (et par conséquent la clé USB) le Bios me renvoie automatiquement sur Windows, alors même que la clé est toujours active et placée en 1st Boot.

Je viens de refaire F12. C'est bien ça : dans la fenêtre "Please Select Boot Device" Windows Boot Manager est redevenu le choix par défaut. Pour booter sur la clé, il faut que je tape systématiquement F12 pour sélectionner manuellement UEFI : Sandisk, Partition 1.

Beaucoup de complications pour rien, à mon avis. Mais "faut vivre avec son temps", pas vrai ?

Hors ligne

#22 16-01-2018 14:44:21

d33p
Adhérent(e)
Lieu : Longwy
Distrib. : Debian testing buster 64bits
Noyau : Linux, en fonction des updates testing buster
(G)UI : GNOME, en fonction des updates testing buster
Inscription : 01-12-2015

Re : Pas de boot en USB

t'es en live "cd/usb" en fait? t'as pas l'installation en dur?

Dernière modification par d33p (16-01-2018 14:52:18)


science sans conscience n'est que ruine de l'âme...
Location:
https://framacarte.org/en/map/debian-fa … 78/5.76506

Hors ligne

#23 16-01-2018 17:55:10

Marc02
Membre
Distrib. : DFLinux Stretch
Noyau : Debian 9
(G)UI : xxxxx
Inscription : 14-01-2018

Re : Pas de boot en USB

Exact d33p, je suis nouveau dans Linux.

Je cherche une distribution simple, facile à prendre en main pour un débutant. Et sur ce plan, DFLinux me paraît être un très bon choix avec son "HandyMenu", ses nombreux guides et tutos. Pour l'instant je me contente d'en explorer les possibilités en USB-live, on verra par la suite.

Autant j'étais content de travailler avec XP, autant je déteste cette usine à gaz qu'est Windows 10. Ce que je trouve stupéfiant ce que (dans tous les domaines : voir la téléphonie ! ) au lieu d'aller dans le sens de la simplification, on s'ingénie au contraire à tout complexifier. Si les geeks adorent, ben moi pas.

Hors ligne

#24 16-01-2018 19:51:54

d33p
Adhérent(e)
Lieu : Longwy
Distrib. : Debian testing buster 64bits
Noyau : Linux, en fonction des updates testing buster
(G)UI : GNOME, en fonction des updates testing buster
Inscription : 01-12-2015

Re : Pas de boot en USB

oui, alors pour moi rien d'anormal sur le fait que tu doives remettre les parametres à la main dans le BIOS concernant un live CD/usb.
raleur peut confirmer ou infirmer, mais cela me semble être le comportement normal...

science sans conscience n'est que ruine de l'âme...
Location:
https://framacarte.org/en/map/debian-fa … 78/5.76506

Hors ligne

#25 16-01-2018 21:42:13

Marc02
Membre
Distrib. : DFLinux Stretch
Noyau : Debian 9
(G)UI : xxxxx
Inscription : 14-01-2018

Re : Pas de boot en USB

Remettre les paramètres à la main dans le Bios est une procédure normale, je suis bien d'accord avec toi . Ce que je trouve anormal, et pour tout dire ridicule, c'est l'invraisemblable labyrinthe que le BIOS/UEFI d'Acer m'a obligé à parcourir, avec l'aide de raleur et la tienne, pour faire un réglage élémentaire qui me demandait cinq minutes dans XP.

Hors ligne

Pied de page des forums