Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-02-2018 01:37:55

sebebof
Membre
Lieu : Avranches
Distrib. : Debian Stretch Testing LXDE
Noyau : 4.14.0-3-amd64
(G)UI : PCManFM
Inscription : 30-12-2017

[Résolu] Adaptateur passe en "offline" quand la batterie est chargée.

Bonjour.

Après qu'elle m’ait lâchée, j'ai changé ma batterie.

Elle est bien reconnue par le système et se charge normalement et s'utilise normalement en nomade.

Ce qui est gênant c'est qu'une fois qu'elle est chargée, l'adaptateur secteur est mis "hors ligne" et ne repasse plus en "connecté" avant que la batterie se soit déchargée ... et que le pc se soit mis en veille prolongée.

Est ce que quelqu'un a une idée du pourquoi et du comment ?


kernel :4.14.0-3-amd64

lxde

Dernière modification par sebebof (26-02-2018 12:27:31)

Hors ligne

#2 22-02-2018 11:53:47

gargamel79
Membre
Lieu : Bressuire
Distrib. : wheezy jessie Stretch
Noyau : 4.9.0-6-686-pae
(G)UI : xfce ou mate
Inscription : 15-11-2009

Re : [Résolu] Adaptateur passe en "offline" quand la batterie est chargée.

Cela ne répond pas exactement à ton problème mais j'avais lu "quelque part" sur le WEB qu'il est déconseillé de charger les batteries à + de 80% et décharger à - de 20%.
Sur mon portable, j'essaie de m'en tenir à cette recommandation.

Hors ligne

#3 22-02-2018 15:50:31

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Adaptateur passe en "offline" quand la batterie est chargée.

Et tu fais ça comment quand le PC ne permet pas de régler un seuil de charge maxi ?

Hors ligne

#4 22-02-2018 15:56:28

gargamel79
Membre
Lieu : Bressuire
Distrib. : wheezy jessie Stretch
Noyau : 4.9.0-6-686-pae
(G)UI : xfce ou mate
Inscription : 15-11-2009

Re : [Résolu] Adaptateur passe en "offline" quand la batterie est chargée.

Je surveille l'uplet de chargement de batterie sur Mate. Mais il arrive parfois que je débranche en catastrophe !

Hors ligne

#5 22-02-2018 16:20:13

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Adaptateur passe en "offline" quand la batterie est chargée.

Tu débranches quoi ? Le secteur, la batterie ?

Dernière modification par raleur (22-02-2018 16:55:08)

Hors ligne

#6 22-02-2018 21:45:36

Philou92
Adhérent(e)
Lieu : Hauts de Seine
Distrib. : Debian stretch 9.4
Noyau : Linux 4.9.0-6-amd64
(G)UI : Gnome 3.22
Inscription : 29-04-2015

Re : [Résolu] Adaptateur passe en "offline" quand la batterie est chargée.

sebebof a écrit :

Bonjour.

Après qu'elle m'ai lâché j'ai changé ma batterie.

Elle est bien reconnue par le système et se charge normalement et s'utilise normalement en nomade.

Ce qui est gênant c'est qu'une fois qu'elle est chargée, l'adaptateur secteur est mis "hors ligne" et ne repasse plus en "connecté" avant que la batterie se soit déchargée ... et que le pc se soit mis en veille prolongée.

Est ce que quelqu'un a une idée du pourquoi et du comment ?


kernel :4.14.0-3-amd64

lxde



Etrange.

Quelle est la référence du pc, la référence de la batterie d'origine, la référence de la batterie de remplacement ?
Quelle est l'interface graphique (GUI) employée ?


Chaque siècle fera son œuvre, aujourd’hui civique, demain humaine. Aujourd’hui la question du droit, demain la question du salaire. Salaire et droit, au fond c’est le même mot. L’homme ne vit pas pour n’être point payé ; Dieu en donnant la vie contracte une dette ; le droit, c’est le salaire inné ; le salaire, c’est le droit acquis.
             Quatrevingt-treize
             Victor Hugo.

Hors ligne

#7 22-02-2018 21:52:10

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Adaptateur passe en "offline" quand la batterie est chargée.

Au fait, que signifie exactement que l'adaptateur secteur est mis "hors ligne" ?

Hors ligne

#8 23-02-2018 12:15:58

gargamel79
Membre
Lieu : Bressuire
Distrib. : wheezy jessie Stretch
Noyau : 4.9.0-6-686-pae
(G)UI : xfce ou mate
Inscription : 15-11-2009

Re : [Résolu] Adaptateur passe en "offline" quand la batterie est chargée.

raleur a écrit
Tu débranches quoi ? Le secteur, la batterie ?


Je débranche le chargeur de mon portable, et éventuellement la prise secteur du chargeur smile

Hors ligne

#9 23-02-2018 14:36:21

raleur
Membre
Inscription : 03-10-2014

Re : [Résolu] Adaptateur passe en "offline" quand la batterie est chargée.

Donc tu décharges et recharges sans cesse la batterie, ce qui l'use encore plus vite que la maintenir à pleine charge.

Dernière modification par raleur (23-02-2018 14:37:56)

Hors ligne

#10 24-02-2018 11:32:00

sebebof
Membre
Lieu : Avranches
Distrib. : Debian Stretch Testing LXDE
Noyau : 4.14.0-3-amd64
(G)UI : PCManFM
Inscription : 30-12-2017

Re : [Résolu] Adaptateur passe en "offline" quand la batterie est chargée.

Bonjour.

Je n'ai pas pu revenir vous lire avant ....

gargamel79 a écrit :

raleur a écrit
Tu débranches quoi ? Le secteur, la batterie ?


Je débranche le chargeur de mon portable, et éventuellement la prise secteur du chargeur smile



@gargamel Je ne peux pas faire ça. J'ai essayé et après 2h j'ai rebranché l'adaptateur au PC sans qu'il se remette à recharger la batterie ...
Il a fallu qu'elle se vide et redémarre le pc (veille prolongée en fait). Alors seulement l'adaptateur apparaissait connecté ...


J'ai d'ailleurs testé l'inverse. Une fois la batterie rechargée (et donc l'adaptateur automatiquement switché en "off-line") j'ai débranché la batterie à chaud. Le PC s'est éteint comme s'il n'était pas branché ....

raleur a écrit :

Donc tu décharges et recharges sans cesse la batterie, ce qui l'use encore plus vite que la maintenir à pleine charge.



Je pense, comme @Raleur, que la batterie s'usera plus vite en étant sans cesse vidée et remplie....

voici les infos que j'ai collecté sur mon PC

uname -a
Linux debian-seb 4.14.0-3-amd64 #1 SMP Debian 4.14.13-1 (2018-01-14) x86_64 GNU/Linux



upower -d
Device: /org/freedesktop/UPower/devices/line_power_ACAD
  native-path:          ACAD
  power supply:         yes
  updated:              sam. 24 févr. 2018 10:03:06 CET (144 seconds ago)
  has history:          no
  has statistics:       no
  line-power
    warning-level:       none
    online:              yes
    icon-name:          'ac-adapter-symbolic'

Device: /org/freedesktop/UPower/devices/battery_BAT1
  native-path:          BAT1
  vendor:               LGC
  model:                DELL 49VTP27J
  serial:               FA9D
  power supply:         yes
  updated:              sam. 24 févr. 2018 10:05:07 CET (23 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               charging
    warning-level:       none
    energy:              9,4461 Wh
    energy-empty:        0 Wh
    energy-full:         56,7543 Wh
    energy-full-design:  57,72 Wh
    energy-rate:         18,5481 W
    voltage:             11,312 V
    time to full:        2,6 hours
    percentage:          16%
    capacity:            98,3269%
    technology:          lithium-ion
    icon-name:          'battery-low-charging-symbolic'
  History (charge):
    1519463107  16,000  charging
  History (rate):
    1519463107  18,548  charging

Device: /org/freedesktop/UPower/devices/DisplayDevice
  power supply:         yes
  updated:              sam. 24 févr. 2018 10:05:07 CET (23 seconds ago)
  has history:          no
  has statistics:       no
  battery
    present:             yes
    state:               charging
    warning-level:       none
    energy:              9,4461 Wh
    energy-full:         56,7543 Wh
    energy-rate:         18,5481 W
    time to full:        2,6 hours
    percentage:          16%
    icon-name:          'battery-low-charging-symbolic'

Daemon:
  daemon-version:  0.99.7
  on-battery:      no
  lid-is-closed:   no
  lid-is-present:  yes
  critical-action: HybridSleep
 



Actuellement la batterie est en charge et j'ai :

acpi -ab
Battery 0: Charging, 30%, 02:05:25 until charged
Adapter 0: on-line
 



J'éditerai ce post avec la même commande un fois que la batterie aura été rechargée ...

Hors ligne

#11 24-02-2018 13:54:20

sebebof
Membre
Lieu : Avranches
Distrib. : Debian Stretch Testing LXDE
Noyau : 4.14.0-3-amd64
(G)UI : PCManFM
Inscription : 30-12-2017

Re : [Résolu] Adaptateur passe en "offline" quand la batterie est chargée.

Une fois la batterie chargée j'ai :

acpi -ab
Battery 0: Discharging, 86%, 02:53:33 remaining
Adapter 0: off-line
 

Hors ligne

#12 26-02-2018 12:23:19

sebebof
Membre
Lieu : Avranches
Distrib. : Debian Stretch Testing LXDE
Noyau : 4.14.0-3-amd64
(G)UI : PCManFM
Inscription : 30-12-2017

Re : [Résolu] Adaptateur passe en "offline" quand la batterie est chargée.

Bonjour.

Problème résolu ... après un passage sur W10. ops.gif

Je pense que l'électronique de la batterie devait attendre un "signal" de windows pour justifier la charge complète.

Voici maintenant ce que j'obtiens :

:~$ upower -d
Device: /org/freedesktop/UPower/devices/line_power_ACAD
  native-path:          ACAD
  power supply:         yes
  updated:              lun. 26 févr. 2018 08:48:07 CET (8443 seconds ago)
  has history:          no
  has statistics:       no
  line-power
    warning-level:       none
    online:              yes
    icon-name:          'ac-adapter-symbolic'

Device: /org/freedesktop/UPower/devices/battery_BAT1
  native-path:          BAT1
  vendor:               LGC
  model:                DELL 49VTP27J
  serial:               FA9D
  power supply:         yes
  updated:              lun. 26 févr. 2018 11:08:10 CET (40 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               fully-charged
    warning-level:       none
    energy:              55,5999 Wh
    energy-empty:        0 Wh
    energy-full:         56,1882 Wh
    energy-full-design:  57,72 Wh
    energy-rate:         0,0111 W
    voltage:             12,454 V
    percentage:          98%
    capacity:            97,3462%
    technology:          lithium-ion
    icon-name:          'battery-full-charged-symbolic'

Device: /org/freedesktop/UPower/devices/DisplayDevice
  power supply:         yes
  updated:              lun. 26 févr. 2018 08:50:10 CET (8320 seconds ago)
  has history:          no
  has statistics:       no
  battery
    present:             yes
    state:               fully-charged
    warning-level:       none
    energy:              55,5999 Wh
    energy-full:         56,1882 Wh
    energy-rate:         0,0111 W
    percentage:          98%
    icon-name:          'battery-full-charged-symbolic'

Daemon:
  daemon-version:  0.99.7
  on-battery:      no
  lid-is-closed:   no
  lid-is-present:  yes
  critical-action: HybridSleep
 



:~$ acpi -ab
Battery 0: Unknown, 98%
Adapter 0: on-line
 




Bref, cela fonctionne maintenant, je reste sur l'adaptateur une fois que la batterie est rechargée, ce qui est bien plus confortable ...

Hors ligne

Pied de page des forums