Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-12-2009 14:37:51

Fourch
Membre
Distrib. : Sid
Noyau : 2.6.30-2_amd64
(G)UI : Gnome
Inscription : 26-08-2009

Problème Xgl

Bonjour à tous.

Il y a longtemps, j'étais venu poster ici pour des problèmes avec mes drivers proprio ATI. Après plusieurs heures de combat, j'avais enfin réussi à atteindre un compromis, mais jamais vraiment l'effet désiré. Puis ça a de nouveau foiré, et j'ai vraiment laissé tomber. Sauf que là je reviens à la charge car j'aimerai faire tourner des jeux natifs linux, et c'est bête de pas en profiter.

Voilà mon problème : je n'arrive pas à avoir l'accélération 3D.

En gros :  j'ai installé la dernière version de fglrx depuis les dépots, ou même depuis le site. J'ai configuré bien mon xorg.conf (du moins je pense, je vous le mets à la fin du post au cas où) et lorsque j'essaie d'activer compiz pour voir, cela ne marche pas. Parcontre, je n'ai plus de contour de fenêtres (pratique pour les fermer...). Bref, j'ai essayé de lancer le jeu, et un message d'erreur me dit :

X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  137 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  22
  Current serial number in output stream:  22


Remarquez que ce message apparait également pour xglinfo.

Lorsque je lance compiz depuis le terminal, voilà :

Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
Detected PCI ID for VGA: 01:00.0 0300: 1002:9498 (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: not present.
aborting and using fallback: /usr/bin/metacity


Ou encore, lorsque je tente de lancer une application comme avant-windows-navigator :

Attention: votre affichage n'est pas composé. Lancez compiz (-fusion) ou un autre gestionnaire de composite.


Bref, rien n'est bon quoi. Pourtant, l'installation des fglrx s'est déroulée sans encombres. J'accède bien à une interface graphique, je peux changer la résolution avec le panneau de controle catalyst. Mais même dans ce panneau là, l'option d'anticrénelage est grisée.

Donc je demande votre aide pour essayer une bonne fois pour toutes de résoudre ce problème et d'enfin profiter pleinement de mon Linux. Merci

Pour info :

Debian SID
Kernel : 2.6.32-trunk-amd64

xorg.conf :

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/cyrillic"
    FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/100dpi"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "dbe"
    Load  "extmod"
    Load  "record"
    Load  "dri2"
    Load  "dri"
    Load  "glx"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
    Option        "XkbRules" "xorg"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "fr"
    Option        "XkbVariant" "latin9"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Dernière modification par Fourch (26-12-2009 23:50:51)

Hors ligne

#2 12-01-2010 22:29:52

Fourch
Membre
Distrib. : Sid
Noyau : 2.6.30-2_amd64
(G)UI : Gnome
Inscription : 26-08-2009

Re : Problème Xgl

petit UP

Hors ligne

#3 24-01-2010 14:35:59

Fourch
Membre
Distrib. : Sid
Noyau : 2.6.30-2_amd64
(G)UI : Gnome
Inscription : 26-08-2009

Re : Problème Xgl

Si je ne suis pas dans la bonne section, est-ce qu'un modo peut faire migrer mon post svp ? Merci

Hors ligne

#4 24-01-2010 17:55:15

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Problème Xgl

Voilà mon coco...

Peux pas t'aider davantage, je n'ai pas de carte ati. smile
As-tu vu ce lien : http://secian.free.fr/astuces/ati.html

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#5 24-01-2010 20:55:05

Fourch
Membre
Distrib. : Sid
Noyau : 2.6.30-2_amd64
(G)UI : Gnome
Inscription : 26-08-2009

Re : Problème Xgl

Merci smolski, je vais  regarder ce lien attentivement.

Hors ligne

#6 24-01-2010 22:12:01

Fourch
Membre
Distrib. : Sid
Noyau : 2.6.30-2_amd64
(G)UI : Gnome
Inscription : 26-08-2009

Re : Problème Xgl

Bon j'ai essayé la méthode de Secian, et ça ne marche toujours pas :

J'ai bien suivi toutes les étapes, jusqu'à l'étape où il faut tester le fglrxinfo et voilà le fameux résultat :

X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  135 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  14
  Current serial number in output stream:  14


Le fameux message du bonheur quoi...

J'ai du donc réinstaller les drivers à partir du .run du site ATI. En gros, je suis revenu à l'état d'avant.

Ce qu'il faut savoir c'est que j'ai le même problème sur 2 ordinateurs différents. Seuls points communs : debian (l'un squeeze, l'autre sid) et 2 ati (une 4875 et une 4650).

La malédiction continue...

Dernière modification par Fourch (24-01-2010 22:16:01)

Hors ligne

#7 24-01-2010 22:20:34

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Problème Xgl

Salut Fourch !

Cela n'aura pas été faute d'essayer en tout cas ! smile

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#8 25-01-2010 14:08:10

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Problème Xgl

Bjr,
Essaie de voir du coté d'Envy.
De mémoire c'est plus spécifique à Ubuntu, mais il y a peut être moyen. Par exemple en trouvant une install réussie chez les cousins et en reprenant le xorg.conf

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#9 26-01-2010 22:24:57

Fourch
Membre
Distrib. : Sid
Noyau : 2.6.30-2_amd64
(G)UI : Gnome
Inscription : 26-08-2009

Re : Problème Xgl

OK je vais essayer, mais la dernière fois jme souviens que ça n'avait pas été concluant.

Sinon, je suis le seul à avoir des problèmes avec Debian + ATI Proprio ?

J'ai rien fait pour en plus lol

Hors ligne

#10 27-01-2010 17:07:26

matt91150
Invité

Re : Problème Xgl

Bonjour,

Je suis egalement ennuyer avec les pilotes ati propriétaire installer via le script .run.
J'ai le meme type de message d'erreur que toi (je tourne avec une carte integré hd3100).
J'ai bien essayer les pilotes libres mais il y a que les prorio qui me reconnaisse correstement la resolution de mon tft 22" .
Je precise que je roule avec une debian squeeze et le meme kernel que toi!!!

Dernière modification par matt91150 (27-01-2010 17:13:16)

#11 27-01-2010 20:58:01

Fourch
Membre
Distrib. : Sid
Noyau : 2.6.30-2_amd64
(G)UI : Gnome
Inscription : 26-08-2009

Re : Problème Xgl

AH c'est cool ça. Enfin non c'est pas cool que t'aies le même problème que moi, c'est juste que ça me rassure de ne pas être le seul dans cette situation. On va quand même réussir à trouver une solution, parce que ça ne peut plus durer ! Là pour te dire, j'ai testé la modifs que proposait le site de Secian, et je suis revenu à ma config d'avant mais ça ne marche plus très bien. J'ai un problème de défilement des pages sur Firefox (iceweasel). C'est saccadé lorsque je scroll une page. J'avais déjà eu ce problème, c'était justement du aux pilotes et au manque d'accélération matérielle. Mais là, j'arrive pas à corriger le problème.

C'est quand même triste que ça ne marche pas sur Debian mais que ça marche bien sur Ubuntu !

Dernière modification par Fourch (27-01-2010 20:58:46)

Hors ligne

Pied de page des forums