Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-01-2010 00:00:39

ptilou
Membre
Distrib. : Squeeze, Ubuntu studio 12.04
(G)UI : Gnome, E17, XFCE
Inscription : 08-01-2010

Open Office par ssh[Résolu]

Bonsoir à tous et joyeuse bonne année

Voici le petit probléme qui me préoccupe:
J'ai une machine sous Lenny avec instrallé un serveur ssh
Une machine cliente sous Ubuntu 8.04
ssh en lui même fonctionne sans probléme: transfert de fichier et ouverture de fichier sur le serveur par la machine distante. Sauf Open office qui me demande User/mot de passe et refuse mes entrées (pourtant correctes) puis à la 3ème tentative me jette comme un malpropre. Le même fichier dans les mêmes conditions s'ouvre sans problème avec Abiword.
Donc je pense à un problème Open Office (paramétrage...?)
J'ai fait le test dans les deux sens en installant un serveur ssh sur la machine Ubuntu et et tentant d'ouvrir un fichier sur la machine sous Lenny. Le résultat est le même.

Merci de votre aide

Linuxien de longue date mais tout nouveau Débianeux

Dernière modification par ptilou (10-01-2010 20:12:17)


Il y a pire que le bruit des bottes: le silence des pantoufles

Hors ligne

#2 10-01-2010 08:49:34

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Open Office par ssh[Résolu]

Salut ptilou,

T'en fait pas, mon ptilou...

Open office est en graphique si je n'm'abuse ?

[large]ssh[/large] ne s'emploie qu'en ligne de commande, vois le tuto là :
http://debian-facile.org/doc:reseau:ssh#introduction

Keu s'est pas long et qu'il y en a à apprendre wink

Amitié, Joh... jo

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#3 10-01-2010 13:39:58

ptilou
Membre
Distrib. : Squeeze, Ubuntu studio 12.04
(G)UI : Gnome, E17, XFCE
Inscription : 08-01-2010

Re : Open Office par ssh[Résolu]

Merci pour ta réponse..... Mais ça ne resoud pas mon problème.
Je vais l'expliquer autrement.
Me connecter sur le serveur ssh ne pose aucune sorte de problème. Que ce soit en ligne de commande par ssh user@xxx.xxx.xxx.xxx par l'interface graphique de Gnome (se connecter à un serveur) ou dans Nautilus par ssh://user@xxx.xxx.xxx.xxx ou par Filezilla
Tout ça fonctionne nickel. Mon "disque" serveur monte bien sur le client. Que ce soit en ligne de commande ou par Nautilus je peux me balader dessus sans soucis. C'est après que ça corse.
Aucun problème pour modifier un fichier .jpg distant avec Gimp ni pour afficher un .pdf ni pour modifier un .odt avec Abiword (tout ça sous Gnome) Par contre impossible d'ouvrir quoi que se soit avec Open Office.
C'est clairement un problème de droit mais je sais pas le résoudre.
2 symptome complémentaires:
Gimp me demande à l'ouverture du fichier distant s'il peut ouvrir le trousseau de clé. Open Office ne demande rien et génère sur le serveur la log que voici
Jan 10 11:59:48 lennyserv sshd[3928]: Accepted password for brice from 192.168.1.11 port 46164 ssh2
Jan 10 11:59:48 lennyserv sshd[3928]: pam_unix(sshd:session): session opened for user brice by (uid=0)
Jan 10 11:59:48 lennyserv sshd[3931]: subsystem request for sftp
Jan 10 12:00:35 lennyserv sshd[3935]: Invalid user  from 192.168.1.11
Jan 10 12:00:35 lennyserv sshd[3935]: Failed none for invalid user  from 192.168.1.11 port 52521 ssh2
Jan 10 12:00:35 lennyserv sshd[3935]: pam_unix(sshd:auth): check pass; user unknown
Jan 10 12:00:35 lennyserv sshd[3935]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=device3.home
Jan 10 12:00:37 lennyserv sshd[3935]: Failed password for invalid user  from 192.168.1.11 port 52521 ssh2

J'ai vu sur les forums Open Office que d'autres avaient le même probleme mais je n'ai pas vu de solution.
Bon pour l'instant je me débrouille avec Abiword et je vais tester Genumeric pour les tabeaux voir Koffice donc c'est pas bloquant mais ça m'agace et étant d'un naturel obstiné...

Il y a pire que le bruit des bottes: le silence des pantoufles

Hors ligne

#4 10-01-2010 15:15:18

chiwawa
Membre
Distrib. : Débian Satable
Noyau : Celui présent dans la dernière stable
(G)UI : Gnome 3
Inscription : 18-04-2009

Re : Open Office par ssh[Résolu]

Question bette pourquoi ne rapatrie tu pas ce malheureux fichier pour le travailler en local est une fois fini tu le renvois sur l'autre poste.

Sinon faut voir au niveau des comptes présent sur tes deux machine.

Car sa bloque a ce niveau (Jan 10 12:00:35 lennyserv sshd[3935]: Invalid user  from 192.168.1.11).
un problème d'utilisateur ont dirai.

Après moi sur mon serveur j'utilise un système de clé (j'ai pas entrer 100 par jours le même pass est ces plus sécurité en plus).
Sinon utilisée Ooo a distance, j'ai jamais tester j'avoue.

Tous mes PC sont sous Débian maintenant.
Poste mobile => ASUS M51S.
Poste fixe => PROC AMD double cœur + 4 go de ram + 3 disques en raid 5 + disque système (un jour ce sera un ssd promis).

Hors ligne

#5 10-01-2010 15:36:05

ptilou
Membre
Distrib. : Squeeze, Ubuntu studio 12.04
(G)UI : Gnome, E17, XFCE
Inscription : 08-01-2010

Re : Open Office par ssh[Résolu]

chiwawa a écrit :

Question bette pourquoi ne rapatrie tu pas ce malheureux fichier pour le travailler en local est une fois fini tu le renvois sur l'autre poste.


Ben justement pour ne pas avoir à faire la manip. Mais c'est vrai et je pourrais même écrire un petit script pour rapatrier le fichier, lancer open office, remettre le fichier à sa place et effacer la copie mais c'est un peu lourdingue.   Et de toute manière pour l'instant comme je l'ai dit je contourne le problème en passant par Abiword

Car sa bloque a ce niveau (Jan 10 12:00:35 lennyserv sshd[3935]: Invalid user  from 192.168.1.11).
un problème d'utilisateur ont dirai.


Je crois aussi mais il n'y a que pour Open Office que le problème se pose.???


Il y a pire que le bruit des bottes: le silence des pantoufles

Hors ligne

#6 10-01-2010 16:53:50

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Open Office par ssh[Résolu]

Bjr,
Regarde sur cette page ce qu'il te reste à configurer pour que ça fonctionne >> openoffice mode serveur

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#7 10-01-2010 20:11:21

ptilou
Membre
Distrib. : Squeeze, Ubuntu studio 12.04
(G)UI : Gnome, E17, XFCE
Inscription : 08-01-2010

Re : Open Office par ssh[Résolu]

@phlinux
Merci pour le lien il m'a donné des idées et permis de vérifier ma config. Elle était bonne pour ce que je veut en faire (pas de forward X)
Par contre le problème s'est résolu de lui-même par le passage de la 2.4 à la 3.1 d'open office (Lenny et la 8.04 Ubuntu ont la 2.4 installée par défaut)
Avec la 3.1 sur le client plus de soucis. J'avais quand même testé Koffice pas de soucis non plus.
Bref tout roule reste le mode spacial de Nautilus mais c'est une autre histoire

Il y a pire que le bruit des bottes: le silence des pantoufles

Hors ligne

Pied de page des forums