Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-01-2010 01:53:17

caribou
Membre
Inscription : 11-01-2010

ALSA problème d'enregistrement sur carte son VIA

Bonjour,

je suis sous Debian lennny 64 bits avec un noyau 2.6.26. Ma carte mère est une Asus P5QD Turbo, j'utilise la carte son intégrée qui est censée être une VIA VT1708s d'après la doc. ALSA est bien installé sur mon système, version 1.0.16.

Normalement cette carte son a 6 E/S, à savoir 4 sorties et 2 entrées (Mic et Line-in). Or je viens de me rendre compte que je n'avais qu'une seule sortie qui fonctionnait (j'ai donc du son qui sort de mes hauts-parleurs) mais par contre pas moyen d'enregistrer quoi que ce soit. Par ailleurs la prise casque et la prise micro en façade ne marchent pas :-(

Cartes présentes:

$ lspci -k
...
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel
...
01:00.1 Audio device: ATI Technologies Inc HD48x0 audio
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel
...


Les cartes son reconnues par le système:

$ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfe6f8000 irq 22
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfe7fc000 irq 17


Bon, j'ai deux cartes son puisque ma carte video ATI HDMI est reconnue comme carte son mais ça c'est pas surprenant parait-il (voir par exemple ici)

$ cat /proc/asound/card0/codec#0 |grep Codec
Codec: VIA ID 397
$ cat /proc/asound/card1/codec#0 |grep Codec
Codec: ATI ATI R6xx HDMI


alsamixer ne m'offre que quatre réglages possibles: Master, PCM, Capture et Digital, aucun n'est muet et le volume est au maxi.

Et pourtant, pas moyen d'enregistrer quoi que ce soit. Par exemple, si je fais $ arecord essai.wav puis $ aplay essai.wav, ça ne me donne absolument rien.

Dans Gnome>Préférences>Son, le test "capture audio" ne me donne qu'une sorte de souffle mais pas de son.

En bootant sur un LiveCD, j'ai exactement le même problème.

J'ai passé deux jours à fouiner à droite à gauche, rien de concluant pour l'instant, même si j'ai vu pas mal de problèmes "approchants".
Merci d'avance

PS: les modules ALSA sont bien chargés

$ lsmod |grep snd
snd_pcm_oss            40864  0
snd_mixer_oss          19072  1 snd_pcm_oss
snd_seq_dummy           7428  0
snd_seq_oss            33728  0
snd_seq_midi           11072  0
snd_rawmidi            26912  1 snd_seq_midi
snd_seq_midi_event     11904  2 snd_seq_oss,snd_seq_midi
snd_seq                55008  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_seq_device         11796  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd_hda_intel         430796  2
snd_pcm                81416  2 snd_pcm_oss,snd_hda_intel
snd_page_alloc         13072  2 snd_hda_intel,snd_pcm
snd_hwdep              12296  1 snd_hda_intel
snd_timer              26120  2 snd_seq,snd_pcm
snd                    64632  14 snd_pcm_oss,snd_mixer_oss,snd_seq_oss,snd_rawmidi,snd_seq,snd_seq_device,snd_hda_intel,snd_pcm,snd_hwdep,snd_timer
soundcore              12432  1 snd

Hors ligne

#2 11-01-2010 10:12:07

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : ALSA problème d'enregistrement sur carte son VIA

Bonjour et bienvenu sur DF caribou !

Tu indiques :

alsamixer ne m'offre que quatre réglages possibles: Master, PCM, Capture et Digital,...


Je pense que tu as essayé de naviguer dans alsa mixer avec les flèces de ton clavier et le [Tabulation] également ?

Egalement, tour ou portable ton pc ?

En bootant sur un LiveCD, j'ai exactement le même problème.


Quelle distro ?

Je ne suis pas très doué côté matériel, ces questions sont essentiellement destinées à aider un plusss calé que moi pour t'aider. wink

Amitié, Joel


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 11-01-2010 10:19:01

caribou
Membre
Inscription : 11-01-2010

Re : ALSA problème d'enregistrement sur carte son VIA

Bonjour smolski et merci de ton aide,
effectivement j'ai navigué dans alsamixer avec les tabulations, mais sans succès.
Je suis sous debian lenny, et le liveCD sur lequel j'ai booté pour voir est également debian lenny. Mon PC est une tour.

J'ai essayé sans succès quelques options du module snd-hda-intel du genre model=allout ou model=6stack-digout mais ça ne fonctionne pas; ce n'est pas très surprenant puisque quand je vais voir dans ALSA-Configuration.txt la liste des cartes supportées, je ne trouve rien qui ressemble à celle que j'ai.

Dernière modification par caribou (11-01-2010 10:37:47)

Hors ligne

#4 12-01-2010 01:40:46

caribou
Membre
Inscription : 11-01-2010

Re : ALSA problème d'enregistrement sur carte son VIA

Bon, rien de neuf ???  sad
J'ai trouvé une page sur le driver snd-hda-intel écrite par l'un des créateurs du driver. Il donne pas mal d'indications qui peuvent être utiles, et également plusieurs utilitaires utiles pour déboguer ou configurer les drivers, notamment hda-analyzer et codecgraph. En plus il y a une belle GUI  tongue

Le premier permet de tripatouiller tous les réglages du driver, muter, démuter toutes les E/S et c'est comme ça que j'ai vu que les deux prises jack en façade n'étaient pas reconnues par la carte son (pourtant les branchements sont faits). J'ai aussi réussi à faire fonctionner une deuxième sortie, mais rien du côté des entrées.

Le deuxième utilitaire permet de faire de jolis graphes montrant les connexions internes entre les différents noeuds de la carte son (entrées, sorties, amplificateurs, mixers...) dans le genre de cet exemple: 3-3-10-ALC888.jpg Pour moi, ça donne pas quelque chose de très beau et d'ailleurs ça ne m'a pas beaucoup aidé à résoudre mon problème. Enfin si ça peut être utile à d'autres...

Donc je suis toujours preneur de tout conseil ou indice...

Hors ligne

#5 23-01-2010 23:20:13

caribou
Membre
Inscription : 11-01-2010

Re : ALSA problème d'enregistrement sur carte son VIA

Entre temps j'ai changé de carte son. Pour info, j'ai pris une M-Audio audiophile 24/96 qui marche très bien sous debian, aucun problème d'instal ou de config :-)

Hors ligne

Pied de page des forums