Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 17-01-2010 15:21:50

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Carte Nvidia Geforce GTX 275 Xorg -configure ne fonctionne pas

Bonjour,

Je n'arrive pas à installer les pilotes de ma carte Nvidia GTX 275
J'utilise les pilotes nvidia des sources non-free de sid de debian
Sur mon pc en 64 bytes Xorg -configure ne fonctionne pas.

Que faire ?

logo_3dminfographie_signature.png

Hors ligne

#2 17-01-2010 15:26:29

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Carte Nvidia Geforce GTX 275 Xorg -configure ne fonctionne pas

Bjr,
De mémoire il n'y a pas un gestionnaire des pilotes de cartes video dans un des menus de gnome ? Affichage ou un truc comme ça

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#3 17-01-2010 15:35:02

Berillions
Membre
Distrib. : Squeeze
Noyau : 2.6.39-bpo2
(G)UI : Xfce 4.6
Inscription : 02-05-2009

Re : Carte Nvidia Geforce GTX 275 Xorg -configure ne fonctionne pas

Salut damien,

Si tu utilises les drivers des dépôts non-free, les drivers sont les 190.42 si je ne me trompe pas.
J'avais également eu ce problème, voir ici, le message #3

En mode console :

La commande Xorg -configure ne fonctionne pas, c'est X -configure que j'ai du lancé pour créer le fichier xorg.conf.new dans /root.
Vérifie ensuite dans ce fichier que tu as bien "nvidia" dans driver, ca tu dois le savoir. Puis un simple mv /root/xorg.conf.new /etc/X11/xorg.conf suivi d'un reboot et tu devrais avoir les drivers d'installés.

Berillions

Hors ligne

#4 17-01-2010 19:15:49

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : Carte Nvidia Geforce GTX 275 Xorg -configure ne fonctionne pas

Re

phlinux a écrit :

De mémoire il n'y a pas un gestionnaire des pilotes de cartes video dans un des menus de gnome ?


Si tu n'installe pas nvidia-settings -> non

X -configure oups merci Berillions

Il me semble nécessaire d'ajouter au wiki l'install des pilotes proprios concernant squeeze.
Voici comment j'ai installé les pilotes pour cette carte Nvidia Geforce GTX 275.

J'ai téléchargé les pilotes nvidia propriétaires sur le site.
Petite précision je suis en squeeze et j'ai été obligé d'ajouter les dépôts de sid avec le fichier preferences qui va avec cf. http://debian-facile.org/forum/viewtopic.php?id=1924
Ajouté quelques nouveaux paquets.

aptitude install binutils gcc module-assistant nvidia-kernel-source nvidia-kernel-common nvidia-setings


Ensuite j'ai lancé module-assistant

m-a update
m-a prepare
m-a a-i nvidia-kernel


Ensuite un

/etc/init.d/gdm stop


X -configure


cp /root/xorg.conf.new /etc/X11/xorg.conf


puis

sh NVIDIA-Linux-x86_64-190.53-pkg2.run


Une belle galère quoi
Je commence à regretter ma Lenny mais bon pour du nouveau matos je n'ai pas le choix.

Petit + qui m'énerve.
Je n'ai pas de fréquence d'affichage correcte..... grggrrrr  60Hz sad

Voici ce que me done la commande xrandr

Screen 0: minimum 320 x 240, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 0mm x 0mm
   1280x1024      50.0*    51.0 
   1280x960       52.0 
   1024x768       53.0     57.0     58.0 
   1152x864       54.0     55.0     56.0 
   960x600        59.0 
   960x540        60.0 
   840x525        61.0     62.0 
   832x624        63.0 
   800x600        64.0     65.0     66.0     67.0 
   720x450        68.0 
   700x525        69.0 
   680x384        70.0     71.0 
   640x480        72.0     73.0     74.0 
   512x384        75.0     76.0 
   400x300        77.0 
   320x240        78.0     79.0


Encore une belle misère de configuration manuelle de xorg.conf
cf. http://debian-facile.org/forum/viewtopi … 620#p17620

A bientôt
damien


logo_3dminfographie_signature.png

Hors ligne

#5 17-01-2010 21:30:48

Berillions
Membre
Distrib. : Squeeze
Noyau : 2.6.39-bpo2
(G)UI : Xfce 4.6
Inscription : 02-05-2009

Re : Carte Nvidia Geforce GTX 275 Xorg -configure ne fonctionne pas

Salut damien,

Dis voir, j'ai une petite question concernant ta méthode d'installation des drivers. Pour lances-tu un X-configure avant l'installation du .run?
Sachant qu'à la fin de l'installation de celui-ci, il te demande si tu veux qu'il configure lui-même le nouveau xorg.conf.

De plus, je ne vois pas l'utilité d'installer le paquet nvidia-setting car si je ne me trompe pas, celui-ci est installé grâce au .run.

Je dis cela mais je peux raconter des bêtises smile

Berillions

Dernière modification par Berillions (17-01-2010 21:31:29)

Hors ligne

#6 18-01-2010 00:25:48

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : Carte Nvidia Geforce GTX 275 Xorg -configure ne fonctionne pas

Oui J'ai préféré qu'il génère un xorg.conf avant.
Même si effectivement on peux s'en passer.
De même pour nvidia-settings

Est-il possible d'avoir une fréquence de résolution d'affichage à 75 Hz pour du 1280x1024 ?
Merci

logo_3dminfographie_signature.png

Hors ligne

#7 18-01-2010 04:45:27

le_fada
Membre
Lieu : Toujours à l'ouest
Distrib. : Sid «ad vitam æternam»
Noyau : 2.6.33-amd64
(G)UI : gnome-shell
Inscription : 23-09-2009

Re : Carte Nvidia Geforce GTX 275 Xorg -configure ne fonctionne pas

Salut Damien,

je ne comprends pas trop ta façon d'installer les drivers nVidia. Tu commences bien en utilisant module-assistant ( méthode recommandée par Debian ), puis tu écrases tout ce que tu viens de faire en installant le .run proprio ( qui pose souvent problème au changement de version ) !
Je ne vois pas l'utilité de la première partie dans ce cas.

Pour ma part, à chaque changement de noyau ou de version de nvidia-glx, je procède ainsi, sans problème :

m-a clean
m-a prepare ( pour vérifier que kbuild est la dernière version )
m-a a-i -i nvidia ( pour construire le module )

... et, si la version du pilote a changée :

aptitude install nvidia-glx nvidia-settings

Hors ligne

#8 18-01-2010 12:04:43

Berillions
Membre
Distrib. : Squeeze
Noyau : 2.6.39-bpo2
(G)UI : Xfce 4.6
Inscription : 02-05-2009

Re : Carte Nvidia Geforce GTX 275 Xorg -configure ne fonctionne pas

Bonjour,

Par contre, j'ai une question concernant l'installation des drivers via le .run.

Prenons l'exemple ou j'installe les .run des drivers Nvidia 190.53 sur ma Debian Squeeze. Jusque là, aucun soucis tout se passe bien.
Ensuite, sur un coup de folie, je décide d'upgrader Squeeze en Sid.

D'après le wiki, vu que l'installation des drivers se sont fait via le .run, les drivers ne sont compatibles qu'avec le noyau 2.6.30.
D'ou le besoin de recompiler le nouveau noyau.

C'est à ce point là que j'ai eu un gros problème. En effet, hier soir, ma Debian m'a servi de cobaye et j'ai fait ce que j'ai écris plus haut.
J'en suis arrivé à ces 3 points qui sont expliqué dans la dernière partie du wiki Nvidia :

m-a clean
m-a prepare
m-a update
m-a a-i nvidia


Les 3 premiers points se passe pour le mieu, je télécharge les paquets qu'il me manque mais je remarque également qu'il télécharge les nvidia-kernel-source et nvidia-kernel-common en version 190.43.

Soit, c'est peut-être tout à fait normal mais cela me génère une erreur lorsque je passe à m-a a-i nvidia. L'erreur qu'il m'est rapporté est qu'il m'est impossible de compiler le noyau actuel (2.6.32) avec le driver 190.53 vu que les sources d'Nvidia dans les dépôts sont en version 190.43 .

Donc voilà mon problème, je suis actuellement en Sid avec les drivers 190.53 d'installer via les .run (Je ne sais pas pourquoi ils n'y sont pas dans les dépôts).

Quelle est la manipulation à faire pour ne pas avoir de problème lors de la compilation du nouveau noyau de Sid si celui-ci passe en 2.6.33.

Merci

Dernière modification par Berillions (18-01-2010 12:05:16)

Hors ligne

#9 18-01-2010 17:20:45

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Carte Nvidia Geforce GTX 275 Xorg -configure ne fonctionne pas

re-
D'après cette doc > http://doc.ubuntu-fr.org/nvidia.runil faut prendre les .run sur le site nvidia.

Et une chose qui me parait importante : sortir de l'environnement graphique, donc exit gdm ou autre

Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#10 18-01-2010 17:24:40

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Carte Nvidia Geforce GTX 275 Xorg -configure ne fonctionne pas

re-

damien a écrit :

Est-il possible d'avoir une fréquence de résolution d'affichage à 75 Hz pour du 1280x1024 ?
Merci


Je crois qu'on a déjà répondu.
Donne le retour de

$ xrandr


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#11 18-01-2010 21:06:08

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : Carte Nvidia Geforce GTX 275 Xorg -configure ne fonctionne pas

@le_fada

le_fada a écrit :

Tu commences bien en utilisant module-assistant ( méthode recommandée par Debian ), puis tu écrases tout ce que tu viens de faire en installant le .run proprio


J'ai installé une squeeze en netinstall.
J'ai été obligé d'utiliser module-assistant sinon le .run ne fonctionne pas.
Le .run demande un paquet du style nvidia-kernel nvidia-devel,..

@Berillions

Berillions a écrit :

Ensuite, sur un coup de folie, je décide d'upgrader Squeeze en Sid.


J'ai essayé une mise à jour sid. Résultat le .run ne s'exécute même pas.
Parce que gcc est à la version 4.4 dans sid alors que le pilote 190.53 de Nvidia demande la version 4.3 de gcc.
J'ai donc réinstallé tout le système en squeeze.

@phlinux

phlinux a écrit :

D'après cette doc > http://doc.ubuntu-fr.org/nvidia.runil faut prendre les .run sur le site nvidia.
Et une chose qui me parait importante : sortir de l'environnement graphique, donc exit gdm ou autre


J'ai téléchargé le pilote 190.53 sur le site de Nvidia
Je stope toujours gdm quand j'installe le .run

/etc/init.d/gdm stop


phlinux a écrit :

Je crois qu'on a déjà répondu.
Donne le retour de xrandr


Tu n'a pas du lire ce que j'ai écrit cf. http://debian-facile.org/forum/viewtopi … 817#p17817

J'ai toujours une fréquence d'affichage pourrie. sad
a+


logo_3dminfographie_signature.png

Hors ligne

#12 18-01-2010 21:47:55

phlinux
Membre
Lieu : S-M
Distrib. : Jessie
Noyau : 4.6
(G)UI : Openbox (+Rox+Feh)
Inscription : 10-05-2009

Re : Carte Nvidia Geforce GTX 275 Xorg -configure ne fonctionne pas

re-
La manip pour .run c'est pour Berillions

Ok pour xrandr, j'avais pas lu c'est vrai. 'tain c'est vachement limité comme carte (bon ok, j'arrête)

Ce qu'il aurait fallu c'est xrandr sans le xorg.conf, parce que si ça se trouve il agit sur les paramètres de la carte. A moins que tu aies constaté le même résultat de xrandr avec et sans  xorg.conf ?

Et un paquet comme grandr ça aide pas ?

Dernière modification par phlinux (18-01-2010 22:32:46)


Pages perso : feh, omegat, udisks, sa station de travail comme passerelle

Hors ligne

#13 22-01-2010 15:18:27

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : Carte Nvidia Geforce GTX 275 Xorg -configure ne fonctionne pas

Salut

phlinux a écrit :

'tain c'est vachement limité comme carte (bon ok, j'arrête)


Bizarre pour une carte qui fait au moins 35 centimètres sur 10 d'épais avec 3 ventilo.
Je ne peux même pas vérifier les températures.

Je ne sais pas comment j'ai fait mais je suis arrivé à une fréquence de 75 Hz en 1280x1024.
Par contre xrandr me donne toujours la même chose.
Pourtant la résolution réelle de l'écran est 1024x768@75
Cette résolution semble être celle que je trouve dans Préférences -> Affichage sauf que celui-ci est réglé sur 50 Hz ??????? Il y a franchement moyen de rien n'y comprendre avec xranr...

En fait c'est

# nvidia-settings


qui gère cette résolution en auto.

J'ai désactivé ces options dans le xorg.conf

@+


logo_3dminfographie_signature.png

Hors ligne

Pied de page des forums