Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-01-2019 12:08:37

Lupa
Membre
Distrib. : Debian Stretch 4.9.110-3+deb9u6 (2018-10-08)
Noyau : 4.9.0-8-amd64
(G)UI : xfce
Inscription : 28-06-2017

Besoin de précision sur apt et apt-get

Bonjour à tous smile

Selon ce que j'avais (mal) compris, ce serait la même chose.

Or, j'ai dû utiliser apt-get pour installer WebMin.

Je rajoute ceci à sources.list :


deb http://download.webmin.com/download/repository sarge contrib
 



J'ai besoin des paquets suivants :
libnet-ssleay-perl
libauthen-pam-perl
libpam-runtime
libio-pty-perl
python libwww-perl
liblwp-protocol-https-perl
nfs-kernel-server

Je les installe avec


apt install libnet-ssleay-perl
etc...
 



Puis


apt update && apt upgrade
apt-get install webmin # apt-get [b]pas[/b] apt install webmin : ça n'installe pas WebMin
 



Ajout de la clef etc, mais c'est hors sujet.

Donc : pourquoi parfois apt install et parfois apt-get install ?

C'est là que j'ai du mal à comprendre.
Merci wink

Hors ligne

#2 12-01-2019 12:17:34

pas-si-facile
Membre
Lieu : Paris
Distrib. : Debian 9 stable
Noyau : Linux 4.9.0-8-amd64
(G)UI : Xfce
Inscription : 09-01-2019

Re : Besoin de précision sur apt et apt-get

Hors ligne

#3 12-01-2019 13:07:10

Lupa
Membre
Distrib. : Debian Stretch 4.9.110-3+deb9u6 (2018-10-08)
Noyau : 4.9.0-8-amd64
(G)UI : xfce
Inscription : 28-06-2017

Re : Besoin de précision sur apt et apt-get

Salut smile

Le cahiers de l'administrateur Debian !! Je les ai achetés... mais j'y pensais pas ! Je vais lire wink
Merci smile

Hors ligne

#4 12-01-2019 13:08:58

chalu
Modératrice
Lieu : Anjou
Distrib. : Debian Stretch + backports
Noyau : Linux 4.9.0-8-amd64
(G)UI : Mate 1.20
Inscription : 11-03-2016

Re : Besoin de précision sur apt et apt-get

Bonjour smile

Ajout de la clef etc, mais c'est hors sujet.


Ce n’est pas sûr. Une des différences c’est qu’apt est plus strict sur la gestion des dépôts .
Dommage de ne pas avoir fait un copié collé des retours

Hors ligne

#5 12-01-2019 13:17:35

Lupa
Membre
Distrib. : Debian Stretch 4.9.110-3+deb9u6 (2018-10-08)
Noyau : 4.9.0-8-amd64
(G)UI : xfce
Inscription : 28-06-2017

Re : Besoin de précision sur apt et apt-get

Bonjour, Chalu smile

C'est vrai.
L'OS me répondait que WebMin est inconnu ou quelque chose comme ça.
Je vais refaire le truc dans une VM, et je donne le retour.

Voici les captures, dans la VM :

181022a2a3bcc21029a4f79f8606de17df1a910a.png

et là, ça fonctionne :

adda3f651f103cc9faa98c13569a8b62a5af8ea0.png

Peut-être manquait-il un paquet ?
En tout cas, avec


apt update
apt install webmin
 



"Impossible de trouver le paquet webmin".

Mais avec


apt-get update
apt-get install webmin
 



... ben ça marche.
scratchhead.gif

Dernière modification par Lupa (13-01-2019 18:08:39)

Hors ligne

Pied de page des forums