Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-03-2010 16:00:27

vishnu4030
Membre
Lieu : Liège - Belgique
Distrib. : Wheezy
Noyau : 3.2
(G)UI : Xfce
Inscription : 13-03-2010

Installation imprimante réseau (SMB) [résolu]

Bonjour,

Je viens d'installer "manuellement" Debian Squeeze 64 bits. Ubuntu 9.10 64 bits est aussi installé sur ce PC. Je n'arrive cependant pas à installer mon imprimante Epson C1100; celle-ci est connectée à un serveur (Debian Etch) via USB.

Avec Ubuntu, pas de problème. Avec Debian, l'imprimante n'est pas trouvée. Je m'explique : dans Système - Administration - Impression, je fais Fichier - Connexion et je mets le nom de mon serveur; ensuite Nouveau et je sélectionne Windows Printer via Samba, dans le champs smb://, j'entre le nom de mon serveur, je clique sur Parcourir et là... rien.

En suivant la même procédure avec Ubuntu, je trouve mon imprimante. Par ailleurs, via Nautilus, j'arrive à accéder à mon serveur.

Aurais-je raté quelque(s) chose(s) lors de l'installation manuelle ?

Merci pour votre aide.

Dernière modification par vishnu4030 (20-03-2010 17:39:13)

Hors ligne

#2 13-03-2010 23:45:02

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Installation imprimante réseau (SMB) [résolu]

Bonjour vishnu4030, et bienvenue ici.

Quel est ton gestionnaire de fenêtres? Je suppose que c'est Gnome, mais chez moi je n'ai pas d'option Impression dans /Système/Administration.

As-tu configuré le réseau sous Debian? Peux-tu pinguer le serveur? Si oui, tu peux essayer de voir dans les paquets samba-* le(s)quel(s) seraient installé sous Ubuntu et ne le seraient pas sous Debian.

Si tu ne comprends pas quelque chose, n'hésites pas à poser des questions.

@+

Hors ligne

#3 14-03-2010 16:15:33

vishnu4030
Membre
Lieu : Liège - Belgique
Distrib. : Wheezy
Noyau : 3.2
(G)UI : Xfce
Inscription : 13-03-2010

Re : Installation imprimante réseau (SMB) [résolu]

Oui, c'est bien Gnome; pour avoir Système - Administration - Impression, j'ai installé system-config-printer.

Le ping fonctionne. Mon serveur fait 2 choses : serveur de fichiers et serveur d'impression. En serveur de fichiers, pas de problème.

Excellente suggestion pour les paquets samba. Le problème est bien là.

Ubuntu :
libsmbclient
libwbclient0
nautilus-share
python-smbc
samba-common
samba-common-bin
smbclient

Debian :
gnome-system-tools
libsmbclient
libwbclient

J'ai installé smbclient qui installe aussi samba-common et samba-common-bin. Ensuite, dans Système - Administration - Impression, Nouveau et je sélectionne Windows Printer via Samba, dans le champs smb://, j'entre le nom de mon serveur, je clique sur Parcourir et là... je trouve bien mon imprimante.

Bon... ça n'imprime pas... mais c'est un autre problème !

Merci pour ton aide tux12.

Dernière modification par vishnu4030 (14-03-2010 16:16:18)

Hors ligne

#4 14-03-2010 18:39:27

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : Installation imprimante réseau (SMB) [résolu]

Curiosité, comme ça.

Pourquoi faut-il passer par Samba et l'intermédiaire de l'univers Windows même si les deux machines (ordi et serveur) sont en Linux ?

Portez la paix
Patrick Allaire, ptre

Hors ligne

#5 14-03-2010 18:41:23

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Installation imprimante réseau (SMB) [résolu]

Bonjour,

Bon, ça avance, c'est déjà bien. smile

Si tu veux continuer dans ce fil, ça ne me gène pas. C'est l'ensemble du fil qui devrait se trouver dans "Serveurs", mais encore fallait-il le savoir au départ. Allez, hop, je déplace et tu peux continuer à la suite. On à fait l'install de samba, maintenant on configure.

Par contre j'aimerais que tu ajoutes SMB à la fin du sujet du fil (en éditant ton premier post) pour faire apparaître que le fil concerne samba, et non CUPS qui est le gestionnaire d'impression réseau natif Unix.
Ça facilitera les recherches ultérieures. Merci d'avance.

Edit: @Patriboom, C'est une bonne question en effet. Lorsqu'on n'utilise pas de machines sous Windows, il n'y a effectivement aucun besoin d'utiliser samba.

Dernière modification par tux12 (14-03-2010 18:44:29)

Hors ligne

#6 14-03-2010 20:31:13

vishnu4030
Membre
Lieu : Liège - Belgique
Distrib. : Wheezy
Noyau : 3.2
(G)UI : Xfce
Inscription : 13-03-2010

Re : Installation imprimante réseau (SMB) [résolu]

Je viens de constater que le sujet a été déplacé...

Pour le sujet, SMB est ajouté.

@Patriboom
Bien d'accord... Pour être exhaustif, j'ai 4 PC : un (vieux AMD Athlon XP2000) sous XP, un portable (Pentium M 1.76 GHz) sous Ubuntu 9.10, mon dernier PC (AMD Athlon II X4 620) sous Ubuntu 9.10 et mon serveur (http://www.norhtec.com/products/mcsr/index.html) sous Lenny (pas Etch comme je l'ai dit initialement).

Je continue à chercher pour imprimer. Le serveur reçoit bien les données à imprimer mais rien ne sort.

Hors ligne

#7 16-03-2010 21:28:25

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Installation imprimante réseau (SMB) [résolu]

Bonjour,

Alors vishnu4030, tu en es où?
As-tu essayé de comparer les fichiers de config samba d'un système fonctionnel avec le debian?
Qu'est ce qui te fait dire que le serveur reçoit bien les données?

@+

Hors ligne

#8 19-03-2010 15:29:58

vishnu4030
Membre
Lieu : Liège - Belgique
Distrib. : Wheezy
Noyau : 3.2
(G)UI : Xfce
Inscription : 13-03-2010

Re : Installation imprimante réseau (SMB) [résolu]

Le problème vient bien de mon serveur...

Au départ, je pensais à une mauvaise installation du driver que j'ai du compiler (+ problème récurrent avec libstdc++5). Après avoir connecté l'imprimante directement à mon PC, tout fonctionne (que ce soit avec Debian Squeeze ou avec Ubuntu 9.10); donc le driver est OK.

Ensuite, reconnexion de l'imprimante au serveur et là, rebelotte, cela ne fonctionne pas. En fait, quelque soit le PC (XP ou Linux, 32 bits ou 64 bits) je n'arrive plus à imprimer. Même pas à partir de mon serveur.

J'ai bien désinstallé et réinstallé l'imprimante sur le serveur, en vain...

@tux12 : ce qui me fait dire que le serveur reçoit bien les données, c'est que le HD mouline; de plus, CUPS sur mon PC est configuré pour ré-envoyer les données en cas d'erreur et là, le HD du serveur n'arrête plus de mouliner !

Hors ligne

#9 19-03-2010 21:53:56

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Installation imprimante réseau (SMB) [résolu]

Bonjour,

En fait, quelque soit le PC [...] je n'arrive plus à imprimer. Même pas à partir de mon serveur.


Ok, donc le problème est localisé au serveur, ce n'est plus un problème réseau. Je te suggère d'ouvrir un fil dans la rubrique Configuration si tu penses que nous pouvons t'être utile pour la configuration (locale) de l'impression sur le serveur. Le présent fil pourra être ultérieurement repris pour la configuration de l'impression réseau si le besoin s'en faisait sentir.

Merci de ta compréhension.
@+

Hors ligne

#10 20-03-2010 17:38:38

vishnu4030
Membre
Lieu : Liège - Belgique
Distrib. : Wheezy
Noyau : 3.2
(G)UI : Xfce
Inscription : 13-03-2010

Re : Installation imprimante réseau (SMB) [résolu]

C'est résolu...

En activant dans CUPS sur le serveur la sortie des infos de debug, j'ai remarqué dans le fichier error_log qu'un script se plantait; il lui manquait "bc" (un utilitaire pour calculer). Je l'ai (ré)installé. Tout est OK.

Je ne sais pas pourquoi bc a disparu. A part des aptitude update et aptitude safe-upgrade, je ne fais rien d'autre sur mon serveur...

Hors ligne

#11 20-03-2010 23:57:15

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Installation imprimante réseau (SMB) [résolu]

Bonjour,

Curieux en effet cette disparition de bc. Enfin, tu as pu résoudre ton problème, c'est déjà bien.
Merci pour le retour d'information. smile

@+

Hors ligne

#12 22-03-2010 08:54:37

vishnu4030
Membre
Lieu : Liège - Belgique
Distrib. : Wheezy
Noyau : 3.2
(G)UI : Xfce
Inscription : 13-03-2010

Re : Installation imprimante réseau (SMB) [résolu]

Bonjour,

De rien...

Merci aussi pour ton aide.

@+

Hors ligne

Pied de page des forums