Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-11-2019 18:09:10

Debarguenon
Membre
Lieu : BZH
Distrib. : Debian 10
Noyau : Linux 4.19.0-6-686
(G)UI : LXDE
Inscription : 08-11-2019

Faire reconnaître le fimware brcmfmac43340-sdio

Bonsoir

Je reprends mon fil https://debian-facile.org/viewtopic.php?id=25620 dans cette rubrique car il s'agit pour le moment d'un problème matériel et non d'un problème réseau, bien qu'il s'agisse de ma carte wifi.

Après adaptation du sources-list, J'ai installé le firmware (non-free) de la carte wifi avec "apt-get install firmware-brcm80211"

Pour autant le système semble ne pas vraiment reconnaître la carte :

# dmesg | grep brcm


[    9.091885] bluetooth hci0: firmware: [b]failed to load brcm/BCM43341B0.hcd [/b](-2)
[    9.092008] bluetooth hci0: Direct firmware load for brcm/BCM43341B0.hcd [b]failed with error -2[/b]
[    9.092014] Bluetooth: hci0: BCM: [b]Patch brcm/BCM43341B0.hcd not found[/b]
[    9.237818] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43340-sdio for chip BCM43340/2
[    9.238209] usbcore: registered new interface driver brcmfmac
[    9.274375] brcmfmac mmc1:0001:1: firmware: direct-loading firmware brcm/brcmfmac43340-sdio.bin
[    9.274430] brcmfmac mmc1:0001:1: firmware: failed to load brcm/brcmfmac43340-sdio.txt (-2)
[    9.274566] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43340-sdio.txt [b]failed with error -2[/b]
[   10.283290] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50




Toute aide et la bienvenue ;-)

merci

Edit : ajout des balises codes en suivant le tuto : https://debian-facile.org/atelier:bbcode?s


Profond adepte du joli ciel libre ;-)

Hors ligne

#2 08-11-2019 18:20:30

chalu
Modératrice
Lieu : Anjou
Distrib. : openSUSE Leap 15.1
Noyau : Linux 4.12.14
(G)UI : KDE 5
Inscription : 11-03-2016

Re : Faire reconnaître le fimware brcmfmac43340-sdio

Bonsoir,
Que donne

apt policy firmware-brcm80211



As-tu redémarré le PC après installation ?


Bien débuter sur Debian :
->Les principales commandes Linux
Bien débuter sur openSUSE :
->Site officiel + Wiki frForum fr sur alionet+Guide du débutant

Hors ligne

#3 08-11-2019 23:08:42

èfpé
Membre
Inscription : 10-07-2016

Re : Faire reconnaître le fimware brcmfmac43340-sdio

Bonsoir Debarguenon,

Debarguenon a écrit :

dmesg | grep brcm

[    9.274375] brcmfmac mmc1:0001:1: firmware: direct-loading firmware brcm/brcmfmac43340-sdio.bin
[    9.274430] brcmfmac mmc1:0001:1: firmware: failed to load brcm/brcmfmac43340-sdio.txt (-2)
[    9.274566] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43340-sdio.txt failed with error -2
[   10.283290] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50


Le paquet firmware-brcm80211/firmware brcmfmac43340-sdio.bin est effectivement installé/chargé.
Quant au fichier brcmfmac43340-sdio.txt manquant il s'agit d'un problème connu : voir ici, ici ou .

Hors ligne

#4 09-11-2019 09:59:10

Debarguenon
Membre
Lieu : BZH
Distrib. : Debian 10
Noyau : Linux 4.19.0-6-686
(G)UI : LXDE
Inscription : 08-11-2019

Re : Faire reconnaître le fimware brcmfmac43340-sdio

Bonjour à tous ici sur DF ;-)

[Détection carte RÉSOLUE]

Pour répondre à Chalu :

$ apt policy firmware-brcm80211
firmware-brcm80211:
  Installé : 20190114-2
  Candidat : 20190114-2
 Table de version :
 *** 20190114-2 500
        500 http://deb.debian.org/debian buster/non-free i386 Packages
        100 /var/lib/dpkg/status





Pour répondre à èfpé :
Concernant le fichier brcmfmac43340-sdio.txt manquant, j'ai suivi les recommandations du lien https://bugs.debian.org/cgi-bin/bugrepo … bug=821400 et j'ai fait ceci :

# cp /sys/firmware/efi/efivars/nvram-74b00bd9-805a-4d61-b51f-43268123d113 /lib/firmware/brcm/brcmfmac43340-sdio.txt



J'ai du redémarrer ma machine car la commande modprobe (même en root) n'est pas présente sur mon système et j'ignore pourquoi sad.

Après le reboot, j'ai bien ma carte wlan0:

$ ip link sh
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enx7824afc6e6dd: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1492 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 78:24:af:d7:d7:ee brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 6c:fa:a7:30:76:89 brd ff:ff:ff:ff:ff:ff



Il me reste à savoir comment me connecter en wifi en GUI ou en CLI  car pour l'instant avec l'environnement LXDE je n'ai pas trouvé de menu qui me saute aux yeux pour dire que c'est par là que ça se passe.

On y croit (si si)

Si je ne trouve pas, je reviendrai dans la rubrique Réseau du forum.

Merci à vous


Profond adepte du joli ciel libre ;-)

Hors ligne

#5 09-11-2019 11:16:09

raleur
Membre
Inscription : 03-10-2014

Re : Faire reconnaître le fimware brcmfmac43340-sdio

Debarguenon a écrit :

la commande modprobe (même en root) n'est pas présente sur mon système et j'ignore pourquoi


Probablement parce que tu n'utilises pas su correctement. Si modprobe était vraiment manquant, le système ne fonctionnerait pas.

Debarguenon a écrit :

comment me connecter en wifi en GUI ou en CLI  car pour l'instant avec l'environnement LXDE


Il doit y avoir un applet Wicd dans la barre de tâches.

Hors ligne

Pied de page des forums