Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-08-2010 13:24:22

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

insta cinelerra

bonjour,

je galère avec l'insta de cinelerra sur ma Lenny

j'ai essayé de le télécharger par les paquet gits

le ./configure se passe bien mais au make j'ai une erreur x264

qth264.lo -MD -MP -MF .deps/qth264.Tpo -c qth264.c  -fPIC -DPIC -o .libs/qth264.o
qth264.c: In function 'encode':
qth264.c:245: attention : passing argument 1 of 'x264_nal_encode' from incompatible pointer type
qth264.c:245: attention : passing argument 2 of 'x264_nal_encode' from incompatible pointer type
qth264.c:245: attention : passing argument 3 of 'x264_nal_encode' makes pointer from integer without a cast
qth264.c:245: erreur: too many arguments to function 'x264_nal_encode'
qth264.c:245: erreur: valeur void n'a pas été ignorée comme elle aurait dû l'être
make[3]: *** [qth264.lo] Erreur 1
make[3]: quittant le répertoire « /home/chris/my_cinelerra/quicktime »
make[2]: *** [all-recursive] Erreur 1
make[2]: quittant le répertoire « /home/chris/my_cinelerra/quicktime »
make[1]: *** [all-recursive] Erreur 1
make[1]: quittant le répertoire « /home/chris/my_cinelerra »
make: *** [all] Erreur 2


x264 est bien installé, je l'ai même réinstallé depuis les sources téléchargées sur le site officiel

y'a vraiment personne qui a déjà réussi à installer cette petite bête ??

Dernière modification par totophe56 (08-08-2010 13:26:38)

Hors ligne

#2 09-08-2010 02:24:29

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : insta cinelerra

Salut

Toujours passer par les dépôts debian. Les dépôts exotiques où les sites officiels c'est en dernier recours lorsqu'on ne peut faire autrement. Le paquet cinelerra se trouve dans le dépôt debian-multimedia. Pour un fichier sources.list complet voir le wiki. Penser à installer la clé pour ce dépôt.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#3 09-08-2010 11:43:55

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Re : insta cinelerra

cela ne change rien, liblame0 et libjpegtoll se tape dessus, on ne peut pas en installer un sans que l'autre ne soit désinstallé sad

apt-get install cinelerra
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
  cinelerra: Dépend: liblame0 (>= 3.97) mais ne sera pas installé
             Dépend: libquicktimehv (= 1:2.1.0-2svn20081020.1) mais ne sera pas installé
E: Paquets défectueux
station:/home/chris# apt-get install liblame
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet liblame
station:/home/chris# apt-get install liblame0
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libswscale0 kde-i18n-af libamrnb3 libx264-60 libx264-65 libamrwb3 libdirac0
  libschroedinger-1.0-0 libxvidcore4
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  libavcodec51 libmjpegtools-dev libmjpegtools0 libmp3lame-dev libmp3lame0
  libquicktime-dev libquicktime1 mjpegtools
Les NOUVEAUX paquets suivants seront installés :
  liblame0
0 mis à jour, 1 nouvellement installés, 8 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0o/208ko dans les archives.
Après cette opération, 13,8Mo d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? o
ATTENTION : les paquets suivants n'ont pas été authentifiés.
  liblame0
Faut-il installer ces paquets sans vérification (o/N) ? o
(Lecture de la base de données... 134420 fichiers et répertoires déjà installés.)
Suppression de mjpegtools ...
Suppression de libmjpegtools-dev ...
Suppression de libquicktime-dev ...
Suppression de libmjpegtools0 ...
Suppression de libquicktime1 ...
Suppression de libavcodec51 ...
Suppression de libmp3lame-dev ...
Suppression de libmp3lame0 ...
Traitement des actions différées (« triggers ») pour « man-db »...
Sélection du paquet liblame0 précédemment désélectionné.
(Lecture de la base de données... 134113 fichiers et répertoires déjà installés.)
Dépaquetage de liblame0 (à partir de .../liblame0_3.97-0.0_amd64.deb) ...
Paramétrage de liblame0 (3.97-0.0) ...
station:/home/chris# apt-get install cinellera
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet cinellera
station:/home/chris# apt-get install cinelerra
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
  cinelerra: Dépend: libmjpegtools0 (>= 1:1.8.0) mais ne sera pas installé
             Dépend: libquicktimehv (= 1:2.1.0-2svn20081020.1) mais ne sera pas installé
E: Paquets défectueux

Hors ligne

#4 09-08-2010 11:53:52

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

Re : insta cinelerra

Salut totophe56

Comme dit martin_mtl il faut passer par les dépôts debian.
Pour visualiser les dépôts deb :

cat /etc/apt/sources.list


Pour installer ce n'est pas comme Windows ou tu télécharges l'exe du soft et tu l'executes, il te suffit juste d'utiliser le terminal root

aptitude install cinelerra


Petit conseil il existe une recherche très intéressante avec aptitude :

aptitude search cinelerra


La compilation ne se fait que si le programme que tu veux utiliser ne se trouve pas dans les dépôts.

Bon courage totophe56
damien


logo_3dminfographie_signature.png

Hors ligne

#5 09-08-2010 18:54:29

totophe56
Membre
Distrib. : Jessie 64 bits
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE
Inscription : 22-07-2010

Re : insta cinelerra

rien à faire, toujours ces soucis de dépendances :-(

Hors ligne

#6 09-08-2010 20:02:51

Asmodée
Membre
Lieu : /dev/null
Distrib. : Squeeze
Inscription : 16-05-2010

Re : insta cinelerra

ATTENTION : les paquets suivants n'ont pas été authentifiés.
  liblame0


me fait deja penser que tu n'utilises pas que les depots officiels... Petit cachotier...
Pense a installer la cle du depot. Si c'est debian-multimedia, la cle se trouve sous la forme d'un paquet dans synaptic.

Ensuite, il faut mettre ses depots a jour AVANT d'installer quoique ce soit.

Hors ligne

#7 10-08-2010 02:58:55

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : insta cinelerra

Salut

Les paquets suivants contiennent des dépendances non satisfaites :
  cinelerra: Dépend: libmjpegtools0 (>= 1:1.8.0) mais ne sera pas installé
             Dépend: libquicktimehv (= 1:2.1.0-2svn20081020.1) mais ne sera pas installé
E: Paquets défectueux


Il semble bien y avoir un problème avec les paquets dans debian-multimedia. Si je regarde dans le dépôt, on que la version de libquicktimehv n'est pas la bonne. La version présente dans le dépôt est la 2.1.0~svn20080706-0.0 alors que apt-get réclame la 2.1.0-2svn20081020.1.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

Pied de page des forums