Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-08-2010 13:33:47

Aragorn
Membre
Distrib. : Sid
Noyau : 2.6.32-5-amd64
(G)UI : Openbox
Inscription : 12-07-2010

[Résolu] startx ne fonctionne plus en mode user.

Bonjour à tous,
Je ne peux plus ouvrir une session X en mode user depuis le passage aux drivers fglrx !
Je règle un problème, et je tombe sur un autre !
Si je le fais, je tombe sur un écran noir où tout est inopérant, notamment la souris.
Je fais alors un CTRL + ALT + F1 et là, j'ai droit à un No protocol specified qui déroule ...
Je reboote, et en mode root, un startx fonctionne : il m'ouvre une session Openbox par défaut, c'est-à-dire qu'il n'a pas pris en compte mon fichier /home/fab/.config/openbox/autostart.sh avec mes "réglages" (fond d'écran, tint2, ...).
Merci.

Dernière modification par Aragorn (12-08-2010 16:42:59)

Hors ligne

#2 08-08-2010 16:24:06

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : [Résolu] startx ne fonctionne plus en mode user.

Salut,

essaye voir de supprimer le fichier .Xauthority ds /home/utilisateur/ et reboot.

Hors ligne

#3 08-08-2010 23:47:52

Aragorn
Membre
Distrib. : Sid
Noyau : 2.6.32-5-amd64
(G)UI : Openbox
Inscription : 12-07-2010

Re : [Résolu] startx ne fonctionne plus en mode user.

Salut,
Ta solution fonctionne, mais peux-tu m'en dire davantage ?
Est-ce un problème de droit ?
Merci.

Hors ligne

#4 10-08-2010 22:35:31

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : [Résolu] startx ne fonctionne plus en mode user.

Salut,

j'avais eu le même souci en installant le pilote fglrx, et l'erreur indiqué .Xauthority,
j'ai donc testé en le virant de /home/... et ça a fonctionné, pas trouvé d'explications
sur le net à part un report bugs qui désignait fglrx-atieventsd et effectivement un prob. de droit.

Hors ligne

#5 11-08-2010 17:37:51

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 3.16.0-4-amd64 - 3.16.39-1
(G)UI : gnome 1:3.14+3
Inscription : 21-10-2008

Re : [Résolu] startx ne fonctionne plus en mode user.

Salut !

Merci de cette solution trouvée pour ce problème clairement posé et [Résolu] donc...

Aussi, un petit [Résolu] dans le titre (éditer le premier post pour le faire) et ce monde sera une vallée paisible où coule une rivière bien tranquille. smile

Amitié, Joel

"Théo et Adama te rappellent pourquoi Zyed et Bouna couraient…"
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

Pied de page des forums