Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-09-2010 10:32:54

Aragorn
Membre
Distrib. : Sid
Noyau : 2.6.32-5-amd64
(G)UI : Openbox
Inscription : 12-07-2010

[Résolu] Paquet non mis à jour.

Bonjour à tous,
Depuis quelques jours, un paquet dont j'ignore le nom, n'est plus mis à jour.

État actuel : 1 mise à jour restante [-6].
root@debian:/home/fab#


Comment identifier ce paquet, et que faut-il faire exactement ?
Merci.

Dernière modification par Aragorn (13-09-2010 14:42:24)

Hors ligne

#2 13-09-2010 00:14:06

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu] Paquet non mis à jour.

Bonjour Aragorn,

Ce que tu nous montre indique juste qu'il y a une mise à jour non effectuée. Pas qu'elle ne peut l'être.
Alors en supposant que la commande qui t'a renvoyé cela soit aptitude update , tu devrais pouvoir t'en sortir avec un aptitude safe-upgrade.

Si vraiment un paquet n'est pas mis à jour, ça doit vouloir dire que tu as demandé à ce qu'il soit maintenu dans la version actuelle. Généralement on obtient dans ce cas un message du genre "le paquet xxx peut être mis à jour mais vous avez demandé à ce qu'il soit maintenu...."

@+

Edit: Après lecture du post de Martin, je vois que j'ai encore dit des sottises. Pourtant il y avait bien un moins devant le 6. :shame:

Dernière modification par tux12 (13-09-2010 02:29:18)

Hors ligne

#3 13-09-2010 02:21:19

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] Paquet non mis à jour.

Salut Aragon

Avec la branche Sid, ce genre de chose arrive à l'occasion. Deux choses peuvent expliquer ce comportement. 1) Tous les nouveaux paquets n'arrivent pas en même temps dans le dépôt Sid et certains ne sont alors pas mis à jour à cause d'un problème de dépendance. Dans ce cas, il suffit d'être patient et le tout finit par se replacer. 2) Un changement de version d'un paquet demande la suppression d'une ancienne version de paquets ou même la suppression de certains pour installer les plus récents.

Voici comment je procède :
1) Aptitude safe-upgrade. Mise à jour des paquets donc.

Si je vois qu'un paquet n'est pas mis à jour, comme dans ton exemple, je fais un :

aptitude full-upgrade -s


pour voir le résultat. Si aptitude me propose une mise à jour de version, suppression de paquets et installation d'autres, sans vouloir tout chambarder ou enlever des paquets essentiels pour moi, je refais la commande sans le -s. Si les changement sont trop important, ou même dommageable, je ne fais rien et attend la ou les prochaine mise à jour qui vont régler le problème.


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

En ligne

#4 13-09-2010 14:39:55

Aragorn
Membre
Distrib. : Sid
Noyau : 2.6.32-5-amd64
(G)UI : Openbox
Inscription : 12-07-2010

Re : [Résolu] Paquet non mis à jour.

Bonjour à tous,
J'ai tenu compte de vos remarques, et je ne touche à rien car j'ai besoin d'acroread :

root@debian:/home/fab# aptitude full-upgrade -s
Les NOUVEAUX paquets suivants vont être installés :
  lib32v4l-0{a} libv4l-0{a}
Les paquets suivants seront mis à jour :
  ia32-libs{b}
1 paquets mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 33,7Mo d'archives. Après dépaquetage, 8 806ko seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
  ia32-libs: Casse: ia32-libs-gtk (< 20100905) mais 20090804 est installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Supprimer les paquets suivants :
1)     acroread                      
2)     acroread-data                
3)     acroread-debian-files        
4)     acroread-dictionary-en        
5)     acroread-l10n-en              
6)     ia32-libs-gtk                



Accepter cette solution ? [Y/n/q/?]


@ +

Hors ligne

Pied de page des forums