Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-12-2010 07:33:57

Ichigo-Roku
Membre
Lieu : ::1
Inscription : 11-11-2009

[Résolu] Clé USB qui ne se monte plus automatiquement

Bonjour,

Mes clés USB ne se montent plus automatiquement, avant je branchais la clé et une fenêtre s'affichait avec mes fichiers.

J'ai cette erreur :

Impossible de monter USB2Gio

Error mounting: mount exited with exit code 1: helper failed with:
mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so


Lorsque je fais :

# mount -t vfat /dev/sdc1 /mnt/


Ca marche mais je n'arrive pas à mettre les droits, ce qui marche pour mes disques dur ne marche pas pour mes clés, une fois montés le dossier redevient sous la propriété de "root".

Faut savoir que c'est une netinstall avec un gnome-core, j'ai peut-être oublié un paquet ou quelque chose qui fait que ça ne marche pas...

Je vous remercie d'avance pour votre aide.

Dernière modification par Bleryu (01-02-2011 08:11:14)

Hors ligne

#2 01-12-2010 08:01:18

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Clé USB qui ne se monte plus automatiquement

Bonjour Bleryu,

Cette commandede mount venant obligatoirement de root :

# mount -t vfat /dev/sdc1 /mnt/


Il est tout à fait normal que ce soit root qui en soit le propriétaire.

Pour monter manuellement une partition et donner les droits à l'user, il faut créer le répertoire d'accueil

# mkdir /media/disk-fat


(par exemple)
Puis en root, le passer en droit du groupe user avec les commandes chmod 775 et chown root:user et l'option -R pour les deux.
Ensuite, monter avec root le répertoire du disk vfat dans ce répertoire :

# mount -t vfat /dev/sdc1 /media/disk-fat


Voir le wiki là :
http://debian-facile.org/doc:systeme:droits-unix-bis

Pour ce qu'il est du montage automatique, je sais pas. smile

Amitié, Joel


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 01-12-2010 22:01:53

Ichigo-Roku
Membre
Lieu : ::1
Inscription : 11-11-2009

Re : [Résolu] Clé USB qui ne se monte plus automatiquement

J'avais bien fait ça avec /media/USB et ça ne marchait pas non plus, il reprenait les permissions root.

Edit : en fait les dossiers à l'intérieur son à root, c'est pas possible de mettre la clé USB à moi ?

Dernière modification par Bleryu (01-12-2010 22:05:09)

Hors ligne

#4 01-12-2010 23:45:27

Invité-5
Banni(e)

Re : [Résolu] Clé USB qui ne se monte plus automatiquement

#5 02-12-2010 07:44:13

Ichigo-Roku
Membre
Lieu : ::1
Inscription : 11-11-2009

Re : [Résolu] Clé USB qui ne se monte plus automatiquement

Ouais mais ça ne m'aide pas trop.

Bizarrement ça ne m'a jamais fait ça... Je ne comprends pas trop.

Hors ligne

#6 02-12-2010 11:24:13

Invité-5
Banni(e)

Re : [Résolu] Clé USB qui ne se monte plus automatiquement

Salut,

Essaye

# aptitude install gnome-disk-utility


Gère et configure les disques et media amovibles.

@

#7 02-12-2010 18:07:07

Ichigo-Roku
Membre
Lieu : ::1
Inscription : 11-11-2009

Re : [Résolu] Clé USB qui ne se monte plus automatiquement

Je viens d'installer ça et malheureusement c'est pareil.

Si j'avais su que j'aurais eu tant d'emmerdes je serais toujours avec ma Arch, surtout avec mon utilisation basique de ma distro. sad

Hors ligne

#8 12-01-2011 18:09:16

dbkblk
Membre
Distrib. : Debian Wheezy 64bits
Noyau : 3.2
(G)UI : Gnome 3.2
Inscription : 24-10-2010

Re : [Résolu] Clé USB qui ne se monte plus automatiquement

Je ne sais pas si tu as toujours le problème mais je l'avais et je viens de le résoudre en supprimant les entrées de mon DD externe et de ma clé usb dans /etc/fstab.
Ils étaient branchés lors de l'installation et Debian les a interprétés comme des CD-ROM !

M. Gandhi: "C'est une erreur de croire nécessairement faux ce qu'on ne comprend pas."
C'est quoi ce bordel ?

Hors ligne

#9 12-01-2011 20:27:59

eol
Membre
Inscription : 03-09-2009

Re : [Résolu] Clé USB qui ne se monte plus automatiquement

Pour que les fichier montés gardent les droits utilisateurs,
tu peux créer une arborescence media dans ton home ( ~/media/sdc1, etc ... )
configurer sudo pour avoir les droits de monter les périphériques usb classiques avec mount :

ton_nom_utilisateur ton_nom_de_machine=NOPASSWD: /bin/mount /dev/sd[b-z]?*


et monter les clés avec :

$ sudo mount /dev/sdc1 -o uid=`id -u` ~/media/sdc1


par exemple,

Si tu ne veux pas utiliser sudo :

# mount /dev/sdc1 -o uid=ton_nom_utilisateur ~/media/sdc1


devrait fonctionner.

Si tu veux que tout se monte automatiquement, soit tu créer des règles udev,
( désolé, je n'en sais pas beaucoup plus )
soit tu installes d'autres paquets.

Hors ligne

#10 01-02-2011 08:10:54

Ichigo-Roku
Membre
Lieu : ::1
Inscription : 11-11-2009

Re : [Résolu] Clé USB qui ne se monte plus automatiquement

dbkblk, c'était bien ça merci. wink

Désolé pour la réponse tardive mais j'avais oublié.

Hors ligne

#11 26-12-2011 22:39:46

dagnu
Membre
Inscription : 26-12-2011

Re : [Résolu] Clé USB qui ne se monte plus automatiquement

Bonjour à tous.
J'ai besoin d'une petite précision. Le message d'erreur est le suivant :

message d'erreur a écrit :

Error mounting: mount exited with exit code 1: helper failed with:
mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so


Et voici un extrait de mon fstab :

fstab a écrit :

...# swap was on /dev/sda5 during installation
UUID=8c5ba5e1-7b60-4c80-b8fa-1b2d90d012f9 none            swap    sw              0       0
/dev/sdc1       /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/scd0       /media/cdrom1   udf,iso9660 user,noauto     0       0
/dev/sdb1       /media/usb0     auto    rw,user,noauto  0       0
...


Il faut donc que je supprime purement et simplement la ligne avec sdc1 (la 3°)?

Merci, bonne journée.

Dernière modification par dagnu (26-12-2011 22:42:12)

Hors ligne

#12 26-12-2011 22:44:50

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Clé USB qui ne se monte plus automatiquement

Saut dagnu et bienvenue sur df !

Alors sur le forum, on parle de son propre problème sans s'accrocher au problème d'un autre précédent.
Voir le tuto là :
http://debian-facile.org/atelier:bernacle

Reprends par copié/collé ta question et ouvres-en une dans la même section, ça l'fera, sûr !

Amitié, Joel smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#13 26-12-2011 22:56:54

dagnu
Membre
Inscription : 26-12-2011

Re : [Résolu] Clé USB qui ne se monte plus automatiquement

Bonjour, smolski, désolé de cette méprise je suis tes conseils.
Merci.

Hors ligne

Pied de page des forums