Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#51 10-12-2010 20:46:36

eol
Membre
Inscription : 03-09-2009

Re : Mise a jour d'un serveur debian 3.1

deamon974 a écrit :

Smolski tu veut dire que je doit mettre un source list lenny en place ?


Si tu as déjà fait le passage complet à Etch et qu'il n'y a pas de soucis même après un reboot,
oui, tu peux envisager de passer à Lenny.

Hors ligne

#52 10-12-2010 21:01:27

deamon974
Membre
Inscription : 08-12-2010

Re : Mise a jour d'un serveur debian 3.1

Nn mais je n'ai pas compris ton message a propos de oldstable et stable qu'est ce que je doit faire en claire?

Hors ligne

#53 10-12-2010 21:08:05

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Mise a jour d'un serveur debian 3.1

Une fois la stabilité de l'oldstable établie, tu passes à la suite du programme pour migrer vers lenny en stable, et là, ton fichier preferences entrera en action.

Maintenant, je ne sais pas si c'est le moment de le faire si tu n'as pas tout réglé avec le oldstable Etch ?

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#54 11-12-2010 01:51:45

Clem
Membre
Lieu : Au coin du bois
Distrib. : Stable && Sid
Noyau : 3.16-2 & 3.17-1 *-amd-64
(G)UI : XMonad & Mate(?)
Inscription : 09-03-2010

Re : Mise a jour d'un serveur debian 3.1

bonsoir,

deamon974 a écrit :

Nn mais je n'ai pas compris ton message a propos de oldstable et stable qu'est ce que je doit faire en claire?


Etch est la oldstable et Lenny la Stable. ( et Sarge la old-old-stable)
Mais il te faut avant tout terminer ton passage en oldstable ( qui n'est pas encore fait ):

deamon974 a écrit :

apt-get -s dist-upgrade

Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
The following packages will be REMOVED:
  base-config libnewt0.51 netkit-inetd ntp-server
The following NEW packages will be installed:
  cpp-4.1 dctrl-tools debian-archive-keyring dmidecode file gcc-4.1
  gcc-4.1-base gettext gnupg gpgv intltool-debian laptop-detect libdb4.3
  libdb4.4 libdevmapper1.02 libedit2 libgnutls13 libkrb53 libldap2 libmagic1
  libncursesw5 libnewt0.52 libpcap0.8 libpci2 libreadline5 libsasl2-2
  libselinux1 libsepol1 libsigc++-2.0-0c2a libslang2 libssl0.9.8 libssp0
  libstdc++6 libtasn1-3 lsb-base mktemp modconf openbsd-inetd
  openssh-blacklist openssh-client openssh-server po-debconf readline-common
  sysvinit-utils tasksel-data update-inetd vim-runtime
The following packages have been kept back:
  util-vserver
  util-vserver
The following packages will be upgraded:
  adduser apt apt-show-versions apt-utils aptitude at base-files base-passwd
  bash binutils bsdmainutils bsdutils bzip2 console-common console-data
  console-tools coreutils cpio cpp cpp-3.3 cron dash debconf debconf-i18n
  debianutils debootstrap dhcp-client discover1 discover1-data dpkg dpkg-dev
  dselect e2fslibs e2fsprogs eject exim4 exim4-base exim4-config
  exim4-daemon-light fdutils findutils gcc gcc-3.3 gcc-3.3-base gettext-base
  grep grep-dctrl groff-base grub gzip hostname hotplug ifupdown info
  initrd-tools initscripts iproute iptables iputils-ping kernel-package
  klogd less libacl1 libapt-pkg-perl libattr1 libblkid1 libbz2-1.0 libc6
  libc6-dev libcomerr2 libconsole libdb1-compat libdb3 libdb4.2 libdiscover1
  libgcc1 libgcrypt11 libgdbm3 libgpg-error0 libgpmg1 liblocale-gettext-perl
  liblockfile1 liblzo1 libncurses5 libncurses5-dev libopencdk8
  libpam-modules libpam-runtime libpam0g libpcre3 libpopt0 libss2
  libssl0.9.7 libstdc++5 libtext-charwidth-perl libtext-iconv-perl
  libtext-wrapi18n-perl libtextwrap1 libusb-0.1-4 libuuid1 libwrap0
  linux-kernel-headers locales login logrotate lsof lvm-common lvm2 mailx
  make makedev man-db manpages module-init-tools modutils mount nano ncftp
  ncurses-base ncurses-bin net-tools netbase ntp ntp-simple ntpdate nvi
  passwd patch pciutils perl perl-base perl-modules ppp pppconfig pppoe
  pppoeconf procps psmisc sed ssh sudo sysklogd sysv-rc sysvinit tar tasksel
  tcpd telnet usbutils util-linux vim vim-common wget whiptail zlib1g
155 upgraded, 47 newly installed, 4 to remove and 1 not upgraded.
2 not fully installed or removed.


En clair il reste 155 paquets à passer en Etch et 47 nouveaux paquets à installer et que tu vas devoir configurer.

Par ailleurs cette commande:

deamon974 a écrit :

dpkg --configure -a
Setting up tzdata (2008e-1etch3) ...
dpkg (subprocess): unable to execute post-installation script: Permission denied
dpkg: error processing tzdata (--configure):
 subprocess post-installation script returned error exit status 2
Setting up base-files (3.1.2) ...
dpkg (subprocess): unable to execute post-installation script: Permission denied
dpkg: error processing base-files (--configure):
 subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
 tzdata
 base-files


Nous montre que ce sont les paquets tzdata et base-files qui bloquent la mise à jour de udev.

Et j'ajouterai que c'est cohérent puisque le fichiers /etc/debian_version fait parti du paquet base-files et celui ci nous retourne ceci:

deamon974 a écrit :

cat /etc/debian_version
#3.1


Tu es toujours en old-old-stable, c'est a dire en Sarge.

C'est la commande:

apt-get dist-upgrade


Qui permet le passage d'une branche à l'autre comme je te l'indiquais dans mon (gentil) rtfm.

Si il y a des blocages, tu va devoir les "résoudre à la main" ( hé oui, Sarge est un ancêtre plutôt rustique et il faut attendre Lenny pour profiter du confort "moderne" ).

Pour ce faire tu peux utiliser apt-get avec l'options -t qui permet de choisir le logiciel selon la branche ( exemple: apt-get -t etch install libc6 . Un paquet dont eol à souligné qu'il était critique et assez chatouilleux à la mises à jour ) mais sans fichiers préférences il te suffit juste de les installer l version la plus haute étant choisie d'office parmis les logiciels disponible.

J'ajouterai que faire des simulations ( option -s ) de dist-upgrade au fur et à mesure de l'installation manuelle te permettra de voir ce qui bloque, ce qui ne bloque pas et ce qui ne bloque plus.

De plus :

deamon974 a écrit :

df -h

Filesystem            Size  Used Avail Use% Mounted on
/dev/sda3             897M  106M  744M  13% /
tmpfs                1014M     0 1014M   0% /dev/shm
/dev/mapper/rootvg-homelv
                      1.9G   22M  1.8G   2% /home
/dev/mapper/rootvg-usrlv
                      3.0G  553M  2.3G  20% /usr
/dev/mapper/rootvg-varlv
                      3.0G  112M  2.7G   4% /var
/dev/mapper/rootvg-vserverslv
                      9.9G  8.4G  1.1G  90% /vservers


montre que tes partitions ( particulièrement '/dev/mapper/rootvg-vserverslv' La racine en lvm ? Raid ?  )ont tendances à se remplir, veille bien la dessus.

Donc en résumé:

deamon974 a écrit :

#cat /etc/apt/preferences

Package: *
Pin: release a=stable
Pin-Priority: 990

Package: *
Pin: release a=testing
Pin-Priority: 66

Package: *
Pin: release a=unstable
Pin-Priority: 33


Comme l'a relevé Smolsky mentionner stable n'a pour le moment aucun intérêt et:
Surtout pas de Sid/Squeeze ( Squeeze=Testing) sur un serveur ! ( mon dieu !! )

Si tu veux utiliser un fichier préférences ( ce qui n'est pas obligatoire dans ton cas ) utilise plutôt celui ci:

Package: *
Pin: release a=oldstable
Pin-Priority: 990

Package: *
Pin: release a=stable
Pin-Priority: 10


Etch à une priorité de 990 et Lenny de 10 en attendant d'y arriver. La priorité de Sarge ( oui oui, tu es toujours en Sarge) est par défaut à 500 .

Je te conseil ce sources.list lors de la première migration:

deb http://archive.debian.org/debian/ sarge main contrib non-free
deb http://archive.debian.org/debian/ etch main contrib non-free


pour mieux gérer les dépendances entre les branches.

deamon974 a écrit :

tu veut dire que je doit mettre un source list lenny en place ?


Non ! Pas pour le moment. Une fois le passage complet en Etch et lorce que celui ci sera établi et *stabilisé*. Et seulement à ce moment là.

deamon974 a écrit :

Ben moi jespere juste que je ne pas faire n'importe quoi sur ce serveur tongue

Meme si celui si n'est pas tres important je voudrais bien réussir


Ne te presse ( ne t'empresse ? ) surtout pas. Si tu parcours le lien que j'ai donné plus haut ( le post de fran.b ) tu peut constater que le sysadmin qui a posté la demande d'aiden'a pas fait sa migration sur quelques jours, mais sur quelques semaines ( ben oui roll )

D'après les quelques échos que j'ai eu sur les forums, Debian à l'époque de Sarge ç'était vraiment de l'artisanat ( rien à voir avec le système ultra-moderne, giga-performant et inégalable que l'on connait aujourd'hui cool Ha une petite voix me souffle que je suis partial lol ).
Donc vas y tout doucement.

Le passage Sarge>> Etch va être le plus hard-core.
Après Etch >> Lenny ce sera du gateau ( en comparaison je veux dire, hein ) 

eol a écrit :

il y a pas longtemps sur l'autre forum Debian, un mec venait se plaindre
que du fait que son Gnome boîtait, son serveur était inaccessible
et qu'il perdait des clients en permanence à cause de ça ...


lol ( la créature verte me manque d'un coup )
M'enfin je me méfie car qu'en on parle du loup on en voit vite la queue roll ( oui c'était nul )
[small]J'aime pas les chiens[/small] neutral

Encouragement sincères,
Clem smile
@+

Dernière modification par Clem (11-12-2010 06:53:30)


Moi, je suis PC (x86_64) et formater windows, c'était MON idée
Le sommeil de la raison ...

Hors ligne

#55 11-12-2010 08:15:13

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Mise a jour d'un serveur debian 3.1

Pour connaître les branches debian, tu tapes branches dans le cadre de la recherche du wiki df et tu obtiens ce lien :
http://debian-facile.org/doc:systeme:ap … hes-debian

Trop.... facile, n'est-il pas ? wink

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#56 14-12-2010 07:48:52

deamon974
Membre
Inscription : 08-12-2010

Re : Mise a jour d'un serveur debian 3.1

Bonjour

Merci beaucoup pour vos réponses

Donc à partir du code & de la source list sarge j'obtien donc:

apt-get -s update
tice-vserver:/etc/apt# apt-get -s update
Hit http://archive.debian.org sarge/main Packages
Hit http://archive.debian.org sarge/main Release            
Hit http://archive.debian.org sarge/contrib Packages        
Hit http://archive.debian.org sarge/contrib Release          
Hit http://archive.debian.org sarge/non-free Packages        
Hit http://archive.debian.org sarge/non-free Release        
Reading Package Lists... Done


Maintenant pour le -s upgrade j'obtient

tice-vserver:/etc/apt# apt-get -s upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages will be upgraded:
  base-config bsdutils dhcp-client exim4 exim4-base exim4-config
  exim4-daemon-light grub gzip info libc6 libc6-dev libdevmapper1.01 libgcc1
  libgnutls11 libpcre3 libssl0.9.7 libtasn1-2 locales login man-db mount
  passwd perl perl-base perl-modules ppp ssh sudo tar util-linux vim
  vim-common
33 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Conf base-files (3.1.2 Debian:3.1r8/oldstable)
Inst bsdutils [1:2.12p-4sarge1] (1:2.12p-4sarge2 Debian:3.1r8/oldstable)
Conf bsdutils (1:2.12p-4sarge2 Debian:3.1r8/oldstable)
Inst gzip [1.3.5-10sarge1] (1.3.5-10sarge2 Debian:3.1r8/oldstable)
Conf gzip (1.3.5-10sarge2 Debian:3.1r8/oldstable)
Inst login [1:4.0.3-31sarge5] (1:4.0.3-31sarge9 Debian:3.1r8/oldstable)
Conf login (1:4.0.3-31sarge9 Debian:3.1r8/oldstable)
Inst mount [2.12p-4sarge1] (2.12p-4sarge2 Debian:3.1r8/oldstable)
Conf mount (2.12p-4sarge2 Debian:3.1r8/oldstable)
Inst perl-modules [5.8.4-8sarge3] (5.8.4-8sarge6 Debian:3.1r8/oldstable)
Inst libc6-dev [2.3.2.ds1-22] (2.3.2.ds1-22sarge6 Debian:3.1r8/oldstable) []
Inst locales [2.3.2.ds1-22] (2.3.2.ds1-22sarge6 Debian:3.1r8/oldstable) []
Inst libc6 [2.3.2.ds1-22] (2.3.2.ds1-22sarge6 Debian:3.1r8/oldstable)
Conf libc6 (2.3.2.ds1-22sarge6 Debian:3.1r8/oldstable)
Inst perl [5.8.4-8sarge3] (5.8.4-8sarge6 Debian:3.1r8/oldstable) []
Inst perl-base [5.8.4-8sarge3] (5.8.4-8sarge6 Debian:3.1r8/oldstable)
Conf perl-base (5.8.4-8sarge6 Debian:3.1r8/oldstable)
Inst tar [1.14-2] (1.14-2.4 Debian:3.1r8/oldstable)
Conf tar (1.14-2.4 Debian:3.1r8/oldstable)
Inst util-linux [2.12p-4sarge1] (2.12p-4sarge2 Debian:3.1r8/oldstable)
Conf util-linux (2.12p-4sarge2 Debian:3.1r8/oldstable)
Inst vim [1:6.3-071+1sarge1] (1:6.3-071+1sarge3 Debian:3.1r8/oldstable) []
Inst vim-common [1:6.3-071+1sarge1] (1:6.3-071+1sarge3 Debian:3.1r8/oldstable)
Inst libgcc1 [1:3.4.3-13] (1:3.4.3-13sarge1 Debian:3.1r8/oldstable)
Conf libgcc1 (1:3.4.3-13sarge1 Debian:3.1r8/oldstable)
Inst exim4-config [4.50-8] (4.50-8sarge2 Debian:3.1r8/oldstable)
Inst exim4-base [4.50-8] (4.50-8sarge2 Debian:3.1r8/oldstable)
Inst passwd [1:4.0.3-31sarge5] (1:4.0.3-31sarge9 Debian:3.1r8/oldstable)
Conf passwd (1:4.0.3-31sarge9 Debian:3.1r8/oldstable)
Inst libtasn1-2 [0.2.10-3] (0.2.10-3sarge1 Debian:3.1r8/oldstable)
Inst libgnutls11 [1.0.16-13.1] (1.0.16-13.2sarge2 Debian:3.1r8/oldstable)
Inst libpcre3 [4.5-1.2sarge1] (4.5+7.4-2 Debian:3.1r8/oldstable)
Inst exim4-daemon-light [4.50-8] (4.50-8sarge2 Debian:3.1r8/oldstable)
Inst exim4 [4.50-8] (4.50-8sarge2 Debian:3.1r8/oldstable)
Inst info [4.7-2.2] (4.7-2.2sarge2 Debian:3.1r8/oldstable)
Inst man-db [2.4.2-21] (2.4.2-21sarge1 Debian:3.1r8/oldstable)
Inst libssl0.9.7 [0.9.7e-3sarge1] (0.9.7e-3sarge5 Debian:3.1r8/oldstable)
Inst ssh [1:3.8.1p1-8.sarge.4] (1:3.8.1p1-8.sarge.6 Debian:3.1r8/oldstable)
Inst base-config [2.53.10] (2.53.10.3 Debian:3.1r8/oldstable)
Inst dhcp-client [2.0pl5-19.1] (2.0pl5-19.1sarge3 Debian:3.1r8/oldstable)
Inst grub [0.95+cvs20040624-17] (0.95+cvs20040624-17sarge1 Debian:3.1r8/oldstable)
Inst libdevmapper1.01 [2:1.01.00-4] (2:1.01.00-4sarge1 Debian:3.1r8/oldstable)
Inst ppp [2.4.3-20050321+2] (2.4.3-20050321+2sarge1 Debian:3.1r8/oldstable)
Inst sudo [1.6.8p7-1.3] (1.6.8p7-1.4 Debian:3.1r8/oldstable)
Conf tzdata (2008e-1etch3 )
Conf perl (5.8.4-8sarge6 Debian:3.1r8/oldstable)
Conf perl-modules (5.8.4-8sarge6 Debian:3.1r8/oldstable)
Conf libc6-dev (2.3.2.ds1-22sarge6 Debian:3.1r8/oldstable)
Conf locales (2.3.2.ds1-22sarge6 Debian:3.1r8/oldstable)
Conf vim-common (1:6.3-071+1sarge3 Debian:3.1r8/oldstable)
Conf vim (1:6.3-071+1sarge3 Debian:3.1r8/oldstable)
Conf exim4-config (4.50-8sarge2 Debian:3.1r8/oldstable)
Conf exim4-base (4.50-8sarge2 Debian:3.1r8/oldstable)
Conf libtasn1-2 (0.2.10-3sarge1 Debian:3.1r8/oldstable)
Conf libgnutls11 (1.0.16-13.2sarge2 Debian:3.1r8/oldstable)
Conf libpcre3 (4.5+7.4-2 Debian:3.1r8/oldstable)
Conf exim4-daemon-light (4.50-8sarge2 Debian:3.1r8/oldstable)
Conf exim4 (4.50-8sarge2 Debian:3.1r8/oldstable)
Conf info (4.7-2.2sarge2 Debian:3.1r8/oldstable)
Conf man-db (2.4.2-21sarge1 Debian:3.1r8/oldstable)
Conf libssl0.9.7 (0.9.7e-3sarge5 Debian:3.1r8/oldstable)
Conf ssh (1:3.8.1p1-8.sarge.6 Debian:3.1r8/oldstable)
Conf base-config (2.53.10.3 Debian:3.1r8/oldstable)
Conf dhcp-client (2.0pl5-19.1sarge3 Debian:3.1r8/oldstable)
Conf grub (0.95+cvs20040624-17sarge1 Debian:3.1r8/oldstable)
Conf libdevmapper1.01 (2:1.01.00-4sarge1 Debian:3.1r8/oldstable)
Conf ppp (2.4.3-20050321+2sarge1 Debian:3.1r8/oldstable)
Conf sudo (1.6.8p7-1.4 Debian:3.1r8/oldstable)


Pouvez vous me renseigner sur l'interprétation de a derniere commande lancer,surtout la différence entre le conf et le Inst juste avant les packet només!

amitier deamon974.

Hors ligne

#57 14-12-2010 08:17:14

deamon974
Membre
Inscription : 08-12-2010

Re : Mise a jour d'un serveur debian 3.1

Et finalement c'est à chaque fois base-files qui empeche la mise à jour.

tice-vserver:/etc/apt# apt-get dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
The following packages will be upgraded:
  base-config bsdutils dhcp-client exim4 exim4-base exim4-config
  exim4-daemon-light grub gzip info libc6 libc6-dev libdevmapper1.01 libgcc1
  libgnutls11 libpcre3 libssl0.9.7 libtasn1-2 locales login man-db mount
  passwd perl perl-base perl-modules ppp ssh sudo tar util-linux vim
  vim-common
33 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 0B/30.9MB of archives.
After unpacking 302kB disk space will be freed.
Do you want to continue? [Y/n]
Preconfiguring packages ...
Setting up base-files (3.1.2) ...
dpkg (subprocess): unable to execute post-installation script: Permission denied
dpkg: error processing base-files (--configure):
 subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
 base-files
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#58 14-12-2010 12:07:11

Clem
Membre
Lieu : Au coin du bois
Distrib. : Stable && Sid
Noyau : 3.16-2 & 3.17-1 *-amd-64
(G)UI : XMonad & Mate(?)
Inscription : 09-03-2010

Re : Mise a jour d'un serveur debian 3.1

Salut,

deamon974 a écrit :

apt-get -s update
tice-vserver:/etc/apt# apt-get -s update
Hit http://archive.debian.org sarge/main Packages
Hit http://archive.debian.org sarge/main Release            
Hit http://archive.debian.org sarge/contrib Packages        
Hit http://archive.debian.org sarge/contrib Release          
Hit http://archive.debian.org sarge/non-free Packages        
Hit http://archive.debian.org sarge/non-free Release        
Reading Package Lists... Done


1. Pourquoi '-s' ?
2. Pourquoi Etch n'apparait pas?

deamon974 a écrit :

surtout la différence entre le conf et le Inst juste avant les packet només!


Inst: dpkg désarchive et installe les fichiers du paquet ( manuel, executable ... etc ... )
Conf: dpkg ( et debconf ? ) procède a la configuration automatique.

Pour le reste:

#apt-get -t etch -s install base-file udev


#apt-get -t etch -s install -f base-file


Tu es arrivé sur quel version du noyau du coup ? ( uname -a )

Edit=

deamon974 a écrit :

Inst gzip [1.3.5-10sarge1] (1.3.5-10sarge2 Debian:3.1r8/oldstable)
Conf gzip (1.3.5-10sarge2 Debian:3.1r8/oldstable)


J'ai raté un épisode ? neutral
Sarge n'est pas encore à jour?
Si c'est le cas tu dois te retrouver avec un mélange de Sarge ( plusieurs version logiciels différent de Sarge en fait ) et de Etch... Ce qui expliquerai les blocages.

Je comprends plus rien. Tu pourrais faire un résumé de la situation steupl' ? smile

Dernière modification par Clem (14-12-2010 12:29:20)


Moi, je suis PC (x86_64) et formater windows, c'était MON idée
Le sommeil de la raison ...

Hors ligne

#59 14-12-2010 13:13:30

deamon974
Membre
Inscription : 08-12-2010

Re : Mise a jour d'un serveur debian 3.1

Donc en résumer j'ai essayer de mettre à jour ma sarge mais comme le paquet base files bloqué je penser avoir rater quelque chose dans la mise à jour

J'ai aussi essayer d'installer le udev mais encore une fois le base-files pose toujours autant de probleme mais je crois que c'est pour cela que cette sarge ne veut pas ce mettre à jour

Au début j'ai penser lavoir mise à jour mais finalement je vois bien qu'il ne la pas fait

Pour répondre à ta question je suis toujours sur une 3.1

Dernière modification par deamon974 (14-12-2010 13:36:56)

Hors ligne

#60 14-12-2010 13:42:55

Clem
Membre
Lieu : Au coin du bois
Distrib. : Stable && Sid
Noyau : 3.16-2 & 3.17-1 *-amd-64
(G)UI : XMonad & Mate(?)
Inscription : 09-03-2010

Re : Mise a jour d'un serveur debian 3.1

Ouaip,
Il se pourrait qu'il y ai un conflit entre base-files et le paquet 'base' (si un barbu pouvait confirmer ou infirmer neutral [small]je ne savais pas ce que c'était un ordinateur à l'époque de Sarge[/small] hmm ) .
Renvoi nous:

apt-cache policy base-files base base-config udev dpkg


Et les sorties d'erreurs de :

Clem a écrit :

#apt-get -t etch -s install base-file udev


#apt-get -t etch -s install -f base-file


deamon974 a écrit :

Donc en résumer j'ai essayer de mettre à jour ma sarge mais comme le paquet base files bloqué je penser avoir rater quelque chose dans la mise à jour


Oui tu as alterné les mises à jour de Sarge et de Etch. Ca va être le merdier dans la gestion des dépendances sad


Moi, je suis PC (x86_64) et formater windows, c'était MON idée
Le sommeil de la raison ...

Hors ligne

#61 14-12-2010 14:19:44

deamon974
Membre
Inscription : 08-12-2010

Re : Mise a jour d'un serveur debian 3.1

# apt-cache policy base-files base base-config udev dpkg
base-files:
  Installed: 3.1.2
  Candidate: 3.1.2
  Version Table:
 *** 3.1.2 0
        990 http://archive.debian.org sarge/main Packages
        100 /var/lib/dpkg/status
base:
  Installed: (none)
  Candidate: (none)
  Version Table:
base-config:
  Installed: 2.53.10
  Candidate: 2.53.10.3
  Version Table:
     2.53.10.3 0
        990 http://archive.debian.org sarge/main Packages
 *** 2.53.10 0
        100 /var/lib/dpkg/status
udev:
  Installed: (none)
  Candidate: 0.056-3
  Version Table:
     0.056-3 0
        990 http://archive.debian.org sarge/main Packages
dpkg:
  Installed: 1.10.28
  Candidate: 1.10.28
  Version Table:
 *** 1.10.28 0
        990 http://archive.debian.org sarge/main Packages
        100 /var/lib/dpkg/status


# apt-get -t etch -s install base-file udev
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package base-fil


apt-get -t etch -s install -f base-file
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package base-file


voila tt les codes demander.

Hors ligne

#62 14-12-2010 14:28:24

Clem
Membre
Lieu : Au coin du bois
Distrib. : Stable && Sid
Noyau : 3.16-2 & 3.17-1 *-amd-64
(G)UI : XMonad & Mate(?)
Inscription : 09-03-2010

Re : Mise a jour d'un serveur debian 3.1

Autant pour moi, il y a un 's' et j'était resté sur Etch

#apt-get -s install base-files udev

#apt-get -s install -f base-files

Après il faudrait savoir si la suppression de base-config permettrai l'installation de base-files. Je n'en sais rien: dans la version que j'utilise (Sid) ce paquet n'existe pas.

En tout cas il est rassurant de voir que ces paquets ne sont pas passés en Etch smile

Moi, je suis PC (x86_64) et formater windows, c'était MON idée
Le sommeil de la raison ...

Hors ligne

#63 14-12-2010 14:34:42

deamon974
Membre
Inscription : 08-12-2010

Re : Mise a jour d'un serveur debian 3.1

Tu me rassure aussi par la meme occasion !

# apt-get -t etch -s install -f base-file
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package base-file


# apt-get -s install -f base-files
Reading Package Lists... Done
Building Dependency Tree... Done
base-files is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 33 not upgraded.
2 not fully installed or removed.
Conf base-files (3.1.2 Debian:3.1r8/oldstable)
Conf tzdata (2008e-1etch3 )


Tu pense vraiment qu'il faudrais que je le supprime?

Hors ligne

#64 14-12-2010 14:39:13

Clem
Membre
Lieu : Au coin du bois
Distrib. : Stable && Sid
Noyau : 3.16-2 & 3.17-1 *-amd-64
(G)UI : XMonad & Mate(?)
Inscription : 09-03-2010

Re : Mise a jour d'un serveur debian 3.1

deamon974 a écrit :

Tu pense vraiment qu'il faudrais que je le supprime?


Pas base-files !!
Par contre aujourd'hui base-config n'existe plus ... donc hmm .

Je ne pense pas grand chose ... je suppute.

Tente ça et donne nous le retour:
# apt-get install -f base-files
Attention ça n'est plus une simulation, ça peut être violent neutral


Moi, je suis PC (x86_64) et formater windows, c'était MON idée
Le sommeil de la raison ...

Hors ligne

#65 14-12-2010 14:45:56

deamon974
Membre
Inscription : 08-12-2010

Re : Mise a jour d'un serveur debian 3.1

Alrs supputons bien:P

tu peut me donner cette commande pour supprimer ce paquet, je la connais mais je veut en être sure!

# apt-get install -f base-files
Reading Package Lists... Done
Building Dependency Tree... Done
base-files is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 33 not upgraded.
2 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Setting up base-files (3.1.2) ...
dpkg (subprocess): unable to execute post-installation script: Permission denied
dpkg: error processing base-files (--configure):
 subprocess post-installation script returned error exit status 2
Setting up tzdata (2008e-1etch3) ...
dpkg (subprocess): unable to execute post-installation script: Permission denied
dpkg: error processing tzdata (--configure):
 subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
 base-files
 tzdata
E: Sub-process /usr/bin/dpkg returned an error code (1)

Dernière modification par deamon974 (14-12-2010 14:51:27)

Hors ligne

#66 14-12-2010 14:52:24

Clem
Membre
Lieu : Au coin du bois
Distrib. : Stable && Sid
Noyau : 3.16-2 & 3.17-1 *-amd-64
(G)UI : XMonad & Mate(?)
Inscription : 09-03-2010

Re : Mise a jour d'un serveur debian 3.1

Je viens de trouver ça:

clem@Sid:~$ apt-cache show tzdata
Package: tzdata
Priority: required
Section: libs
Installed-Size: 6276
Maintainer: GNU Libc Maintainers <debian-glibc@lists.debian.org>
Architecture: all
Version: 2010o-1
Replaces: libc0.1, libc0.3, libc6, libc6.1
Provides: tzdata-squeeze
Depends: debconf (>= 0.5) | debconf-2.0
Filename: pool/main/t/tzdata/tzdata_2010o-1_all.deb
Size: 764012


Replaces: libc0.1, libc0.3, libc6, libc6.1


En Sid, càd que ca n'a rien à voir avec ton système.
Avant toute choses montre:

apt-cache policy libc6 tzdata


Cf ici, ( paquet importants )

deamon974 a écrit :

tu peut me donner cette commande pour supprimer ce paquet, je la connais mais je veut en être sure!


Celle que je t'ai donnée fera le boulot.
L'option -f force la mises à jour.

Dernière modification par Clem (14-12-2010 15:02:24)


Moi, je suis PC (x86_64) et formater windows, c'était MON idée
Le sommeil de la raison ...

Hors ligne

#67 14-12-2010 15:05:47

deamon974
Membre
Inscription : 08-12-2010

Re : Mise a jour d'un serveur debian 3.1

# apt-cache policy libc6
libc6:
  Installed: 2.3.2.ds1-22
  Candidate: 2.3.2.ds1-22sarge6
  Version Table:
     2.3.2.ds1-22sarge6 0
        990 http://archive.debian.org sarge/main Packages
 *** 2.3.2.ds1-22 0
        100 /var/lib/dpkg/status


voila ce que donne  ce code.

Hors ligne

#68 14-12-2010 15:09:48

Clem
Membre
Lieu : Au coin du bois
Distrib. : Stable && Sid
Noyau : 3.16-2 & 3.17-1 *-amd-64
(G)UI : XMonad & Mate(?)
Inscription : 09-03-2010

Re : Mise a jour d'un serveur debian 3.1

Ha smile
C'est surement la que ça coince.

#apt-get -t sarge install libc6


Hop!
Puis tu relance.

#apt-get update
#apt-get dist-upgrade
#dpkg --configure -a


Moi, je suis PC (x86_64) et formater windows, c'était MON idée
Le sommeil de la raison ...

Hors ligne

#69 14-12-2010 16:09:04

deamon974
Membre
Inscription : 08-12-2010

Re : Mise a jour d'un serveur debian 3.1

Aucun moyen base-files bloque toujours

# apt-get -t sarge install libc6
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  libc6-dev locales
Suggested packages:
  glibc-doc manpages-dev
The following packages will be upgraded:
  libc6 libc6-dev locales
3 upgraded, 0 newly installed, 0 to remove and 30 not upgraded.
2 not fully installed or removed.
Need to get 0B/11.4MB of archives.
After unpacking 369kB disk space will be freed.
Do you want to continue? [Y/n]
Preconfiguring packages ...
Setting up base-files (3.1.2) ...
dpkg (subprocess): unable to execute post-installation script: Permission denied
dpkg: error processing base-files (--configure):
 subprocess post-installation script returned error exit status 2
Errors were encountered while processing:
 base-files
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#70 14-12-2010 16:32:56

Clem
Membre
Lieu : Au coin du bois
Distrib. : Stable && Sid
Noyau : 3.16-2 & 3.17-1 *-amd-64
(G)UI : XMonad & Mate(?)
Inscription : 09-03-2010

Re : Mise a jour d'un serveur debian 3.1

deamon974 a écrit :

# apt-get -t sarge install libc6
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
libc6-dev locales
Suggested packages:
  glibc-doc manpages-dev
The following packages will be upgraded:
  libc6 libc6-dev locales


Tu les ajoutes à l'installation forcée.
# apt-get -t sarge install libc6 libc6-dev locales tzdata
Et j'jouterai même tzdata

Au fur et a mesure que ça coince tu ajoute les paquets aux dépendances. ( The following extra packages will be installed:
libc6-dev locales )
Au bout d'un moment ça va se débloquer, même si ta commande fait 10 lignes.

Ps: au fait:

#apt-cache policy tzdata


Ca donne quoi ?


Moi, je suis PC (x86_64) et formater windows, c'était MON idée
Le sommeil de la raison ...

Hors ligne

#71 14-12-2010 16:42:53

deamon974
Membre
Inscription : 08-12-2010

Re : Mise a jour d'un serveur debian 3.1

Meme apres installation forcé le base-files bloque toujours aucune possiblilité d'installer les paquets

# apt-cache policy tzdata
tzdata:
  Installed: 2008e-1etch3
  Candidate: 2008e-1etch3
  Version Table:
 *** 2008e-1etch3 0
        100 /var/lib/dpkg/status

Hors ligne

#72 14-12-2010 16:54:24

Clem
Membre
Lieu : Au coin du bois
Distrib. : Stable && Sid
Noyau : 3.16-2 & 3.17-1 *-amd-64
(G)UI : XMonad & Mate(?)
Inscription : 09-03-2010

Re : Mise a jour d'un serveur debian 3.1

Rha!! yikes

deamon974 a écrit :

# apt-cache policy tzdata
tzdata:
  Installed: 2008e-1etch3
  Candidate: 2008e-1etch3
  Version Table:
*** 2008e-1etch3 0
        100 /var/lib/dpkg/status


Base-file est bloqué parce que libc6 est bloqué parce que tzdata est bloqué...
Quel merdier!

1. Modifie ton fichier preferences:

Package: *
Pin: release a=oldstable
Pin-Priority: -10


Atention c'est bien un 'moins' -10

Après la modification poste:

apt-cache policy


Pour voir si c'est bon.
Et:

#apt-get update
#apt-get dist-upgrade


Normalement ça va forcer la désinstallation de tout ce qui vient de Etch.

Edit=

Je suis surpris qu'il n'y ait pas de version disponible pour sarge:

# apt-cache policy tzdata
tzdata:
  Installed: 2008e-1etch3
  Candidate: 2008e-1etch3
  Version Table:
*** 2008e-1etch3 0
        100 /var/lib/dpkg/status


Re Edit=

ls /var/cache/apt/archives/tzdata*


et

df -h

Dernière modification par Clem (14-12-2010 17:45:35)


Moi, je suis PC (x86_64) et formater windows, c'était MON idée
Le sommeil de la raison ...

Hors ligne

#73 14-12-2010 18:00:08

deamon974
Membre
Inscription : 08-12-2010

Re : Mise a jour d'un serveur debian 3.1

J'ai discuter avec fran.b et voila en résumer de ce que j'ai fait avec son aide.

Il m'a tt d'abord demander lui montrer ce que retourne la commande mount

  # mount
/dev/sda3 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/mapper/rootvg-homelv on /home type ext3 (rw)
/dev/mapper/rootvg-usrlv on /usr type ext3 (rw)
/dev/mapper/rootvg-varlv on /var type ext3 (rw,noexec)
/dev/mapper/rootvg-vserverslv on /vservers type ext3 (rw)


Puis par la suite à la decouverte de la ligne: /dev/mapper/rootvg-varlv on /var type ext3 (rw,noexec)
Il ma demmander d'effectuer cette commande.

 # mount /var -o remount,exec


Finalement sa ma bien débloquer le base-files au moment de la mise à jour et sa ma permis de faire certaine mise à jour de ma sarge mais il y a encore des bloquage:

# apt-get upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  libc6-dev: Depends: libc6 (= 2.3.2.ds1-22sarge6) but 2.3.2.ds1-22 is installed
  locales: Depends: glibc-2.3.2.ds1-22sarge6
E: Unmet dependencies. Try using -f.


Dans ces dernierres ligne il mais bien conseiller de faire un

#apt-get -f install libc6-dev
&
#apt-get -f install locales

Hors ligne

#74 14-12-2010 18:09:13

Clem
Membre
Lieu : Au coin du bois
Distrib. : Stable && Sid
Noyau : 3.16-2 & 3.17-1 *-amd-64
(G)UI : XMonad & Mate(?)
Inscription : 09-03-2010

Re : Mise a jour d'un serveur debian 3.1

deamon974 a écrit :

J'ai discuter avec fran.b et voila en résumer de ce que j'ai fait avec son aide.


Cool, lui au moins sait de quoi il parle, alors que moi... j'improvise tongue

Voir l'édit avant !

deamon974 a écrit :

#apt-get -f install libc6-dev
&
#apt-get -f install locales


Et ça à donné quoi ??
Fait même

#apt-get -f install libc6


En une ligne:

#apt-get -f install libc6 locales libc6-dev tzdata


Edit =[small]( rha je réagis au ralenti, besoin de sommeil moi )[/small]
Heu :

# apt-get upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  libc6-dev: Depends: libc6 (= 2.3.2.ds1-22sarge6) but 2.3.2.ds1-22 is installed
  locales: Depends: glibc-2.3.2.ds1-22sarge6
E: Unmet dependencies. Try using -f.


Fait même un dist-upgrade plutôt qu'un simple upgrade.

Dernière modification par Clem (14-12-2010 18:19:32)


Moi, je suis PC (x86_64) et formater windows, c'était MON idée
Le sommeil de la raison ...

Hors ligne

#75 14-12-2010 18:27:39

deamon974
Membre
Inscription : 08-12-2010

Re : Mise a jour d'un serveur debian 3.1

Voila les résultat des commande demander

# apt-get -f install libc6-dev
Reading Package Lists... Done
Building Dependency Tree... Done
libc6-dev is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  libc6-dev: Depends: libc6 (= 2.3.2.ds1-22sarge6) but 2.3.2.ds1-22 is to be installed
  locales: Depends: glibc-2.3.2.ds1-22sarge6
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


# apt-get -f install locales  
Reading Package Lists... Done
Building Dependency Tree... Done
locales is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  libc6-dev: Depends: libc6 (= 2.3.2.ds1-22sarge6) but 2.3.2.ds1-22 is to be installed
  locales: Depends: glibc-2.3.2.ds1-22sarge6
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


Puis

 apt-get -f install libc6
Reading Package Lists... Done
Building Dependency Tree... Done
Suggested packages:
  glibc-doc
The following packages will be upgraded:
  libc6
1 upgraded, 0 newly installed, 0 to remove and 25 not upgraded.
3 not fully installed or removed.
Need to get 0B/4886kB of archives.
After unpacking 233kB disk space will be freed.
(Reading database ... 33475 files and directories currently installed.)
Preparing to replace libc6 2.3.2.ds1-22 (using .../libc6_2.3.2.ds1-22sarge6_i386.deb) ...
Unpacking replacement libc6 ...
dpkg: error processing /var/cache/apt/archives/libc6_2.3.2.ds1-22sarge6_i386.deb (--unpack):
 trying to overwrite `/usr/share/zoneinfo/Africa/Algiers', which is also in package tzdata
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.3.2.ds1-22sarge6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


# apt-get dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  libc6-dev: Depends: libc6 (= 2.3.2.ds1-22sarge6) but 2.3.2.ds1-22 is installed
  locales: Depends: glibc-2.3.2.ds1-22sarge6
E: Unmet dependencies. Try using -f.


Alala ce sarge pouquoi existe t'il ?:P

Hors ligne

Pied de page des forums