Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-12-2010 14:57:55

CrassFlict
Membre
Distrib. : Jessie 64bits
Noyau : Linux 3.16.0-4-amd64
Inscription : 25-12-2010

[Résolu] Squeeze et Amarok 1.4

Question résolue partiellement. Je n'ai pas réussi a installer amarok 1.4, mais on m'informe de l'existence de clementine un fork de amarok 1.4, qu'il est plus pertinent d'utiliser aujourd'hui puisque que amarok 1.4 est amené a tombé dans la désuètude...

#####

Bonjour a tou-te-s

J'ai tout récemment migrer d'ubuntu a debian squeeze. La migration s'est imposée pour 2 raisons : (i) avoir une distribution qui me correspond en terme de philisophie (ii) passer aux choses serieuses ous GNU/Linux après des années d'utilisation basique en tant qu'utilisateur.
Tout fonctionne très bien jusqu'a présent ! J'ai un petit soucis, mineur mais qui me chifonne un peu quand meme : j'aimerais bien utiliser amarok 1.4 plutot que 2.*, car comme pleins d'autres gens qui ont gouté aux 2, je me sens bien a plus a l'aise avec la 1.4 qui correspond a mes besoins.

J'ai suivi les conseils du post suivant : http://debian-facile.org/forum/viewtopic.php?id=1948

Cependant, je n'ai toujours pas réussi a installer la version 1.4.
le gestionnaire de paquet m'installe toujours la 2.*. De plus, cette version une fois installée n'est pas fonctionnelle (je n'arrive pas a l'utiliser).

Voila mon source.list :

[c]## Squeeze
# Main, contrib et non-free
deb http://ftp.fr.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ squeeze main contrib non-free

# Security
deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main

## Lenny
# Main
deb http://ftp.de.debian.org/debian lenny main[/c]


le fichier des préférences (dont je découvre en ce moment l'utilisation, ca a l'air très pratique) :


[c]Package: *
Pin: release a=squeeze
Pin-priority: 900

Package: *
Pin: release a=lenny
Pin-priority: 90

Package: amarok
Pin: version 1.4.10-2
Pin-Priority: 1001[/c]

apt-cache madison paquet amarok me donne :

[c]
# apt-cache madison paquet amarok
    amarok |    2.3.1-1 | http://ftp.fr.debian.org/debian/ squeeze/main i386 Packages
    amarok | 1.4.10-2lenny1 | http://ftp.de.debian.org/debian/ lenny/main i386 Packages
    amarok |    2.3.1-1 | http://ftp.fr.debian.org/debian/ squeeze/main Sources
N: Impossible de trouver le paquet paquet[/c]

De ce que je comprends de tout ca, il y a un conflit entre les 2 versions (?).
Comment résoudre ce pb ? Merci pour vos conseils qui me permettront d'utiliser ce bon vieux amarok 1.4 et d'avancer dans la compréhension du fonctionnement de debian.

Bien a vous,
CrassFlict

Dernière modification par CrassFlict (31-12-2010 15:53:52)

Hors ligne

#2 30-12-2010 15:20:34

Clem
Membre
Lieu : Au coin du bois
Distrib. : Stable && Sid
Noyau : 3.16-2 & 3.17-1 *-amd-64
(G)UI : XMonad & Mate(?)
Inscription : 09-03-2010

Re : [Résolu] Squeeze et Amarok 1.4

Bonjour,

Et que renvoi:

$apt-cache policy

$apt-cache policy amarok

Par ailleurs il me semble que pour avoir un logiciel utilisable il faudrait rapatrier toutes les dépendances du-dit logiciel depuis Lenny ( et Dieu sait si Amarok est lourd sad )

Moi, je suis PC (x86_64) et formater windows, c'était MON idée
Le sommeil de la raison ...

Hors ligne

#3 30-12-2010 15:28:54

CrassFlict
Membre
Distrib. : Jessie 64bits
Noyau : Linux 3.16.0-4-amd64
Inscription : 25-12-2010

Re : [Résolu] Squeeze et Amarok 1.4

bonjour clem

merci pour ta réponse :

$apt-cache policy

Fichiers du paquet :
100 /var/lib/dpkg/status
     release a=now
500 http://ftp.de.debian.org/debian/ lenny/main Translation-fr
500 http://ftp.de.debian.org/debian/ lenny/non-free i386 Packages
     release v=5.0.7,o=Debian,a=stable,n=lenny,l=Debian,c=non-free
     origin ftp.de.debian.org
500 http://ftp.de.debian.org/debian/ lenny/contrib i386 Packages
     release v=5.0.7,o=Debian,a=stable,n=lenny,l=Debian,c=contrib
     origin ftp.de.debian.org
500 http://ftp.de.debian.org/debian/ lenny/main i386 Packages
     release v=5.0.7,o=Debian,a=stable,n=lenny,l=Debian,c=main
     origin ftp.de.debian.org
500 http://security.debian.org/ squeeze/updates/main i386 Packages
     release o=Debian,a=testing,n=squeeze,l=Debian-Security,c=main
     origin security.debian.org
500 http://ftp.fr.debian.org/debian/ squeeze/main Translation-fr
500 http://ftp.fr.debian.org/debian/ squeeze/non-free i386 Packages
     release o=Debian,a=testing,n=squeeze,l=Debian,c=non-free
     origin ftp.fr.debian.org
500 http://ftp.fr.debian.org/debian/ squeeze/contrib i386 Packages
     release o=Debian,a=testing,n=squeeze,l=Debian,c=contrib
     origin ftp.fr.debian.org
500 http://ftp.fr.debian.org/debian/ squeeze/main i386 Packages
     release o=Debian,a=testing,n=squeeze,l=Debian,c=main
     origin ftp.fr.debian.org
Paquets étiquetés :
     amarok -> (non trouvé)


$apt-cache policy amarok

amarok:
  Installé : (aucun)
  Candidat : 2.3.1-1
  Étiquette de paquet : (non trouvé)
Table de version :
     2.3.1-1 1001
        500 http://ftp.fr.debian.org/debian/ squeeze/main i386 Packages
     1.4.10-2lenny1 1001
        500 http://ftp.de.debian.org/debian/ lenny/main i386 Packages
        100 /var/lib/dpkg/status


Par ailleurs il me semble que pour avoir un logiciel utilisable il faudrait rapatrier toutes les dépendances du-dit logiciel depuis Lenny ( et Dieu sait si Amarok est lourd sad )


est ce que cela ne fait pas automatiquement puisque lenny est configurer dans le sourcelist ?

Hors ligne

#4 30-12-2010 15:39:09

pascal.dte
Membre
Inscription : 30-12-2010

Re : [Résolu] Squeeze et Amarok 1.4

Clementine-player se base sur Amarok 1.4. Vous trouvere des infos et les paquets pour squeeze (32 et 64 bits) :

site de clementine

Cela semble plus simple que d'utiliser des paquets kde en versions différentes. Je l'avais déjà utilisé (dans gnome) sans soucis.
smile

Hors ligne

#5 31-12-2010 15:51:56

CrassFlict
Membre
Distrib. : Jessie 64bits
Noyau : Linux 3.16.0-4-amd64
Inscription : 25-12-2010

Re : [Résolu] Squeeze et Amarok 1.4

pascal.dte a écrit :

Cela semble plus simple que d'utiliser des paquets kde en versions différentes. Je l'avais déjà utilisé (dans gnome) sans soucis.
smile


merci pour l'info !!
en effet cela parait plus simple, et dans un avenir proche, il semble qu'il serait de plus en plus hasardeux d'installer amarok 1.4.

ca fait plaisir de voir que ce projet de fork existe !
merci pour l'info, et pour votre aide, je vais de ce pas installer clementine !

Hors ligne

#6 01-01-2011 09:40:15

Clem
Membre
Lieu : Au coin du bois
Distrib. : Stable && Sid
Noyau : 3.16-2 & 3.17-1 *-amd-64
(G)UI : XMonad & Mate(?)
Inscription : 09-03-2010

Re : [Résolu] Squeeze et Amarok 1.4

Clementine me parait effectivement la solution la plus simple et la moins dangereuse.

D'autant que le pinning ( rétro-pinning en ait ) n'était pas pris en compte sur tout système hmm

Tout est bien qui finit bien smile

Moi, je suis PC (x86_64) et formater windows, c'était MON idée
Le sommeil de la raison ...

Hors ligne

Pied de page des forums