Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-02-2011 12:04:39

Nails
Membre
Distrib. : 5.0.6
Noyau : 2.6.26-2-686
(G)UI : Aucune
Inscription : 10-02-2011

[Résolu] Samba Authentification

Bonjour à tous,

Me voila nouveau sur ce forum, j'espère pouvoir obtenir un peu d'aide et en fournir à ce forum smile

Je possède un serveur d'impression CUPS couplé à un SAMBA.
J'ai donc +/- 10 imprimantes avec une dizaine de poste.

Tout marche plus ou moins bien, sauf un petit détail ; depuis les postes l'installation de 2 imprimantes "foire" avec comme message d'erreur coté log :

[2011/02/09 17:32:56,  0] smbd/service.c:make_connection_snum(1086)
  Can't become connected user!


et coté windows :
bugsamba.png

Bon je l'avoue je début complètement en Samba et je l'ai configurer un peu comme un goret

Mon smb.conf :

# Samba config file created using SWAT
# from UNKNOWN ()
# Date: 2011/02/08 12:53:56

[global]
        server string = %h server
        obey pam restrictions = Yes
        password server = None
        passdb backend = tdbsam
        pam password change = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
        unix password sync = Yes
        lanman auth = Yes
        client lanman auth = Yes
        client plaintext auth = Yes
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        printcap name = cups
        dns proxy = No
        ldap ssl = no
        panic action = /usr/share/samba/panic-action %d
        valid users = magasin, root, hotline, yallouac
        admin users = root, yallouac
        printer admin = root, hotline, yallouac
        oplocks = No
        level2 oplocks = No

[homes]
        comment = Home Directories
        username = magasin
        valid users = %S
        write list = root
        read only = No
        create mask = 0700
        directory mask = 0700
        browseable = No


[printers]
        comment = All Printers
        path = /var/spool/samba
        printer admin = root, administrateur, yallouac, magasin
        read only = No
        create mask = 0700
        printable = Yes
        browseable = No

[print$]
        comment = Printer Drivers
        path = /var/lib/samba/printers
        username = root
        valid users = root, hotline, yallouac, magasin, nchenaux
        write list = root
        read only = No
        inherit permissions = Yes
        only user = Yes


[Outillage]
        comment = Kyocera FS-1030D
        path = /var/spool/samba
        printer admin = root, administrateur, hotline, magasin
        read only = No
        create mask = 0700
        guest ok = Yes
        hosts allow = 10.0.13., 192.168.*.*
        printable = Yes
        printer name = Outillage
        share modes = No

[Mag_Animalerie]
        comment = FS-1370DN
        path = /var/spool/samba
        printer admin = root, administrateur, yallouac, magasin
        read only = No
        create mask = 0700
        printable = Yes
        printer name = Mag_Animalerie
        share modes = No


Au tout début toutes les imprimantes marchaient impec', puis est arrivé ce soucis avec dans un premier temps un message de refus de connexion, puis ce message de driver. A noté que je peut les installé en choisissant un driver en local, ces postes sont pour beaucoup en windows 2000.


J'ai fait un peu le tour de divers forum (developpez/sdz/ubuntu) mais malheureusement aucune réponse hmm

Je n'ai pas envie de faire un trop gros "pavé" pour faire fuir les lecteurs, donc si vous avez besoins de plus d'information (résultat de testparm ou smbclient) n'hésitez pas!

Ps: Pourquoi seuls 2 imprimantes s'affiche dans mon smb.conf alors que j'en dispose de 10? Et que ce sont ces 2 imprimantes qui bug.

Ps2 : Sur tout les postes auxquels je ne me connecte pas en root j'ai le même message ( can't become a connected users ... )
Alors qu'en root :

smbd/service.c:make_connection_snum(1198)
  w2kvlg101 (::ffff:X.X.X.X) connect to service print$ initially as user root (uid=0, gid=0) (pid 3538)

Dernière modification par Nails (14-02-2011 10:24:55)

Hors ligne

#2 11-02-2011 23:42:35

Pollux
Membre
Distrib. : Squeeze
Noyau : 2.6.32
(G)UI : aucune
Inscription : 19-11-2009

Re : [Résolu] Samba Authentification

ta des utilisateurs crée au moins big_smile

Hors ligne

#3 14-02-2011 09:46:13

Nails
Membre
Distrib. : 5.0.6
Noyau : 2.6.26-2-686
(G)UI : Aucune
Inscription : 10-02-2011

Re : [Résolu] Samba Authentification

Ouep des deux cotés avec les même logins.

Bon du coup j'ai modifier une partie de mon smb.conf :

local master = No


Il était à Yes.  Maintenant j'ai une bonne identification :

smbd/service.c:make_connection_snum(1198)
  w2kvlganimaleri (::ffff:10.0.13.113) connect to service print$ initially as user magasin (uid=1004, gid=1004) (pid 25770)

Hors ligne

#4 14-02-2011 10:21:32

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Samba Authentification

Merci du retour Nails,

Un petit [Résolu] dans le titre, non ?
Voir là :
http://debian-facile.org/atelier:indications-forum

Hop ! smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#5 14-02-2011 10:23:58

Nails
Membre
Distrib. : 5.0.6
Noyau : 2.6.26-2-686
(G)UI : Aucune
Inscription : 10-02-2011

Re : [Résolu] Samba Authentification

wink

Hors ligne

Pied de page des forums