Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 07-04-2011 22:56:55

samzor
Membre
Distrib. : Lenny
Noyau : 2.6.26.2
(G)UI : bash =)
Inscription : 07-04-2011

Re : Problème de démarrage : INIT cannot execute "/etc/init.d/rcS"

wai enfaite j'avais une 2ème lenny, j'ai pris le bash et j'ai créé un iso je le monte dans le datastore vmware là on va voir.

Hors ligne

#27 07-04-2011 23:01:05

samzor
Membre
Distrib. : Lenny
Noyau : 2.6.26.2
(G)UI : bash =)
Inscription : 07-04-2011

Re : Problème de démarrage : INIT cannot execute "/etc/init.d/rcS"

bon ya du nouveau..........

Ya pleinnnnnnn de command not found

A voir il voit bash maintenant

Penses-tu que c'est le ln -s bash ?

Dernière modification par samzor (07-04-2011 23:02:47)

Hors ligne

#28 07-04-2011 23:05:20

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : Problème de démarrage : INIT cannot execute "/etc/init.d/rcS"

euh!

T'as fait quoi ?

...

En fait tu claques direct bash dans /bin/bash

Et /bin/sh doit être crée ainsi

cd /bin
ln -s /bin/bash sh


...

Hors ligne

#29 07-04-2011 23:06:59

samzor
Membre
Distrib. : Lenny
Noyau : 2.6.26.2
(G)UI : bash =)
Inscription : 07-04-2011

Re : Problème de démarrage : INIT cannot execute "/etc/init.d/rcS"

il m'a dit qu'il existait alors je l'ai delete : rm sh

et je l'ai recréé avec ta commande now je vois sh -> /bin/bash

Bon jai rebooter et toujours 10000 messages d'erreur du genre : /lib/init/vars.sh: line 16: egrep:command not found

/etc/rc2.d/s99fail2ban: line 30 : tail:command not found

On dirait qu'il reconnait plus aucune commande...

Dernière modification par samzor (07-04-2011 23:09:04)

Hors ligne

#30 07-04-2011 23:07:24

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : Problème de démarrage : INIT cannot execute "/etc/init.d/rcS"

Rediriges cette commande dans un fichier texte et donnes moi le resultat :

ls -l /target/bin | grep sh > ls_sh.txt


...

Hors ligne

#31 07-04-2011 23:14:32

samzor
Membre
Distrib. : Lenny
Noyau : 2.6.26.2
(G)UI : bash =)
Inscription : 07-04-2011

Re : Problème de démarrage : INIT cannot execute "/etc/init.d/rcS"

voilà la sortie : wwwjbtech.ch/deb.png

Hors ligne

#32 07-04-2011 23:16:36

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : Problème de démarrage : INIT cannot execute "/etc/init.d/rcS"

Yep!

En fait, je viens de me rendre compte que sh pointe directement vers bash.

Essayes avec :

cd /bin
rm sh
ln -s bash sh


...

Hors ligne

#33 07-04-2011 23:21:23

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : Problème de démarrage : INIT cannot execute "/etc/init.d/rcS"

Et aussi :

chmod 755 /bin/bash


...

Hors ligne

#34 07-04-2011 23:21:37

samzor
Membre
Distrib. : Lenny
Noyau : 2.6.26.2
(G)UI : bash =)
Inscription : 07-04-2011

Re : Problème de démarrage : INIT cannot execute "/etc/init.d/rcS"

wai mais ça revient au même point que j'étais avant de taper ta commande non ?

c'est fait j'ai rebooter et toujours les même erreurs ...

www.jbtech.ch/deb2.png

Dernière modification par samzor (07-04-2011 23:23:19)

Hors ligne

#35 07-04-2011 23:27:38

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : Problème de démarrage : INIT cannot execute "/etc/init.d/rcS"

Yep!

Ouép ! En relisant l'ensemble, apparement il te manque pas mal de chose, egrep, tail, bash et peut être plus.

Ce qui aurait été salvateur fût de pouvoir au moins démarrer le système et d'effectuer une installation des paquets manquants...mais je sens qu'à un moment donné, on va bloquer.

Si la remise en place de bash n'apporte rien, il te faudra faire une sauvegarde de tes données si besoin et hélas, tout réinstaller.
sad

@+

Zoroastre.

Hors ligne

#36 07-04-2011 23:29:47

samzor
Membre
Distrib. : Lenny
Noyau : 2.6.26.2
(G)UI : bash =)
Inscription : 07-04-2011

Re : Problème de démarrage : INIT cannot execute "/etc/init.d/rcS"

Waip c'est ce que je vais faire le truc c'est que je comprends pas trop ce qui s'est passé .... et ça m'énerve smile

J'ai pas envie que ça m'arrive de nouveau...

Dernière modification par samzor (07-04-2011 23:33:21)

Hors ligne

#37 07-04-2011 23:33:49

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : Problème de démarrage : INIT cannot execute "/etc/init.d/rcS"

Yep!

J'ai vu des cas similaires sur le net aprés une réinstallation malheuseuse.

C'est, je pense, exeptionnelle.

Voir ici :

http://www.google.fr/search?hl=fr&sourc … =&aql=&oq=

@+

Zoroastre.

Hors ligne

#38 07-04-2011 23:37:30

samzor
Membre
Distrib. : Lenny
Noyau : 2.6.26.2
(G)UI : bash =)
Inscription : 07-04-2011

Re : Problème de démarrage : INIT cannot execute "/etc/init.d/rcS"

mwai ça me suffit pas... en tout cas merci d'avoir tenté de m'aider et de répondre aussi rapidement smile super forum, je vais dormir et je verrais demain si je wipe cette satanée VM sad

Hors ligne

#39 08-04-2011 08:28:30

samzor
Membre
Distrib. : Lenny
Noyau : 2.6.26.2
(G)UI : bash =)
Inscription : 07-04-2011

Re : Problème de démarrage : INIT cannot execute "/etc/init.d/rcS"

Bon alors je confirme ce n'était pas après une mise à jour de Queeze car mon fichier sources.list a toujours les dépots pour lenny ...

Hors ligne

Pied de page des forums