Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-01-2008 15:07:52

Hubert
Membre
Inscription : 07-01-2008

Problème avec une carte son.

Bonjour,
Sur mon PC en Debian Etch j'ai  2 cartes son :
- une intégrée à la carte mère : VT8237-AC97
-  une PCI  MAudio Revolution 5.1
Ces 2 cartes fonctionnent normalement mais avec la MAudio les voix sont plus graves,
Je m'en aperçois lorsque j'écoute une radio que j'ai l'habitude d'écouter avec une autre moyen.
Quand j'écoute de la musique je ne m'en aperçois pas, par contre si j'écoute un chanteur c'est flagrant.
J'utilise XMMS ou VLC ou Mplayer et le problème est identique
Sur le site d' ALSA il y a des bugs répertoriés pour la MAudio Revolution5.1 mais ce problème n'existe pas.
Si quelqu'un a une idée, je le remercie de me la communiquer.
Hubert

Hors ligne

#2 12-01-2008 20:42:01

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : Problème avec une carte son.

Salut, t'as regardé en règlant via alsamixer en console ?

une fois réglé tu passes en root et tu saisis --> alsactl store
pour enregistrer tes paramètres

Hors ligne

#3 13-01-2008 12:18:01

Hubert
Membre
Inscription : 07-01-2008

Re : Problème avec une carte son.

Dans alsamixer je ne sais pas où se situe les règlages des graves et aigus

Hubert

Hors ligne

#4 13-01-2008 12:32:25

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : Problème avec une carte son.

Salut,

bass, trèble

198981747920080113113211.png

Hors ligne

#5 13-01-2008 21:17:05

Hubert
Membre
Inscription : 07-01-2008

Re : Problème avec une carte son.

Dans alsamixer je n'ai pas de réglages repérés  bass ou treble

Hors ligne

#6 14-01-2008 03:22:45

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : Problème avec une carte son.

Hubert a écrit :

Dans alsamixer je n'ai pas de réglages repérés  bass ou treble


Je vais supposer hardiment que tu n'as pas le driver idéal pour cette carte son. Veux-tu préciser sur laquelle des deux cartes sons que tu as sont branchées tes enceintes ?


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#7 14-01-2008 12:51:42

Hubert
Membre
Inscription : 07-01-2008

Re : Problème avec une carte son.

Bonjour,
Les enceintes sont branchées sur la carte que je choisis et installe avec ALSACONF
Après avec ALSAMIXER je peux vérifier la carte installée,
Dans une autre console je lance APLAY -vv musique.wav et je retourne dans ALSAMIXER pour jouer sur les réglages.

Hubert

Hors ligne

#8 14-01-2008 14:44:27

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : Problème avec une carte son.

ALSA est l'acronyme de Advanced Linux Sound Architecture. Regardes du côté de /usr/share/alsa 
pour jeter un coup d'oeil à la liste des cartes supportées.

Vois ton pilote sur le site du fabriquant de ta carte son, puis écris-lui pour lui demander s'il sait que d'autres OS existent, après Windows et Mac ?

C'est une honte de payer le prix pour une carte son externe et de ne pas pouvoir l'utiliser sur la plateforme qu'on veut. sad

Comment se comporte la carte PCI ? Comment se comporte la carte intégrée AC97 ? Fais-nous une comparaison de ce que tu trouves comme fonctionnalités dans alsamixer, s'il te plaît.

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#9 14-01-2008 20:24:37

pascal77
Membre
Lieu : MELUN 77
Distrib. : Lenny
Noyau : 2.6.30-bpo.1-amd64
(G)UI : Kde
Inscription : 10-09-2007
Site Web

Re : Problème avec une carte son.

Ce n'est pas sur Debian mais voilà ce que j'ai trouvé sur alsa
http://fr.gentoo-wiki.com/HOWTO_ALSA_so … ka_dmix_fr

Hors ligne

#10 16-01-2008 09:47:51

Hubert
Membre
Inscription : 07-01-2008

Re : Problème avec une carte son.

Bonjour,
Sur le site ALSA pour la carte Maudio Revolution5.1 (qui me pose problème) le module est snd-ice1724.
Hier j'ai fait un essai en bootant avec une KNOPPIX sur CD, mes 2 cartes sons ont fonctionnées correctement et la carte  Maudio révolution5.1 n'a pas accentué les sons graves ; la version ALSA était V1.0.13

J'ai booté à nouveau avec ma Debian Etch dont ALSA est à la même révision V1.0.13 et en jouant sur les réglages de Alsamixer  et en changeant la valeur de Multi Track Internal Clock les effets de sons graves ont diparus.
Ce paramètre Multi Track Internal Clock  était à 44100 je l'ai passé à 48000, mais  j'ai maintenant un effet inverse : les voix aigues sont déformées.
Si quelqu'un peut m'expliquer ?
Merci
Hubert

Hors ligne

#11 17-01-2008 01:39:04

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : Problème avec une carte son.

Hubert a écrit :

Ce paramètre Multi Track Internal Clock  était à 44100 je l'ai passé à 48000, mais  j'ai maintenant un effet inverse : les voix aigues sont déformées.
Si quelqu'un peut m'expliquer ?


Pourrais-tu copier ici ce que te donne la commande :

lspci | grep audio


s'il te plaît ?


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#12 17-01-2008 18:44:10

Hubert
Membre
Inscription : 07-01-2008

Re : Problème avec une carte son.

lspci| grep audio :

  00:0e.0 Multimedia audio controller: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller (rev 01)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)

Hors ligne

#13 17-01-2008 20:32:40

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : Problème avec une carte son.

Hubert a écrit :

lspci| grep audio :

  00:0e.0 Multimedia audio controller: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller (rev 01)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)


Voici une piste : par comparaison, la carte que j'ai est une Creative Labs. Le driver est emu10k1.

Voici mon lspci :

$ lspci | grep audio
05:07.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 06)


Quand je cherches emu10k1 sur les packages Debian,

http://www.debian.org/distrib/packages

(toutes sections, toutes architectures, pour simplifier la recherche), je trouve tout de suite :

Package ld10k1 (entres autres, y compris une dépendance nommée awesfx).

Tu as deux cartes, aussi je t'invite à faire des recherches sur les deux cartes, à partir des informations de ton lspci. J'espère que tu trouveras ce qu'il faut pour régler le son (quitte à aller chercher dans le système de la Knoppix pour voir quel est le driver qui la fait tourner, et laquelle des deux cartes est alors utilisée).


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#14 18-01-2008 09:53:33

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : Problème avec une carte son.

(quitte à aller chercher dans le système de la Knoppix pour
voir quel est le driver qui la fait tourner, et laquelle des deux cartes est alors utilisée).


Je sens comme une attitude défiance vis a vis de Knoppix, serait ce un pis allé ?  wink

Dernière modification par freddec (18-01-2008 09:53:50)


Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#15 18-01-2008 12:24:06

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : Problème avec une carte son.

freddec a écrit :

(quitte à aller chercher dans le système de la Knoppix pour
voir quel est le driver qui la fait tourner, et laquelle des deux cartes est alors utilisée).


Je sens comme une attitude défiance vis a vis de Knoppix, serait ce un pis allé ?  wink


Mais non pourquoi ? J'aime beaucoup Knoppix, j'ai d'ailleurs une Kaella installée en ram (boot sur image iso) et je l'utilise de temps en temps. Par ailleurs dans le passé j'ai eu beaucoup de joie avec Knoppix plusieurs jours de suite : elle m'a servi de passerelle vers le web, (la configuration avec ppp fonctionnait, depuis la sortie de la 3.8 : wao ! c'était déjà cool) car j'avais des problèmes avec l'autre machine, que je ne parvenais pas à cerner par moi-même.


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#16 18-01-2008 12:48:19

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : Problème avec une carte son.

CT de l'humour Mel wink

Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

Pied de page des forums