Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-05-2011 22:27:31

david42
Membre
Distrib. : Squeeze
Noyau : 2.6.32-5-amd64
Inscription : 18-05-2011

[Résolu] Serveur Web injoignable via internet

Bonjour,

lasse des serveurs mutualisés, j'ai décidé d'installer mon propre serveur. Décidé a faire mes premiers pas sous linux, j'ai installé une Debian squeeze amd64, y est rajouté apache, puis fait un premier test. En local j'arrive a afficher la page, mais impossible d'y acceder via le net ( ip public ). Sur la freebox le port 80 vers l'ip du serveur est ouvert. Après quelques recherches j'ai décommenté la ligne net.ipv4.ip_forward=1 dans /etc/sysctl.conf puis redemarré le serveur ... sans effet ... ca fait plusieurs jours que je décortique les tuto du net en vain.
Si ce problème vous parle, une solution me ravirait.

Cordialement.

Edit : Me suis trompé, merci de déplacer ce post dans la section appropriée ( réseau ou serveur )

Dernière modification par david42 (20-06-2011 20:13:03)

Hors ligne

#2 18-05-2011 23:52:37

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu] Serveur Web injoignable via internet

Bonjour,

j'ai installé une Debian squeeze amd64, y est rajouté apache, puis fait un premier test.


Je suppute que tu as oublié de passer par la case "config du serveur". ??

Il me semble qu'apache n'est joignable par défaut que depuis l'hôte local (mais je peux me tromper...).

Quoi qu'il en soit, quand tu parles d'accès en local, il s'agit d'un accès depuis la même machine ou d'une autre machine du LAN?
Pareil concernant l'accès depuis Internet; tu http//ton_ip_publique depuis une machine du LAN ou tu as vraiment un accès depuis une machine sur Internet?
L'accès se fait par une IP ou par un nom de domaine (ou sous-domaine dyndns ou autre)?

Sinon tu peux aussi
- lancer un tcpdump sur l'interface réseau du serveur pour vérifier que les requêtes arrivent jusqu'à lui.
- regarder dans les logs du serveur (access.log, error.log) ce qu'on y trouve (ou pas).
- nous faire part des résultats et du contenu de ta config d'apache.
- nous fournir le résultat de route -n (en root) sur le serveur.

@+

Hors ligne

#3 19-05-2011 00:57:17

david42
Membre
Distrib. : Squeeze
Noyau : 2.6.32-5-amd64
Inscription : 18-05-2011

Re : [Résolu] Serveur Web injoignable via internet

Bonjour Tux12,

effectivement je n'ai pas configurer le serveur apache, j'ai fait l'install deux fois en suivant ces tuto :
http://www.papygeek.com/series/installe … e-complet/
http://olange.developpez.com/articles/d … e=sommaire
http://www.alsacreations.com/tuto/lire/ … A-a-Z.html
hum, deux install avec trois tuto ...
A savoir, je compte refaire l'installation demain si je trouve pas de solution, si vous avez un tuto simple mais sérieux je prend.

La page index.html est joignable depuis le serveur "http://localhost" et depuis une autre machine du reseau interne "http://192.168.0.3/" mais impossible depuis "http://82.243.165.245/", idem en passant par une machine externe ( http://alyze.info/ ).

Pas testé avec un nom de domaine, car me suis dit que ca arrangerait rien
j'ai installé tcpdump #apt-get install tcpdump  puis # tcpdump eth0 .

Dans le fichier access.log :

::1 - - [17/May/2011:21:52:57 +0200] "OPTIONS * HTTP/1.0" 200 152 "-" "Apache/2.2.16 (Debian) (internal dummy connection)"
192.168.0.3 - - [17/May/2011:22:00:38 +0200] "GET /phpmyadmin HTTP/1.1" 404 446 "-" "Mozilla/5.0 (X11; U; Linux x86_64; fr-fr) AppleWebKit/531.2+ (KHTML, like Gecko) Version/5.0 Safari/531.2+ Debian/squeeze (2.30.6-1) Epiphany/2.30.6"
192.168.0.3 - - [17/May/2011:22:00:38 +0200] "GET /favicon.ico HTTP/1.1" 404 445 "http://192.168.0.3/phpmyadmin" "Mozilla/5.0 (X11; U; Linux x86_64; fr-fr) AppleWebKit/531.2+ (KHTML, like Gecko) Version/5.0 Safari/531.2+ Debian/squeeze (2.30.6-1) Epiphany/2.30.6"
127.0.0.1 - - [17/May/2011:22:20:19 +0200] "GET /phpmyadmin HTTP/1.1" 404 444 "-" "Mozilla/5.0 (X11; U; Linux x86_64; fr-fr) AppleWebKit/531.2+ (KHTML, like Gecko) Version/5.0 Safari/531.2+ Debian/squeeze (2.30.6-1) Epiphany/2.30.6"
127.0.0.1 - - [17/May/2011:22:20:19 +0200] "GET /favicon.ico HTTP/1.1" 404 444 "http://localhost/phpmyadmin" "Mozilla/5.0 (X11; U; Linux x86_64; fr-fr) AppleWebKit/531.2+ (KHTML, like Gecko) Version/5.0 Safari/531.2+ Debian/squeeze (2.30.6-1) Epiphany/2.30.6"
127.0.0.1 - - [17/May/2011:22:20:19 +0200] "GET /favicon.ico HTTP/1.1" 404 444 "-" "-"
127.0.0.1 - - [17/May/2011:22:20:28 +0200] "GET / HTTP/1.1" 200 423 "-" "Mozilla/5.0 (X11; U; Linux x86_64; fr-fr) AppleWebKit/531.2+ (KHTML, like Gecko) Version/5.0 Safari/531.2+ Debian/squeeze (2.30.6-1) Epiphany/2.30.6"
192.168.0.1 - - [18/May/2011:19:19:56 +0200] "GET / HTTP/1.1" 200 480 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1"
192.168.0.1 - - [18/May/2011:19:19:56 +0200] "GET /favicon.ico HTTP/1.1" 404 501 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1"
192.168.0.1 - - [18/May/2011:19:19:56 +0200] "GET /favicon.ico HTTP/1.1" 404 501 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1"
192.168.0.1 - - [18/May/2011:19:19:56 +0200] "GET /favicon.ico HTTP/1.1" 404 501 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1"


Dans le fichier error.log

[Tue May 17 21:52:58 2011] [notice] Apache/2.2.16 (Debian) PHP/5.3.3-7+squeeze1 with Suhosin-Patch configured -- resuming normal operations
[Tue May 17 21:53:01 2011] [notice] caught SIGTERM, shutting down
[Tue May 17 21:53:02 2011] [notice] Apache/2.2.16 (Debian) PHP/5.3.3-7+squeeze1 with Suhosin-Patch configured -- resuming normal operations
[Tue May 17 22:00:38 2011] [error] [client 192.168.0.3] File does not exist: /var/www/phpmyadmin
[Tue May 17 22:00:38 2011] [error] [client 192.168.0.3] File does not exist: /var/www/favicon.ico, referer: http://192.168.0.3/phpmyadmin
[Tue May 17 22:20:19 2011] [error] [client 127.0.0.1] File does not exist: /var/www/phpmyadmin
[Tue May 17 22:20:19 2011] [error] [client 127.0.0.1] File does not exist: /var/www/favicon.ico, referer: http://localhost/phpmyadmin
[Tue May 17 22:20:19 2011] [error] [client 127.0.0.1] File does not exist: /var/www/favicon.ico
[Wed May 18 19:04:24 2011] [notice] caught SIGTERM, shutting down
[Wed May 18 19:04:25 2011] [notice] Apache/2.2.16 (Debian) PHP/5.3.3-7+squeeze1 with Suhosin-Patch configured -- resuming normal operations
[Wed May 18 19:19:56 2011] [error] [client 192.168.0.1] File does not exist: /var/www/favicon.ico
[Wed May 18 19:19:56 2011] [error] [client 192.168.0.1] File does not exist: /var/www/favicon.ico
[Wed May 18 19:19:56 2011] [error] [client 192.168.0.1] File does not exist: /var/www/favicon.ico
[Wed May 18 19:50:54 2011] [notice] caught SIGTERM, shutting down
[Wed May 18 19:54:03 2011] [notice] Apache/2.2.16 (Debian) PHP/5.3.3-7+squeeze1 with Suhosin-Patch configured -- resuming normal operations
[Wed May 18 20:05:46 2011] [notice] caught SIGTERM, shutting down
[Wed May 18 20:07:25 2011] [notice] Apache/2.2.16 (Debian) PHP/5.3.3-7+squeeze1 with Suhosin-Patch configured -- resuming normal operations
[Wed May 18 21:28:35 2011] [notice] caught SIGTERM, shutting down
[Wed May 18 21:28:36 2011] [notice] Apache/2.2.16 (Debian) PHP/5.3.3-7+squeeze1 with Suhosin-Patch configured -- resuming normal operations
[Wed May 18 22:57:22 2011] [notice] caught SIGTERM, shutting down
[Wed May 18 22:57:23 2011] [notice] Apache/2.2.16 (Debian) PHP/5.3.3-7+squeeze1 with Suhosin-Patch configured -- resuming normal operations
[Wed May 18 23:02:29 2011] [notice] caught SIGTERM, shutting down
[Wed May 18 23:02:30 2011] [notice] Apache/2.2.16 (Debian) PHP/5.3.3-7+squeeze1 with Suhosin-Patch configured -- resuming normal operations


# route -n
root@Badaboom:/var/log/apache2# route -n

Table de routage IP du noyau
Destination     Passerelle      Genmask         Indic Metric Ref    Use Iface
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0         192.168.0.254   0.0.0.0         UG    0      0        0 eth0


pour la config apache c'est pas comme sous win, voici le fichier qui semble correspondre
/etc/apache2/apache2.conf .

### Section 1: Global Environment
#
# The directives in this section affect the overall operation of Apache,
# such as the number of concurrent requests it can handle or where it
# can find its configuration files.
#

#
# ServerRoot: The top of the directory tree under which the server's
# configuration, error, and log files are kept.
#
# NOTE!  If you intend to place this on an NFS (or otherwise network)
# mounted filesystem then please read the LockFile documentation (available
# at <URL:http://httpd.apache.org/docs/2.2/mod/mpm_common.html#lockfile>);
# you will save yourself a lot of trouble.
#
# Do NOT add a slash at the end of the directory path.
#
#ServerRoot "/etc/apache2"

#
# The accept serialization lock file MUST BE STORED ON A LOCAL DISK.
#
LockFile ${APACHE_LOCK_DIR}/accept.lock

#
# PidFile: The file in which the server should record its process
# identification number when it starts.
# This needs to be set in /etc/apache2/envvars
#
PidFile ${APACHE_PID_FILE}

#
# Timeout: The number of seconds before receives and sends time out.
#
Timeout 300

#
# KeepAlive: Whether or not to allow persistent connections (more than
# one request per connection). Set to "Off" to deactivate.
#
KeepAlive On

#
# MaxKeepAliveRequests: The maximum number of requests to allow
# during a persistent connection. Set to 0 to allow an unlimited amount.
# We recommend you leave this number high, for maximum performance.
#
MaxKeepAliveRequests 100

#
# KeepAliveTimeout: Number of seconds to wait for the next request from the
# same client on the same connection.
#
KeepAliveTimeout 15

##
## Server-Pool Size Regulation (MPM specific)
##

# prefork MPM
# StartServers: number of server processes to start
# MinSpareServers: minimum number of server processes which are kept spare
# MaxSpareServers: maximum number of server processes which are kept spare
# MaxClients: maximum number of server processes allowed to start
# MaxRequestsPerChild: maximum number of requests a server process serves
<IfModule mpm_prefork_module>
    StartServers          5
    MinSpareServers       5
    MaxSpareServers      10
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>

# worker MPM
# StartServers: initial number of server processes to start
# MaxClients: maximum number of simultaneous client connections
# MinSpareThreads: minimum number of worker threads which are kept spare
# MaxSpareThreads: maximum number of worker threads which are kept spare
# ThreadLimit: ThreadsPerChild can be changed to this maximum value during a
#              graceful restart. ThreadLimit can only be changed by stopping
#              and starting Apache.
# ThreadsPerChild: constant number of worker threads in each server process
# MaxRequestsPerChild: maximum number of requests a server process serves
<IfModule mpm_worker_module>
    StartServers          2
    MinSpareThreads      25
    MaxSpareThreads      75
    ThreadLimit          64
    ThreadsPerChild      25
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>

# event MPM
# StartServers: initial number of server processes to start
# MaxClients: maximum number of simultaneous client connections
# MinSpareThreads: minimum number of worker threads which are kept spare
# MaxSpareThreads: maximum number of worker threads which are kept spare
# ThreadsPerChild: constant number of worker threads in each server process
# MaxRequestsPerChild: maximum number of requests a server process serves
<IfModule mpm_event_module>
    StartServers          2
    MaxClients          150
    MinSpareThreads      25
    MaxSpareThreads      75
    ThreadLimit          64
    ThreadsPerChild      25
    MaxRequestsPerChild   0
</IfModule>

# These need to be set in /etc/apache2/envvars
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}

#
# AccessFileName: The name of the file to look for in each directory
# for additional configuration directives.  See also the AllowOverride
# directive.
#

AccessFileName .htaccess

#
# The following lines prevent .htaccess and .htpasswd files from being
# viewed by Web clients.
#
<Files ~ "^\.ht">
    Order allow,deny
    Deny from all
    Satisfy all
</Files>

#
# DefaultType is the default MIME type the server will use for a document
# if it cannot otherwise determine one, such as from filename extensions.
# If your server contains mostly text or HTML documents, "text/plain" is
# a good value.  If most of your content is binary, such as applications
# or images, you may want to use "application/octet-stream" instead to
# keep browsers from trying to display binary files as though they are
# text.
#
DefaultType text/plain


#
# HostnameLookups: Log the names of clients or just their IP addresses
# e.g., www.apache.org (on) or 204.62.129.132 (off).
# The default is off because it'd be overall better for the net if people
# had to knowingly turn this feature on, since enabling it means that
# each client request will result in AT LEAST one lookup request to the
# nameserver.
#
HostnameLookups Off

# ErrorLog: The location of the error log file.
Deny from all
    Satisfy all
</Files>

#
# DefaultType is the default MIME type the server will use for a document
# if it cannot otherwise determine one, such as from filename extensions.
# If your server contains mostly text or HTML documents, "text/plain" is
# a good value.  If most of your content is binary, such as applications
# or images, you may want to use "application/octet-stream" instead to
# keep browsers from trying to display binary files as though they are
# text.
#
DefaultType text/plain


#
# HostnameLookups: Log the names of clients or just their IP addresses
# e.g., www.apache.org (on) or 204.62.129.132 (off).
# The default is off because it'd be overall better for the net if people
# had to knowingly turn this feature on, since enabling it means that
# each client request will result in AT LEAST one lookup request to the
# nameserver.
#
HostnameLookups Off

# ErrorLog: The location of the error log file.
# If you do not specify an ErrorLog directive within a <VirtualHost>
# container, error messages relating to that virtual host will be
# logged here.  If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
#
ErrorLog ${APACHE_LOG_DIR}/error.log

#
# LogLevel: Control the number of messages logged to the error_log.
# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
#
LogLevel warn

# Include module configuration:
Include mods-enabled/*.load
Include mods-enabled/*.conf

# Include all the user configurations:
Include httpd.conf

# Include ports listing
Include ports.conf

#
# The following directives define some format nicknames for use with
# a CustomLog directive (see below).
# If you are behind a reverse proxy, you might want to change %h into %{X-Forwarded-For}i
#
LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

# Include of directories ignores editors' and dpkg's backup files,
# see README.Debian for details.

# Include generic snippets of statements
Include conf.d/

# Include the virtual host configurations:
Include sites-enabled/


serveur en 192.168.0.3
pc sous win avec accès ssh 192.168.0.1
gateway freebox 192.168.0.254

Ce "phaseweb.fr" qui apparait dans les log est un nom donné lors de l'install, c'est peut etre ca le pb.
Déjà, merci tux12, pour ces fichiers et commande qui m'étaient inconnus wink

Hors ligne

#4 19-05-2011 03:35:52

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu] Serveur Web injoignable via internet

Re,

Au vu des logs, il n'y a rien qui provienne de la box ou d'une IP publique, seulement les requêtes de tes clients locaux. Le reste de la config réseau semble correcte (la passerelle est déclarée sur le serveur, on est sur le même réseau) et le serveur devrait pouvoir répondre.

Je pense donc que le NAT du port 80 de la box (redirection vers le port 80 de ton serveur) sur la box ne se fait pas. À confirmer éventuellement avec tcpdump ou wireshark (ce dernier nécessitant un environnement graphique, ce qui n'est pas forcément le cas sur un serveur web).
Autre possibilité, qu'il y ait erreur sur l'IP publique, auquel cas même la box ne voit pas arriver la requête.
Voir aussi d'éventuelles options de filtrage de la box (pare-feu) ou du serveur si tu as configuré un pare-feu sur celui-ci.

@+

Dernière modification par tux12 (19-05-2011 04:03:57)

Hors ligne

#5 19-05-2011 19:01:23

david42
Membre
Distrib. : Squeeze
Noyau : 2.6.32-5-amd64
Inscription : 18-05-2011

Re : [Résolu] Serveur Web injoignable via internet

Merci pour cette inspection !
Coté routeur/box ca semble ok, les connexions en ssh se font depuis mon taf donc l'IP public est correcte. Il reste le pare-feu, il n'y en a pas dans la box c'est peut etre IPtables, mais la doc m'inspire guère pour le moment ...
Ce soir, reinstall simple et sans modif exotique ...

A + wink

Hors ligne

#6 20-05-2011 01:37:41

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu] Serveur Web injoignable via internet

Bonsoir,

Par défaut (à moins que ça ait changé avec Squeeze) NetFilter (iptables étant la commande de configuration) laisse tout passer sous Debian. Donc à moins que tu ais établi des règles (ou installé un programme graphique de gestion des règles - mais tu devrais le savoir) il n'y a pas de blocage de ce côté là.

Pour se convaincre que la requête arrive bien, il suffit de lancer tcpdump -i eth0 tcp port 80 en root sur le serveur puis de tenter de le joindre. Tu dois voir s'afficher une ligne de requête et (quand ça marche) une ligne de réponse du serveur.

Sinon il faut se pencher sur la config d'Apache. wink

Hors ligne

#7 21-05-2011 23:05:14

david42
Membre
Distrib. : Squeeze
Noyau : 2.6.32-5-amd64
Inscription : 18-05-2011

Re : [Résolu] Serveur Web injoignable via internet

Bonjour,
je reviens honteux, après trois nouvelles install ... le pb venait du routage de la box ... j'avais pas vérifié dans les redirections de plage de ports, et avais oublié ce chaotique essai d'IPCop ... j'ai pas  trouvé de corde, sortez batons et légumes pourris pour la sentence ...
Merci Tux12 pour le temps passé, les fichiers log et tcpdump resteront souvent utiles.

Cordialement, le boulet, qui reste discrètement dans un coin de cette communauté appréciable.

A plus wink

Hors ligne

#8 21-05-2011 23:20:45

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu] Serveur Web injoignable via internet

lol Bonsoir david42 lol

L'avantage en sniffant le réseau au niveau de la machine considérée, c'est qu'on sait rapidement ce qui arrive ou pas, et on peut ainsi distinguer ce qui est "réseau" de ce qui relève de la configuration locale. wink

Pour les légumes faudra attendre, je finis juste de planter là. En attendant sois le bienvenue sur DF. smile

@+

Merci de passer le fil en résolu.

Hors ligne

Pied de page des forums