Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-06-2011 11:15:14

remim
Membre
Inscription : 18-06-2011

Disque dur USB auto-alimenté qui " décroche " du montage : Kernel fail

Bonjour,

Sous Gnome 2.30.2, Aussitôt après le branchement d'un ou des deux disques ou bien lorsque j'y accède après un temps plutôt court, Kernel Oops me signale une défaillance :

WARNING: at /tmp/buildd/linux-2.6-2.6.32/debian/build/source_i386_none/fs/buffer.c:1160 mark_buffer_dirty+0x20/0x7a()
Hardware name: A7N8X-E
Modules linked in: cpufreq_stats cpufreq_userspace cpufreq_conservative cpufreq_powersave ppdev lp sco bridge stp rfcomm bnep l2cap crc16 bluetooth rfkill binfmt_misc fuse asb100 hwmon_vid loop tuner_simple tuner_types tea5767 tuner msp3400 bttv snd_wavefront v4l2_common snd_cs4236 videodev v4l1_compat snd_wss_lib radeon snd_opl3_lib ir_common videobuf_dma_sg snd_hwdep ttm snd_mpu401 videobuf_core snd_mpu401_uart drm_kms_helper snd_intel8x0 snd_ens1371 snd_seq_midi drm btcx_risc snd_seq_midi_event snd_ac97_codec snd_rawmidi snd_bt87x ac97_bus i2c_algo_bit tveeprom snd_seq snd_pcm snd_seq_device snd_timer shpchp parport_pc ns558 pci_hotplug i2c_nforce2 parport pcspkr gameport snd snd_page_alloc button processor i2c_core evdev soundcore ext3 jbd mbcache usbhid hid sg sr_mod sd_mod crc_t10dif cdrom ata_generic usb_storage ohci_hcd uhci_hcd sata_sil pata_amd thermal sym53c8xx libata scsi_transport_spi ehci_hcd scsi_mod floppy forcedeth thermal_sys usbcore nls_base [last unloaded: scsi_wait_scan]
Pid: 3680, comm: kjournald Not tainted 2.6.32-5-686 #1
Call Trace:
[<c1030645>] ? warn_slowpath_common+0x5e/0x8a
[<c103067b>] ? warn_slowpath_null+0xa/0xc
[<c10cde48>] ? mark_buffer_dirty+0x20/0x7a
[<f804e365>] ? journal_update_superblock+0x5b/0x99 [jbd]
[<f804e4b8>] ? __journal_abort_soft+0x89/0xa1 [jbd]
[<f804c390>] ? journal_commit_transaction+0x962/0xd56 [jbd]
[<c103b020>] ? lock_timer_base+0x19/0x35
[<c103b22e>] ? try_to_del_timer_sync+0x4f/0x56
[<f804eb7f>] ? kjournald+0xb9/0x1e0 [jbd]
[<c1043f5a>] ? autoremove_wake_function+0x0/0x2d
[<f804eac6>] ? kjournald+0x0/0x1e0 [jbd]
[<c1043d28>] ? kthread+0x61/0x66
[<c1043cc7>] ? kthread+0x0/0x66
[<c1003d47>] ? kernel_thread_helper+0x7/0x10
---[ end trace 8d912e6919de919c ]---

Le uname -a :

rem@jardin:~$ uname -a
Linux jardin 2.6.32-5-686 #1 SMP Wed May 18 07:08:50 UTC 2011 i686 GNU/Linux

J'ai deux disques usb auto-alimentés (par le PC) externes identiques :

Disk /dev/sdg: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x3cac3cac

   Device Boot      Start         End      Blocks   Id  System
/dev/sdg1               1       60802   488385536   83  Linux

Disk /dev/sdf: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x3cac3cac

   Device Boot      Start         End      Blocks   Id  System
/dev/sdf1               1       60802   488385536   83  Linux

lsusb :

rem@jardin:~$ lsusb
Bus 006 Device 002: ID 046d:c501 Logitech, Inc. Cordless Mouse Receiver
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 058f:6362 Alcor Micro Corp. Flash Card Reader/Writer
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 007: ID 0bc2:2300 Seagate RSS LLC
Bus 001 Device 006: ID 0bc2:2300 Seagate RSS LLC

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Montés par Gnome (sans indication notées dans le /etc/fstab) :

rem@jardin:~$ mount
/dev/sda2 on / type ext3 (rw,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
udev on /dev type tmpfs (rw,mode=0755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=620)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
/dev/sdg1 on /media/SEA-ONE type ext3 (rw,nosuid,nodev,uhelper=udisks)
/dev/sdf1 on /media/SEA-TWO type ext3 (rw,nosuid,nodev,uhelper=udisks)


Je suis bien embêté de ne savoir me dépatouiller avec cet " ennui " ; à savoir est-ce un problème de courant ? Est-ce une configuration de ma Debian qui est mal faite ? Est-ce le fantôme de Windaube qui me hante ;-)

Si vous me lisez et pensez pouvoir m'aider, je vous remercie de m'adresser un mot.

Il s'agit de ma sauvegarde et de sa sécurité qui, pour l'instant, il m'est impossible de réaliser.

Merci.

Hors ligne

Pied de page des forums