Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-08-2011 13:19:31

rAnDoM
Membre
Lieu : Nantes
Distrib. : Sid
Noyau : 2.6.32-5-amd64
(G)UI : Gnome 2.30.2
Inscription : 12-08-2011

[RESOLU] Installation ATI HD5770

Salut à tous,

Je viens d'installer Squeeze, et je suis en train d'installer ma carte graphique.
J'ai suivi ce tuto et modifiant un peu à l'aide de ce post.

Toutes les étapes se passent à peu près bien, jusqu'à ce que je fasse le fglrxinfo pour tester, et là j'obtiens ceci en résultat :

random@random-tour:~$ fglrxinfo
Error: couldn't find RGB GLX visual!


Je débute sous Debian, et je ne trouve pas d'où ça peut venir.... vous avez des idées ?

je continue de chercher, mais pour le moment rien n'a pu m'aider.

Merci à tous ! smile

Dernière modification par rAnDoM (19-08-2011 22:19:51)

Hors ligne

#2 12-08-2011 16:28:28

pili36
Membre
Lieu : Lille
Distrib. : Debian Jessie / Raspbian Jessie
Noyau : 3.16_amd64 / 3.16_armhf
(G)UI : Xfce / Lxde
Inscription : 03-11-2009

Re : [RESOLU] Installation ATI HD5770

Salut rAnDoM,

Je ne sais pas quelles manips tu as fait exactement, mais si avec le paquet  fglrx fourni par debian ta carte graphique n'est pas prise en charge, tu peux télécharger directement les drivers ATI radeon sur le site AMD ici.

Tu as alors un fichier du type ati-driver-installer-xx-x-xxxx.run. Tu le lances dans un terminal en root et les drivers ATI correspondant à ta carte graphique seront installés.

Cordialement.

Debian Jessie Amd64, Xfce, Lenovo G50, Amd Q4000 4*1,3Ghz, 4Go RAM, Amd Radeon R3
Debian Jessie Amd64, (pour Steam), Xfce, Amd Athlon 860K 4*3.7Ghz, 8Go RAM, AMD Radeon R7 250 2Go
Raspbian Jessie Armhf, Lxde, Raspberry Pi model B

Hors ligne

#3 12-08-2011 16:39:47

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU] Installation ATI HD5770

Bonjour rAnDoM et bienvenue sur df !

Aie !
Le run est déconseillé à l 'utilisation, voir pour nvidia là :
http://debian-facile.org/?s[]=run#installation_du_pilote_proprietaire_avec_le_run

Mais si tu ne peux l'éviter ?

Amitié, Joel smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 12-08-2011 16:48:43

rAnDoM
Membre
Lieu : Nantes
Distrib. : Sid
Noyau : 2.6.32-5-amd64
(G)UI : Gnome 2.30.2
Inscription : 12-08-2011

Re : [RESOLU] Installation ATI HD5770

Bonjour ! Merci pour vos réponses !

On va dire "qu'en attendant" je vais installer le .run, mais si quelqu'un a des idées sur le pourquoi du comment, je veux bien être mis au jus ! smile

Hors ligne

#5 13-08-2011 09:54:19

Invité-5
Banni(e)

Re : [RESOLU] Installation ATI HD5770

http://wiki.debian.org/fr/ATIProprietary

pili36 a écrit :

tu peux télécharger directement les drivers ATI radeon sur le site AMD ici.


Mauvaise idée !

rAnDoM a écrit :

On va dire "qu'en attendant" je vais installer le .run, mais si quelqu'un a des idées sur le pourquoi du comment, je veux bien être mis au jus ! smile


Parce-que les pilotes de CG doivent être absolument installés en console tty sans l'interface graphique ! http://debian-facile.org/doc:systeme:console

Si vraiment tu as décidé d'installer le .run http://smxi.org/

EDIT : J'ai eu la même CG il n'y a pas longtemps et elle a très bien fonctionné avec le pilote du dépôt Debian ?

Dernière modification par Invité-5 (13-08-2011 10:15:51)

#6 17-08-2011 16:43:10

rAnDoM
Membre
Lieu : Nantes
Distrib. : Sid
Noyau : 2.6.32-5-amd64
(G)UI : Gnome 2.30.2
Inscription : 12-08-2011

Re : [RESOLU] Installation ATI HD5770

Bonjour Darien !

Merci pour ta réponse, j'étais indisponible quelques jours smile

Je n'ai donc pas installé le .run, après ton conseil et les avis que j'ai lu dessus...

J'ai été dans la tty1, et j'ai désinstallé tous les drivers, ensuite j'ai tout réinstallé, j'ai généré le xorg.conf... et rien n'y fait ! J'ai toujours ce message d'erreur :


random@randoom-tour:~$ fglrxinfo
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  139 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  13
  Current serial number in output stream:  13


Dites moi que vous avez encore des idées big_smile

Merci de votre aide !

Dernière modification par rAnDoM (17-08-2011 16:43:22)

Hors ligne

#7 19-08-2011 10:36:40

rAnDoM
Membre
Lieu : Nantes
Distrib. : Sid
Noyau : 2.6.32-5-amd64
(G)UI : Gnome 2.30.2
Inscription : 12-08-2011

Re : [RESOLU] Installation ATI HD5770

Personne n'a d'idée ?

C'est assez ignoble au final le résultat que j'ai pour le moment.. j'ai installé via les dépôts et lorsque je déplace une fenêtre, ça saccade, et lorsque je scrolle dans Eclipse par exemple, ça saccade également... quelle(s) commande(s) dois-je faire pour retourner avec les drivers installés de base ?

Merci beaucoup à vous d'aider un noob dans ses démarches smile

Hors ligne

#8 19-08-2011 11:33:06

bract
Modérateur
Lieu : Pays du kiwi
Distrib. : wheezy
Noyau : 3.2.0-3 amd64
(G)UI : gnome 3.4.2 + lxde(eeepc)
Inscription : 05-02-2011

Re : [RESOLU] Installation ATI HD5770

bonjour,
je n'utilise pas de carte ATI, mais si cela peut t'aider wink

http://www.commentcamarche.net/forum/af … -fglrx-ati

bract

L'asso est lancée. cool
La connaissance s'acquiert par l'expérience, tout le reste n'est que de l'information.[Albert Einstein]

Hors ligne

#9 19-08-2011 12:09:39

rAnDoM
Membre
Lieu : Nantes
Distrib. : Sid
Noyau : 2.6.32-5-amd64
(G)UI : Gnome 2.30.2
Inscription : 12-08-2011

Re : [RESOLU] Installation ATI HD5770

J'ai enfin réussi... avec smxi.... (version 11.6) (même si l'installation faisait des trucs bizarres... genre le xorg.conf était corrompu et il fallait le modifier à la main...)
Merci beaucoup Darien (et les autres ;-) )

J'essaierai plus tard avec les pilotes libres...

Dernière modification par rAnDoM (19-08-2011 12:37:49)

Hors ligne

#10 19-08-2011 20:09:55

Invité-5
Banni(e)

Re : [RESOLU] Installation ATI HD5770

Peux-tu mettre résolu et remplir infodistri pour nous "faciliter" la vie ?
http://debian-facile.org/manuel:inscription_au_forum

#11 19-08-2011 22:19:25

rAnDoM
Membre
Lieu : Nantes
Distrib. : Sid
Noyau : 2.6.32-5-amd64
(G)UI : Gnome 2.30.2
Inscription : 12-08-2011

Re : [RESOLU] Installation ATI HD5770

Yes sir !

Hors ligne

Pied de page des forums