Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-09-2011 16:05:01

Arvedui
Membre
Distrib. : Stable
Noyau : Linux 2.6.32-5-amd64
(G)UI : GNOME 2.30
Inscription : 03-09-2011

Accélération graphique nvidia non possible

Bonjour à toutes et à tous,

Voici mon problème, j'ai installé Squeeze, jusque là, aucun soucis, et j'ai voulu mettre en place l'accélération graphique de ma carte Nvidia GT425m. J'ai suivi scrupuleusement diverses insructions qui ont toute amenés à des problèmes de plus ou moins randes envergures (certains paquets ne s'installaient pas etc etc) mais surtout, il m'amène toujours vers le fatal écran noir avec une simple et unique barre horizontale clignotante !! Avec quelque fois un message, de ce que je peux me rappeler, il disait : drivers found but devices...et quelque chose. Je ne comprends pas, j'ai pourtant fait tout ce qu'il fallait faire (a priori ^^), mais dès que je fais : nvidia-xconfig et dès que je reboot, nada, kapoute, plus rien ! Je suppose donc que c'est le xorg.conf qui est mal configuré, mais je ne vois pas comment le bien configurer, d'autant plus que j'y ai ajouté ce qu'il me semblait être les bonnes conf. ! Voilà, j'espère que quelqu'un aura soluion à mon problème, mercui d'avance et bonne fin de journée !

Linuxi Gratia !

Hors ligne

#2 03-09-2011 17:18:22

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : Accélération graphique nvidia non possible

tu as employé quelle(s) méthode(s) ?

amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#3 03-09-2011 17:34:03

Arvedui
Membre
Distrib. : Stable
Noyau : Linux 2.6.32-5-amd64
(G)UI : GNOME 2.30
Inscription : 03-09-2011

Re : Accélération graphique nvidia non possible

Oh pardon, j'ai d'abord utilisé une méthode "à la sauce Debian" qui consistait à installer les pilotes suivants :

# aptitude install nvidia-kernel-common nvidia-kernel-source nvidia-xconfig nvidia-settings nvidia-glx nvidia-glx-ia64


Puis ensuite :

# aptitude install module-assistant build-essential linux-headers-2.6-$(uname -r)


Puis après installer avec module-assistant le pilote de mon Nvidia. Le seul problème, c'est que cette opération m'a amené à taper également nvidia-xconfig, ce qui a généré un nouveau xorg.con, lequel m'a mené vers un écran noir avec une barre horizointale, bref, je n'ai pu accéder à l'interface graphique.

Je me suis donc rabattu vers la méthode émise sur ce site, id est : Manuel Nvidia Debian-Facile. Cependant, cela m'a amené vers la même fenêtre, en revanche, les pilotes ont pu être installé sans trop de soucis. La dernière source que j'ai utilisé et avec laquelle ça a absolument bien marché, si ce n'est que je me retrouve encore devant ce sempiternelle écran noir est celle provenant de ce site : Lux-Populi. Voilà, mais j'ai beau mettre ma configuration, rien n'y fait, j'ai même l'impression qu'à certains égards, c'est pire puisque la barre horizontale de texte ornant l'écran noir clignote encore plus vite selon les configs ! Voilà ce que j'ai fait, et j'en suis à cette dernière méthode je n'ai rien changé si ce n'est que j'ai supprimé le xorg.conf qui m'incombait.


Linuxi Gratia !

Hors ligne

#4 03-09-2011 18:33:34

Invité-5
Banni(e)

Re : Accélération graphique nvidia non possible

En somme tu as foutu la pagaille générale. Vois => http://debian-facile.org/forum/viewtopi … 948#p34948

Sinon, recommence tout http://debian-facile.org/

#5 03-09-2011 18:37:08

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : Accélération graphique nvidia non possible

tout semble avoir été fait correctement , là je sèche sad
a moins que ce soit l'ecran qui n'est pas reconnu, as-tu gardé une copie du xorg.conf d'avant les soucis ?

edit ah oui bien vu Darien !

Xorg -configure a la place de nvidia-xconfig ça peut aider smile

Dernière modification par misaine (03-09-2011 18:51:55)


amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#6 03-09-2011 19:01:06

Arvedui
Membre
Distrib. : Stable
Noyau : Linux 2.6.32-5-amd64
(G)UI : GNOME 2.30
Inscription : 03-09-2011

Re : Accélération graphique nvidia non possible

Bonjour, désolé, une coupure de net... Sinon, je n'ai pas le xorg.conf correspondant, j'ai essayé de purger au maximu ma Deb avec les fragments de Nvidia qui trainaient. J'ai déjà essayé cette méthode (le Xorg config), mais ça n'a mené à rien là encore. :S En revanche je suis allé chez un forum "ami", debian-fr, je vais suivre les insructions d'un de leur membre, si la solution y est, je la posterai. Merci beaucoup en tout cas, pour tes réponses, je tiendrai au courant. wink j'espère ne pas t'avoir faire perdre du temps :S

Dernière modification par Arvedui (03-09-2011 19:06:23)


Linuxi Gratia !

Hors ligne

#7 03-09-2011 19:15:57

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : Accélération graphique nvidia non possible

ok vois avec clochette , mais c'est les mêmes méthodes , même smxi est proposé à la fin du tuto DF

amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#8 03-09-2011 19:37:03

Arvedui
Membre
Distrib. : Stable
Noyau : Linux 2.6.32-5-amd64
(G)UI : GNOME 2.30
Inscription : 03-09-2011

Re : Accélération graphique nvidia non possible

Effectivement, de toute façon, même après l'avoir refait, ça ne fonctionne toujours pas, pfou, dur dur la vie informatique, qui a dit que rester les fesses posées sur sa chaise n'était pas fatiguant ? tongue

Linuxi Gratia !

Hors ligne

#9 03-09-2011 21:24:45

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : Accélération graphique nvidia non possible

ah mais tu n'as pas tout dit! (j'ai z'yeuté a côté) .si c'est ce fameux portable avec 2 CG (intel + nvidia)
bonjour la galère !

Dernière modification par misaine (03-09-2011 21:26:13)


amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#10 04-09-2011 08:37:20

Arvedui
Membre
Distrib. : Stable
Noyau : Linux 2.6.32-5-amd64
(G)UI : GNOME 2.30
Inscription : 03-09-2011

Re : Accélération graphique nvidia non possible

Ah bon ?! 'Gloups !' Et dire que je pensais que ça n'allait pas durer longtemps... Tu as déjà connu des soucis de ce type ?

Linuxi Gratia !

Hors ligne

#11 04-09-2011 09:52:36

Invité-5
Banni(e)

Re : Accélération graphique nvidia non possible

Normalement, quand tu as la barre clignotante c'est plutôt le fichier /etc/X11/xorg.conf qui est en cause et non le pilote de ta CG. Essaye d'éradiquer tout ce que tu avais installé pour nVidia et recommences. Avant, pour plus de sécurité tu pourras upgrader ton kernel vers la version 2.6.38 qui se trouve dans le dépôt squeeze-backports. D'ailleurs poste ton fichier /etc/apt/sources.list dans la balise code =>   http://debian-facile.org/forum/help.php#img

#12 04-09-2011 10:28:52

Arvedui
Membre
Distrib. : Stable
Noyau : Linux 2.6.32-5-amd64
(G)UI : GNOME 2.30
Inscription : 03-09-2011

Re : Accélération graphique nvidia non possible

Bonjour, merci, j'ai déjà mis les backports, dés mon install, voilà mon sources.list :

deb http://ftp2.fr.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp2.fr.debian.org/debian/ squeeze main contrib non-free

deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

# squeeze-updates, previously known as 'volatile'
deb http://ftp2.fr.debian.org/debian/ squeeze-updates main contrib
deb-src http://ftp2.fr.debian.org/debian/ squeeze-updates main contrib

deb http://www.debian-multimedia.org squeeze main non-free

deb http://backports.debian.org/debian-backports squeeze-backports main


Et si jamais il y a aussi besoin de voir mes preferences :

Package: *
Pin: release a=squeeze-backports
Pin-Priority: 200


Je vais don upgrader mon kernel comme tu me le suggères.

Dernière modification par Arvedui (04-09-2011 10:30:39)


Linuxi Gratia !

Hors ligne

#13 04-09-2011 10:49:34

Invité-5
Banni(e)

Re : Accélération graphique nvidia non possible

Réctification => Un sources.list complet pour Squeeze
En principe tu n'as pas besoin de fichier /etc/apt/preferences pour squeeze-backports. Son niveau de preferences est de 100 par défaut !

#14 04-09-2011 11:15:37

Arvedui
Membre
Distrib. : Stable
Noyau : Linux 2.6.32-5-amd64
(G)UI : GNOME 2.30
Inscription : 03-09-2011

Re : Accélération graphique nvidia non possible

J'ai bien upgradé mon kernel au 2.6.38 par les backports, et j'ai, après avoir purger ma Deb des paquets nVidia, refait la manip, c'est toujours la même chose, le même écran m'arrive à chaque fois.

Pour ce qui est des preferences, c'est pour autoriser les mises à jours autos des paquets installés. ^^

Dernière modification par Arvedui (04-09-2011 11:16:51)


Linuxi Gratia !

Hors ligne

#15 04-09-2011 12:03:50

Invité-5
Banni(e)

Re : Accélération graphique nvidia non possible

misaine a écrit :

ah mais tu n'as pas tout dit! (j'ai z'yeuté a côté) .si c'est ce fameux portable avec 2 CG (intel + nvidia)
bonjour la galère !


Problème similaire avec la même CG sous testing/Wheezy => http://debian-facile.org/forum/viewtopic.php?id=4279

#16 04-09-2011 13:07:26

Arvedui
Membre
Distrib. : Stable
Noyau : Linux 2.6.32-5-amd64
(G)UI : GNOME 2.30
Inscription : 03-09-2011

Re : Accélération graphique nvidia non possible

Ok, merci, je vais voir smile

Linuxi Gratia !

Hors ligne

#17 04-09-2011 13:32:18

Arvedui
Membre
Distrib. : Stable
Noyau : Linux 2.6.32-5-amd64
(G)UI : GNOME 2.30
Inscription : 03-09-2011

Re : Accélération graphique nvidia non possible

J'ai essayé de reconfigurer X, seul problème, déjà, c'est que, lorsque je tape :

invoke-rc.d gdm3 stop


C'est un écran noir qui s'affiche, je peux certes écrire tout ce que je veux, en revanche, le système ne veut rien savoir. Lorsque je faius en mode sans échec :

Xorg -configure


un message apparait avec des noms de drives à foison (nvidia, nv, nouveau...) suivis de :

vmware: Please ignore above "FATAL: Module vmwgfx not found."
Fatal: Module nVidia not found.
(EE) NVIDIA: Failed to load the NVIDIA kernel module.
Please check your system's kernel log for additional error messages.
(EE) Failed to load module "nvidia" (module-specific error, 0)


Linuxi Gratia !

Hors ligne

Pied de page des forums