Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-10-2011 22:41:40

ostyll
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.0.0-1-amd64
(G)UI : Gnome 2.30.2
Inscription : 13-05-2010

[Résolu] Problème installation fglrx driver depuis mise a jour !!!

Bonjour à tous,

J'ai un petit problème et je pense que c'est un bug du fglrx-driver, mais bon je me lance quand même. Après une mise à jour du xserver-xorg mon driver ati plantait mon interface graphique j'ai du le déinstaller pour passer en mode pilote libre mais j'éssai de le réinstaller mais impossible :

apt-get install fglrx-driver
Les paquets suivants contiennent des dépendances non satisfaites :
fglrx-driver : Dépend: xorg-video-abi-6.0
                Recommande: fglrx-modules-dkms (= 1:10-9-3) mais ne sera pas installé ou
                            fglrx-source (= 1:10-9-3) mais ne sera pas installé
                Recommande: fglrx-glx mais ne sera pas installé
                Recommande: fglrx-glx-ia32 mais ne sera pas installé
                Recommande: fglrx-atieventsd mais ne sera pas installé

Donc je tiens a préciser que j'ai une debian wheezy et une ati HD 5450 !!!

Dernière modification par ostyll (17-10-2011 10:29:24)

Hors ligne

#2 07-10-2011 04:06:08

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] Problème installation fglrx driver depuis mise a jour !!!

Salut

Question : dans ton fichier /etc/sources.list, as-tu des lignes concernant testing seulement ? Parce qu'avec cette branche, il est vivement recommandé d'avoir au moins le dépôt pour la stable aussi et même ceux pour sid. (Les paquets dans testing arrivent de sid et il se peut à l'occasion que le dépôt ne soit pas complet, d'où les problèmes de dépendances.) Comme cela, en cas de dépendances non satisfaites, il est toujours possible d'aller piocher dans un autre dépôt. Donc, je préconise un fichier sources.list avec les trois branches et un fichier /etc/preferences où on met la priorité de sid à 90 (les priorités pour stable et testing auront la même valeur ; ce qui ne pose pas de problème). Avec ça, il sera possible d'aller piocher dans sid avec l'option -t : aptitude -t sid... Perso, je préfère utiliser aptitude qui gère mieux ce genre de problème.

Note : je viens de voir que le paquet fglrx-driver n'est pas disponible dans testing (du moins pas maintenant).

Dernière modification par martinux_qc (07-10-2011 04:27:25)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#3 07-10-2011 04:28:29

Invité-5
Banni(e)

Re : [Résolu] Problème installation fglrx driver depuis mise a jour !!!

100 % d'accord avec martin. Sans entrer dans les détails avant d'utiliser les branches supérieurs à stable renseignez vous svp.   wink

#4 07-10-2011 09:46:34

ostyll
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.0.0-1-amd64
(G)UI : Gnome 2.30.2
Inscription : 13-05-2010

Re : [Résolu] Problème installation fglrx driver depuis mise a jour !!!

salut,

merci a marin_mtl d'avoir répondu a mon post mais j'ai oublier de vous le signaler aussi, dans mon fichier sources.list j'ai effectivement la branche stable et sid et c'est justement pour ca que je post ce message !!! Est ce que quelqu'un à eu le même problème que moi.

Hors ligne

#5 07-10-2011 10:02:17

saintshakajin
Modérateur
Distrib. : Unstable
Noyau : uname -r
(G)UI : KDE4
Inscription : 01-06-2007

Re : [Résolu] Problème installation fglrx driver depuis mise a jour !!!

Salut,

A moins que tu aies fait un pinning, tu ne précises pas la branche lors de ton installation et de ce fait, c'est Testing qui est pris par défaut.

aptitude install -t unstable fglrx-driver

Hors ligne

#6 08-10-2011 05:36:40

ostyll
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.0.0-1-amd64
(G)UI : Gnome 2.30.2
Inscription : 13-05-2010

Re : [Résolu] Problème installation fglrx driver depuis mise a jour !!!

ben je sais vraiment pas c'est quoi le problème du paquet fglrx-driver depuis quelques temps suite au conseil de sainshakajin j'ai procéder à un :

aptitude install -t unstable fglrx-driver


et voila mon résultat :

Les NOUVEAUX paquets suivants vont être installés :
  fglrx-driver{b} glx-alternative-fglrx{a} glx-alternative-mesa{a}
  glx-diversions{a} libfglrx{a} libgl1-fglrx-glx{a} libxvbaw1{a}
  nvidia-installer-cleanup{a}
Les paquets suivants sont RECOMMANDÉS mais ne seront pas installés :
  fglrx-atieventsd fglrx-glx-ia32 fglrx-modules-dkms
0 paquets mis à jour, 8 nouvellement installés, 0 à enlever et 227 non mis à jour.
Il est nécessaire de télécharger 22,7 Mo/22,7 Mo d'archives. Après dépaquetage, 70,1 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
  fglrx-driver: Dépend: xorg-video-abi-10 qui est un paquet virtuel ou
                         xorg-video-abi-8 qui est un paquet virtuel ou
                         xorg-video-abi-6.0 qui est un paquet virtuel
                Dépend: xserver-xorg-core (< 2:1.10.99) mais 2:1.11.1-1 est installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     fglrx-driver [Non installé]

Hors ligne

#7 08-10-2011 10:06:49

Invité-5
Banni(e)

Re : [Résolu] Problème installation fglrx driver depuis mise a jour !!!

Maintenant il te faut "jongler = manier avec une grande aisance" entre tous ces paquets.
Rassure-toi c'est n'est que le pinning classique, mais au même temps si tu n'as pas d'habitude content toi d'installer ton driver fglrx version stable.
Suffirait pour une ATI HD 5450

ostyll a écrit :

install fglrx-driver
Les paquets suivants contiennent des dépendances non satisfaites :
fglrx-driver : Dépend: xorg-video-abi-6.0
                Recommande: fglrx-modules-dkms (= 1:10-9-3) mais ne sera pas installé ou
                            fglrx-source (= 1:10-9-3) mais ne sera pas installé
                Recommande: fglrx-glx mais ne sera pas installé
                Recommande: fglrx-glx-ia32 mais ne sera pas installé
                Recommande: fglrx-atieventsd mais ne sera pas installé

Donc je tiens a préciser que j'ai une debian wheezy et une ati HD 5450 !!!


poste #6 a écrit :

Dépend: xserver-xorg-core (< 2:1.10.99) mais 2:1.11.1-1 est installé.


SOIT => FORCER LA VERSION STABLE  2:1.10.4-1~bpo60+1  de/du XSERVER-XORG-CORE QUI SE TROUVE DANS SQUEEZE BACKPORTS SOIT L'UTILISER  2:1.7.7-13  STABLE

Tu as 7 paquets version stable 1:10-9-3 à installer :

fglrx-modules-dkms 1:10-9-3     
fglrx-driver                 1:10-9-3
fglrx-source               1:10-9-3
fglrx-glx                      1:10-9-3       
fglrx-control               1:10-9-3
fglrx-glx-ia32             1:10-9-3
fglrx-atieventsd         1:10-9-3

J'espère de ne pas me tromper dans cette explication. Wiki est ton ami. Courage.  wink

Dernière modification par Invité-5 (08-10-2011 11:15:41)

#8 08-10-2011 14:38:00

ostyll
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.0.0-1-amd64
(G)UI : Gnome 2.30.2
Inscription : 13-05-2010

Re : [Résolu] Problème installation fglrx driver depuis mise a jour !!!

Ben écoute Darien merci pour ton aide mais j'ai suivis ton tuto mais je but sur fglrx-driver qui depend xorg-video-abi-6.0. Alors que j'ai bien forcer la version stable !

Hors ligne

#9 08-10-2011 14:47:49

ostyll
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.0.0-1-amd64
(G)UI : Gnome 2.30.2
Inscription : 13-05-2010

Re : [Résolu] Problème installation fglrx driver depuis mise a jour !!!

Ben finalement j'ai du installer le fglrx-driver depuis le dépôts sid et la sa marche nickel !
Merci à tous pour votre aide ! big_smile

Hors ligne

#10 08-10-2011 15:20:56

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Problème installation fglrx driver depuis mise a jour !!!

Super ostyll !

Reste à nous mettre le [Resolu] dans le titre alors !
Voir : http://debian-facile.org/atelier:resolu

Amitié, Joel smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#11 08-10-2011 16:26:36

Invité-5
Banni(e)

Re : [Résolu] Problème installation fglrx driver depuis mise a jour !!!

ostyll a écrit :

Ben finalement j'ai du installer le fglrx-driver depuis le dépôts sid et la sa marche nickel !


Tout est bien qui finit bien. Content pour toi.  smile

#12 08-10-2011 20:02:57

ostyll
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.0.0-1-amd64
(G)UI : Gnome 2.30.2
Inscription : 13-05-2010

Re : [Résolu] Problème installation fglrx driver depuis mise a jour !!!

Je pense que j'ai crier victoire donc en faite j'ai réussi à installer le fglrx driver mais après un aticonfig --initial il lance interface graphique mais plante juste après clavier souris rien ne marche !!!
C'est vraiment la première fois que cela m' arrive je pense que j'ai me racheter une carte nvidia car vraiment les pilotes ati même si il y a une nette amélioration mais bon cela pose encore problème !:(:(

Hors ligne

#13 08-10-2011 20:37:12

saintshakajin
Modérateur
Distrib. : Unstable
Noyau : uname -r
(G)UI : KDE4
Inscription : 01-06-2007

Re : [Résolu] Problème installation fglrx driver depuis mise a jour !!!

Salut smile

Je vois qu'il y a recommandé mais non-installé: fglrx-modules-dkms.
Le module fglrx est-il bien installé?

Hors ligne

#14 08-10-2011 20:44:37

ostyll
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.0.0-1-amd64
(G)UI : Gnome 2.30.2
Inscription : 13-05-2010

Re : [Résolu] Problème installation fglrx driver depuis mise a jour !!!

Ben actuellement non il n'est pas installé car il plantais mon serveur X mais oui j'arrive à installer le fgrlx mais à partir des dépôts stable mais pas autrement !

Hors ligne

#15 13-10-2011 19:24:42

ostyll
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.0.0-1-amd64
(G)UI : Gnome 2.30.2
Inscription : 13-05-2010

Re : [Résolu] Problème installation fglrx driver depuis mise a jour !!!

Ben je pense que j'ai juste attendre la sortie du nouveau driver de ati pour corriger mon problème si quelqu'un a arrivé a réparer ce petit bug.

Hors ligne

#16 17-10-2011 10:28:56

ostyll
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.0.0-1-amd64
(G)UI : Gnome 2.30.2
Inscription : 13-05-2010

Re : [Résolu] Problème installation fglrx driver depuis mise a jour !!!

Enfin j'ai réussi a résoudre mon problème alors j'étais obliger de downgrader le noyau 3.0.0-1 vers 2.6.32-5 puis les paquets xorg et après j'ai pu installer le paquet fglrx-driver !
Voila merci à tous ceux qui mon aider cela ma permis de résoudre mon problème ! En attendant que le nouveau driver ati est compatible à la dernière version du xorg.

Dernière modification par ostyll (17-10-2011 10:29:06)

Hors ligne

#17 24-05-2012 10:15:12

Herbert west
Membre
Distrib. : stable 64 mise a jour regulièrement
Noyau : 3.x.x-x-amd64
(G)UI : gnome 3
Inscription : 17-05-2012

Re : [Résolu] Problème installation fglrx driver depuis mise a jour !!!

ostyll a écrit :

Enfin j'ai réussi a résoudre mon problème alors j'étais obliger de downgrader le noyau 3.0.0-1 vers 2.6.32-5 puis les paquets xorg et après j'ai pu installer le paquet fglrx-driver !
Voila merci à tous ceux qui mon aider cela ma permis de résoudre mon problème ! En attendant que le nouveau driver ati est compatible à la dernière version du xorg.


Salut ,
Si ça peut t'aider regarde mon Post qui utilise une soluTion de repli avec les pilotes firemeware-Linux-nonfree avec les pilotes libres radeon etc et mésa pour l'accélération.  Ça me permet d'avoir un bureau avec la bonne résolution et d'utiliser gnome3, mais ma carte est un peu sous exploitée. Je vais essayer de voir si je peux y ajouter des réglages
Schuss

Dernière modification par Herbert west (24-05-2012 12:09:27)


I72600k / radeonhd 6870 /asus p8p67 pro b3/syncmaster 3D Samsung 23p displayport
debian stable 64
Linux derniereversion 3.x.x-x-amd64
" Y a t il un sous-sol dans votre appartement ? "

Hors ligne

Pied de page des forums