Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-01-2012 22:37:13

maleksah
Membre
Distrib. : squeeze 6.0.4 AMD64
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 29-01-2012

[Résolu] problème au démarrage de debian

bonsoir, J'ai un problème au démarrage de debian. lorsque debian s'ouvre il y a la fenetre de chargement comme dab
et après j'ai un écran noir et un tiré en haut à gauche qui clignote.
Rien ne se passe après l'écran reste comme ça.
Je sais pas quoi faire sad

Dernière modification par maleksah (01-02-2012 16:42:07)

Hors ligne

#2 31-01-2012 23:20:53

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : [Résolu] problème au démarrage de debian

Ça semble être un problème de paramétrage de la carte graphique à vue de nez. Donne des indications sur ton matériel et l'historique des événements.

« La religion et l'art sont les luxes des lâches, qui permettent de fuir la réalité quand elle devient trop difficile à affronter. La différence c'est que la religion transforme tout mensonge en vérité alors que l'art transforme toute vérité en mensonge. »

Hors ligne

#3 01-02-2012 08:30:08

maleksah
Membre
Distrib. : squeeze 6.0.4 AMD64
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 29-01-2012

Re : [Résolu] problème au démarrage de debian

Haricophile a écrit :

Ça semble être un problème de paramétrage de la carte graphique à vue de nez. Donne des indications sur ton matériel et l'historique des événements.


J'ai une nvidia geforce 9600GT
Comment avoir l'historique des événements ?
merci

Hors ligne

#4 01-02-2012 08:35:29

dbkblk
Membre
Distrib. : Debian Wheezy 64bits
Noyau : 3.2
(G)UI : Gnome 3.2
Inscription : 24-10-2010

Re : [Résolu] problème au démarrage de debian

As tu *tenté de* configurer ta carte graphique ? Ou c'était comme ça de base ?
Normalement pour une carte Nvidia c'est:
Installation des pilotes:
apt-get install linux-headers-$(uname -r) nvidia-kernel-dkms nvidia-xconfig nvidia-settings

Configuration de la carte:
nvidia-xconfig

...et si tu veux utiliser le pilote libre "nouveau", tu n'as rien a configurer !

M. Gandhi: "C'est une erreur de croire nécessairement faux ce qu'on ne comprend pas."
C'est quoi ce bordel ?

Hors ligne

#5 01-02-2012 15:30:22

Invité-5
Banni(e)

Re : [Résolu] problème au démarrage de debian

Peut-être trouverai tu ton bonheur ici => http://debian-facile.org/

#6 01-02-2012 16:09:44

maleksah
Membre
Distrib. : squeeze 6.0.4 AMD64
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 29-01-2012

Re : [Résolu] problème au démarrage de debian

j'ai installé un pilote nvidia hier à laide de ce tuto http://debian-facile.org/
première partie.
Après quand j'ai redémarré le pc j'ai eu cet écran noir.
Comment puis-je désinstaller l'ancien pilote de la carte graphique et comment installer un autre qui fonctionne ?
merci

Hors ligne

#7 01-02-2012 16:13:09

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] problème au démarrage de debian

Tu peux démarrer en mode de dépannage (recovery),
effacer le Xorg de nvidia,

mv /etc/X11/xorg.conf /etc/X11/xorg.conf-nvidia.bak


supprimer les paquets nvidia,

aptitude purge "~i^nvidia"


et rebooter.

reboot


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#8 01-02-2012 16:41:42

maleksah
Membre
Distrib. : squeeze 6.0.4 AMD64
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 29-01-2012

Re : [Résolu] problème au démarrage de debian

captnfab a écrit :

Tu peux démarrer en mode de dépannage (recovery),
effacer le Xorg de nvidia,

mv /etc/X11/xorg.conf /etc/X11/xorg.conf-nvidia.bak


supprimer les paquets nvidia,

aptitude purge "~i^nvidia"


et rebooter.

reboot


Merci ça marche Debian s'ouvre normalement !!
Merci encore big_smile

Hors ligne

#9 01-02-2012 16:44:10

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] problème au démarrage de debian

Bien joué \o/

Comme quoi, le pilote propriétaire ne marche pas toujours mieux (plus droit ?) que le pilote libre smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#10 01-02-2012 17:49:53

dbkblk
Membre
Distrib. : Debian Wheezy 64bits
Noyau : 3.2
(G)UI : Gnome 3.2
Inscription : 24-10-2010

Re : [Résolu] problème au démarrage de debian

Je pense qu'il serait plus judicieux de mettre la méthode "alternative" en méthode principale dans le wiki nvidia. L'autre méthode est, ermm rustique et plus complexe qu'un simple "apt-get install linux-headers-$(uname -r) nvidia-kernel-dkms nvidia-xconfig nvidia-settings && nvidia-xconfig" et redémarrage..
Je ne vois pas l'intérêt de compliquer les choses !

Dernière modification par dbkblk (01-02-2012 17:51:01)


M. Gandhi: "C'est une erreur de croire nécessairement faux ce qu'on ne comprend pas."
C'est quoi ce bordel ?

Hors ligne

#11 02-02-2012 22:05:43

Invité-5
Banni(e)

Re : [Résolu] problème au démarrage de debian

Croyez-moi, croyez-moi pas je ne voulais pas "intervenir"

deb http://debian.mines.inpl-nancy.fr/debian/ sid main
deb-src http://debian.mines.inpl-nancy.fr/debian/ sid main

deb http://mirror.home-dn.net/debian-multimedia/ sid main
deb-src http://mirror.home-dn.net/debian-multimedia/ sid main


J'utilise forcement driver nouveau ! Beaucoup d'aspects doivent être considérés par son utilisation comme par exemple la gestion d'énergie et de ce côté-ci ce n'est pas encore la joie totale.

En revanche avec proprio ça va tout seul (en même temps je ne suggère pas non plus d'installer nvidia-proprio)  Si vous n'aimez pas la compilation, tant pis il y a d'autres méthodes.

Pied de page des forums