Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-03-2012 10:34:18

Nizar89
Membre
Inscription : 06-03-2012

Problème avec Compiz

Bonjour à tous!
Débutant sur debian (j'y suis passé la semaine dernière, après 2 ans sous Ubuntu), j'ai essayé de réinstaller Compiz, et pouvoir faire mumuse de nouveau avec le totalement inutile bureau en 3D, ainsi qu'autre fioritures.
J'ai suivis la même démarche que sur Ubuntu, en installant compiz-manager. Bien sûr, j'ai oublié les pilotes graphiques, ce que j'installe juste après (j'ai une nvidia).
Premier problème: rien ne se passe. J'ai beau mettre toute les options que je veux, rien ne change.
Je tombe donc là dessus, après quelques recherches:
http://debian-facile.org/forum/viewtopic.php?id=3531

Et je suis la solution de Darien (j'ai d'ailleurs hésité à faire remonter le topic, si vous préférez que je le fasse plutôt que d'en créer un nouveau, dites le moi).
Au moment ou je lance compiz --replace, j'ai eu ce message d'erreur qui tournait en boucle:

Erreur GConf : Échec lors de la connexion au serveur de configuration. Cela est généralement dû à un défaut (absence ou mauvaise configuration) du démon de bus de session D-Bus. Veuillez consulter http://projects.gnome.org/gconf/ pour plus d'informations. (Détails :  1: La connexion à la session a échoué : Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)


ctrl+c : je perds tout les bordure, de même que la possibilité de me déplacer entre les bureaux.
Je relance mon pc, réessaie, mais là je n'ai plus la même erreur, mais celle ci:

compiz --replace
compiz (core) - Warn: SmcOpenConnection failed: None of the authentication protocols specified are supported


Le ctrl+c me fait de nouveau tout perdre.
Depuis, dès que je relance compiz --replace, j'ai toujours ça.

Note: J'ai vérifié, le pilote non-libre est toujours installé, et compiz icon est bien lancé.

Des idées?
Merci!

Hors ligne

#2 06-03-2012 20:12:00

bract
Modérateur
Lieu : Pays du kiwi
Distrib. : wheezy
Noyau : 3.2.0-3 amd64
(G)UI : gnome 3.4.2 + lxde(eeepc)
Inscription : 05-02-2011

Re : Problème avec Compiz

Bonjour, smile
as-tu essayé ceci

a+

bract

L'asso est lancée. cool
La connaissance s'acquiert par l'expérience, tout le reste n'est que de l'information.[Albert Einstein]

Hors ligne

#3 08-03-2012 12:37:18

Nizar89
Membre
Inscription : 06-03-2012

Re : Problème avec Compiz

Merci pour la réponse!
Le problème vient peut être de là.
J'avais testé le Xorg -configure avant, et il me renvoyait une erreur, vu que le fichier de conf était quand même créer, je n'y prêtais pas attention. Je me dis maintenant qu'il ne le prend peut être pas en compte.
Donc, à la fin de Xorg -configure, j'ai:

[drm] No DRICreatePCIBusID symbol
Number of created device do not match number of detected devices
Configuration failed.


Et si je lance X -config /root/xorg.conf.new
J'ai un écran noir avec quelques couleurs en haut (un bout du navigateur qui s'affiche), et je ne peux rien faire. Si je retourne sur la console d'où j'ai lancé la commande, j'ai:

(EE) SynPS/2 Synaptics Touchpad Unable to query/initialize Synaptics hardware
(EE) Preinit failed for input device "SynPS/2 Synaptics TouchPad"


Merci smile.

Dernière modification par Nizar89 (08-03-2012 12:38:46)

Hors ligne

#4 03-07-2012 09:48:13

bundy
Membre
Distrib. : wheezy
Noyau : desktop 3.2.0-4-amd64; laptop 3.2.0-4-686
(G)UI : desktop gnome 3 avec shell ; laptop lxde
Inscription : 14-09-2010

Re : Problème avec Compiz

bonjour, smile

normalement , avec une nvidia tout est assez simple et tu n'as pas à aller tripatouiller les fichiers de conf , tout ce fait automatiquement.

tu as message un d'erreur avec gconf , je pense qu'il te manque un paquet pour fair le "lien" entre gconf et ta nvidia .

il faut que tous ces paquets soient installés :

  nvidia-kernel-dkms ; nvidia-glx ; nvidia-settings ; nvidia-xconfig

mets à jour apt

#aptitude update


puis

# aptitude install nvidia-kernel-dkms nvidia-glx nvidia-settings nvidia-xconfig


on verra bien ceux qui étaient là ou pas


configure x

# nvidia-xconfig


assures toi que fusion-icon est bien dans les appli au démarage puis tu reboot


#reboot


si ça ne marche pas, potasse ça et essaye de voir ce qui pourrait te manquer

Dernière modification par bundy (03-07-2012 09:49:28)

Hors ligne

Pied de page des forums