Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-04-2008 16:31:11

kutio
Membre
Inscription : 13-04-2008

Carte wifi non reconnu par iwconfig

Bonjour tout le monde, alors voilà j'ai acheter un laptop fujistu siemens esprimo-mobile-v5515
j'ai une carte wifi Atheros b/g


voila ce que m'indique lspci pour ma carte wifi :

02:00.0 Ethernet controller: Atheros Communications, Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)


Mon probleme est que ma carte wifi n'est pas reconnue pas iwconfig :

laptop:/home/ksz# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.


Alors j'ai essayé d'installer les drivers du site de SIS avec ndiswrapper, comme cela : (dernier ndiswrapper, et dernier driver sis163u )

laptop:/home/ksz/wireless# ndiswrapper -i sis163u.inf
driver sis163u is already installed

laptop:/home/ksz/wireless# ndiswrapper -l
sis163u : driver installed

laptop:/home/ksz/wireless# ndiswrapper -m
module configuration already contains alias directive

laptop:/home/ksz/wireless# depmod -a
laptop:/home/ksz/wireless# modprobe ndiswrapper


voila ce que m'indique lsmod :
laptop:/home/ksz/wireless# lsmod
Module                  Size  Used by
ndiswrapper           174588  0
isofs                  32996  0
zlib_inflate           14560  1 isofs
udf                    77668  1
rfcomm                 36784  0
l2cap                  22880  5 rfcomm
bluetooth              53636  4 rfcomm,l2cap
ipv6                  240836  14
ppdev                   8804  0
parport_pc             33668  0
lp                     11076  0
parport                34280  3 ppdev,parport_pc,lp
acpi_cpufreq            9260  1
cpufreq_ondemand        8492  1
cpufreq_conservative     7560  0
cpufreq_powersave       1856  0
cpufreq_stats           5184  0
freq_table              4512  3 acpi_cpufreq,cpufreq_ondemand,cpufreq_stats
cpufreq_userspace       4260  0
loop                   16804  0
joydev                 11360  0
snd_hda_intel         275264  1
snd_pcm_oss            38272  0
snd_mixer_oss          15296  1 snd_pcm_oss
snd_pcm                71780  2 snd_hda_intel,snd_pcm_oss
snd_timer              21092  1 snd_pcm
psmouse                36464  0
snd                    48612  7 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               7552  1 snd
ath_pci                89568  0
snd_page_alloc         10056  2 snd_hda_intel,snd_pcm
serio_raw               6660  0
rtc                    13052  0
wlan                  184048  1 ath_pci
ath_hal               191504  1 ath_pci
pcspkr                  3200  0
sis190                 19652  0
mii                     5312  1 sis190
video                  18672  0
output                  3744  1 video
ac                      6116  0
battery                13572  0
button                  8432  0
shpchp                 31028  0
pci_hotplug            27712  1 shpchp
evdev                  11104  6
ext3                  122888  2
jbd                    43732  1 ext3
mbcache                 8288  1 ext3
sg                     33264  0
usbhid                 28096  0
hid                    34272  1 usbhid
sd_mod                 27200  4
sr_mod                 16708  1
cdrom                  32512  1 sr_mod
generic                 4388  0 [permanent]
sis5513                 7556  0 [permanent]
ide_core              108292  2 generic,sis5513
sata_sis                8708  3
ehci_hcd               32524  0
ohci_hcd               21988  0
pata_sis               13860  2 sata_sis
ata_generic             7428  0
usbcore               132940  5 ndiswrapper,usbhid,ehci_hcd,ohci_hcd
libata                144464  3 sata_sis,pata_sis,ata_generic
scsi_mod              141164  4 sg,sd_mod,sr_mod,libata
thermal                16028  0
processor              36520  4 acpi_cpufreq,thermal
fan                     4772  0


Je reboot... et quand je fais iwconfig j'ai tjrs :

laptop:/home/ksz/wireless# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.



Voila j'espere que j'ai été assez clair sur mon probleme.

Je vous remercie d'avance

Hors ligne

#2 13-04-2008 18:41:55

Thom1
Membre
Inscription : 29-11-2007
Site Web

Re : Carte wifi non reconnu par iwconfig

Salut,

Avant de rebooter, est-ce que ta carte est reconnu avec ndiswrapper ?
As-tu ajouté "ndiswrapper" à ton fichier /etc/modules pour que le module soit chargé au démarrage ?
Pense bien aussi à mettre en blacklist le module natif de ta carte wifi dans /etc/modprobe.d/blacklist pour éviter les conflits

Dernière modification par Thom1 (14-04-2008 11:59:07)

Hors ligne

#3 14-04-2008 13:22:44

kutio
Membre
Inscription : 13-04-2008

Re : Carte wifi non reconnu par iwconfig

Ok c'est bon probleme resolu, en faite sur mon cd de driver de mon laptop, il y a tous les drivers wlan de la gamme fujistu et enfaite j'avais pas pris le bon driver donc c'est pour cela que ma carte était pas détectée. Enfaite c'était tout con mais comme je n'avais jamais utilisé ndiswrapper je pensais pas que en plus que le driver soit installé il fallait que ça soit marqué que le matériel soit reconnu.

Hors ligne

#4 15-04-2008 01:34:25

saintshakajin
Modérateur
Distrib. : Unstable
Noyau : uname -r
(G)UI : KDE4
Inscription : 01-06-2007

Re : Carte wifi non reconnu par iwconfig

Bête question, pourquoi n'as-tu pas essayé avec les drivers madwifi qui devraient normalement supporter ta carte?

Hors ligne

#5 15-04-2008 21:26:56

kutio
Membre
Inscription : 13-04-2008

Re : Carte wifi non reconnu par iwconfig

Avec madwifi ça marchait pas du tout, au démarrage il me disait que ma carte était pas supporté

Hors ligne

Pied de page des forums