Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-04-2008 14:12:24

Druviel
Membre
Inscription : 10-04-2008

[résolu]Installation de code::blocks

Bonjour à tous,

J'aurais aimer savoir comment installer Code::Blocks

J'ai des paquets .deb

j'ai essayé donc de faire un

dpkg -i *.deb


dans le répertoire ou ils sont mis évidemment.

mais voici le retour,

Sélection du paquet codeblocks précédemment désélectionné.
(Lecture de la base de données... 122374 fichiers et répertoires déjà installés.)
Dépaquetage de codeblocks (à partir de codeblocks_8.02_amd64.deb) ...
Sélection du paquet codeblocks-contrib précédemment désélectionné.
Dépaquetage de codeblocks-contrib (à partir de codeblocks-contrib_8.02_amd64.deb) ...
Sélection du paquet codeblocks-dbg précédemment désélectionné.
Dépaquetage de codeblocks-dbg (à partir de codeblocks-dbg_8.02_amd64.deb) ...
Sélection du paquet codeblocks-dev précédemment désélectionné.
Dépaquetage de codeblocks-dev (à partir de codeblocks-dev_8.02_amd64.deb) ...
Sélection du paquet libcodeblocks0 précédemment désélectionné.
Dépaquetage de libcodeblocks0 (à partir de libcodeblocks0_8.02_amd64.deb) ...
Sélection du paquet libwxsmithlib0 précédemment désélectionné.
Dépaquetage de libwxsmithlib0 (à partir de libwxsmithlib0_8.02_amd64.deb) ...
Sélection du paquet libwxsmithlib0-dev précédemment désélectionné.
Dépaquetage de libwxsmithlib0-dev (à partir de libwxsmithlib0-dev_8.02_amd64.deb) ...
dpkg : des problèmes de dépendances empêchent la configuration de libcodeblocks0 :
 libcodeblocks0 dépend de libwxbase2.8-0 (>= 2.8.7.1) ; cependant :
  Le paquet libwxbase2.8-0 n'est pas installé.
 libcodeblocks0 dépend de libwxgtk2.8-0 (>= 2.8.7.1) ; cependant :
  Le paquet libwxgtk2.8-0 n'est pas installé.
dpkg : erreur de traitement de libcodeblocks0 (--install) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de libwxsmithlib0 :
 libwxsmithlib0 dépend de libcodeblocks0 (= 8.02) ; cependant :
 Le paquet libcodeblocks0 n'est pas encore configuré.
dpkg : erreur de traitement de libwxsmithlib0 (--install) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de libwxsmithlib0-dev :
 libwxsmithlib0-dev dépend de libcodeblocks0 (= 8.02) ; cependant :
 Le paquet libcodeblocks0 n'est pas encore configuré.
dpkg : erreur de traitement de libwxsmithlib0-dev (--install) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de codeblocks :
 codeblocks dépend de libcodeblocks0 (= 8.02) ; cependant :
 Le paquet libcodeblocks0 n'est pas encore configuré.
dpkg : erreur de traitement de codeblocks (--install) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de codeblocks-contrib :
 codeblocks-contrib dépend de codeblocks (= 8.02) ; cependant :
 Le paquet codeblocks n'est pas encore configuré.
 codeblocks-contrib dépend de libwxsmithlib0 (= 8.02) ; cependant :
 Le paquet libwxsmithlib0 n'est pas encore configuré.
dpkg : erreur de traitement de codeblocks-contrib (--install) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de codeblocks-dbg :
 codeblocks-dbg dépend de codeblocks (= 8.02) ; cependant :
 Le paquet codeblocks n'est pas encore configuré.
dpkg : erreur de traitement de codeblocks-dbg (--install) :
 problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de codeblocks-dev :
 codeblocks-dev dépend de libcodeblocks0 (= 8.02) ; cependant :
 Le paquet libcodeblocks0 n'est pas encore configuré.
dpkg : erreur de traitement de codeblocks-dev (--install) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 libcodeblocks0
 libwxsmithlib0
 libwxsmithlib0-dev
 codeblocks
 codeblocks-contrib
 codeblocks-dbg
 codeblocks-dev


Que faire ?

Merci d'avance

Dernière modification par Druviel (21-04-2008 20:27:25)


C'est parce que la vitesse de la lumière est supérieure à celle du son, que tant de gens paraissent brillant avant d'avoir l'air con.

Hors ligne

#2 21-04-2008 16:21:07

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : [résolu]Installation de code::blocks

Salut

Pas de debian sous la main pour tester mais je viens de trouver un tuto --> http://arnaud-feltz.developpez.com/tuto … de-blocks/

@+

Hors ligne

#3 21-04-2008 17:13:46

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [résolu]Installation de code::blocks

Salut

Comme tu as pu le constater (si tu as lu les log)  tu as un pb de dépendance.
Il te manque les libwxbase2.8-0 et ibwxgtk2.8-0 a toi de les trouver

Ils existent sur Debian...dans les dépôts expérimental....si tu es joueur wink

http://packages.debian.org/search?keywo … ection=all

sinon trouver un dép sur apt-get.org, j'ai trouvé ceci
http://www1.apt-get.org/search.php?quer … %5B%5D=all
Attention le lien est assez long a ouvrir (+/- 1minute), c'est normal il lance une recherche sur tout les dépots recensé sur apt-get.org, soit patient

Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#4 21-04-2008 18:12:59

Druviel
Membre
Inscription : 10-04-2008

Re : [résolu]Installation de code::blocks

Le tuto est pas mal oui, mais le prob. c'est que je suis sur Sid est les dépôts sont ceux de etch je crois.

Sa ne change rien? :$

C'est parce que la vitesse de la lumière est supérieure à celle du son, que tant de gens paraissent brillant avant d'avoir l'air con.

Hors ligne

#5 21-04-2008 19:23:17

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : [résolu]Installation de code::blocks

http://arnaud-feltz.developpez.com/ a écrit :

Notez que j'ai mis etch-wx, mais c'est valable aussi si vous êtes sous sid, pour ceux qui sont sous Ubuntu, sont aussi présent : dapper-wx, edgy-wx, feisty-wx et gusty-wx.

Hors ligne

#6 21-04-2008 19:42:36

Druviel
Membre
Inscription : 10-04-2008

Re : [résolu]Installation de code::blocks

Oui mais la suite ne marche pas :s

Bon j'ai trouver : sa pourras peut-être servir à quelqu'un !!!

Comment installer Code::Blocks

Il s'agit du dernier post

merci à tous, en tout cas.

Dernière modification par Druviel (21-04-2008 20:27:03)


C'est parce que la vitesse de la lumière est supérieure à celle du son, que tant de gens paraissent brillant avant d'avoir l'air con.

Hors ligne

Pied de page des forums