Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-05-2012 17:50:39

Franz
Membre
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 08-05-2012

Config spéciale pour les videos des forums ?

Que ce soit dans iceweasel ou dans Epiphany, si une video est dans un sujet je n'ai qu'un cadre noir inerte.
Idem pour un site comme SoundCloud où l'icone "play" de la lecture audio reste insensible au pointeur de la souris.
Ce qui est étrange, c'est que sur YouTube ça fonctionne tout à fait normalement big_smile

Les plugins Shockwave flash, vlc multimedia, windows media player et Cie sont présents. Voyez mon horrible désarroi roll

Qu'en pensez-vous ?

Vieux processeur amd sempron 3000+ cadencé à 2 Gz

Hors ligne

#2 14-05-2012 17:58:09

vrms33
Modérateur
Distrib. : stable
(G)UI : LXDE
Inscription : 06-11-2011

Re : Config spéciale pour les videos des forums ?

Bonjour,
tu peux nous donner un lien vers une vidéo que tu ne lis pas, pour tester ? wink

Donnez votre avis ou participez :  projet ebook Debian débutants.

Hors ligne

#3 14-05-2012 18:39:30

Franz
Membre
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 08-05-2012

Re : Config spéciale pour les videos des forums ?


Vieux processeur amd sempron 3000+ cadencé à 2 Gz

Hors ligne

#4 14-05-2012 19:19:58

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Config spéciale pour les videos des forums ?

Bonsoir,

Vraiment à tout hasard : un module genre Adblock qui ferait son œuvre ?

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#5 14-05-2012 19:32:34

Franz
Membre
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 08-05-2012

Re : Config spéciale pour les videos des forums ?

Hélas ...  je n'ai pour l'instant que des modules gentils big_smile

Vieux processeur amd sempron 3000+ cadencé à 2 Gz

Hors ligne

#6 14-05-2012 19:39:46

vrms33
Modérateur
Distrib. : stable
(G)UI : LXDE
Inscription : 06-11-2011

Re : Config spéciale pour les videos des forums ?

Bonsoir Franz,
bon, chez moi je les lis parfaitement, mais j'ai le paquet flashplugin-nonfree d'installé en ce moment !  (Honte à moi ! big_smile)

Donnez votre avis ou participez :  projet ebook Debian débutants.

Hors ligne

#7 14-05-2012 19:40:42

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Config spéciale pour les videos des forums ?

Je ne vois pas.
Pour le premier lien, c'est très étrange, comme tu le dis car c'est une vidéo Youtube encapsulée.

et clic droit propriétés, tu peux modifier quelque chose ?

Dernière modification par paskal (14-05-2012 19:41:29)


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#8 14-05-2012 20:07:31

Franz
Membre
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 08-05-2012

Re : Config spéciale pour les videos des forums ?

non rien ne change tongue

vrms33 a écrit :

bon, chez moi je les lis parfaitement, mais j'ai le paquet flashplugin-nonfree d'installé en ce moment !  (Honte à moi ! big_smile)


J'essaie de le trouver. Quelle serait la formule magique pour installer ce si honteux module ? big_smile

Synaptic (que j'utilisais avant de me perdre dans aptitude)  est-il bien pour ce genre de chose ?


Vieux processeur amd sempron 3000+ cadencé à 2 Gz

Hors ligne

#9 14-05-2012 20:27:20

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Config spéciale pour les videos des forums ?

aptitude est très bien smile
# aptitude flashplugin-nonfree # aptitude install flashplugin-nonfree
Moi aussi je l'ai installé mais je n'ai point honte, môa, môssieur. tongue

Dernière modification par paskal (14-05-2012 21:09:43)


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#10 14-05-2012 20:50:17

Franz
Membre
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 08-05-2012

Re : Config spéciale pour les videos des forums ?

aptitude flashplugin-nonfree


cela ne donne rien au terminal en root (retour chariot et rien ne se passe)

Une recherche dans aptitude ne donne rien. Dans synaptic non plus (ça doit être normal donc).
Là je patauge un peu big_smile

Dernière modification par Franz (14-05-2012 20:54:03)


Vieux processeur amd sempron 3000+ cadencé à 2 Gz

Hors ligne

#11 14-05-2012 21:02:48

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Config spéciale pour les videos des forums ?

Salut Franz !

Il faut ajouter install pour que cela marche :

aptitude install flashplugin-nonfree


Ben forcément alors, là ça va mieux marcher ! big_smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#12 14-05-2012 21:08:50

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Config spéciale pour les videos des forums ?

pfff, besoin de vacances, moi. roll
dsl, Franz sad

N'oublie pas d'ajouter contrib dans ton sources.list ; voir http://debian-facile.org/manuel:sources.list-df

Dernière modification par paskal (14-05-2012 21:12:05)


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#13 14-05-2012 21:30:22

vrms33
Modérateur
Distrib. : stable
(G)UI : LXDE
Inscription : 06-11-2011

Re : Config spéciale pour les videos des forums ?

paskal a écrit :

Moi aussi je l'ai installé mais je n'ai point honte, môa, môssieur. tongue


Tu devrais aussi pourtant ! lol
Mais bon, ça réglera le problème de Franz sans doute si il accepte la honte lui aussi ! wink


Donnez votre avis ou participez :  projet ebook Debian débutants.

Hors ligne

#14 14-05-2012 21:34:23

Franz
Membre
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 08-05-2012

Re : Config spéciale pour les videos des forums ?

Avec install c'est mieux en effet lol

Par contre

Pas de version candidate trouvée pour flashplugin-nonfree
Pas de version candidate trouvée pour flashplugin-nonfree
Aucun paquet ne va être installé, mis à jour ou enlevé.


Je vais voir ce contrib

pfff, besoin de vacances, moi. roll
dsl, Franz sad


Juste une étourderie wink


Voici mon sources.lis
t...c'est un peu léger non ?

deb http://ftp.fr.debian.org/debian/ squeeze main
deb-src http://ftp.fr.debian.org/debian/ squeeze main

deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

# squeeze-updates, previously known as 'volatile'
deb http://ftp.fr.debian.org/debian/ squeeze-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ squeeze-updates main contrib non-free


Vieux processeur amd sempron 3000+ cadencé à 2 Gz

Hors ligne

#15 14-05-2012 21:40:33

vrms33
Modérateur
Distrib. : stable
(G)UI : LXDE
Inscription : 06-11-2011

Re : Config spéciale pour les videos des forums ?

Hello, non très bien ton sources.list ! wink
A la ligne "deb http://ftp.fr.debian.org/debian/ squeeze main" tu rajoutes contrib pour avoir :

deb http://ftp.fr.debian.org/debian/ squeeze main contrib


puis

aptitude update


puis

aptitude install flashplugin-nonfree


puis je te conseille si t'en a plus besoin de ressortir "contrib" et de refaire aptitude update, ça sert à rien mais c 'est plus propre de remettre en l'état si tu n'as plus besoin de contrib pour d'autres choses.


Donnez votre avis ou participez :  projet ebook Debian débutants.

Hors ligne

#16 14-05-2012 21:43:11

Ghost
Membre
Distrib. : Stable/SID
Noyau : 3.13 Amd 64
(G)UI : Gnome Shell
Inscription : 26-03-2012
Site Web

Re : Config spéciale pour les videos des forums ?

Bonsoir,
Tu peux rajouter si tu le désire aussi les backports :

deb http://backports.debian.org/debian-backports squeeze-backports main non-free


Voir utilisation dans le Wiki : http://debian-facile.org/manuel:depot_backports?s[]=backports

Hors ligne

#17 14-05-2012 22:15:01

Franz
Membre
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 08-05-2012

Re : Config spéciale pour les videos des forums ?

J'ai fait la manip du "contrib" puis installé flashplugin-nonfree puis remis en état le sources.list

Je fais un reboot car un redemarrage de iceweasel ne change rien.

Vieux processeur amd sempron 3000+ cadencé à 2 Gz

Hors ligne

#18 14-05-2012 22:28:36

Franz
Membre
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 08-05-2012

Re : Config spéciale pour les videos des forums ?

Comment fait-on pour enlever le plugin que je viens d'installer car ça fait planter le navigateur ? lol

Sur les deux exemples (anafrog et soundcloud) et chaque fois que j'ouvre une page avec des video intégrées.

Et après je vais me reposer roll

Vieux processeur amd sempron 3000+ cadencé à 2 Gz

Hors ligne

#19 14-05-2012 22:31:45

Ghost
Membre
Distrib. : Stable/SID
Noyau : 3.13 Amd 64
(G)UI : Gnome Shell
Inscription : 26-03-2012
Site Web

Re : Config spéciale pour les videos des forums ?

 aptitude remove flashplugin-nonfree


En root en console.

Hors ligne

#20 14-05-2012 22:39:28

vrms33
Modérateur
Distrib. : stable
(G)UI : LXDE
Inscription : 06-11-2011

Re : Config spéciale pour les videos des forums ?

Tiens, chez moi aucun problème, ce n'est pas Flash qui est en cause, mais autre chose dans ta config... mais quoi ? neutral

Donnez votre avis ou participez :  projet ebook Debian débutants.

Hors ligne

#21 14-05-2012 22:55:35

Franz
Membre
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 08-05-2012

Re : Config spéciale pour les videos des forums ?

Voila c'est fait Ghost ! merci (ça ne plante plus ... ouf !)

Tiens, chez moi aucun problème, ce n'est pas Flash qui est en cause, mais autre chose dans ta config... mais quoi ?


C'était bien d'avoir essayé ! Pas de souci, c'est comme avant. wink

Tu as raison ce n'est peut-être pas Flash, car je viens de m'apercevoir que les videos fonctionnent avec Epiphany. Par contre l'histoire du player sur le site soundcloud c'est inerte.

Par contre l'écoute sur Youtube sur Epiphany prend 90 o/o du cpu avec de la tremblotte dans le son !!! (avec top en console la colonne commande indique gtk-gnash ) si ça vous dit quelque chose ...
Pour info, sur mon ancien Mepis les videos étaient normales.

Nous verrons cela demain ou plus tard car ce sont des détails. Merci encore et que ça ne vous empêche pas de dormir big_smile

Dernière modification par Franz (14-05-2012 23:12:05)


Vieux processeur amd sempron 3000+ cadencé à 2 Gz

Hors ligne

#22 15-05-2012 10:36:07

Franz
Membre
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 08-05-2012

Re : Config spéciale pour les videos des forums ?

Voila ce que m'indique le lecteur de la video:

Gnash est le lecteur GNU SWF basé sur GameSWF.
Moteur de rendu : OpenGL, Cairo, AGG
Hardware Acceleration: XVideo
GUI : GTK2
Média : FFmpeg (avcodec version: 52.1.1)

J'ai remarqué que ce gtk-gnash suscite beaucoup de mécontentement dans les forums linux. En effet il mange 90 o/o de cpu.
Est-ce que c'est ce truc que vous avez sur vos machines ?

Vieux processeur amd sempron 3000+ cadencé à 2 Gz

Hors ligne

#23 15-05-2012 11:06:53

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : Config spéciale pour les videos des forums ?

De mon expérience il y a un certain nombre de trucs qui influent. Commençons par simple :
  * Le blocage des cookies et des scripts (noscript...)
  * les adblock (parfois) et le blocage de "fonctionalités" diverses comme les iframes.
  * Le fait d'être identifié à youtube (ou équivalent) cf. cookies, en particulier pour accéder à html5 pour youtube (ce qui résoud le paramètre "flash" au détriment de la vie privée).

Gnash marche plus ou moins bien selon les périodes et les sites, donc ne pas généraliser. Mais en cas général la chose d'Adaube est plus universelle.



REMARQUE : Pas d'utilisation de Flash d'Adaube sans l'addon Betterprivacy ou équivalent, la solution alternative étant un

rm -Rf ~/.macromedia ~/.adobe


perfectible dans un script et/ou pouvant être inséré dans le script de démarrage de Iceweasel. Avec Gnash on sait ce qu'on stocke ou pas sur le disque, par contre le Flashplayer d'Adaube a pour caractéristique principale de ne pas être du web, donc de contourner les préférences et la politique de sécurité du navigateur. Dans ~/.macromedia on trouve pleins de traceurs et de cochoncetées diverses et malsaines. Dans ~/.adobe il n'y a, je crois, qu'un cookie identifiant.

Bien évidemment,  Gnash ne pose pas ce problème, ce qui est une des raisons du pourquoi il ne marche pas sur tous les sites, une autre étant qu'il est toujours un métro de retard sur les nouvelles versions de Flash.


« Un optimiste, explique Raymond Aubrac, n’est pas un être satisfait, content de la situation actuelle. C’est quelqu’un qui pense qu’il peut faire quelque chose qui servira. »

Hors ligne

#24 15-05-2012 14:04:46

Franz
Membre
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 08-05-2012

Re : Config spéciale pour les videos des forums ?

merci Haricophile smile

en particulier pour accéder à html5 pour youtube (ce qui résoud le paramètre "flash" au détriment de la vie privée)


C'est justement avec html5 mais seulement sur Epiphany que je peux lire les videos inégrées aux forum mais c'est d'une lenteur abominable, probléme que je n'avais absolument pas avec mon Mepis 7 que je ne pouvais plus upgrader. mad
Ce html5 est-il installable en plugin sur iceweasel ?

Que signifie cette commande que tu indiques:

rm -Rf ~/.macromedia ~/.adobe


En définitive je crois que je vais renoncer aux videos et aux lectures audio sur soundcloud sinon je vais péter un plomb big_smile
Ce qui est embêtant c'est que j'en ai besoin pour mon travail musical.


Vieux processeur amd sempron 3000+ cadencé à 2 Gz

Hors ligne

#25 15-05-2012 15:03:37

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Config spéciale pour les videos des forums ?

rm -Rf ~/.macromedia ~/.adobe


Voir la commande rm :
http://debian-facile.org/doc:systeme:rm

Quant à l'utilisation du symbole ~, c'est pour indiquer que l'on démarre depuis le répertoire de l'user en session.

big_smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums