Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-06-2012 16:39:09

bilox777
Membre
Inscription : 30-05-2012

Pas de son sous debian

Bonjour je viens d'écumer tout le web en recherche de solution pour le son mais voila toujours un problem


C'est pas la premiere fois que j'ai des problème avec le son avec linuc mint et ubuntu je devais changer le device utilisé pour le son (intel analogique et hdmi output)
Mais voila je ne sais plus absolument quoi faire je ne sais pas quelle carte son utilisé ni comment modifier l'ordre d'utilisation (je tien a préciser que j'ai fait er refait le tuto venant de DF mais rien a faire


Voila le résultat de différente commande

aplay -l

**** List of PLAYBACK Hardware Devices ****

card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

card 1: Generic [HD-Audio Generic], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0



Mon fichier alsa-base.conf



# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-1
install sound-slot-1 /sbin/modprobe snd-card-0
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd$
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modp$
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modp$

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2


Voila merci de votre aide

Hors ligne

#2 01-06-2012 17:54:14

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Pas de son sous debian

Salut bilox777,

As-tu consulté le tuto sur le son ici :
http://debian-facile.org/doc:materiel:c … :depannage

smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 01-06-2012 21:22:58

bilox777
Membre
Inscription : 30-05-2012

Re : Pas de son sous debian

oui je l'ai consulté mais je ne sais pas quelle solution utilisé

Hors ligne

#4 01-06-2012 22:10:36

Yvance77
Membre
Lieu : Nice - Monaco
Distrib. : Mint 14 Nadia sur Netbook & PC
Noyau : Mignon tout plein
(G)UI : Mate
Inscription : 22-05-2012

Re : Pas de son sous debian

Salut,

Vois ce FIL, j'ai eu le même souci. Solution n°4 pour moi sur le wiki en lien au-dessus.

Bye

Dernière modification par Yvance77 (01-06-2012 22:11:17)


A trop faire de l'économie un idéal, nous faisons l'économie de l'Idéal !

Hors ligne

#5 02-06-2012 18:06:21

bilox777
Membre
Inscription : 30-05-2012

Re : Pas de son sous debian

merci de ta réponse


Le probleme est que la commande cat /proc/asound/modules me donne ceci

0 snd_hda_intel
1 snd_hda_intel

Il y a pas un probleme ?



et le fichier alsa-base.conf me donne ceci


# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2


option snd_hda_intel  index=0


Mais sa marche toujours pas


Merci de me répondre

Hors ligne

#6 02-06-2012 18:20:41

bilox777
Membre
Inscription : 30-05-2012

Re : Pas de son sous debian

Voila le résultat de la commande

cat /proc/asound/cards

0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xf5e00000 irq 22
1 [Generic        ]: HDA-Intel - HD-Audio Generic


voici pour cat /proc/asound/modules

0 snd_hda_intel
1 snd_hda_intel

Hors ligne

#7 03-06-2012 09:17:34

Yvance77
Membre
Lieu : Nice - Monaco
Distrib. : Mint 14 Nadia sur Netbook & PC
Noyau : Mignon tout plein
(G)UI : Mate
Inscription : 22-05-2012

Re : Pas de son sous debian

Salut,

Mets le ainsi pour voir et reboot:

0 snd_hda_intel [Generic] index=0
1 snd_hda_intel [Intel] index=1

A trop faire de l'économie un idéal, nous faisons l'économie de l'Idéal !

Hors ligne

#8 03-06-2012 10:08:46

bilox777
Membre
Inscription : 30-05-2012

Re : Pas de son sous debian

Yvance77 a écrit :

Salut,

Mets le ainsi pour voir et reboot:

0 snd_hda_intel [Generic] index=0
1 snd_hda_intel [Intel] index=1


Je met sa ou ?
Dans le fichier alsa-base dans module ou cards ?

Hors ligne

#9 03-06-2012 10:38:12

bilox777
Membre
Inscription : 30-05-2012

Re : Pas de son sous debian

Bon j'ai remplie le fichier alsa-base de ces ligne mais rien a faire meme en changant l'ordre d'utilisation j'ai toujours le meme probleme dans alsamixer c'est toujours la sortie hdmi qui est utilisé

Hors ligne

#10 03-06-2012 11:09:40

bilox777
Membre
Inscription : 30-05-2012

Re : Pas de son sous debian

Bon je continue dans mes recherche et voila ou j'en suis


Malgré toute les modification apporté a mon alsa-base c'est toujours le 1 snd_hda_intel qui se lance (c'est la sortie hdmi pour moi )
Meme en suprimant la ligne  "1 snd_hda_intel"c'est encore lui qui se lance


Je pense que le probleme vient des module qui porte le meme nom mais qui ne sont pas utilisé par les meme card voir mais commande module et card

Alors voila comment faire comprendre au systémé que se sont 2 module différent pour 2 card différent car la mes modification ne donne rien



Merci de m'aider

Hors ligne

#11 03-06-2012 11:23:47

Yvance77
Membre
Lieu : Nice - Monaco
Distrib. : Mint 14 Nadia sur Netbook & PC
Noyau : Mignon tout plein
(G)UI : Mate
Inscription : 22-05-2012

Re : Pas de son sous debian

Tu édites en root

alsa-base.conf

Et tu remplaces le contenu que tu as par celui-ci :

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2


options snd_hda_intel [Generic] index=0
options snd_hda_intel [Intel] index=1


Et tu rebootes. On va voir ainsi si OK

Dernière modification par Yvance77 (03-06-2012 11:29:36)


A trop faire de l'économie un idéal, nous faisons l'économie de l'Idéal !

Hors ligne

#12 03-06-2012 12:04:26

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Pas de son sous debian

Tu édites en root

alsa-base.conf

Et tu remplaces le contenu que tu as par celui-ci :


[large]ATTENTION ![/large]
Oups ! Faire une sauvegarde de l'ancien en le renommant alsa-base-sav par exemple avant de le modifier ! big_smile

Tchibâââ ! lol


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#13 03-06-2012 14:23:05

bilox777
Membre
Inscription : 30-05-2012

Re : Pas de son sous debian

Merci pour ta réponse mais la situation a empiré

Non seulement ta modification ne resout pas le problème mais en plus les commande cat ...module et cat ....cards me donne plus rien c'est comme si debian ne reconait plus mais carte son !!!

Hors ligne

#14 03-06-2012 15:07:32

bilox777
Membre
Inscription : 30-05-2012

Re : Pas de son sous debian

Bonjour j'ai trouver la solution


En fait la situation avais empiré alors j'ai décidé de purger les paquet alsa-base alsa-utils et d'installer les codec de ma carte graphique qui est une realtec

http://www.realtek.com.tw/

Voir la section quick lincks puis HD Audio Codec Driver et installer le codec suivant votre noyau unix (pour moi 2.6)

En fin je réinstalle alsa avec aptitude install alsa-base alsa-utils
Je configure alsa automatiquement avec dpkg-reconfigure alsa-base
Puis j'applique la solution 2 du wiki


Voila merci beaucoup de votre aide

Hors ligne

#15 04-06-2012 01:33:30

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : Pas de son sous debian

Salut

Pas toujours facile ces problèmes de son. Enfin, l'important c'est que tu as réussi à trouver la solution. Il ne manque qu'un petit [Résolu] et on en parlera plus smile.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

Pied de page des forums