Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-09-2012 17:25:23

tagada
Membre
Lieu : Massy-les flots
Distrib. : Sid & Wheezy & Suse 12.2
Noyau : 3.2.0-3
(G)UI : KDE
Inscription : 16-04-2012

systemsettings en root ne marche pas!! ???

Bonjour
j'ai voulu configurer l'horloge avec MenuK-configuration du système
mais c'est en grisé; il faut être root pour modifier.
Je suis donc passé par la console, mais ça n'ouvre rien et ça me répond ceci:

root@Debianisette:~# systemsettings
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
systemsettings(3965): KUniqueApplication: Cannot find the D-Bus session server:  "/usr/bin/dbus-launch terminated abnormally with the following error: No protocol specified
Autolaunch error: X11 initialization failed.
"

systemsettings(3964): KUniqueApplication: Pipe closed unexpectedly.


Que dois-je faire, svp ???


L'ordi: un des années 2000, ram 2x512MB, avec Nvidia Geforce 7600 GT,
Connecté à Internet via câble Bouyghes (descendante à 30.3Mbps)
Connecté via écran IIyama à soixante-huitard, wé mon pote, ça existe encore.

Hors ligne

#2 29-09-2012 17:35:01

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : systemsettings en root ne marche pas!! ???

installer kdesu ou kdesudo et depuis ton user faire : kdesu systemsetting

Le message dit que root ne peux pas utiliser interface graphique.

Salutation

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#3 29-09-2012 19:33:46

tagada
Membre
Lieu : Massy-les flots
Distrib. : Sid & Wheezy & Suse 12.2
Noyau : 3.2.0-3
(G)UI : KDE
Inscription : 16-04-2012

Re : systemsettings en root ne marche pas!! ???

j'ai installé kdesudo puis:
alain@Debianisette:~$ kdesudo systemsettings
il m'a demandé mon mdp; c'était pas celui du root mais celui du user
puis, chouette! la fenêtre appelée Configuration du système.
Donc ça marche; s'ouvre la fenêtre Config du système et je suis en kdesudo
Oui mais à Administration du système-Date et heure,
pas moyen de cocher: Définir automatiquement la date et l'heure qui reste en grisé. Je ne suis pas en super-u?
Ce que je veux faire car hier, j'ai eu la surprise de voir mon heure fausse d'une heure. J'avais donc cliqué-droite sur l'horloge en bas à droite puis Régler la date et l'heure, constaté que c'était en grisé et non coché le automatique et avais dû corrigé "à la main" l'heure de l'horloge.

L'ordi: un des années 2000, ram 2x512MB, avec Nvidia Geforce 7600 GT,
Connecté à Internet via câble Bouyghes (descendante à 30.3Mbps)
Connecté via écran IIyama à soixante-huitard, wé mon pote, ça existe encore.

Hors ligne

#4 29-09-2012 19:59:26

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : systemsettings en root ne marche pas!! ???

Salut

Il y a très longtemps que je n'ai pas pratiqué KDE mais il n'y aurait pas un bouton, un endroit où cliquer une fois que tu es rendu sur l'écran pour régler la date et l'heure qui te permet de passer en root (en mode administrateur) ? Bref, ce que l'on peut voir sur cette image.

Dernière modification par martinux_qc (29-09-2012 20:05:46)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#5 29-09-2012 20:42:25

moniroje
Membre
Inscription : 18-05-2008

Re : systemsettings en root ne marche pas!! ???

J'ouvre Régler la date et l'heure qui correspond à ton image; ben non, il n'y a pas Administrator mode....

Hors ligne

#6 29-09-2012 20:46:28

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : systemsettings en root ne marche pas!! ???

Bon, il va falloir qu'un utilisateur de KDE passe par ici pour en savoir plus.

Sinon, tu as Windows installé en plus sur ton ordi ? Si je pose la question, c'est à propos de ton décalage d'une heure qui t'a surpris.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#7 30-09-2012 02:08:23

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : systemsettings en root ne marche pas!! ???

Ben chez moi j'ai aucun soucis apres le changement je fais accepter, je rentre mon pass et voila.


http://images.debian-facile.org/file-Rf … 7db68952a2
http://images.debian-facile.org/file-R6 … e2b2676d96

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#8 30-09-2012 03:01:28

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : systemsettings en root ne marche pas!! ???

Bon en fait, et comme le montre les image de Matt, le panneau pour changer l'heure et la date est comme celui-là.

Donc, en cliquant sur "Apply" (ou appliqué), cela devrait le faire.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#9 30-09-2012 04:44:57

zozo
Membre
Distrib. : testing (avec pinning de partout)
Noyau : 3.16.0-4-amd64
(G)UI : gnome
Inscription : 04-04-2010

Re : systemsettings en root ne marche pas!! ???

Chez moi deux méthodes :
- Alt+F2 : kdesu systemsettings (et pas kdesudo) -> j'entre le mot de passe root et ça marche
- dans un terminal :
$ xhost +local:root (en utilisateur ; j'autorise root à utiliser ma session x)
$ su (mot de passe root)
# systemsettings (je suis root et je peux lancer des applications graphiques à partir d'un terminal)

Hors ligne

#10 30-09-2012 15:24:58

tagada
Membre
Lieu : Massy-les flots
Distrib. : Sid & Wheezy & Suse 12.2
Noyau : 3.2.0-3
(G)UI : KDE
Inscription : 16-04-2012

Re : systemsettings en root ne marche pas!! ???

Merci pour vos réponses. C'est chouette!
@martinux: non, il n'y a pas de windows sur mon ordi: trop fragile entre mes mains, je l'ai viré il y a... déjà 10 ans!
@MaTTux: j'ai fait comme toi en changeant l'heure; mais ce que je voulais en plus, c'est cocher ce que tu as dans ta fig1: Poner dia y hora automedicament
@martinux: exact, c'est cette figure. Sur ton image pareil que chez moi: est en grisé : Set data and time automatically
@zozo: j'ai fait comme tu as dit: Exécuter une commande: kdesu systemsettings et oui , ça marche pour régler l'heure. Mais pas moyen de cocher le bouton: Définir automatiquement la date et l'heure.

L'ordi: un des années 2000, ram 2x512MB, avec Nvidia Geforce 7600 GT,
Connecté à Internet via câble Bouyghes (descendante à 30.3Mbps)
Connecté via écran IIyama à soixante-huitard, wé mon pote, ça existe encore.

Hors ligne

#11 30-09-2012 17:05:18

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : systemsettings en root ne marche pas!! ???

Salut

Pour pouvoir régler l'heure automatiquement sur un serveur, et donc avoir cette option dans ta fenêtre, il te faut installer un paquet comme ntp.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

Pied de page des forums