Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-10-2012 17:14:41

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

[Résolu] Live-boot et backports

Bonjour

Je voudrais tester une Debian Squeeze pur jus sur mon portable disposant d'une puce wifii realtek 81921ce. Pour cela, il me faut un noyau et un pilote (propriétaire sad ) issus des backports.
J'arrive à activer ces dépots mais pas à installer des paquets qui en proviennent. Quelles options utiliser dans live-build (version sid3.0~a63-1) pour forcer l'installation d'un paquet des dépôts backports ?

Merci d'avance

Dernière modification par bendia (08-10-2012 09:15:27)


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

#2 06-10-2012 19:22:21

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Live-boot et backports

Il y a de la doc ici: http://debianandi.blogspot.fr/2011/09/h … istro.html

J'espère que ça pourra aider smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 08-10-2012 09:15:08

bendia
Admin stagiaire
Distrib. : Jessie
Noyau : 3.16.0-4-amd64
(G)UI : Gnome + XFCE + Console
Inscription : 20-03-2012
Site Web

Re : [Résolu] Live-boot et backports

Merci smile

Désolé pour la réponse tardive. La version live-build de Sid semble buggée et il m'a fallut plusieurs essais (assez long) pour m'en apercevoir. Je suius donc repasser sous Squeeze et après quelques autres essais (long eux aussi), ça marche !

Ton lien m'a permis de mettre en lumière une option qui ne m'avait encore jamais sautée aux yeux. J'ai donc relu avec une plus grande attention que précédemment le man

--interactive shell



Pour résumer un fichier de Pinning pour fimware-realtek et firmware-linux-nonfree
(Le pinning sur linux-image n'ayant pas fonctionné)

Package: firmware-linux-nonfree firmware-realtek
Pin: origin "backports.debian.org"
Pin-Priority: 900



l'option

--linux-packages linux-image-3.2.0-0-bpo.3


qui ne parvient pas à installer ce noyau mais qui n'en installe aucun automatiquement tongue

Lorsque arrive le prompt

aptitude install -t squeeze-backports linux-image-3.2.0-0.bpo.3-amd64


Répondre aux questions du resolver d'aptitude
Et après ça, ça fonctionne smile

Edit : En prime, le fichier auto/config

#!/bin/sh

lb config noauto \
        --apt "aptitude" \
  --apt-options "" \
        --bootappend-live "locales=fr_FR.UTF-8 keyboard-layouts=fr" \
        --bootappend-install "locales=fr_FR.UTF-8" \
        --architecture "amd64" \
        --distribution "squeeze" \
        --linux-packages "linux-image-3.2.0-0.bpo.3" \
        --archive-areas "main contrib non-free" \
        --backports "true" \
        --interactive "shell" \
        --packages-lists "gnome-core"
  "${@}"

Dernière modification par bendia (08-10-2012 09:17:00)


Ben
___________________
La seule question bête, c'est celle qu'on ne pose pas.
file-Re06858991f6f328b4907296ac5cea283

Hors ligne

Pied de page des forums