Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-10-2012 15:12:12

Arg
Membre
Inscription : 12-10-2012

[Résolu] Changement d'alias phpmyadmin sur Squeeze

Salut à tous,

Je suis en train de terminer la configuration un serveur LAMP sur un serveur dédié avec Squeeze. Tout marche au poil, je peux me connecter à distance sur mondomaine/phpmyadmin et me logger sans problème. Par contre, impossible de changer l'alias de phpmyadmin. Niveau sécurité, j'ai un peu l'impression que mon serveur est en train de courir slip au milieu de la jungle du web.

Voici le contenu de mon /etc/phpmyadmin/apache.conf

# phpMyAdmin default Apache configuration

Alias /bordel /usr/share/phpmyadmin

<Directory /usr/share/phpmyadmin>
        Options FollowSymLinks
        DirectoryIndex index.php
        Options None
        AllowOverride None
        Order allow,deny
        Allow from all

        <IfModule mod_php5.c>
                AddType application/x-httpd-php .php
                php_flag magic_quotes_gpc Off
                php_flag track_vars On
                php_flag register_globals Off
                php_value include_path .
        </IfModule>

</Directory>

# Authorize for setup
<Directory /usr/share/phpmyadmin/setup>
    <IfModule mod_authn_file.c>
    AuthType Basic
    AuthName "phpMyAdmin Setup"
    AuthUserFile /etc/phpmyadmin/htpasswd.setup
    </IfModule>
    Require valid-user
</Directory>

# Disallow web access to directories that don't need it
<Directory /usr/share/phpmyadmin/libraries>
    Order Deny,Allow
    Deny from All
</Directory>
<Directory /usr/share/phpmyadmin/setup/lib>
    Order Deny,Allow
    Deny from All
</Directory>
 



J'ai bien redémarré Apache mais mondomaine/phpmyadmin est toujours accessible alors que mondomaine/bordel (désolé je suis limite nervous breakdown) reste désespérément "Not Found".

apache2ctl -t -M |grep alias
Renvoie :
alias_module (shared)
Syntax OK
 



a2enmod alias
Renvoie :
Module alias already enabled
 



grep conf.d /etc/apache2/apache2.conf
Renvoie :
Include conf.d/



Voilà, je ne comprends rien. J'ai essayé plusieurs synstaxes pour l'alias avec des ", ou des ', ou encore en terminant les chemins par /. Bref, si quelqu'un peut me donner quelques pistes pour me sortir de là,..

Dernière modification par Arg (15-10-2012 18:13:43)

Hors ligne

#2 15-10-2012 14:30:34

Arg
Membre
Inscription : 12-10-2012

Re : [Résolu] Changement d'alias phpmyadmin sur Squeeze

J'ai la solution. Je la poste ici au cas où quelqu'un ferrait un jour la même bourde.

Mon répertoire /etc/apache2/conf.d ne contenait aucune référence au apache.conf de phpmyadmin. Il fallait donc créer un lien symbolique :

ln -s /etc/phpmyadmin/apache.conf /etc/apache2/conf.d/apache.conf



Ensuite en redémarrant apache mon alias était pris en compte.

J'avais aussi fait l'erreur de créer un lien symbolique de /usr/share/phpmyadmin vers /var/www/phpmyadmin qu'il fallait supprimer.

Hors ligne

#3 15-10-2012 14:44:48

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Changement d'alias phpmyadmin sur Squeeze

Merci du retour Arg ! smile
Il reste juste à mettre [Résolu] dans le titre en éditant ton premier post...
Voir le tuto :
http://debian-facile.org/atelier:resolu

wink

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums