Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-10-2012 14:18:42

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Résolution d'écran maximum trop basse

Bonjour,
J'ai une debian wheezy installée sur un pentium 4 HP dx6 100 mt
Je crois que la carte graphique est une integrated intel graphics media accelerator 900.

J'avais un écran crt 17', je viens de le remplacer par un écran plat 19'. Quand je vais dans "affichage" la résolution maximum disponible est de 1024x768, et l'écran est marqué comme inconnu. (c'est un dell)

Qu'est ce que je peux faire pour augmenter la résolution ?

Merci d'avance

Dernière modification par blux (19-10-2012 14:19:00)

Hors ligne

#2 19-10-2012 18:54:45

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Résolution d'écran maximum trop basse

Salut,

  • Est-ce que tu as un fichier /etc/X11/xorg.conf ? (si oui que contient-t-il ?)

  • que donne « xrandr -q » ?


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 19-10-2012 19:37:24

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Re : Résolution d'écran maximum trop basse

Salut captnfab,

Merci de te pencher sur mon cas.

Pas de xorg.conf dans /etc/X11

xrandr -q donne :

Screen 0: minimum 320 x200, current 1024 x 768, maximum 4096 x 4096
VGA1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
1024x768 60.0*
800x600 60.3 56.2
848x480 60.0
640x480 59.9

Hors ligne

#4 20-10-2012 07:49:48

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : Résolution d'écran maximum trop basse

Visiblement, tu es déja au maximum supporté...
Tu as peut-être besoin d'installer un pilote supplémentaire. Pour savoir, peux-tu retourner le résultat de la commande "lspci"?
Comme ça, on pourra savoir si un noyau plus récent gère mieux ton matériel.

YA3HGA-H

Hors ligne

#5 20-10-2012 09:39:06

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Re : Résolution d'écran maximum trop basse

root@debian:/# lspci
00:00.0 Host bridge: Intel Corporation 82915G/P/GV/GL/PL/910GL Memory Controller Hub (rev 04)
00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Integrated Graphics Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FB/FW (ICH6/ICH6W) SATA Controller (rev 03)
40:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)

Hors ligne

#6 20-10-2012 09:47:18

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Résolution d'écran maximum trop basse

Il y a une chance que ce soit juste parce que l'écran n'est pas reconnu. Si tu sais qu'il peut supporter une résolution supérieure, tu peux créer un fichier xorg.conf et le personnaliser.

D'abord, il te faut fermer ton serveur X.

Tu te logues ensuite en root sur un TTY et tu lances un Xorg -configure

Cela te génère un xorg.conf

Voici la syntaxe générale d'un xorg.conf.
Il y a deux endroits où tu peux jouer : pour le moniteur, et pour ce qu'ils appellent "Screen".

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "LCD Panel 1024x768"
HorizSync 31.5 - 48.0
VertRefresh 56.0 - 65.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#7 20-10-2012 09:48:24

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Résolution d'écran maximum trop basse


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#8 20-10-2012 09:59:36

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Résolution d'écran maximum trop basse

Mhh, normalement les pilotes libres sont bien. Au fait, tu as bien « xserver-xorg-video-intel » d'installé ?

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#9 20-10-2012 20:35:13

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Re : Résolution d'écran maximum trop basse

xserver-xorg-video-intel est installé.

Xorg -configure renvoie :

libkmod: ERROR ../libkmod/libkmod.c:505 kmod_lookup_alias_from_builtin_file: could not open builtin file '/lib/modules/3.1.0-1-686-pae/modules/builtin.bin'
FATAL: Module fbcon not found.
Number of created screens does not match number of detected devices.
Configuration failed.
Server terminated with error (2). Closing log file.

Dernière modification par blux (20-10-2012 20:36:15)

Hors ligne

#10 20-10-2012 20:53:38

faustus
Membre
Inscription : 01-10-2012

Re : Résolution d'écran maximum trop basse

Tu peux faire ça :

xrandr --newmode $(gtf 1280 1024 60 | sed -ne 's/"//g;s/ Modeline //p')


En changeant évidemment 1280 1024 60 par les dimensions et la fréquence de rafraîchissement de ton écran.
Ça crée un nouveau mode.
Ensuite il suffit de l'ajouter à xrandr :

  xrandr --addmode VGA1 1280x1024_60.00


Là encore en mettant les bonnes valeurs pour 1280x1024_60.00

Trouvé ici : Fréquence non listée dans les modes disponibles et là, un peu autrement, III.5. Forcing a preferred mode

Hors ligne

#11 20-10-2012 21:29:45

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Re : Résolution d'écran maximum trop basse

faustus a écrit :

Tu peux faire ça :

xrandr --newmode $(gtf 1280 1024 60 | sed -ne 's/"//g;s/ Modeline //p')


En changeant évidemment 1280 1024 60 par les dimensions et la fréquence de rafraîchissement de ton écran.
Ça crée un nouveau mode.
Ensuite il suffit de l'ajouter à xrandr :

  xrandr --addmode VGA1 1280x1024_60.00


Là encore en mettant les bonnes valeurs pour 1280x1024_60.00

Trouvé ici : Fréquence non listée dans les modes disponibles et là, un peu autrement, III.5. Forcing a preferred mode



J'ai appliqué ça, puis j'ai pu changer l'affichage dans les paramètres système, et ça fonctionne, puis j'ai reboot pour etre sur, j'ai relancé x, et j'ai un écran qui dit :

impossible d'appliquer la configuration enregistrée pour les écrans

aucun des modes choisis n'est compatible avec les modes possibles :
Tests des modes pour le CRTC 63
CRTC 63 : test du mode 1024x768@60Hz avec une sortie à 1440x900@60Hz (passe 0)
CRTC 63 : test du mode 800x600@60Hz avec une sortie à 1440x900@60Hz (passe 0)
CRTC 63 : test du mode 800x600@56Hz avec une sortie à 1440x900@60Hz (passe 0)
CRTC 63 : test du mode 848x480@60Hz avec une sortie à 1440x900@60Hz (passe 0)
CRTC 63 : test du mode 640x480@60Hz avec une sortie à 1440x900@60Hz (passe 0)
CRTC 63 : test du mode 1024x768@60Hz avec une sortie à 1440x900@60Hz (passe 1)
CRTC 63 : test du mode 800x600@60Hz avec une sortie à 1440x900@60Hz (passe 1)
CRTC 63 : test du mode 800x600@56Hz avec une sortie à 1440x900@60Hz (passe 1)
CRTC 63 : test du mode 848x480@60Hz avec une sortie à 1440x900@60Hz (passe 1)
CRTC 63 : test du mode 640x480@60Hz avec une sortie à 1440x900@60Hz (passe 1)
Tests des modes pour le CRTC 64
CRTC 64 : test du mode 1024x768@60Hz avec une sortie à 1440x900@60Hz (passe 0)
CRTC 64 : test du mode 800x600@60Hz avec une sortie à 1440x900@60Hz (passe 0)
CRTC 64 : test du mode 800x600@56Hz avec une sortie à 1440x900@60Hz (passe 0)
CRTC 64 : test du mode 848x480@60Hz avec une sortie à 1440x900@60Hz (passe 0)
CRTC 64 : test du mode 640x480@60Hz avec une sortie à 1440x900@60Hz (passe 0)
CRTC 64 : test du mode 1024x768@60Hz avec une sortie à 1440x900@60Hz (passe 1)
CRTC 64 : test du mode 800x600@60Hz avec une sortie à 1440x900@60Hz (passe 1)
CRTC 64 : test du mode 800x600@56Hz avec une sortie à 1440x900@60Hz (passe 1)
CRTC 64 : test du mode 848x480@60Hz avec une sortie à 1440x900@60Hz (passe 1)
CRTC 64 : test du mode 640x480@60Hz avec une sortie à 1440x900@60Hz (passe 1)
 



Le fond d'écran est devenu bleu, la resolution est revenue en 1024x768, les barres d'outils semblent fonctionner convenablement.

Dernière modification par blux (25-10-2012 11:56:04)

Hors ligne

#12 24-10-2012 19:43:35

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Re : Résolution d'écran maximum trop basse

J'ai toujours pas su régler le problème. Personne peux m'aider ?

Hors ligne

#13 27-10-2012 08:08:34

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Résolution d'écran maximum trop basse

Si tu connais bien les caractéristiques de ton écran, essai de construire xorg.conf à la mano :
http://www.thinkwiki.org/wiki/Intel_Gra … erator_900

Respecte bien ses fréquences, exemple à titre indicatif :

HorizSync    31.5-90
VertRefresh  50-90


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#14 06-11-2012 14:06:53

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Résolution d'écran maximum trop basse

Bonjour,

blux a écrit :

J'ai appliqué ça, puis j'ai pu changer l'affichage dans les paramètres système, et ça fonctionne, ...
... la resolution est revenue en 1024x768, les barres d'outils semblent fonctionner convenablement.


As-tu pérennisé la modeline générée par xrandr dans le fichier xorg.conf ?


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#15 06-11-2012 14:22:18

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Re : Résolution d'écran maximum trop basse

paskal a écrit :



As-tu pérennisé la modeline générée par xrandr dans le fichier xorg.conf ?



Non.

comment je peux le faire ?

Hors ligne

#16 06-11-2012 15:39:25

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Résolution d'écran maximum trop basse

A priori, le mieux est de mettre cette modeline dans le fichier xorg.conf, sous la section "Monitor".
D'autres possibilités existent, que je n'ai pas encore testées sous Debian : https://wiki.archlinux.org/index.php/Xr … persistent

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#17 07-11-2012 02:08:03

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Re : Résolution d'écran maximum trop basse

Il n'y a pas de fichier xorg.conf dans /etc/X11, et lorsque j'essaye d'en generer un avec Xorg -configure, ça donne :

libkmod: ERROR ../libkmod/libkmod.c:505 kmod_lookup_alias_from_builtin_file: could not open builtin file '/lib/modules/3.1.0-1-686-pae/modules/builtin.bin'
FATAL: Module fbcon not found.
Number of created screens does not match number of detected devices.
Configuration failed.
Server terminated with error (2). Closing log file.

Hors ligne

#18 07-11-2012 09:41:06

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Résolution d'écran maximum trop basse

Passe en console par Ctrl-Alt-F1 et connecte-toi en root.
Stoppe le serveur X :

# invoke-rc.d gdm3 stop


Puis génère dans /root le fichier xorg.conf.new de base :

# X -configure


et copie-le dans /etc/X11.
Édite-le :

# nano /etc/X11/xorg.conf


et modifie la section "Moniteur" de cette façon, mais en l'adaptant à ta sortie de xrandr :

Section "Monitor"
    Identifier  "VGA1"
    Modeline    "1280x1024_60.00"  106.47  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync
    Option      "PreferredMode" "1280x1024_60.00"
EndSection


Surtout, veille bien à ce que l'identifiant du moniteur soit le même dans la section "Screen"

Relance X pour la prise en compte :

# invoke-rc.d gdm3 start


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#19 08-11-2012 00:30:35

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Re : Résolution d'écran maximum trop basse

# X -configure

renvoie

libkmod: ERROR ../libkmod/libkmod.c:505 kmod_lookup_alias_from_builtin_file: could not open builtin file '/lib/modules/3.1.0-1-686-pae/modules/builtin.bin'
FATAL: Module fbcon not found.
Number of created screens does not match number of detected devices.
Configuration failed.
Server terminated with error (2). Closing log file.

Hors ligne

#20 08-11-2012 13:54:09

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Résolution d'écran maximum trop basse

Es-tu sûr que X est bien stoppé ?
Pour vérifier : lorsque tu tapes Alt-F7, tu dois te retrouver avec un _ clignotant.
(tu pourras repasser en console par Ctrl-Alt-F1)

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#21 08-11-2012 14:19:58

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Re : Résolution d'écran maximum trop basse

gnome ne se lance pas au démmarage, je dois entrer startx pour le lancer.  lorsque je tapes alt-F7, jai toujours "root@debian:~# _ clignotant.

Hors ligne

#22 08-11-2012 15:17:54

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Résolution d'écran maximum trop basse

Et ça le faisait avant de changer d'écran ?
Du coup, je me demande si ton installation initiale était complète.

I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#23 08-11-2012 15:29:55

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Re : Résolution d'écran maximum trop basse

Je sais pas. J'ai pas essayé avant de changer d'écran, vu que la résolution était adaptée.

Hors ligne

#24 08-11-2012 17:17:58

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Résolution d'écran maximum trop basse

Je veux parler de ça :

blux a écrit :

gnome ne se lance pas au démarrage, je dois entrer startx pour le lancer.


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

#25 08-11-2012 17:33:53

blux
Membre
Distrib. : Wheezy
Noyau : Linux 3.1.0-1-686-pae
(G)UI : gnome3
Inscription : 05-11-2008

Re : Résolution d'écran maximum trop basse

Ah, pardon ^^
C'est moi qui l'ai désactivé.

Hors ligne

Pied de page des forums