Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 05-06-2008 19:33:08

bluenote
Membre
Lieu : Balaruc-les-Bains (34)
Distrib. : Jessie (Debian 8)
Noyau : Linux 3.16.0-4-amd64
(G)UI : Dolphin
Inscription : 05-06-2008
Site Web

[RESOLU 90%]Imprimante Laser Samsung ML-2010R

Hello,

Ma configuration :

Debian Lenny EM64T noyau 2.6.22-3-amd64

J'ai le problème suivant avec ce périphérique :

Lorsque je le connecte sur un port USB, j'obtiens ce message dans /var/log/messages :

[c]Jun  5 19:08:18 Achille kernel: usb 2-2: new full speed USB device using uhci_hcd and address 18
Jun  5 19:08:18 Achille kernel: usb 2-2: configuration #1 chosen from 1 choice
Jun  5 19:08:18 Achille kernel: drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 18 if 0 alt 0 proto 2 vid 0x04E8 pid 0x326C
[/c]

Dans /proc/bus/usb/devices, j'ai bien :

[c]T:  Bus=02 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#= 17 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=16 #Cfgs=  1
P:  Vendor=04e8 ProdID=326c Rev= 1.00
S:  Manufacturer=Samsung
S:  Product=Samsung ML-2010
S:  SerialNumber=4421BKEQ222322V.
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=07(print) Sub=01 Prot=02 Driver=usblp
E:  Ad=02(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=83(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
[/c]

Jusqu'ici tout va bien, mais un "sudo lsusb" (sudo pour cause de bug sur udev...) ne m'affiche strictement rien pour mon imprimante. Idem avec "lpinfo -v", rien n'apparait.

De même, CUPS ne m'affiche rien correspondant à un périphérique à configurer sur USB.

J'ai réussi à l'installer avec le pilote Foomatic/GDI sur Debian Etch i386 (pas avec le pilote préconisé : Splix) mais sur cette machine, lsusb et lpinfo -v m'affiche correctement le périphérique...

Si qqn peut m'éclairer, merci d'avance wink

Dernière modification par bluenote (06-06-2008 00:48:05)

Hors ligne

#2 05-06-2008 20:01:08

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [RESOLU 90%]Imprimante Laser Samsung ML-2010R

Aucune certitude, mais ça ne pourrai pas venir du kernel 64 bit ? (y 'a souvent des soucis de driver avec ces noyal)
Essai de poser un kernel 32 bit pour voir

Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#3 05-06-2008 21:13:59

bluenote
Membre
Lieu : Balaruc-les-Bains (34)
Distrib. : Jessie (Debian 8)
Noyau : Linux 3.16.0-4-amd64
(G)UI : Dolphin
Inscription : 05-06-2008
Site Web

Re : [RESOLU 90%]Imprimante Laser Samsung ML-2010R

Oui comme je disais avec une debian Etch 32 bits ça marche mais aussi avec une sidux 64 bits (testée à l'instant). Les packages usbutils et udev sont quasiment dans la même version qu'avec ma debian Lenny, bizarre... J'ai oublié de relever la version du noyau par contre, j'y retourne wink

->Debian Lenny : 2.6.22-3-amd64
->Sidux : 2.6.24.4.slh.5-sidux-amd64

J'ai remarqué quelque chose d'étrange quand je suis en console :

%sudo lsusb

usb 2-1: USB disconnect, address 7
drivers/usb/class/usblp.c: usblp0: removed
usb 2-1: new full speed USB device using uhci_hcd and address 8
usb 2-1: configuration #1 chosen from 1 choice
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 8 if 0 alt 0 proto 2 vid 0x04E8 pid 0x326C
Bus 008 Device 001: ID 0000:0000
Bus 007 Device 001: ID 0000:0000
Bus 005 Device 001: ID 0000:0000
Bus 006 Device 001: ID 0000:0000
Bus 002 Device 003: ID 0451:1446 Texas Instruments, Inc. TUSB2040/2070 Hub
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 003: ID 093a:2500 Pixart Imaging, Inc. USB Optical Mouse
Bus 001 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000


udev (?)

Dernière modification par bluenote (05-06-2008 22:57:14)

Hors ligne

#4 06-06-2008 00:46:28

bluenote
Membre
Lieu : Balaruc-les-Bains (34)
Distrib. : Jessie (Debian 8)
Noyau : Linux 3.16.0-4-amd64
(G)UI : Dolphin
Inscription : 05-06-2008
Site Web

Re : [RESOLU 90%]Imprimante Laser Samsung ML-2010R

J'ai installé le dernier noyau Debian pour Lenny :

2.6.24-1-amd64

et tout fonctionne en 600 dpi au lieu de 1200 dpi (avec l'ancien pilote Foomatic/GDI !)
Avec le module fourni par Samsung, j'ai une erreur dans CUPS et rien ne sort, avec celui de Linuxprinting.org (Splix), l'imprimante sort une page avec "Internal Error - False".

Voilà, ça servira peut-être à qqn wink

Hors ligne

Pied de page des forums