Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 31-01-2013 00:06:38

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

[Résolu] Mot de passe refusé par gnome! Depuis GIT

Bonjour,

   afin de suivre mes sites web, j'ai installé  GIT.
   Lors de l'installation, on suggère de créer un usager.  Ce que je fis.

   Depuis:  un écran de connexion aparaît au démarrage.  Pas de surprise jusque là:  deux usagers:  moi et le nouveau que j'ai créé pour GIT.

   Le problème:  mon mot de passe n'est pas reconnu.
   Même si j'essaie de me connecter sous "root": le mot de passe n'est pas reconnu!


   Ça va bien!!!!!


    Que faire?


    Je ne sais pas comment, à partir de GRUB, comment passer en mode console admin (root).  Si je le pouvais, je virerais simplement cet imposteur de GIT.

    Merci.

Dernière modification par Patriboom (03-02-2013 04:17:50)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#2 31-01-2013 05:10:36

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

Bonjour,

Le dossier refuse d'évoluer:  J'ai tout balancé GIT, j'ai rétiré l'utilisateur associé

L'écran d'accueil de Gnome me demande encore mon identification et mon mot de passe et les refuse encore comme s'ils n'étaient pas bons ou mal associés!

J'essaie d'entrer sous "root" et ça ne fonctionne pas non plus avec gnome.
Que faire?

Merci

Portez la paix
Patrick Allaire, ptre

Hors ligne

#3 31-01-2013 05:14:48

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

Re-bonjour,

j'ai un détail qui pourrait être important: 

   lorsque j'inscris le bon mot de passe, ça donne l'impression de donner accès au monde de Gnome, mais ça revient aussitôt à la fenêtre d'identification, sans même donner d'explication, sans message "Mot de passe invalide".

Portez la paix
Patrick Allaire, ptre

Hors ligne

#4 31-01-2013 05:45:34

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT


Portez la paix
Patrick Allaire, ptre

Hors ligne

#5 31-01-2013 06:00:46

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

J'obtiens le même bouclage, mais sans qu'il me soit nécessaire de fournir un mot de passe lorsque je clique sur mon usager habituel.

En clair:
     gnome arrête à la fenêtre de connexion
     Je clique sur mon nom d'usager
     Le chargement des préférences semble fonctionner
     Tout est abandonné, et retour à la fenêtre de connexion.



Quelle affaire!

Portez la paix
Patrick Allaire, ptre

Hors ligne

#6 31-01-2013 06:20:46

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

J'ai effacé mes fichiers keyrings  ->  sans résultat

J'ai appliqué (selon http://forums.fedora-fr.org/viewtopic.php?id=43730 )  la commande suivante:   gconftool-2 --set /desktop/gnome/session/required_components/windowmanager --type string 'metacity'   -> sans résultat

Ça fait 3 heures que je perds là-dessus, sans compter que mon ordinateur est bloqué et que je ne peux pas travailler dessus pendant ce temps.

Une idée?

Portez la paix
Patrick Allaire, ptre

Hors ligne

#7 31-01-2013 07:11:31

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

Selon http://www.developpez.net/forums/d91298 … on-ubuntu/

cinq hypothèses:
Tu n'as plus les bons droits sur ton répertoire perso. Ceci dit, en mode "secours" ça ne fonctionnerait pas non plus, a priori.
Ton répertoire est plein.
La session Gnome ne pointe plus sur le bon répertoire.
Un fichier du répertoire .gnome a disparu.
Le gestionnaire de bureau (Gnome) ne démarre plus.

La 3 semble intéressante:  Gnome ne pointe plus sur le bon répertoire.  Quel devrait être ce répertoire et où est le pointeur, vers où doit-il pointer?
La 4 aussi. Mais je ne vois rien de différent entre /root/.gnome et /home/user/.gnome


Les fichiers /var/log/gdm3 ne me donnent rien que je puisse repérer comme aide.  Sais-je lire? Peut-être que pas ce genre d'infos.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#8 31-01-2013 07:40:33

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

Sérieusement ...

   voyez-vous une meilleure solution que de lancer mon portable du haut du 15e étage?

Portez la paix
Patrick Allaire, ptre

Hors ligne

#9 31-01-2013 07:47:34

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

De retour au calme: 

1. Le répertoire n'est pas plein
2. Comment savoir si j'ai les droits sur mon répertoire ?
3. Comment savoir vers où pointe la session gnome?
4. J'ai recopié tous les fichiers de /home/usager/.gnome de mon ancien ordinateur vers le répertoire correspondant du nouveau.  Il ne doit pas manquer de fichier là, car c'est avec l'ancien que je quéris votre aide
5. Le gestionnaire de bureau gnome démarre-t-il ou non?  Comment savoir?

Merci

Portez la paix
Patrick Allaire, ptre

Hors ligne

#10 31-01-2013 09:16:07

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

Voici la bonne piste:

   en root, je démarre startx et tente de travailler dans les usagers et groupes  (en anglais, via le chemin   System - Administration - Users & Groups

   et j'obtiens le message suivant: "The configuration could not be loaded.  An unknown error occured"

   Comment résintaller cela ?

   Merci

Portez la paix
Patrick Allaire, ptre

Hors ligne

#11 31-01-2013 09:36:24

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

Voilà qui progresse, j'espère! 
J'ai désinstallé Gnome au complet!
Je le réinstalle maintenant à partir d'un CD.
Médecine de cheval pour rhume de maringouin.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#12 31-01-2013 10:18:19

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

Toujour la même chose.

À lire le log ci-bas, on croirait que tout est détruit, qu'il ne reste aucun fichier de travail.  Ça me ramène à l'hypothèse d'une pointeur mal orienté.
Pouvez-vous m'aider???


Voici   /var/log/gdm3/:0-greeter.log

** (<unknown>:5857): DEBUG: Client registered with session manager: /org/gnome/SessionManager/Client1
Avertissement du gestionnaire de fenêtres : La lecture du fichier de session enregistré /var/lib/gdm3/.config/metacity/sessions/10d4e30e9e414185a4135961950698608800000058530007.ms a échoué : L'ouverture du fichier « /var/lib/gdm3/.config/metacity/sessions/10d4e30e9e414185a4135961950698608800000058530007.ms » a échoué : Aucun fichier ou dossier de ce type
** (process:5871): DEBUG: Greeter session pid=5871 display=:0.0 xauthority=/var/run/gdm3/auth-for-Debian-gdm-38LIY3/database

(polkit-gnome-authentication-agent-1:5870): GLib-GObject-WARNING **: cannot register existing type `_PolkitError'

(polkit-gnome-authentication-agent-1:5870): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
gdm-simple-greeter[5871]: Gtk-WARNING: /build/buildd-gtk+2.0_2.20.1-2-i386-TNeM25/gtk+2.0-2.20.1/gtk/gtkwidget.c:5628: widget not within a GtkWindow
Avertissement du gestionnaire de fenêtres : Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x160002b (Fenêtre d)
Avertissement du gestionnaire de fenêtres : meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
Avertissement du gestionnaire de fenêtres : Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x160002b (Fenêtre d)
Avertissement du gestionnaire de fenêtres : meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.

(gnome-power-manager:5869): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

** (gnome-power-manager:5869): WARNING **: Failed to send buffer

(gnome-power-manager:5869): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at session startup.

(gnome-power-manager:5869): atk-bridge-WARNING **: IOR not set.

(gnome-power-manager:5869): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at session startup.

(gnome-power-manager:5869): atk-bridge-WARNING **: IOR not set.
Avertissement du gestionnaire de fenêtres : CurrentTime used to choose focus window; focus window may not be correct.
Avertissement du gestionnaire de fenêtres : Got a request to focus the no_focus_window with a timestamp of 0.  This shouldn't happen!
gdm-simple-greeter[5871]: WARNING: Failed to send buffer

(gnome-settings-daemon:5860): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at session startup.

(gnome-settings-daemon:5860): atk-bridge-WARNING **: IOR not set.

(gnome-settings-daemon:5860): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at session startup.

(gnome-settings-daemon:5860): atk-bridge-WARNING **: IOR not set.

(gnome-settings-daemon:5860): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at session startup.

(gnome-settings-daemon:5860): atk-bridge-WARNING **: IOR not set.

(gnome-settings-daemon:5860): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at session startup.

(gnome-settings-daemon:5860): atk-bridge-WARNING **: IOR not set.

(gnome-settings-daemon:5860): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at session startup.

(gnome-settings-daemon:5860): atk-bridge-WARNING **: IOR not set.

(gnome-settings-daemon:5860): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at session startup.

(gnome-settings-daemon:5860): atk-bridge-WARNING **: IOR not set.

(gnome-settings-daemon:5860): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at session startup.

(gnome-settings-daemon:5860): atk-bridge-WARNING **: IOR not set.
gnome-settings-daemon: Fatal IO error 11 (Ressource temporairement non disponible) on X server :0.0.
gnome-settings-daemon: Fatal IO error 11 (Ressource temporairement non disponible) on X server :0.0.
polkit-gnome-authentication-agent-1: Fatal IO error 11 (Ressource temporairement non disponible) on X server :0.0.
The application 'polkit-gnome-authentication-agent-1' lost its connection to the display :0.0;
most likely the X server was shut down or you killed/destroyed
the application.




J'ai créé un fichier /var/lib/gdm3/.config/metacity/sessions/10d4e30e9e414185a4135961950698608800000058530007.ms  en espérant combler ce caprice: en vain.

Je ne connais pas l'exitence d'un fichier  /org tel que mentionné en première de ce log.  Qu'est-ce ?

Merci


Portez la paix
Patrick Allaire, ptre

Hors ligne

#13 31-01-2013 10:37:22

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

Hum.
Salut,
Déjà, essaye d'éviter de flooder comme ça, tant que tu n'as pas de réponse, tu édites ton dernier message.

Lancer startx en root est une mauvaise idée.

Comme je n'ai aucune idée de ce que tu as fait pour provoquer le problème, et que j'ai l'impression que chacune de tes tentatives de réparation a été une agravation, je te donne un listing pour résoudre tous les problèmes les plus probables que j'entrevois pour le moment.

  1. Connecte-toi en root en console

  2. Supprime les dossiers de configuration de gnome de ton utilisateur

    rm -r /home/tonutilisateur/.gnome* /home/tonutilisateur/.config/gnome*

  3. Supprime les anciens logs d'erreurs de session et scripts de démarrage de session :

    rm /home/tonutilisateur/.xsession* /home/tonutilisateur/.xinitrc

  4. Restaure les droits de ton dossier personnel :

    chown -R tonutilisateur: /home/tonutilisateur
    chmod -R u+rw /home/tonutilisateur
    chmod u+x /home/tonutilisateur
    find /home/tonutilisateur -type d -exec chmod u+x {} \;

  5. Supprime les fichiers louches que tu as rajoutés dans /var/lib/gdm3/ ou ailleurs dans ton système.

  6. Assure-toi que ton système soit bien à jour :

    aptitude update
    aptitude safe-upgrade

  7. Si tu n'es pas sûr d'avoir bien réinstallé gnome, tu peux faire un

    aptitude update install -R task-gnome-desktop

  8. Vérifie l'espace disponnible sur /home et sur /tmp avec la commande

    df -h


    Et fais au besoin du ménage dans l'un des deux dossiers.

  9. Redémarre gdm3

    service gdm3 restart

  10. À l'écran de connexion, choisis ton user et choisis gnome dans la liste des WM


Ça devrait le faire

Pour info, installer git ne rajoute pas d'utilisateur. Tu as du essayer d'installer gitolite ou un autre serveur git.

PS: /org ne fait pas référence au système de fichier, mais à un système de fichier virtuel, probablement utilisé par dbus, policykit, etc.


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#14 31-01-2013 16:04:56

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

Merci cptfab,

   j'ai tout fait à la lettre, et je n'ai pas avancé d'un poil.  Même résultat.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#15 31-01-2013 21:04:24

nikau
Banni(e)
Distrib. : jessie
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10.1
Inscription : 19-10-2011

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

bonjour,
 
  vérifie aussi si le répertoire home est bien exécutable sinon tous ses comptes utilisateurs ne sont pas accessibles (même si eux sont sont exécutables avec les droits, je me suis déjà fais avoir avec ça suite à un changement de partition home)

    accès mode console:  ctrl   alt   f1 (f1 à f7)
     login en root  et :
    # chmod +x /home
et créer aussi un nouveau comptes utilisateur pour tester:
   #adduser toto
     création mot de passe ....
  s' il se logue en mode console, lance la session graphique startx ...

Hors ligne

#16 01-02-2013 16:36:54

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

Merci nikau

   je viens d'appliquer la commande chmod sans succès.

   Je suis en session startx pour vous écrire ici.


   J'ai créé un usager bien et  .... et oui ... il se connecte bien.

   Que me suggérez-vous ?   Que faire pour réactiver mon usager original   ( j'aimerais éviter de créer un usager semblable et tout transférer les droits et personnalisations de l'usager original).

Merci

Dernière modification par Patriboom (01-02-2013 19:02:20)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#17 01-02-2013 20:16:41

nikau
Banni(e)
Distrib. : jessie
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10.1
Inscription : 19-10-2011

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

et tu es sûr que le mot de passe est correct ? tu as essayé de le changer en mode console ?
  # passwd ton_utilisateur

pour moi, ce n' est pas un problème de gnome mais de login puisque car ton user principal ne se logue pas en mode console.

Hors ligne

#18 01-02-2013 21:17:05

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

Je suis sûr de mon mot de passe: aucun
Je l'ai en effet changé dès le départ pour m'assurer d'être en mesure de faire les modif. néc.

Quoi qu'il en soit, ça ne coûte pas cher.  J'essaie encore.

Merci.


Après essai:  confirmé:  changement de mot de passe inutile, le problème persiste.

Dernière modification par Patriboom (01-02-2013 21:21:10)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#19 01-02-2013 21:27:50

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

Tu poux nous donner le résultat de la commande suivante :

cat /etc/passwd| grep tonutilisateur

?
Histoire de vérifier si ni le shell ni le home n'ont été modifiés.


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#20 01-02-2013 23:38:25

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

Merci de m'aider ainsi,

voici

cat /etc/passwd| grep patrick
patrick:x:1000:1000:Patrick Allaire,,,:/home/patrick:/bin/bash


Portez la paix
Patrick Allaire, ptre

Hors ligne

#21 02-02-2013 10:58:35

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

Bon bon bon…
Si le pb ne vient pas du système (puisque cela fonctionne avec un nouvel utilisateur), ni du fichier de passwd (puisque celui-ci est correct). C'est que cela vient bien de ton répertoire personnel.

Tu peux nous donner un

ls -lhad /home/patrick/.*

?
Cela nous permettra de vérifier quels sont les fichiers éventuellement chargés au démarrage et que l'on ne voudrait pas...


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#22 02-02-2013 15:43:23

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

Bonjour et merci.

#ls -lhad /home/patrick/.*
drwx------ 63 patrick patrick 4,0K  1 fév 14:19 /home/patrick/.
drwxr-xr-x  5 root    root    4,0K  1 fév 12:07 /home/patrick/..
drwx------  3 patrick patrick 4,0K 23 oct 00:15 /home/patrick/.adobe
drwx------  2 patrick patrick 4,0K 29 nov 18:19 /home/patrick/.aptitude
-rwx------  1 patrick patrick  11K  1 fév 09:38 /home/patrick/.bash_history
-rwxr--r--  1 patrick patrick  220 20 oct 01:41 /home/patrick/.bash_logout
-rwxr--r--  1 patrick patrick 3,2K 26 oct 00:40 /home/patrick/.bashrc
drwxr-xr-x  3 patrick patrick 4,0K 30 jan 13:29 /home/patrick/.bluefish
drwxr-xr-x  5 patrick patrick 4,0K 22 jan 00:52 /home/patrick/.cache
drwxr-xr-x 14 patrick patrick 4,0K 31 jan 08:45 /home/patrick/.config
drwxr-xr-x  2 patrick patrick 4,0K 22 oct 14:54 /home/patrick/.dasher
drwx------  3 patrick patrick 4,0K 20 oct 01:43 /home/patrick/.dbus
-rw-r--r--  1 patrick patrick   57  1 fév 14:19 /home/patrick/.dmrc
-rwx------  1 patrick patrick   16 25 nov 18:27 /home/patrick/.esd_auth
drwxr-xr-x  2 patrick patrick 4,0K  1 nov 08:52 /home/patrick/.fontconfig
drwx------  6 patrick patrick 4,0K 28 jan 00:29 /home/patrick/.gconf
drwx------  2 patrick patrick 4,0K 30 jan 13:43 /home/patrick/.gconfd
drwx------  4 patrick patrick 4,0K 22 oct 13:15 /home/patrick/.gegl-0.0
drwx------  3 patrick patrick 4,0K 24 oct 00:20 /home/patrick/.gftp
drwxr-xr-x 22 patrick patrick 4,0K 26 jan 09:50 /home/patrick/.gimp-2.6
-rwxr--r--  1 patrick patrick  459 29 jan 00:01 /home/patrick/.gitconfig
-rwxr-----  1 patrick patrick    0 29 jan 10:57 /home/patrick/.gksu.lock
drwx------  3 patrick patrick 4,0K 22 oct 13:49 /home/patrick/.gnash
drwx------  2 patrick patrick 4,0K 26 nov 23:03 /home/patrick/.gnupg
drwxr-xr-x  2 patrick patrick 4,0K 19 nov 13:26 /home/patrick/.gstreamer-0.10
-rwxr--r--  1 patrick patrick  251 28 jan 00:29 /home/patrick/.gtk-bookmarks
drwx------  2 patrick patrick 4,0K 20 oct 01:43 /home/patrick/.gvfs
drwxr-----  2 patrick patrick 4,0K 22 oct 09:29 /home/patrick/.hplip
-rwx------  1 patrick patrick  44K 28 jan 00:29 /home/patrick/.ICEauthority
drwxr-xr-x  2 patrick patrick 4,0K 20 oct 22:46 /home/patrick/.icons
drwxr-xr-x  3 patrick patrick 4,0K 22 oct 13:40 /home/patrick/.java
drwx------  3 patrick patrick 4,0K  6 déc 20:43 /home/patrick/.kde
drwx------  2 patrick patrick 4,0K  6 jan 13:41 /home/patrick/.kino-history
-rwxr--r--  1 patrick patrick 3,0K  6 jan 13:41 /home/patrick/.kinorc
drwx------  3 patrick patrick 4,0K 20 oct 01:45 /home/patrick/.local
drwx------  3 patrick patrick 4,0K 23 oct 00:15 /home/patrick/.macromedia
drwx------  4 patrick patrick 4,0K 11 nov 00:09 /home/patrick/.mozilla
drwxr-xr-x  2 patrick patrick 4,0K 25 oct 20:45 /home/patrick/.mplayer
drwx------  5 patrick patrick 4,0K 26 jan 11:15 /home/patrick/.mysqlgui
-rwx------  1 patrick patrick   11 12 jan 23:42 /home/patrick/.nano_history
drwxr-xr-x  2 patrick patrick 4,0K 20 oct 01:43 /home/patrick/.nautilus
drwxr-xr-x  3 patrick patrick 4,0K 20 oct 01:48 /home/patrick/.openoffice.org
lrwxrwxrwx  1 patrick patrick   34 30 oct 23:59 /home/patrick/.openshot -> /Documents/Images/Videos/.openshot
lrwxrwxrwx  1 patrick patrick   25 12 jan 23:44 /home/patrick/.opera -> /Documents/archives/opera
-rwxr--r--  1 patrick patrick   37 22 oct 09:28 /home/patrick/.printer-groups.xml
-rwxr--r--  1 patrick patrick 1,3K 29 jan 00:03 /home/patrick/.profile
drwx------  2 patrick patrick 4,0K 21 jan 18:48 /home/patrick/.pulse
-rwx------  1 patrick patrick  256 23 oct 23:36 /home/patrick/.pulse-cookie
-rwx------  1 patrick patrick 900K 30 jan 13:43 /home/patrick/.recently-used.xbel
drwxrwx---  3 patrick patrick 4,0K 22 oct 13:16 /home/patrick/.sane
drwx------  3 patrick patrick 4,0K 21 jan 18:52 /home/patrick/.Skype
drwx------  2 patrick patrick 4,0K 30 jan 22:16 /home/patrick/.ssh
drwxr-xr-x  4 patrick patrick 4,0K 24 oct 20:34 /home/patrick/.sudoku
drwxr-xr-x  2 patrick patrick 4,0K 20 oct 22:46 /home/patrick/.themes
drwx------  4 patrick patrick 4,0K 20 oct 22:47 /home/patrick/.thumbnails
drwx------  2 patrick patrick 4,0K 20 oct 01:43 /home/patrick/.update-notifier
drwxr-xr-x  2 patrick patrick 4,0K  1 nov 08:52 /home/patrick/.ure
drwxr-xr-x  2 patrick patrick 4,0K  4 jan 15:50 /home/patrick/.VirtualBox
drwxr-xr-x  2 patrick patrick 4,0K 14 déc 09:56 /home/patrick/.winff
-rwx------  1 patrick patrick    0 30 jan 22:28 /home/patrick/.Xauthority
-rw-------  1 patrick patrick  303  1 fév 14:19 /home/patrick/.xsession-errors
-rw-------  1 patrick patrick  303  1 fév 13:04 /home/patrick/.xsession-errors.old


Portez la paix
Patrick Allaire, ptre

Hors ligne

#23 02-02-2013 16:47:20

nikau
Banni(e)
Distrib. : jessie
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10.1
Inscription : 19-10-2011

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

tu es bien proprio avec les droits des fichiers de ton home, comme par exemple .Xauthority qu ' il suffit de supprimer en cas de pb, mais ce qui est embêtant: même en mode console tu ne peux te loguer..
c' est pour cela que que je pense que l' erreur  n' est pas forcément dans le home.

vérifie si ton uid est bien 1000

id patrick



en mode console refais un login mot de passe et postes les dernières lignes de /var/log/auth.log

EDIT:

si tu ne trouves pas l' erreur, je te propose un méthode radicale qui fonctionne, (je l' ai déjà fais sans problème)

       -tu renommes ton home/utilisateur  (sauvegarde)  mv /home/patrick /home/patrick.sav
       -tu notes bien tous les groupes dont tu fais parti  (id patrick)
       -tu supprimes ton user patrick et son groupe  ( deluser patrick   et delgroup patrick)
       -tu le recréais: adduser patrick
       -tu réaffecte tous les groupes notés précédemment  (exemple:  adduser patrick fuse ... adduser patrick adm   etc etc )
       -tu lui remet son id à 1000 s' il ne l' est plus: usermod -u 1000 patrick
       -tu supprimes /home/patrick qui vient d' être crée: rm -R /home/patrick
       -tu restaure la sauvegarde:  mv /home/patrick.sav /home/patrick

et voilà..

Dernière modification par nikau (02-02-2013 18:00:44)

Hors ligne

#24 02-02-2013 20:26:27

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

Ah, il ne peut pas se logguer en console non plus ?
Alors le problème doit être dans le .profile ou dans le .bashrc

Tu peux nous paster le contenu de ces deux fichiers ?

J'aimerais bien voir le contenu du .xsession-errors aussi

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#25 02-02-2013 20:29:17

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Mot de passe refusé par gnome! Depuis GIT

Et bien oui, mon uid est bien à 1000

# id patrick
uid=1000(patrick) gid=1000(patrick) groupes=1000(patrick),24(cdrom),25(floppy),29(audio),30(dip),44(video),46(plugdev),109(netdev),110(bluetooth),116(scanner)



Pour cesser d'y perdre mon temps, j'ai tout simplement créé un nouvel usager, je l'ai inscrit dans le groupe patrick, puis j'ai donné les droits 775 aux sous-répetoires et fichiers de patrick.
Prochaine étape, car je vois bien que ça devient insoluble, j'attribuerai la propriété de mes fichiers à mon nouvel usager et ramènerai les droits à 751

Merci


---- j'écrivais en même temps qu'on me donnait une autre piste.
Celle du .profile est intéressante

J'ai bêtement  suivi  http://www.mon-code.net/article/42/inst … -depot-git   et j'ai appliquer sans ceci:

Avec Git on utilise beaucoup (tout le temps) des branches, il est donc utile de savoir dans quelle branche on se situe. Pour cela il faut éditer ou créer le fichier .bash_profile ou .profile à la racine du compte de l'utilisateur et y ajouter:
 
# .bash_profile
 
# Get the aliases and functions
if [ -f ~/.bashrc ]; then
        . ~/.bashrc
fi
 
 
function parse_git_branch {
  git branch --no-color 2> /dev/null | sed -e '/^[^*]/d' -e 's/* \(.*\)/(\1)/'
}
 
function proml {
  local LIGHT_GREEN="\[\033[1;32m\]"
  local       WHITE="\[\033[1;37m\]"
  local  LIGHT_GRAY="\[\033[0;37m\]"
  case $TERM in
    xterm*)
    TITLEBAR='\[\033]0;\u@\h:\w\007\]'
    ;;
    *)
    TITLEBAR=""
    ;;
  esac
 
PS1="${TITLEBAR}\
$LIGHT_GRAY\u@\h:$WHITE\w$LIGHT_GREEN\$(parse_git_branch)\
$LIGHT_GRAY\$ "
PS2='> '
PS4='+ '
}
proml



Voici donc mon .profile

# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
  . "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi


# .bash_profile
 
# Get the aliases and functions
if [ -f ~/.bashrc ]; then
        . ~/.bashrc
fi
 
 
function parse_git_branch {
  git branch --no-color 2> /dev/null | sed -e '/^[^*]/d' -e 's/* \(.*\)/(\1)/'
}
 
function proml {
  local LIGHT_GREEN="\[\033[1;32m\]"
  local       WHITE="\[\033[1;37m\]"
  local  LIGHT_GRAY="\[\033[0;37m\]"
  case $TERM in
    xterm*)
    TITLEBAR='\[\033]0;\u@\h:\w\007\]'
    ;;
    *)
    TITLEBAR=""
    ;;
  esac
 
PS1="${TITLEBAR}\
$LIGHT_GRAY\u@\h:$WHITE\w$LIGHT_GREEN\$(parse_git_branch)\
$LIGHT_GRAY\$ "
PS2='> '
PS4='+ '
}
proml




Je ne me rappelle pas avoir touché au .bashrc mais le voici

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines in the history. See bash(1) for more options
# don't overwrite GNU Midnight Commander's setting of `ignorespace'.
HISTCONTROL=$HISTCONTROL${HISTCONTROL+:}ignoredups
# ... or force ignoredups and ignorespace
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# make less more friendly for non-text input files, see lesspipe(1)
#[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
  # We have color support; assume it's compliant with Ecma-48
  # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
  # a case would tend to support setf rather than setaf.)
  color_prompt=yes
    else
  color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
#    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
    PS1='\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    #alias grep='grep --color=auto'
    #alias fgrep='fgrep --color=auto'
    #alias egrep='egrep --color=auto'
fi

# some more ls aliases
#alias ll='ls -l'
#alias la='ls -A'
#alias l='ls -CF'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    . /etc/bash_completion
fi



Merci.

Dernière modification par Patriboom (02-02-2013 20:35:29)


Portez la paix
Patrick Allaire, ptre

Hors ligne

Pied de page des forums