Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 16-02-2013 10:31:30

mel0311
Membre
Inscription : 16-02-2013

configuration NAT sur debian6

slt tt le monde,

j'ai récemment configuré NAT dans debian6 avec iptables

1 - iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
    ou
    iptables -t nat -A POSTROUTING -s 192.168.1.0/24 ! -d IP-du-FAI -j MASQUERADE

2 - iptables-save >/etc/nat.conf
    iptables-restore < /etc/nat.conf

voilà l'architecture:

INTERNET --> (eth0)DEBIAN6(eth1) --> WIFI -->LAN
3 - configuration de ipv_forwawrd dans /proc/.../ipv4/ip_forward

4 - j'ai inséré dans l'interface eth0 cette ligne afin que iptables s'autodémarre aussi:
    pre-up iptables-restore </etc/nat.conf

Après la configuration (démarrage carte etc..., j'ai même redemarrer le serveur plusieurs fois afin que je voie une erreur), la NAT marchai très bien (les ordinateurs clients ont accès sans aucun problème à l'Internet) pendant au moins 1/2 journée jusqu'à celui ci tourne en mal; c'est à dire que les clients n'arrivent plus à accéder à l'internet...

j'ai revérifié les config, j'ai changé les regles iptables mais celui ci reste insolvable

question:

est ce qu'il y a un service qui s'est arrêter quelque part?
est ce que j'ai mal configuré?


merci de vos réponses chers administrateurs réseau

Hors ligne

#2 18-02-2013 09:02:10

mel0311
Membre
Inscription : 16-02-2013

Re : configuration NAT sur debian6

est ce qu'il y a quelqu'un ici cool

Hors ligne

Pied de page des forums