Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 19-02-2013 20:20:20

pmignon
Membre
Lieu : Lyon
Distrib. : Squeeze
Noyau : 2.6.35-2-686 et amd64
(G)UI : KDE: 4.3
Inscription : 14-06-2008

Re : [Résolu] openGL / nvidia ?


Inadéquation du module nvidia chargé                                                                                                    ?  
  ? Le pilote nvidia qui est en train d'être installé (version 295.59) ne correspond pas au module actuellement chargé (version 195.36.31).                                                                                                                   ?  
  ? Le serveur X ainsi que les applications OpenGL ou GPGPU risquent de ne pas fonctionner correctement.                                                 ?                                                                                                                   ?  
  ? La manière la plus simple de corriger cela est de redémarrer la machine une fois que l'installation est terminée. Vous pouvez également arrêter le serveur X (généralement en arrêtant le gestionnaire de connexion, comme gdm3, kdm ou xdm), retirer vous-même le module (), puis  redémarrer le serveur X.
 

Hors ligne

#27 19-02-2013 20:21:46

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] openGL / nvidia ?

Oui, donc tu fais ce qui est marqué smile Ou plus simple, tu reboot.

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#28 19-02-2013 20:30:43

pmignon
Membre
Lieu : Lyon
Distrib. : Squeeze
Noyau : 2.6.35-2-686 et amd64
(G)UI : KDE: 4.3
Inscription : 14-06-2008

Re : [Résolu] openGL / nvidia ?

super !
j'ai arrete kdm puis effacer le module .. et le programe marche ! pas de complaite sur aopen gl

Merci beaucoup !!!

ça me redonne envie de suivre plus pres le projet debain plutot qyue de venir ici quand j'ai un pb ... big_smile

Aussi j'aimerais bien comprenddre, qu'est-ce qu'on a fait ? a part mettre a jour des paquests du nvidia alternatives, si j'ai bien compris, parceque en fait j'utilise des paquets alternatives et nvidia a la fois ...?

Hors ligne

#29 19-02-2013 20:36:18

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] openGL / nvidia ?

Alors, oui, c'est une bonne idée de faire un petit résumé, et proposer une explication pour l'origine de la panne.

Comme tu n'avais pas les dépôts « contrib », la mise à jour des pilotes nvidia n'avait été que partielle. En particulier, il manquait un paquet permettant au serveur X (Xorg) de discuter avec le module nvidia.

En rajoutant les dépôts contrib, les dépendances se sont « dénouées », et nous avons pu faire une mise à jour complète des pilotes nvidia, tout en installant le paquet anciennement manquant « xserver-xorg-video-nvidia ». Ce faisant, la nouvelle version du module nvidia a été installée, mais n'a pas remplacé celle qui était préalablement chargée en mémoire. Du coup, tu as éteint le serveur X et déchargé l'ancienne version.

La nouvelle version s'est ensuite rechargée toute seule, et le serveur X maintenant capable de communiquer avec elle a pu charger correctement l'accélération graphique. Tes programmes l'utilisant sont donc maintenant capables de fonctionner \o/

That's all folks! smile

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#30 19-02-2013 21:10:30

pmignon
Membre
Lieu : Lyon
Distrib. : Squeeze
Noyau : 2.6.35-2-686 et amd64
(G)UI : KDE: 4.3
Inscription : 14-06-2008

Re : [Résolu] openGL / nvidia ?

Super merci pour le résumé

smile

Hors ligne

Pied de page des forums