Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-04-2013 23:22:41

Debian2Rasp
Membre
Inscription : 07-04-2013

mods-rewrite

Bonsoir à tous,

Voilà, je suis avec un Raspberry et j'ai installé Apache, PHP et MySQL.
En fait tout ça :

apt-get install apache2 apache2-doc apache2-mpm-prefork apache2-utils libexpat1 ssl-cert

et ça :
apt-get install libapache2-mod-php5 php5 php5-common php5-curl php5-dev php5-gd php5-idn php-pear php5-imagick php5-imap php5-json php5-mcrypt php5-memcache php5-mhash php5-ming php5-mysql php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl

dans /var/www j'ai un dossier cakePHP où j'ai copier les fichiers de la dernières versions et quand je vais sur la page j'ai ce message d'erreur :

URL rewriting is not properly configured on your server.    1) Help me configure it 2) I don't / can't use URL rewriting

(en rouge).

Après j'ai fais ceci : a2enmod rewrite et j'ai relancé Apache et même la machine.

Ce que je ne comprends pas c'est que si je fais apache2ctl -t -D DUMP_MODULES je vois bien le module s'afficher.

Je ne vois pas se que je peux faire de plus, quelqu'un peut-il m'aider ?

Merci.

Hors ligne

#2 07-04-2013 23:38:02

Dohri
Membre
Lieu : /home/dohri/canapé
Distrib. : Sid
Noyau : 3.10.1 amd64
Inscription : 19-12-2010
Site Web

Re : mods-rewrite

As tu fait un vhost vers le dossier app/webroot/ ???

par défaut cake voit sa racine comme /var/www/ alors que toi tu l'as mis dans un dossier en plus, du coup le soucis doit venir des .htaccess qui se voient tous un dossier trop haut, d'où l'utilité du vhost wink

Dernière modification par Dohri (07-04-2013 23:42:38)


Asus Zenbook ux32vd > Sid   |   eeepc 1215 > Sid + gnome  |   eeepc 1015 > Squeeze + gnome   |   sony vaio > Squeeze CLI   |   serveur home made > debian squeeze CLI

Hors ligne

#3 07-04-2013 23:48:00

Debian2Rasp
Membre
Inscription : 07-04-2013

Re : mods-rewrite

Alors vhost, je suis désolé mais je ne sais pas de quoi tu me parles smile
Peux-tu m'en dire plus ?

J'ai aussi un problème avec selfoss, j'ai l'impression que les CSS ne sont pas pris en compte. Peut-être le problème est lié.

Hors ligne

#4 07-04-2013 23:53:39

Dohri
Membre
Lieu : /home/dohri/canapé
Distrib. : Sid
Noyau : 3.10.1 amd64
Inscription : 19-12-2010
Site Web

Re : mods-rewrite

Par défaut apache n'a qu'un seul répertoire racine (/var/www) qui est défini par un fichier (/etc/apache2/site-available/default) étant donné que toi tu mets ton site dans un dossier supérieur (cakephp) sa racine n'est plus la même et les fichiers .htaccess de chaque dossier et sous dossier ne correspondent plus...

tu peux soit transférer tout le contenu de ton dossier cakephp à la racine

mv /var/www/cakephp/* /var/www/                      #pour déplacer tous les fichiers
mv /var/www/cakephp/.* /var/www/                              #pour déplacer les fichiers cachés                        
 



mais dans ce cas ce ne sera pas très évolutif comme solution (autant commencer à jouer avec les vhosts ^^)

soit suivre l'excellente documentation de debian-facile pour comprendre et configurer ton vhost http://debian-facile.org/doc:reseau:apache2:multisite?s[]=vhosts wink

Dernière modification par Dohri (08-04-2013 00:12:31)


Asus Zenbook ux32vd > Sid   |   eeepc 1215 > Sid + gnome  |   eeepc 1015 > Squeeze + gnome   |   sony vaio > Squeeze CLI   |   serveur home made > debian squeeze CLI

Hors ligne

#5 08-04-2013 02:21:44

Debian2Rasp
Membre
Inscription : 07-04-2013

Re : mods-rewrite

Bon, je n'ai rien compris ou alors c'est autre chose.
J'ai suivis le tuto dont tu m'as parlé mais j'ai toujours le même problème.

Alors si je fais : apache2ctl -t -D DUMP_MODULES

J'obtiens : (je n'ai fais que des copier/coller pour éviter les erreurs)

/usr/sbin/apache2ctl: 87: ulimit: error setting limit (Operation not permitted)
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
Loaded Modules:
core_module (static)
log_config_module (static)
logio_module (static)
version_module (static)
mpm_prefork_module (static)
http_module (static)
so_module (static)
alias_module (shared)
auth_basic_module (shared)
authn_file_module (shared)
authz_default_module (shared)
authz_groupfile_module (shared)
authz_host_module (shared)
authz_user_module (shared)
autoindex_module (shared)
cgi_module (shared)
deflate_module (shared)
dir_module (shared)
env_module (shared)
headers_module (shared)
mime_module (shared)
negotiation_module (shared)
php5_module (shared)
reqtimeout_module (shared)
rewrite_module (shared)
setenvif_module (shared)
status_module (shared)
Syntax OK

Les fichiers modifiés après ton tuto :
ServerName, ServerAlias, j'ai essayé sans et avec. C'est une utilisation locale donc je ne pense pas en avoir besoin mais pour être sûr j'ai essayé.

<VirtualHost *:80>
        ServerAdmin "Mon mail"
        ServerName      www.cakephp1.fr
        ServerAlias     cakephp1.fr

        DocumentRoot /var/www/cakephp
                DirectoryIndex  index.php
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/cakephp>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>


Mon virtual-host.conf : (je n'ai qu'un site pour le moment)

Alias /cakephp /var/www/cakephp

Le hosts :
127.0.0.1       localhost cakephp
192.168.1.36    cakephp
::1             localhost ip6-localhost ip6-loopback
fe00::0         ip6-localnet
ff00::0         ip6-mcastprefix
ff02::1         ip6-allnodes
ff02::2         ip6-allrouters

127.0.1.1       raspberrypi


J'ai redémarré Apache et le Raspberry mais j'ai toujours le même problème :

URL rewriting is not properly configured on your server.    1) Help me configure it 2) I don't / can't use URL rewriting

De plus, j'ai l'impression qu'aucune CSS n'est pris en compte car avec Selfoss comme CakePHP j'ai une présentation ultra basique, alors que même avec des erreurs cakePHP affiche un minimum une jolie présentation...

Please, HELP ME !!!!!

Merci.


EDIT :

Après la commande apache2ctl -t -D DUMP_MODULES

Je n'avais pas vu ces deux lignes : (j'ai donc fais une mauvaise manip ?)
/usr/sbin/apache2ctl: 87: ulimit: error setting limit (Operation not permitted)
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName


EDIT 2 : il manque des couleurs sur le tuto au niveau du fichier dans sites-available. Mais après modifications, toujours pareil... (a moins que je passe à côtéd'un truc, je modifie ma copier / coller ci-dessus)

Dernière modification par Debian2Rasp (08-04-2013 02:29:55)

Hors ligne

#6 08-04-2013 07:29:16

Dohri
Membre
Lieu : /home/dohri/canapé
Distrib. : Sid
Noyau : 3.10.1 amd64
Inscription : 19-12-2010
Site Web

Re : mods-rewrite

après avoir fait les modifs de ton fichier vhost tu as bien fait la commande:

a2ensite tonsite

??


Asus Zenbook ux32vd > Sid   |   eeepc 1215 > Sid + gnome  |   eeepc 1015 > Squeeze + gnome   |   sony vaio > Squeeze CLI   |   serveur home made > debian squeeze CLI

Hors ligne

#7 08-04-2013 14:03:32

Debian2Rasp
Membre
Inscription : 07-04-2013

Re : mods-rewrite

Il me semble que oui mais là je viens de le refaire et redémarré mon Raspberry, idem, toujours et encore le même problème...

Hors ligne

#8 08-04-2013 14:55:08

Dohri
Membre
Lieu : /home/dohri/canapé
Distrib. : Sid
Noyau : 3.10.1 amd64
Inscription : 19-12-2010
Site Web

Re : mods-rewrite

je tenterai une installation ce soir pour voir un peu ce que ça donne et te dirai ce qu'il en est wink

Asus Zenbook ux32vd > Sid   |   eeepc 1215 > Sid + gnome  |   eeepc 1015 > Squeeze + gnome   |   sony vaio > Squeeze CLI   |   serveur home made > debian squeeze CLI

Hors ligne

#9 08-04-2013 15:00:49

Debian2Rasp
Membre
Inscription : 07-04-2013

Re : mods-rewrite

Ok merci smile
Je désespère là parce que je ne connais pas bien Apache et il me semble avoir suivis le tuto à la lettre.
J'ai vérifié mon PHP info aussi et j'ai bien le module rewrite activé.

J'ai aussi fais une mise à jour de tous les paquets, y compris de la distribution. J'attends ton retour alors avec impatience smile
Merci pour ton aide en tout cas.

EDIT : j'ai aussi fais un chmod 777 -R sur le dossier App/tmp de cakephp.

Dernière modification par Debian2Rasp (08-04-2013 15:01:34)

Hors ligne

#10 08-04-2013 19:05:20

Dohri
Membre
Lieu : /home/dohri/canapé
Distrib. : Sid
Noyau : 3.10.1 amd64
Inscription : 19-12-2010
Site Web

Re : mods-rewrite

Bon en fait je suis un boulet j'avais pas regardé ton fichier vhost...

tu as une erreur:

AllowOverride None



doit être remplacé par:

AllowOverride All



et ne pas oublier ensuite

service apache2 reload

Dernière modification par Dohri (08-04-2013 19:06:39)


Asus Zenbook ux32vd > Sid   |   eeepc 1215 > Sid + gnome  |   eeepc 1015 > Squeeze + gnome   |   sony vaio > Squeeze CLI   |   serveur home made > debian squeeze CLI

Hors ligne

#11 08-04-2013 21:27:24

Debian2Rasp
Membre
Inscription : 07-04-2013

Re : mods-rewrite

Bon, merci mon FAI je n'ai pas eu de connexion Internet aujourd'hui. Heureux en voyant ta réponse et déçus 5 minutes après... TOUJOURS la même chose hmm
Je comprends pas...

Je recopie/colle le fichier :

<VirtualHost *:80>
        ServerAdmin guerrierdeslandes@hotmail.com
        ServerName      www.cakephp1.fr
        ServerAlias     cakephp1.fr

        DocumentRoot /var/www/cakephp
                DirectoryIndex  index.php
        <Directory />
                Options FollowSymLinks
                AllowOverride All
        </Directory>
        <Directory /var/www/cakephp>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride All
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

Merci pour ton aide.

Hors ligne

#12 08-04-2013 21:50:41

Dohri
Membre
Lieu : /home/dohri/canapé
Distrib. : Sid
Noyau : 3.10.1 amd64
Inscription : 19-12-2010
Site Web

Re : mods-rewrite

j'ai fait l'installation et de mon côté ça marche nickel avec ce que je t'ai donné.... hmm
tu peux nous montrer ton fichier .htaccess histoire de voir si tout va bien pour lui?

Asus Zenbook ux32vd > Sid   |   eeepc 1215 > Sid + gnome  |   eeepc 1015 > Squeeze + gnome   |   sony vaio > Squeeze CLI   |   serveur home made > debian squeeze CLI

Hors ligne

#13 08-04-2013 21:55:28

Debian2Rasp
Membre
Inscription : 07-04-2013

Re : mods-rewrite

Oui chef, mais lequel ? Parce que dans cakephp y'en a plusieurs, celui de la racine est comme ceci:

<IfModule mod_rewrite.c>
   RewriteEngine on
   RewriteRule    ^$ app/webroot/    [L]
   RewriteRule    (.*) app/webroot/$1 [L]
</IfModule>

EDIT : celui de App :

<IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteRule    ^$    webroot/    [L]
    RewriteRule    (.*) webroot/$1    [L]
</IfModule>

Dernière modification par Debian2Rasp (08-04-2013 21:56:31)

Hors ligne

#14 08-04-2013 22:11:43

Dohri
Membre
Lieu : /home/dohri/canapé
Distrib. : Sid
Noyau : 3.10.1 amd64
Inscription : 19-12-2010
Site Web

Re : mods-rewrite

oui c'était bien celui là....et il est bon...

ton fichier host indique cakephp alors que dans ton vhost tu renvoi vers cakephp.fr...
de plus tu peux modifier ton fichier host comme ceci

127.0.1.1  cakephp.fr
:wq

Asus Zenbook ux32vd > Sid   |   eeepc 1215 > Sid + gnome  |   eeepc 1015 > Squeeze + gnome   |   sony vaio > Squeeze CLI   |   serveur home made > debian squeeze CLI

Hors ligne

#15 08-04-2013 22:13:20

Debian2Rasp
Membre
Inscription : 07-04-2013

Re : mods-rewrite

j'ai viré le cakephp.fr
Je dois le laisser ?

Je fais la modif avec le 127

Hors ligne

#16 08-04-2013 22:19:22

Dohri
Membre
Lieu : /home/dohri/canapé
Distrib. : Sid
Noyau : 3.10.1 amd64
Inscription : 19-12-2010
Site Web

Re : mods-rewrite

ok...c'est jamais évident de faire ça à distance car on oublie toujours quelque chose et on a pas une vue très facile des événements...et en plus j'ai souvent les yeux qui se croisent ^^
bon on va y arriver wink

Asus Zenbook ux32vd > Sid   |   eeepc 1215 > Sid + gnome  |   eeepc 1015 > Squeeze + gnome   |   sony vaio > Squeeze CLI   |   serveur home made > debian squeeze CLI

Hors ligne

#17 08-04-2013 22:19:28

Debian2Rasp
Membre
Inscription : 07-04-2013

Re : mods-rewrite

Tu veux dire comme ça ? :
127.0.0.1       cakephp.fr
:wq
192.168.1.36    cakephp
::1             localhost ip6-localhost ip6-loopback
fe00::0         ip6-localnet
ff00::0         ip6-mcastprefix
ff02::1         ip6-allnodes
ff02::2         ip6-allrouters

127.0.1.1       raspberrypi

Hors ligne

#18 08-04-2013 22:20:58

Debian2Rasp
Membre
Inscription : 07-04-2013

Re : mods-rewrite

lol, ouais par post interposé c'est pas simple, c'est clair... Ca ne marche toujours pas au passage smile

Hors ligne

#19 08-04-2013 22:22:07

Dohri
Membre
Lieu : /home/dohri/canapé
Distrib. : Sid
Noyau : 3.10.1 amd64
Inscription : 19-12-2010
Site Web

Re : mods-rewrite

non pas tout à fait,
laisse :

127.0.0.1 localhost

et ajoute en dessous:

127.0.1.1 cakephp.fr

pour :wq il n'est pas utile loin de là....c'est moi qui l'ai ajouté sans faire exprès (c'est la commande à taper dans vim pour sauvegarder et quitter...vieux reflexe quand je tape du texte...^^ )

Asus Zenbook ux32vd > Sid   |   eeepc 1215 > Sid + gnome  |   eeepc 1015 > Squeeze + gnome   |   sony vaio > Squeeze CLI   |   serveur home made > debian squeeze CLI

Hors ligne

#20 08-04-2013 22:23:12

Debian2Rasp
Membre
Inscription : 07-04-2013

Re : mods-rewrite

haha, moi qui voulait te demander se que c'était, j'utilise aussi vim mais j'ai pas tilté smile
Je teste et te dis.

Hors ligne

#21 08-04-2013 22:24:37

Debian2Rasp
Membre
Inscription : 07-04-2013

Re : mods-rewrite

mon hosts :

127.0.0.1       localhost
127.0.1.1       cakephp.fr
192.168.1.36    cakephp
::1             localhost ip6-localhost ip6-loopback
fe00::0         ip6-localnet
ff00::0         ip6-mcastprefix
ff02::1         ip6-allnodes
ff02::2         ip6-allrouters

127.0.1.1       raspberrypi

Dans le terminal :
sudo service apache2 reload

Toujours pareil

Dernière modification par Debian2Rasp (08-04-2013 22:33:13)

Hors ligne

#22 08-04-2013 22:37:38

Dohri
Membre
Lieu : /home/dohri/canapé
Distrib. : Sid
Noyau : 3.10.1 amd64
Inscription : 19-12-2010
Site Web

Re : mods-rewrite

et dans ton fichier /etc/apache2/apache2.conf tu as bien une ligne comportant ceci:

AccessFileName .htaccess
 


Asus Zenbook ux32vd > Sid   |   eeepc 1215 > Sid + gnome  |   eeepc 1015 > Squeeze + gnome   |   sony vaio > Squeeze CLI   |   serveur home made > debian squeeze CLI

Hors ligne

#23 08-04-2013 22:42:54

Debian2Rasp
Membre
Inscription : 07-04-2013

Re : mods-rewrite

Oui :

#
# AccessFileName: The name of the file to look for in each directory
# for additional configuration directives.  See also the AllowOverride
# directive.
#

AccessFileName .htaccess

Question con, je me connecte au Raspberry en SSH, je n'y suis pas directement dessus.
Donc de mon ordinateur de bureau, j'ouvre un navigateur internet, j'écris quoi comme adresse ? (actuellement ip/cakephp)

Hors ligne

#24 08-04-2013 22:46:38

Dohri
Membre
Lieu : /home/dohri/canapé
Distrib. : Sid
Noyau : 3.10.1 amd64
Inscription : 19-12-2010
Site Web

Re : mods-rewrite

ah bah non!!

dans le fichier hosts de ton pc tu mets:

192.168.1.36    cakephp1.fr        # ce qui correspond à ton ServerName dans le vhost



et dans ton navigateur tu tape juste cakephp1.fr dans la barre d'adresse wink

Dernière modification par Dohri (08-04-2013 22:51:12)


Asus Zenbook ux32vd > Sid   |   eeepc 1215 > Sid + gnome  |   eeepc 1015 > Squeeze + gnome   |   sony vaio > Squeeze CLI   |   serveur home made > debian squeeze CLI

Hors ligne

#25 08-04-2013 22:52:23

Debian2Rasp
Membre
Inscription : 07-04-2013

Re : mods-rewrite

eh bien si je fais ça, il me dis qu'il ne trouve pas le serveur smile

EDIT : d'un autre ordi, on est d'accord ?

Dernière modification par Debian2Rasp (08-04-2013 22:53:25)

Hors ligne

Pied de page des forums